Elektroda.pl
Elektroda.pl
X
Relpol przekaźniki
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Sterownie rolety- problem

13 Lut 2008 11:30 1493 2
  • Poziom 13  
    Witam
    Mam taki problem.
    Zrobiłem układ do sterowania roletą. Roleta ma silnik z którego wychodzą 3 kable. Dwie fazy i COM. Jedna faza odpowiada za prace silnika w górę, druga za pracę silnika w dół. W silniku zamontowane są krańcówki.
    W załączniku zamieściłem schemat mojego urządzenia. Ta część układu sterowana jest przez mikroporcesor włączając na 1minute jednego triaka w momencie rozwijania potem jest odstęp 1sekundy pomiędzy przełączeniami fazy i załącza się drugi triak na 1 minute. Podczas gdy tak włączam i wyłączam na przemian silnik za którymś razem pali mi się jeden z triaków. Wymieniałem już triaki na różne i ciągle jest ta sama sytuacja. Poza tym jak tam zwijam i rozwijam roletę to po pewnym czasie rozregulowują mi się krańcówki. Za każdym razem pali mi się rezystor R2 lub R8 a potem triak.
    Może wie ktoś jaka może być przyczyna palenia tych triaków i jak temu zaradzić? Nie mam już pomysłu co dodać lub usunąć z układu aby to działało dobrze.
  • Relpol przekaźniki
  • Poziom 31  
    Witam

    Co dają kondensatory 1nF w obwodzie gasikowym. Moim zdaniem nic. Druga rzecz to rezystorki między bramką a anodą. Zasadniczo nie powinno ich tam być. Być może zakłócenia pojawiające się na anodzie poprzez rezystor dostają się na bramkę drugiego triaka czego efektem są awarie. Mówiąc szczerze mam podobne problemy z triakami i tam gdzie ich nie muszę to ich nie stosuję. Nie prościej byłoby zastąpić triaki przekaźnikami ? Dałbym przekaźniki z dwoma parami styków. Połączyć je należałoby tak, żeby włączenie jednego blokowało załączenie drugiego.

    --
    pozdrawiam
  • Relpol przekaźniki
  • Poziom 13  
    Zrobiłem układ w pierwotnej wersji na przekaźnikach ale podczas podłaczenia silnika przekaźniki prawie że się topiły. Mamy tu do czynienia z obciążeniem indukcyjnym i dlatego myślałem że lepiej będzie to zrobić na triaku. Co do tego rezystora to taki sposób podłączenia triaka był sugerowany w datasheecie triaka dlatego tak zrobiłem. Zauważyłem że jak zadziała krańcówka w silniku to strasznie grzeje się warystor zabezpieczający triaka i potem pali się dosłownie mówiąc rezystor R2 lub R8 zależnie czy zadziałała górna krańcówka silnika czy dolna.
    Czy może to mięć jakiś związek że na przewód silnika podawana jest nadal faza a krańcówka rozłącza tą fazę? Może tu powstają jakieś iskrzenia i dlatego pali się triak?