Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Wzmacniacz mono TDA7294 wzmocnienie

Qwet 24 May 2008 17:37 24371 79
Tespol
  • #61
    fuutro
    Level 43  
    Z tym schematem nie mógł wyjść mostek, bo podałeś sygnał o tej samej fazie na oba wejścia i tylko na początki można by dostać łupnięcie w głośniku od stanów nieustalonych i chyba dostałeś (a raczej biedny głośnik, jaki był?). Włącz do do zasilania tylko przez rezystory ok 22-47om/1W albo jakieś żarówki np samochodowe i bez obciążenia na wyjściu pomierz napięcia. Tak na marginesie schemat (z wcześniejszymi poprawkami) jest pod TDA7250 a nie TDA7294.
  • Tespol
  • #62
    Qwet
    Level 33  
    Wiem wiem, w temacie jest 7294 ale nie chciałem już zakładać nowego o 7250 ;)

    Właśnie chodzi o to że wyjście 9 to "non-inverting" a 20 to "inverting", teoretycznie powinno wszystko działać...

    Na oddzielnych kanałach normalnie w półmostku działa elegancko... Może po prostu wystarczy dać na wejście odwracacz fazy na NE5532 i głośnik między kanały..?
  • #63
    fuutro
    Level 43  
    Bardzo bobrze kombinujesz z tym odwracaczem! Można by to przy samym scalaku zrobić ale wymagane są zmiany w układzie a tak robisz dwa identyczne kanały i dodajesz jeszcze jeden scalak w przedwzmacniaczu.
  • Tespol
  • #64
    Qwet
    Level 33  
    Właśnie o to chodzi że przy samym scalaku zrobiłem, ale spaliło głośnik i na wyjściu była połowa napięcia zasilania, jakby jeden kanał był sterowany ciągle maksymalnie w jedną stronę.

    Odwracacz zrobię na zasilanie z akumulatora 12V według tego schematu:
    Wzmacniacz mono TDA7294 wzmocnienie

    Swoją drogą próbowałem wcześniej zasilać przedwzmacniacz z przetwornicy zasilającej wzmacniacz, ale zakłócenia ze stabilizacji napięcia w przetwornicy są tak ogromne że nie pomaga nawet filtr PI - są trzaski przy włączaniu i wyłączaniu kluczowania. Dlatego zdecydowałem się zasilić preampa z akumulatora ;)
  • #65
    fuutro
    Level 43  
    To co jest na schemacie po lewej jest pomylone oznaczenie wejść i docelowo cały układ w obu torach odwraca sygnał mając wzmocnienie regulowane a nie o wartości (-1). Może spróbuj tego tylko daj stabilizację choćby z diodą zenera i z większą pojemnością filtrującą.
    Wzmacniacz mono TDA7294 wzmocnienie
  • #66
    Qwet
    Level 33  
    Zapomniałem zmienić... Na oba wejścia podaję ten sam sygnał mono ;)

    A co do twojego układu to czy mogę użyć NE5532?? Podobno jest dużo lepszy niż TL072...

    Dodano po 1 [minuty]:

    A dlaczego mówisz że odwraca obie części?? Przecież jedna jest na plusie a druga na minusie... O co chodzi??

    Dodano po 2 [minuty]:

    A po co stabilizacja?? Przecież napięcie zasilania to max. 15V, kości takie zasilanie nie zaszkodzi...
  • #67
    fuutro
    Level 43  
    Co do scalaków oba mają małe szumy co predysponuje je do sprzętu audio.
    Po lewej stronie jest pomylony + z - co w efekcie daje dwa wzmacniacze odwracające.
    Zasilani z aku nie jest pozbawione wpływu innych urządzeń więc warto filtrować zasilanie tuż przy scalakach.
  • #68
    Qwet
    Level 33  
    Ale gdyby + i - były podłączone właściwie to też wyjścia byłyby odwracające... nie rozumiem...

    Jako filtr zastosowałem 3 dławiki z ATX (małe dla zasilań ujemnych) i 4 kondensatory 1000uF.

    Zrobiłem właśnie przedwzmacniacz z tego projektu:
    http://www.zpcir.ict.pwr.wroc.pl/~jarekp/proj/pamp/index.html

    Powiem że jestem zawiedziony bo wzmacniacz SZUMI. Kiedy podłączę sam MP3 to nic nie ma szumku, a kiedy podłączę przedwzmacniacz to gra trochę głośniej, ale słychać okrutny szum... W ekranie siedzi, nic nie ma prawa tam się dziać... Czy to znaczy że ta kość mimo że to jedna z najlepszych jednak szumi??

    Ten schemat który podałeś powyżej ładnie odwraca fazę, po podłączeniu głośników pod każdy kanał robi się w uszach niezły surround :D Niestety wogóle nie działa na zasilanie niesymetryczne, z zasilaniem -Vs podłączonym do masy...
  • #69
    fuutro
    Level 43  
    I właśnie do niego trzeba dorobić obwody wstępnej polaryzacji. Szumy mogą wynikać z samej konstrukcji całości wzmacniacza, prowadzenia przewodów i miejsc ich dołączenia. Co do poprzedniego układu to pracuje on jako 2 wzmacniacze w układzie odwracającym ale jak zamiast podać sygnał na - podasz na + to zmienisz rodzaj sprzężenia zwrotnego z ujemnego na dodatnie i może powstać z tego generator lub nawet przerzutnik. Ma on dobre obwody sztucznej masy - dzielnik napięcia zasilania na pół zblokowany kondensatorem.
    Daj taki jeden dzielnik do układu jak ostatnio podesłałem np z rezystorów 4k7, zblokuj kondensatorem ze 100uF/16V, połącz środek dzielnika (sztuczną masę) poprzez ten rezystor R1 z wejściem sygnału. R3 połącz zamiast z masą to z sztuczną masą i powinno wystarczyć przeróbek. Nie zapomnij tylko o kondensatorach sprzęgających na wejściu i wyjściu bo one rozwiązują problem obecności napięcia stałego.
  • #70
    Qwet
    Level 33  
    Poskładałem tak jak mówisz po modyfikacjach i przed modyfikacjami, na różnych fabrycznie nowych NE5532, z różnymi kondensatorami sprzęgającymi i w żadnym ustawieniu odwracacz nie współpracuje z przedwzmacniaczem. Gra, ale potrzebuje kopa sygnałem 5-7V a i tak gra cicho. Nie sprawdziłem nawet czy wogóle odwraca bo staram się sprawić żeby to wogóle działało...

    Dodano po 38 [minuty]:

    Zrobiłem dokładnie taki układ na 5532:
    Wzmacniacz mono TDA7294 wzmocnienie

    Wogóle nie daje dźwięku, ani normalnie ani w mostku. Niezależnie czy podłączę na wejście jeden kanał z MP3 czy przedwzmacniacz do kompa nie odzywa się. Słychać coś dopiero przy sygnale kilku V, a tak chyba nie powinno być... bez tego odwracacza gra głośno przy małym sygnale, nawet w mostku kiedy na wejście dam stereo coś tam gra (różnica kanałów).

    Dodano po 23 [minuty]:

    Już wiem co to za magiczne czary! Ha!

    W końcówce mocy między kanały wpadła cyna. To powodowało zwarcie wyjść, co oznacza uśrednienie sygnału wchodzącego czyli w odwróconej fazie dawało to wzajemną kompensację kanałów! Tyle godzin roboty musiałem odwalić żeby do tego dojść... Dzięki wielkie fuutro za cierpliwość, zabieram się za dopracowanie odwracacza ;)

    Dodano po 43 [minuty]:

    Teraz wszystko działa elegancko w każdej konfiguracji, w mostku gra dużo głośniej niż normalnie ;) Jestem zadowolony...

    Dodano po 1 [godziny] 11 [minuty]:

    Mam jeszcze takie krótkie pytanko - czy wzmacniacz operacyjny typu NE5532 może się spalić na zasilaniu -11V / 0V / +16V ??
  • #71
    fuutro
    Level 43  
    Nie, nic mu nie będzie bo on nie wie na jakim potencjale jest masa i ważne są skrajne szyny zasilania i sztuczna masa dla znalezienia środka napięcia zasilania.
  • #72
    Qwet
    Level 33  
    No racja, tam nie ma nigdzie podłączonej masy :)

    Dołożyłem potencjometr, o tak:
    Wzmacniacz mono TDA7294 wzmocnienie

    i zauważyłem pewną nieprawidłowość... Kiedy reguluję głośność odtwarzaczem to nic się złego nie dzieje, ale kiedy reguluję moim potencjometrem coś złego dzieje się z prądem spoczynkowym...
    Bez sygnału przetwornica bierze 1,8A, to znaczy około 22W mocy. Regulując głośność odtwarzaczem nie ma skoków natężenia, wzrasta ono proporcjonalnie do głośności. Podczas regulacji głośności moim potencjometrem prąd pobierany przez przetwornicę skacze do poziomów 10-20A, a kiedy przestaję regulować wraca do normy - kilka amperów. W głośniku tego wogóle nie słychać... Prąd wzrasta tym bardziej im szybciej przekręcam potencjometr i od razu wraca do normy kiedy przestaję przekręcać. O co tu chodzi? Tak powinno być?? Wzmacniacz jest podłączony w mostku, w półmostku wszystko jest dobrze.
  • #73
    Qwet
    Level 33  
    No to zrobiłem przedwzmacniacz. Z założenia jestem zadowolony bo to wogóle zadziałało od pierwszego uruchomienia :D Ale jest mały problem, konkretnie chodzi o ten element:
    Wzmacniacz mono TDA7294 wzmocnienie

    Potencjometr niskich tonów prawie nic nie zmienia dźwięku, potencjometr wysokich zmienia troszkę bardziej, ale i tak jest to nieznaczna zmiana. Czy można coś zrobić żeby te 2 regulacje miały większy "zasięg" częstotliwości? Np. zasadzić większy kondensator albo opornik, bo potencjometrów o innej rezystancji nie mam, musiałbym znowu lecieć do elektronika. Z góry dziękuję za odpowiedź ;)
  • Helpful post
    #74
    fuutro
    Level 43  
    Zmniejsz te rezystory 22k w gałęzi regulacji basu na mniejsze, np 2,2-10k.
  • #75
    Qwet
    Level 33  
    SUPER!! dałem dwa 4,7k w basie i 2,2n w sopranie i działa tak jak to sobie wymarzyłem! Dzięki wielkie fuutro, po raz kolejny mi pomogłeś...
  • #76
    Qwet
    Level 33  
    Witam ponownie :)
    Zrobiłem już cały sprzęt, przetestowałem, wszystko ładnie działa ;) Tak szmacony na forum głośnik dibeisi w obudowie z BassReflex rusza szybami w całym domu :D Ale jest jeden problem. Wzmacniacz do suba pracuje w mostku na TDA7250 i przy +/-40V pobiera 240W, powyżej tego muzyka zaczyna przerywać w rytm basu. Myślę że to wina kontroli przeciążenia, za szybko reaguje na przyrost prądu w opornikach... Ponieważ nie mam dostępu do oporników np. 0R068 wymyśliłem coś takiego:
    Wzmacniacz mono TDA7294 wzmocnienie

    Czy wolno mi tak zrobić? Jakie oporniki zamiast 10R i 50R mógłbym tam wstawić?
  • #77
    fuutro
    Level 43  
    Może zamiast dzielnika lepiej dać 2-3 rezystory równolegle? np 3*0,22R. Wpłynie to na prąd spoczynkowy - wzrośnie ale prąd ograniczenia też powinien przyjąć większą wartość.
  • #78
    Qwet
    Level 33  
    Ajj.. mam kupować kolejne 12 oporników? Takie są po 3zł/szt... Naprawdę nie da się zrobić tego na dzielniku? Tak się składa, że mam z zasilaczy i monitorów dużo oporników jedno i dwuwatowych o rezystancjach 8R, 10R, 22R, 47R, 50R, 100R, 150R. Dałoby się coś z tego ułożyć? Bardzo mi zależy na takim rozwiązaniu...

    Co do prądu spoczynkowego to nie ma on dla mnie za dużego znaczenia, wzmacniacz prawie cały czas będzie pracował przy mocnym wysterowaniu. Teraz prąd spoczynkowy wynosi trochę ponad 200mA, to jest jakieś 18W mocy. Uważam że to niewiele ;)

    Dodano po 13 [minuty]:

    Pooglądałem sobie notkę tadzia i wygląda na to że piny 4, 7, 14, 17 są w strukturze podłączone tylko do wejść wzmacniaczy operacyjnych, z tego wynika że prąd tych wejść to mikroampery. W takim razie nie ma dużego znaczenia jakie oporniki zastosuję w dzielniku, ważna jest tylko proporcja ;)
  • #79
    fuutro
    Level 43  
    Spróbuj więc tego dzielnika. Może się udać :D
  • #80
    Qwet
    Level 33  
    może? :| Wyczuwam podstęp... (ze strony oporników :P)

    Dodano po 2 [minuty]:

    Ale wpadłem na pomysł! Przecież ja mam 4 oporniki 1R/2W, podłącze je równolegle do już posiadanych 0R1/10W! Jestem genialny :D
    Dzieki fuutro za podsunięty pomysł ;)