Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

silniki krokowe nie dzałaja

djice 24 Mar 2008 23:11 6275 85
  • #61
    Leoo
    Poziom 16  
    ULN2803 zawiera klucze z tranzystorów NPN w układzie Darlingtona. Układ musi być uszkodzony (przebite złącza C-B), skoro napięcie zasilające silniki przenika przez r-pack'a do bramy procesora. Silniki były wymieniane i proponuję sprawdzić czy nie mają zwarć i czy ich napięcie nominalne wynosi 12V ale przed wymianą ULN2803.
  • PCBway
  • #62
    djice
    Poziom 15  
    ok ale jak mogę sprawdzić ich napięcie???
    sprawdziłem,zwarte nie sa...
    silniki krokowe nie dzałaja
    jeszcze mam jedno pytanko to jest płytka zasilająca diodę laserowa i sa na niej 2 wyjścia jedna TI prowadzi do diody laserowej a drógie to TTL...
    i nie wiem do czego służy
  • #63
    Leoo
    Poziom 16  
    Napięcie powinno być podane na etykiecie silnika. Czasem producenci podają prąd fazowy i oporność. Jeśli oporność między końcówką wspólną (podłączoną do +12V) a dowolną inną będzie mniejsza niż około 30Ω, to nie ma sensu naprawiać elektroniki, wpierw trzeba postarać się o inne silniki.
  • #64
    Maciek4141
    Poziom 22  
    Wejście TTL służy do wygaszania lasera. Jeżeli zostanie podane na nie napięcie ok. 5V to laser automatycznie gaśnie. Dzięki temu laser tworzy różne figury.
    Kilka tematów wyżej jest przyklejony temat o zasilaniu diody laserowej i tam są schematy z ttl.


    Pozdrawiam
  • #65
    djice
    Poziom 15  
    silniki sprawdzone i sprawne
  • PCBway
  • #66
    djice
    Poziom 15  
    niestety po wymiane stabilizatora nic sie nie zmieniło
    w zielonym tez wymieniłem 74hc02n nic sie nie zmieniło
  • #67
    Krzysieksiek
    Poziom 20  
    A robiłeś to przy wylutowanym ULN-ie?

    Ewentualnie wyjmij procesor z podstawki i wtedy badaj poziom napięcia. Czy stabilizator się grzeje?
  • #68
    djice
    Poziom 15  
    Wyciągnołem procesor i sprawdziłem napięcie. Stabilizatora wynosi 5V lecz na pinach ULN'a łączących procesor jest zasilanie 2.85V
    silniki krokowe nie dzałaja

    to jeżeli chodzi o czerwony laser.

    Natomiast zielony zaczoł cos tam pracować led na płytce mruga a galva włączają sie po załączeniu zasilania na 10sekund z jednym spowrotem stają
    lecz dioda dalej pulsuje
    silniki krokowe nie dzałaja
  • #69
    bolek
    Specjalista - oświetlenie sceniczne
    no to w zielonym masz pewnie problem konfigarcji za pomocą dip switcha. Ewentualnie może być ustawiony "na dzwięk", ale laser jest głuchy. Jeśli mikrofon nic nie wychwyci to laser się wyłaczy

    Silniki zostawcie- jest to element praktycznie nie śmiertelny. Dwa to ich wygląd jest w porządku- one po prostu tak mają.

    Na pinach ULNa ma być max takie napięcie jakie daje procesor. czyli nie powinno sie tam pojawić więcej niz 5V, więc można uznać za sprawny
  • #70
    djice
    Poziom 15  
    tak ale ja procesor wyjałem wiec z kad tam jest napiecie

    bolek napisał:
    Silniki zostawcie- jest to element praktycznie nie śmiertelny. Dwa to ich wygląd jest w porządku- one po prostu tak mają.


    nie rozumiem tego zdania do czego one jest???
  • #71
    bolek
    Specjalista - oświetlenie sceniczne
    djice napisał:
    tak ale ja procesor wyjałem wiec z kad tam jest napiecie

    bolek napisał:
    Silniki zostawcie- jest to element praktycznie nie śmiertelny. Dwa to ich wygląd jest w porządku- one po prostu tak mają.


    nie rozumiem tego zdania do czego one jest???


    Znaczy że wygląd tych silników jest ok. Wyglądaja jak z demobilu, ale takie właśnie są montowane orginalnie.

    Skor po wyjeciu procka, z wejsć ULN napiecie spada z 7 do 2V to znaczy że ULN jest ok, a problem leży gdzieś w okolicach procka. Musi on sterować czymś jeszcze co ma kontakt z wyższym niż 5V napięciem. Trzeba wyjac procek i zobaczyć na którym pinie jest wyżesz napięcie. Potem obadać do czego to leci.
  • #72
    Krzysieksiek
    Poziom 20  
    djice napisał:
    Wyciągnołem procesor i sprawdziłem napięcie. Stabilizatora wynosi 5V lecz na pinach ULN'a łączących procesor jest zasilanie 2.85V


    Stabilizator jest w porządku.

    Z wypowiedzi wynika że po stronie wejść ULN-a jest poziom napięcia 2,85V. Dzieje się tak ponieważ jest tam ten zestaw rezystorów (SIL drabinka) podciągających.
    Sprawdź jeszcze tę drabinkę, na schemacie RN1 (podejrzanie wygląda i ma dziwny wpływ na układ). Następuje tam coś w rodzaju sumowania się napięć. (Tu mogę się mylić)

    Proponuje też wykonać taką próbę:
    - włożyć procesor w podstawkę,
    - wyciągnąć ULN-a,
    - wyciągnąć ten zestaw RN1,
    - pomierzyć poziom napięć na konkretnie tych wyjściach procesora które są połączone z ULN,
    - jeżeli już wtedy poziom napięć przekracza 5V znaczy to że procesor jest nieodwracalnie uszkodzony,
    - jeżeli poziom napięć będzie w tych miejscach w granicach 5V (nie więcej), to wlutuj tą drabinkę i zobacz co dzieje się wtedy (drabinkę mając wylutowaną - sprawdź),

    Wszystkie te operacje (tzn kolejne zmiany) przeprowadzaj wyłączając zasilanie układu.

    Jeśli możesz to zrób zdjęcie tego co było pod procesorem (zwory i/lub elementy).
  • #73
    djice
    Poziom 15  
    bolek napisał:
    Skor po wyjeciu procka, z wejsć ULN napiecie spada z 7 do 2V to znaczy że ULN jest ok, a problem leży gdzieś w okolicach procka. Musi on sterować czymś jeszcze co ma kontakt z wyższym niż 5V napięciem. Trzeba wyjac procek i zobaczyć na którym pinie jest wyżesz napięcie. Potem obadać do czego to leci.



    sprawdziłem wszystkie piny wszedzie jest 4.90V
    no prawie wszedzie ale nigdzie nie przekracza 5V

    silniki krokowe nie dzałaja

    po wylutowaniu tego RN1 z procesora na ULN idzie 4.25v lecz z ULN na silniki idzie 0,81V no i niestety przy wylutowywaniu RN1 uległ uszkodzeniu.
  • #74
    Krzysieksiek
    Poziom 20  
    Poziom napięć zasilających procesor jet dobry (tzn mieści się w normie).

    Skoda że uszkodziłeś tę drabinkę rezystorów (ale to nic, trzeba kupić nową), bo nie bardzo jest ją chyba teraz jak sprawdzić.

    Wymieniałeś już tego pierwotnego ULN-a ? (bo miał "przebicie").

    Proponuje wlutuj nową drabinkę (RN1) i sprawdź wtedy układ. Jak to nie pomoże wymień też ULN.

    Jeżeli dobrze rozumuje
    Wejścia uln (w tym przypadku) podciągnięte są do plusa zasilania poprzez drabinkę rezystorów. Stan niski na wyjściu procesora powoduje wysterowanie ULN-a a tym samym silnik.
  • #75
    djice
    Poziom 15  
    mam takie pytanko jeżeli RN1 jest rezystorem czy ma jakaś wartość????

    a wiec tak zielonego uruchomiłem nie dokońca ale jest ok jest tak ze jeszcze cos jest nie tak z układem wzmacniacza,ogółem jest tak ze nie reaguje na mikrofon zmienia sie jak chce ale to juz pryszcz..

    a z czerwonym to jestem pewien na 100%ze procesor jest uszkodzony...
    i teraz taka prośbą czy dało by rade skołować taki procesor z wgranym programem???
  • #76
    Krzysieksiek
    Poziom 20  
    Co do RN1 to na 100% ma jakąś wartość (pewnie ok 10k).

    Po czym wnioskujesz że procesor padł? (pewnie masz racje).
    Z procesorem nie ma problemu ale wsad do niego to już pewien problem. O "fabryczny" wsad będzie trudno, możesz sam coś pokombinować.

    Pozdrawiam
  • #77
    djice
    Poziom 15  
    przekładałem procesor do działającego układu...

    Nie uwierzycie byłem w sklepie który nazywa sie MAPLIN to nawet nie wiedzieli co to jest ta sil drabinka...
    czy jest jakiś patent na zrobienie tego z rezystorów???
  • Pomocny post
    #78
    Krzysieksiek
    Poziom 20  
    Tak jest to pakiet rezystorów. Wygląda to TAK

    I co się działo po przełożeniu procka do innego układu (bo układ konfiguracyjny na płytce chyba zbliżony?, a wiele zależy od przypisanych funkcji pinów no i samego wsadu).

    Pozdrawiam
  • #79
    djice
    Poziom 15  
    w sumie po przełożeniu procesora nic sie nie dzieje a powinien chociaż coś wystartować
    A jutro zrobię na pajączku ta drabinkę
  • #80
    djice
    Poziom 15  
    eureka działają obydwa w czerwonym była drabinka walnięta i procesor
    w zielonym 2 scalki LM324,74HC02 i stabilizator
    dziękuje wszystkim za pomoc
  • #81
    Maciek4141
    Poziom 22  
    No to świetnie, masz 2 fajne efekty laserowe za niewielką kasę.

    GRATULACJE
  • #82
    djice
    Poziom 15  
    no nie dokładnie bo jeden procesor jest uszkodony i z tym mam dylemat bo nie wiem co zrobic
  • #83
    Maciek4141
    Poziom 22  
    Oj no to nie dobrze. Możesz spróbować poszukać wsadu w sieci, lub zaczytać za pomocą programatora cały wsad na kompa i na nowy procesor "przelać" ale wątpię żeby ci się to udało, bo chińczyki zabezpieczają procesor przed takimi operacjami.

    Pozdrawiam
  • #84
    djice
    Poziom 15  
    a mam jeszcze taki pomysł jak by mi sie nie udało zczytać programu czy jest sens robienie na przykład 2laserów w jednej obudowie z jednym procesorem
    bo tak myślałem aby połączyć galva na jeden procesor czyli taki sam efekt ale 2 kolory lasera w jednej obudowie
  • #85
    bolek
    Specjalista - oświetlenie sceniczne
    jakie galva?! nie porównuj silnika do galva.

    możesz sobie spokojnie podłączyć dwa silniki równolegle, biorą na tyle mały prąd że ULNowni nic sie nie stanie. Jednak na wszelki wypadek proponuje zmierzyć prąd jaki bierze jeden komplet silnikó
  • #86
    djice
    Poziom 15  
    ale ja chcem dołozyc dodatkowo do kazdego dodatkowego silnika układ z ULN