Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Moduł przy akumulatorku w MP4 - uszkodzony ???

31 Mar 2008 18:54 5251 13
  • Poziom 11  
    Witam szanownych kolegów,
    Mam taki problem z mp4.
    We wnętrzu mp4 znajduje się akumulatorek przy którym znajduje się miniaturowy moduł. Przypuszczam, że kontroluje on poprawność ładowania w/w akumulatorka. Do tego modułu dochodzi dwoma przewodami 5V. Następnie ten moduł połączony jest dwoma przewodami z akumulatorkiem a na nich jest....... właśnie też 5V i prawdopodobnie to było przyczyną spuchnięcia akumulatorka. Próbowałem dobrać jakiś inny moduł z innych akumulatorków używanych w telefonach komórkowych ale niestety te moduły oparte są o inne układy a mają one więcej wyprowadzeń i pewnie są to to jakieś wyprowadzenia kontrolne, których tutaj brak.
    Czy ma ktoś może schemat takiego modułu albo wie, jak ten problem obejść ?? Sam akumulator jest NI-MH 3,7V 750 mAh.
    Moduł ma tylko 4 wyprowadzenia. 2 wejścia - 2 wyjścia.
    Pozdrawiam serdecznie.
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 31  
    Jesli mozesz umiesc fotki.
    przypuszczam, ze to twoje ogniwo zasilajace jest li-ion lub li-poly, spuchnietych NiMh jeszcze nie widzialem...a ogniwa litowe wymagaja specjalnej elektroniki kontrolujacej proces ladowania.Przypuszczam, ze twoja elektronika moze byc dobra...
    Masz jakis inny akumulator litowo-jonowy do podstawienia?
  • Poziom 11  
    Oczywiście, masz rację. Spuchł mi Li-Ion, gdyż podmieniłem go na próbę za Ni-Mh.
    W każdym razie na wejściu modułu jest 5V i na wyjściu jest 5V, a to nieprawidłowo.
    Oryginalnie akumulatorek był Ni-Mh. Powodem wymiany było to, że w ciągu 2 dni w wyłączonej mp4 wyładowywał się prawie całkowicie. Pomiar prądu w czasie czuwania był tak mały, że wyeliminowałem rozładowanie spowodowane np. uszkodzoną elektroniką.
    PS.Fotki modułu wystawie po przyjściu z pracy
  • Poziom 11  
    Zamieszczam zdjęcia modułu.
    U1 - 8205G
    U2 - CS231
    Za wszelką pomoc w zidentyfikowaniu tego ustrojstwa będę wdzięczny.
    Pozdrawiam.

    Moduł przy akumulatorku w MP4 - uszkodzony ???

    Moduł przy akumulatorku w MP4 - uszkodzony ???
  • Poziom 42  
    TPCS8205 - podwójny MOSFET Toschiby
    CS213 (a nie 231) - kontroler baterii. Ciężko o żywego PDFa, ale w tym: http://www.lt-power.com/UpLoadImage/2007/5/27/20075271043841059.pdf , na stronie 3, znajdziesz schemat.

    Akumulator na pewno nie jest NiMH tylko LiIon lub LiPoly. Z dużym prawdopodobieństwem uszkodzony jest MOSFET.
  • Poziom 31  
    Zgadzam sie z Romanem.
    Mysle, ze mozesz np. rozebrac jakis stary akumulator li-ion np. od Nokii, sa tam takie moduly...ja u siebie na stole mam w tej chwili jakas podrobke i jest tam cienka plyteczka z DW01+ i oczywiscie mosfetem, w razie czego mozesz zastosowac jakas taka plyteczke wlasnie z akkusa od tel.gsm


    Moduł przy akumulatorku w MP4 - uszkodzony ???
    Moduł przy akumulatorku w MP4 - uszkodzony ???
    Moduł przy akumulatorku w MP4 - uszkodzony ???

    http://www.ic-fortune.com/upload/Download/DW01+-DS-24_EN.pdf

    A w zalaczniku "żywy" pdf CS213 :D
    Załączniki:
  • Poziom 42  
    U mnie nadal nieżywy - wyświetla się tylko niebieskie logo na stronach od drugiej.
  • Poziom 31  
    Hmm, Roman-zrob cos ze swoim kompem.
    Mam Adobe readera 8.1.0 i doinstalowane rooozne pakiety jezykowe, wszystkie jakich kiedykolwiek moj Adobe chcial.Niemniej sam pdf tego CS213 jest w normalnym-angielskim jezyku wiec nie wiem czy wymaga innych czcionek.
    prosze bardzo-creeny z pulpitu


    Moduł przy akumulatorku w MP4 - uszkodzony ???

    Moduł przy akumulatorku w MP4 - uszkodzony ???
    Moduł przy akumulatorku w MP4 - uszkodzony ???
    Moduł przy akumulatorku w MP4 - uszkodzony ???
    Moduł przy akumulatorku w MP4 - uszkodzony ???



    jak potrzeba zeskanuje wszystko, tylko piszta :D
  • Poziom 11  
    Wielkie dzięki.
    Mam kilka modułów z innych "baterii" ale w każdym są inne scalaki. Próbowałem je użyć ale napięcia są jakieś niewyraźne. Na jednym ok.1,5V a na drugim ok. 2,2V. Być może muszą być wykorzystane dodatkowe wyjścia w tych modułach. Uzbrojony w schematy przez Was nadesłane - powalcze.

    U mnie też tylko loga :) ale w pracy mam starszą wersje Readera więc może dlatego.
    Co do baterii to na 100% jest Ni-MH, wieczorkiem dołączę fotkę tego akku.
  • Poziom 31  
    No to dziwna sprawa z tym Adobe readerem, pewnie kwestia update-ow bo na elke podeslalem plik ze swojego kompa ktory po otwarciu pokazuje mi to, co macie na screenshotach-normalny uczciwy pdf...
  • Poziom 11  
    Koledzy poradźcie, coś jest nie tak.

    Pozbyłem obudowy swój akumulatorek z Nokii żeby móc skontrolować jak zachowuje się moduł w nim podczas ładowania i nie tylko. Rozrysowałem schemat tego modułu i jedyna różnica względem zamieszczonego schematu jest taka, że z nóżki nr.2 wyprowadzone są dwa rezystory i dołączone do dwóch środkowych złoconych styków w module. Zamiast mp4 użyłem zasilacza regulowanego. I tak:
    Zasilacz podłączyłem do dwóch skrajnych wyprowadzeń z modułu czyli do BATT+ i BATT- według schematu. Ustawiłem na 5V i stwierdziłem, że prąd ładowania wynosi 750mA a zapewne byłby większy gdyby nie ograniczenia mojego zasilacza. Bateria w oczach puchła !
    Napięcie na wyjściu zasilacza miało 4,3V.
    Czyli wynika z tego, że te moduły nie ograniczają prądu a napięcie na wejściu musi być ok. 4,2V.
    Czy orientujecie się, czy jest właśnie tak, że to telefony i inne urządzenia regulują napięcie na wejściu akumulatora a co za tym idzie na wejściu modułu i musi ono wynosić ok.4,3V?
    Sam już teraz nie wiem, czy to moduł przy akumulatorku jest uszkodzony czy sama mp4 gdyż napięcie ładowania w tej mp4 równa się 5V.
    Przyznam, że trzy zdobyte moduły zachowują się tak samo.
    Pozdrawiam
  • Poziom 31  
    Ziutek, te moduly ktore sa montowane przy ogniwach litowych maja z reguly za zadanie zabezpieczenie przed nadmiernym napieciem...a bardziej skomplikowane i przed za duzym pradem. wartosc tego pradu jak i napiecia powinna byc wyregulowana przez uklad scalony zewnetrzny, zewnetrzny uklad ladowania.W bateriach nie ma kontrolerow ladowania.To zewnetrzna ladowarka, wbudowana w telefon czy inne urzadzenie, powinna dopilnowac by parametry ladowania ogniwa byly wlasciwe.,Pod obciazeniem napiecie powinno wynosic max 4,3V, prad w zaleznosci od ogniwka...
    jaka pojemnosc ma ten twoj akumulatorek w mp3/4?A moze dasz nazwe urzadzenia, poszukamy schematu?
  • Poziom 11  
    Właśnie rozebrałem mp4 i do czego doszedłem.
    Zasilić ją można albo z zasilacza zewnętrznego 5V albo z gniazda USB.
    Minus modułu w akumulatorze jest połączony z minusem zasilania ( i ogólną masą) a do plusa modułu dołączone jest te 5V ale przez diodę. Podczas ładowania na diodzie jest spadek ok. 0.5V czyli na moduł dochodzi ok. 4.6V.
    W tym momencie podłączyłem to wszystko aby się bateria ładowała, będę sprawdzał co jakiś czas napięcie na niej (tej oryginalnej).
    Ale intryguje mnie pewna rzecz.
    Pomierzyłem elementy na sucho (te które się da) i wygląda, że jest wszystko w porządku. Zwłaszcza, że inne moduły zachowują się tak samo. Dlaczego więc po wymianie ogniwa po jakimś czasie strasznie spuchło???
    Faktem jest, że to oryginalne wygląda inaczej. Jest pozbawione aluminiowej obudowy. Wygląda jak poxylina w sreberku.
    Wracając do tematu zastanawiam się jeszcze nad jedną rzeczą, dlaczego jak podepnę to spuchnięte ogniwo to napięcie rośnie na nim do poziomu napięcia zasilacza??? Czyli ten moduł jednak nie ma ograniczenia napięcia. Przecież po wykryciu, że napięcie na baterii jest powiedzmy już ok. 4.5V czy wyższe to układ powinien odłączyć sterowanie bramkami tranzystorów i ładowanie powinno zostać przerwane. A tak nie jest.
    Model mp4 to :
    http://www.xsonic.pl/xplayer-mp4-slidebox-2gb-sd-photo-p-723.html
    Pozdrawiam
  • Poziom 31  
    No jesli tak masz skonstruowane zasilanie a raczej ladowanie to po proastu porazka.Ogniwa litowo-jonowe czy litowo-polimerowe sa pod tym wzgledem bardzo wymagajace-bo inaczej puchna, co sam zauwazyles...a moze sie to skonczyc nawet eksplozja.
    Nie wiem co za cudowna dioda tam siedzi....ale jak na caly uklad ladowania akkusa to stanowczo za malo.Tez wydawalo mi sie, ze ten uklad zabezpieczajacy powinien odcinac zasilanie od li-iona w momencie gdy napiecie jest za wysokie...chyba, ze on to robi dopiero pod obciazeniem...tzn. gdy podlaczysz akku do zasilania napiecie zasilajace spada, bo akumulator dziala jak "dioda zenera"(sorki za moocne porownanie)...i moze ta elektronika odcina dopiero, gdy "pod obciazeniem" napiecie wzrasta powyzej 4,3V?Druga sprawa to prad, nie wiem jaka byla specyfikacja techniczna oryginalnego ogniwka, ale owe 750mA moze byc troche duzo.
    Moze zmajstruj sobie jakis prosty ukladzik ladowania li-ion, ktory by Ci sie tam zmiescil?
    Poczytaj:
    http://www.swiatelka.pl/viewtopic.php?t=3

    p.s. moze daj ogloszenie w odp.dziale ze szukasz schematu...