Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
IGE-XAOIGE-XAO
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zegarek i Termometr do samochodu

Tomcio7 21 Oct 2011 14:22 118739 175
  • #151
    dondu
    Moderator on vacation ...
    mateusz717828 wrote:
    mam pytanko czy grubość płytki ma znaczenia?znalazłem zakupiona parę lat temu płytkę o gr.2mm i zastanawiam się czy grubość ma znaczenie oraz w jakim celu wszystkie ścieżki cynuje się?

    Nie ma znaczenia. Cynuje się, by nie śniedziały i łatwiej się lutowało.
  • IGE-XAOIGE-XAO
  • #152
    mateusz717828
    Level 10  
    zrobiłem układ wychodząc z założenia mam płytkę,części i otwory w które należy je włożyć , każdy będzie umiał to zrobić .Niestety zrobiłem i nic nawet nie zaświecił LCD , nóżki 7 i 8 na Atmedze wskazują napięcie 5 v podczas regulacji potencjometrem zaświecił się LCD tzn bardzo słabo ponieważ widać kwadraciki na całej długości wyświetlacza nie wiem jak fachowo się to nazywa ale coś tam świeci .Zastanawiam się gdzie teraz sprawdzić napięcie na LCD na której nóżce czy jest 5v bo skoro słabo świeci czyli dostaje zaniżone napięcie a może ktoś go podkrada? Ma ktoś jakieś pomysły?
  • #153
    barti879
    Level 18  
    Napięcie dochodzące do LCD powinno być 5V i można je zmierzyć na 15 i 16 pinie wyświetlacza.
  • #154
    mateusz717828
    Level 10  
    obecnie jestem w pracy ale jak wroce to sprawdze ,co jesli nie bedzie 5v lub bedzie za mało chociaż bardziej obstawiam mniejsze nap.skoro Lcd świeci ale za slabo .Ktory elem.byłby odpowiedzialny?
  • #155
    mateusz717828
    Level 10  
    zmierzylem napiecie na podanych pinach i napiecie wynosi 0.01 gdzie s
    zukać problemu?
  • IGE-XAOIGE-XAO
  • #156
    kranzio
    Level 26  
    Wcześniej napisałeś, że na procku jest 5V. Z tego wynika, że gdzieś po drodze nie zalutowałeś jakiejś zworki lub czegoś innego. Czy procesor jest na pewno zaprogramowany? Wrzuć zdjęcie płytki od strony elementów i od strony ścieżek.
  • #158
    Sensej17
    Level 10  
    Witam. Przeglądnęłam post i nie mogę znaleźć kodu.(znaczy wydaje mi się że to w tym folderze lcd1307ds18b20wersja2 ) Gdzie jest kod aby zaprogramować zegarek i w czym trzeba go otworzyć, bo widzę pliki hex ale nie wiem jak je otworzyć bądź którą wersją programu. Posiadam AVR 4.18
  • #159
    Tomcio7
    Level 17  
    Witam,

    Ze względu na częste meile od użytkowników forum z prośbą o kod źródłowy, informuję iż go już nie posiadam, dlatego też nie wykonam żadnej dodatkowej kompilacji. Kod wynikowy różnych wersji termometru dostępny jest na początku.

    Przeglądając wątek widzę iż kod źródłowy (w znacznej części) został udostępniony w tym wątku: https://www.elektroda.pl/rtvforum/viewtopic.php?p=5291814#5291814

    Jeżeli są chętni do rozwijania tego termometru to oczywiście podane źródło można modyfikować i udostępniać innym.

    Pozdrawiam
  • #160
    mateusz717828
    Level 10  
    termometr złożony, lcd świeci lecz nie ma napisów początkowych jak również po ustawieniach w menu daty.godz itp i zatwierdzeniu na TAK nie wyświetla na przemian temp. i daty.Kolejna kwestia pokazuje mi termometr dziwne wskazania temp.począwszy od -357 poprzez 65 a dojdzie do temp.0 i nic więcej.Czym to może być spowodowane? dziękuje
  • #161
    mateusz717828
    Level 10  
    miał ktoś z was takie problemy??
  • #162
    Sensej17
    Level 10  
    Co do tych dziwnych wskazań sprawdź czy masz poprawnie podłączone czujniki ... u mnie były odwrotnie podłączone... i miałem podobne wskazania przy włączeniu pokazywało -175 a potem ciągle 0.
  • #163
    mateusz717828
    Level 10  
    a nie może być tak że uwalony może być scalak ten mały przy baterii??zauważyłem iż bateria uległa rozładowaniu czyli musi być gdzieś zwarcie.wrr
  • #164
    Jarko63
    Level 1  
    Witam!
    Ja zniszczyłem już 2 mikrokontrolery, bezpowrotnie.
    Mój problem polega na tymże po zaprogramowaniu układu sprawdzałem poprawność działania za pomocą 9V baterii i wszystko śmiga jak należy. Ale po podłączeniu do instalacji w samochodzie zauważalne jest bardzo powolne wyświetlanie informacji po kilku rozłączeniach i włączeniach pada podświetlenie wyświetlacza. W takim wypadku jedyny ratunek to ponowne wgranie programu. Lecz to nie zawsze jest możliwe bo jak wspomniałem 2 układy padły.
    Osobiście podejrzewam stabilizator (nie daje sobie rady) :cry:

    Czy miał ktoś podobny problem?
    Jeśli tak to jak sobie z nim poradził?
  • #165
    Maq134
    Level 9  
    Witam, mam pewien problem z zegarkiem. Otóż ładnie pięknie złożyłem sobie zegarek, ale na wyświetlaczu są kwadraty w dolnej linii. Pomierzyłem napięcia na nóżkach no i wyszlo że na większości coś jest, ale no właśnie ale...
    Na nóżce 5 oraz 6 jest wg mojego miernika 0,03 V i oscyluje do 0,01 (miernik metex m-3650).
    Napięcia nie ma tylko na nóżce 16 oraz i 1 (masa) więc zwarć też do nich nie ma. Otwory 7 8 9 10 w ogóle nie podłączone do wyświetlacza dodatkowo usunięte zwarcia z nóżką 11.

    Napięcie zasilania Atmegi8 równe 5 V
    Program wgrywany kilkukrotnie programatorem stk 200 w programie mkAVRCalculator. W programie oscylator wewnętrzny ustawiony na 1 MHz.

    Co może być i jak to "naprawić", bo już naprawdę nie mam siły do tego :( wersja z zegarkiem.

    Pozdrawiam i z góry dziękuje za odpowiedzi
  • #166
    mateusz717828
    Level 10  
    układ zrobiony przez kolegę który się troszkę przy nim namęczył .Jak oznajmił uwalony był stabilizator i czujniki , po wymianie zaczęło w końcu działać aż do momentu jak zacząłem przewody lutować ponieważ zaczęły się odrywać .I pojawił się problem zegarek wraz z data nie ma podtrzymania czyżby bateria? chociaż jest nowa no i oczywiście temp.na 1czujniku wskazuje dobrze natomiast na 2 jest np 40 stop. po wyjęciu czujnika jednego są wskazania obu temp tzn jedna jest stala a druga stopniowo rośnie,maleje.zamiana czujnika nic nie daje ponieważ jest tak samo jak z 2 czujnikami.
  • #167
    mateusz717828
    Level 10  
    czujnik wymieniłem na nowy i to samo jest wrr.
    zegarek już trzyma i jest ok.pozostaje kwestia czujników nic sie nie zmienia nadal pokazuje dziwne wskazania co może być przyczyna?
  • #168
    paol2
    Level 12  
    witam, zrobiłem ten zegar z termometrem super się spisuje a chciałem zrobić w smd i tu moje pytanie czy to dobrze połączyłem?? poniżej zdjęcie
    Zegarek i Termometr do samochodu
    czerwone linie to zworki a po prawej przyciski
    zapomniałem tylko dodać masę na wyświetlacz
  • #169
    dondu
    Moderator on vacation ...
    Według którego schematu robiłeś?
  • #170
    paol2
    Level 12  
    W/g pierwszego schematu z pierwszego postu autora. schemat był w CiCad`zie
  • #171
    dondu
    Moderator on vacation ...
    Niestety nie zadbałeś o prawidłowe podłączenie mikrokontrolera i wyciąłeś zasilanie jego części. To bardzo istotny błąd.
    Dodatkowo autor schematu, o którym na którym się wzorowałeś nie zadbał o filtrowanie zasilania i zadbanie o pin RESET, co jest bardzo istotne w projektach pracujących w środowiskach trudnych (duże zakłócenia) jakimi są samochody.

    Nanieś poprawki na schemat i PCB według następujących zasad: Minimalne podłączanie pinów mikrokontrolera
  • #172
    paol2
    Level 12  
    poprawiłem
    Zegarek i Termometr do samochodu

    najbardziej chodzi mi o połączenie wyświetlacza z Uc ale filtry na zasilanie będą tak jak i stabilizator i mostek prostowniczy (na wszelki wypadek)
  • #173
    stach1691
    Level 10  
    Witam;) Czy mógłby ktoś przerobić kod do drugiej wersji z zegarkiem tak aby miał funkcje takie jak w pierwszej wersji? może ktoś to już robił. Niestety sam nie umiem tego zrobić.
  • #174
    boody
    Level 1  
    ~Proszę o informacje:
    chcę kupić zestaw na ten zegarek z termometrem.
    Pozdrawiam
  • #175
    kranzio
    Level 26  
    boody wrote:
    ~Proszę o informacje:
    chcę kupić zestaw na ten zegarek z termometrem.
    Pozdrawiam

    Wszystko jest w pierwszym poście na pierwszej stronie. Jest tam schemat, tylko kolega musi sobie ściągnąć darmowy program KiCad.
  • #176
    Optimus Prime
    Level 14  
    Pytanie do autora. Czy jest szansa, żeby do termometra dodać wyświetlanie "C" sam symbol stopnia dziwnie wygląda.
    Pozdrawiam i z góry dziękuję za hex.