Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Toshiba Satellite l300-11l zawiesza się

kolbest 28 Lut 2011 20:24 2175 0
  • #1
    kolbest
    Poziom 9  
    Witam mam problem z laptopem koleżanki.

    Objawy :
    Zawieszenie się systemu windows vista po 2 minutach od włączenia systemu.Latop 2,5 roczny.

    Tak więc odpaliłem system awaryjny i wszystko elegancko śmigało.
    Odpaliłem antywirusy i system się zawieszał ,pojawił się blue screen informujący ,że komputer zostanie wyłączony w celu uchronienia przed zniszczeniem.

    Odpaliłem mem testa - 4 runy nic nie wykazały. Przełożyłem kości ze swojego laptopa i nadal ten sam problem.
    Zasilacz też nie jest problemem.

    Temperatury
    procesor 55 stopni ,
    Dysk twardy 40 stopni.

    *nie mogę znaleść specyfikacji z maksymalnymi temp.

    przy włączeniu przeglądarki itp w trybie awaryjnym nie wzrastają

    Mini dump:
    Code:
    Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
    
    Copyright (c) Microsoft Corporation. All rights reserved.


    Loading Dump File [F:\Mini012911-01.dmp]
    Mini Kernel Dump File: Only registers and stack trace are available

    Symbol search path is: SRV*c:\websymbols*http://msdl.microsoft.com/download/symbols
    Executable search path is:
    Windows Vista Kernel Version 6000 UP Free x86 compatible
    Product: WinNt, suite: TerminalServer SingleUserTS Personal
    Built by: 6000.17021.x86fre.vista_gdr.100218-0019
    Machine Name:
    Kernel base = 0x82400000 PsLoadedModuleList = 0x82511e10
    Debug session time: Sat Jan 29 17:35:47.166 2011 (UTC + 1:00)
    System Uptime: 0 days 23:25:13.100
    Loading Kernel Symbols
    ...............................................................
    ................................................................
    ..................
    Loading User Symbols
    Loading unloaded module list
    .....
    ERROR: FindPlugIns 8007007b
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    Use !analyze -v to get detailed debugging information.

    BugCheck D1, {4, 2, 0, 87f0a1e0}

    Probably caused by : nwifi.sys ( nwifi!MPSetInformation+177 )

    Followup: MachineOwner
    ---------

    kd> !analyze -v
    ERROR: FindPlugIns 8007007b
    *******************************************************************************
    *                                                                             *
    *                        Bugcheck Analysis                                    *
    *                                                                             *
    *******************************************************************************

    DRIVER_IRQL_NOT_LESS_OR_EQUAL (d1)
    An attempt was made to access a pageable (or completely invalid) address at an
    interrupt request level (IRQL) that is too high.  This is usually
    caused by drivers using improper addresses.
    If kernel debugger is available get stack backtrace.
    Arguments:
    Arg1: 00000004, memory referenced
    Arg2: 00000002, IRQL
    Arg3: 00000000, value 0 = read operation, 1 = write operation
    Arg4: 87f0a1e0, address which referenced memory

    Debugging Details:
    ------------------


    READ_ADDRESS: GetPointerFromAddress: unable to read from 825315ac
    Unable to read MiSystemVaType memory at 825117e0
     00000004

    CURRENT_IRQL:  2

    FAULTING_IP:
    ndis!NdisFIndicateStatus+11e
    87f0a1e0 8b4704          mov     eax,dword ptr [edi+4]

    CUSTOMER_CRASH_COUNT:  1

    DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

    BUGCHECK_STR:  0xD1

    PROCESS_NAME:  System

    TRAP_FRAME:  88006884 -- (.trap 0xffffffff88006884)
    ErrCode = 00000000
    eax=83e6b2d8 ebx=86c33c28 ecx=00000001 edx=00000000 esi=87cf1380 edi=00000000
    eip=87f0a1e0 esp=880068f8 ebp=88006944 iopl=0         nv up ei pl zr na pe nc
    cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
    ndis!NdisFIndicateStatus+0x11e:
    87f0a1e0 8b4704          mov     eax,dword ptr [edi+4] ds:0023:00000004=????????
    Resetting default scope

    LAST_CONTROL_TRANSFER:  from 87f0a1e0 to 8248fe14

    STACK_TEXT:
    88006884 87f0a1e0 badb0d00 00000000 83e3c33c nt!KiTrap0E+0x2ac
    88006944 a8b76bf7 00cf1380 8800696c 87cec008 ndis!NdisFIndicateStatus+0x11e
    880069b4 a8b7bc77 87cec008 fd010101 88006c84 nwifi!MPSetInformation+0x177
    880069e0 a8b7f445 87cec008 84670990 88006a50 nwifi!MP6Request+0xed
    880069f0 87fb693e 87dc1570 84670990 87cf15d8 nwifi!FilterRequest+0x13
    88006a50 87eff062 00cf1380 86c33c28 c0000001 ndis!ndisFDoOidRequest+0x199
    88006a7c 87efebc3 00000000 84670990 84670a10 ndis!ndisFQueueRequestOnNext+0x1be
    88006ae4 8cf622c4 86c33c28 84670990 827a4d90 ndis!NdisFOidRequest+0x139
    88006b04 87fb693e 86d5fd60 88006be8 86c33c28 pacer!PcFilterRequest+0x80
    88006b64 87efe3cb 00c33c28 00001388 88006be8 ndis!ndisFDoOidRequest+0x199
    88006b9c 87fcb6bc 86acf0e8 88006be8 00000000 ndis!ndisQueueRequestOnTop+0x24e
    88006bbc 87fe1b2f 00000000 00000000 00006be8 ndis!ndisQuerySetMiniport+0x166
    88006c78 87fe2b83 86acf0e8 00000001 fd010101 ndis!ndisQuerySetMiniportDeviceState+0xbb
    88006d34 87fcb013 84615b20 86acf0e8 88006d7c ndis!ndisDevicePowerOn+0x1e8
    88006d44 82478fc0 84615b20 00000000 83e6b2d8 ndis!ndisWorkItemHandler+0xe
    88006d7c 82625704 84615b20 8800d680 00000000 nt!ExpWorkerThread+0xfd
    88006dc0 8249162e 82478ec3 00000001 00000000 nt!PspSystemThreadStartup+0x9d
    00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x16


    STACK_COMMAND:  kb

    FOLLOWUP_IP:
    nwifi!MPSetInformation+177
    a8b76bf7 8b866c0c0000    mov     eax,dword ptr [esi+0C6Ch]

    SYMBOL_STACK_INDEX:  2

    SYMBOL_NAME:  nwifi!MPSetInformation+177

    FOLLOWUP_NAME:  MachineOwner

    MODULE_NAME: nwifi

    IMAGE_NAME:  nwifi.sys

    DEBUG_FLR_IMAGE_TIMESTAMP:  47916939

    FAILURE_BUCKET_ID:  0xD1_nwifi!MPSetInformation+177

    BUCKET_ID:  0xD1_nwifi!MPSetInformation+177

    Followup: MachineOwner
    ---------

    kd> lmvm nwifi
    start    end        module name
    a8b75000 a8ba0000   nwifi      (pdb symbols)          c:\websymbols\nwifi.pdb\C6EB7DECA7DB4BD187CD741BC052D0231\nwifi.pdb
        Loaded symbol image file: nwifi.sys
        Mapped memory image file: c:\websymbols\nwifi.sys\479169392b000\nwifi.sys
        Image path: \SystemRoot\system32\DRIVERS\nwifi.sys
        Image name: nwifi.sys
        Timestamp:        Sat Jan 19 04:06:33 2008 (47916939)
        CheckSum:         0003515D
        ImageSize:        0002B000
        File version:     6.0.6000.16632
        Product version:  6.0.6000.16632
        File flags:       0 (Mask 3F)
        File OS:          40004 NT Win32
        File type:        3.6 Driver
        File date:        00000000.00000000
        Translations:     0409.04b0
        CompanyName:      Microsoft Corporation
        ProductName:      Microsoft® Windows® Operating System
        InternalName:     NWiFi.SYS
        OriginalFilename: NWiFi.SYS
        ProductVersion:   6.0.6000.16632
        FileVersion:      6.0.6000.16632 (vista_gdr.080118-1500)
        FileDescription:  NativeWiFi Miniport Driver
        LegalCopyright:   © Microsoft Corporation. All rights reserved.


    Usunąłem sterownik ,ale nadal nic to nie zmieniło.

    Wsadziłem recovery , dysk został sformatowany instalacje przebiegła bez problemu ,ale przy pierwszym uruchomieniu po wyborze języka pojawia się czarny ekran i biała strzałka.

    uruchomienie trybu awaryjnego zawiesza się na moment przy sterowniku crcdisk.sys i następnie pojawia się również czarny ekran i biała strzałka ,a komputer zachowuje się tak jakby pracował normalnie (odgłosy).

    A następnie pojawia się okienko error ,że system nie może dokończyć instalacji w trybie awaryjnym.

    Uruchomiłem poprzez pendrive linuxa ,zrobiłem 10 godzinny test dysku wyszlo 197 bad blocków .(dysk 110 gb, jest podzielony na partycje 55 i 55 gb (na drugiej partycji znajduje się 4 gb recovery. To dla mnie nowość -recovery na dysku i do tego mam płytę recovery wypaloną po pierwszym uruchomieniu przez koleżankę). Smart short nie znajduje błędów , Smart long przerywa prace po 10% z powodu błędu.

    Code:
    smartctl 5.39.1 2010-01-28 r3054 [i486-slackware-linux-gnu] (local build)
    
    Copyright (C) 2002-10 by Bruce Allen, http://smartmontools.sourceforge.net

    === START OF INFORMATION SECTION ===
    Model Family:     Hitachi Travelstar 5K250 series
    Device Model:     Hitachi HTS542512K9SA00
    Serial Number:    080517BB6200WBF21SWG
    Firmware Version: BB2OC33P
    User Capacity:    120,034,123,776 bytes
    Device is:        In smartctl database [for details use: -P show]
    ATA Version is:   8
    ATA Standard is:  ATA-8-ACS revision 3f
    Local Time is:    Sun Feb 27 22:51:42 2011 UTC
    SMART support is: Available - device has SMART capability.
    SMART support is: Enabled

    === START OF READ SMART DATA SECTION ===
    SMART overall-health self-assessment test result: PASSED

    General SMART Values:
    Offline data collection status:  (0x00)   Offline data collection activity
                   was never started.
                   Auto Offline Data Collection: Disabled.
    Self-test execution status:      ( 121)   The previous self-test completed having
                   the read element of the test failed.
    Total time to complete Offline
    data collection:        ( 645) seconds.
    Offline data collection
    capabilities:           (0x5b) SMART execute Offline immediate.
                   Auto Offline data collection on/off support.
                   Suspend Offline collection upon new
                   command.
                   Offline surface scan supported.
                   Self-test supported.
                   No Conveyance Self-test supported.
                   Selective Self-test supported.
    SMART capabilities:            (0x0003)   Saves SMART data before entering
                   power-saving mode.
                   Supports SMART auto save timer.
    Error logging capability:        (0x01)   Error logging supported.
                   General Purpose Logging supported.
    Short self-test routine
    recommended polling time:     (   2) minutes.
    Extended self-test routine
    recommended polling time:     (  56) minutes.
    SCT capabilities:           (0x003d)   SCT Status supported.
                   SCT Feature Control supported.
                   SCT Data Table supported.

    SMART Attributes Data Structure revision number: 16
    Vendor Specific SMART Attributes with Thresholds:
    ID# ATTRIBUTE_NAME          FLAG     VALUE WORST THRESH TYPE      UPDATED  WHEN_FAILED RAW_VALUE
      1 Raw_Read_Error_Rate     0x000b   100   100   062    Pre-fail  Always       -       65536
      2 Throughput_Performance  0x0005   100   100   040    Pre-fail  Offline      -       0
      3 Spin_Up_Time            0x0007   253   253   033    Pre-fail  Always       -       0
      4 Start_Stop_Count        0x0012   098   098   000    Old_age   Always       -       3435
      5 Reallocated_Sector_Ct   0x0033   100   100   005    Pre-fail  Always       -       0
      7 Seek_Error_Rate         0x000b   100   100   067    Pre-fail  Always       -       0
      8 Seek_Time_Performance   0x0005   100   100   040    Pre-fail  Offline      -       0
      9 Power_On_Hours          0x0012   091   091   000    Old_age   Always       -       4254
     10 Spin_Retry_Count        0x0013   100   100   060    Pre-fail  Always       -       0
     12 Power_Cycle_Count       0x0032   099   099   000    Old_age   Always       -       2421
    191 G-Sense_Error_Rate      0x000a   100   100   000    Old_age   Always       -       0
    192 Power-Off_Retract_Count 0x0032   100   100   000    Old_age   Always       -       76
    193 Load_Cycle_Count        0x0012   089   089   000    Old_age   Always       -       113540
    194 Temperature_Celsius     0x0002   141   141   000    Old_age   Always       -       39 (Lifetime Min/Max 17/54)
    196 Reallocated_Event_Count 0x0032   100   100   000    Old_age   Always       -       31
    197 Current_Pending_Sector  0x0022   100   100   000    Old_age   Always       -       49
    198 Offline_Uncorrectable   0x0008   100   100   000    Old_age   Offline      -       0
    199 UDMA_CRC_Error_Count    0x000a   200   200   000    Old_age   Always       -       6
    223 Load_Retry_Count        0x000a   100   100   000    Old_age   Always       -       0

    SMART Error Log Version: 1
    No Errors Logged

    SMART Self-test log structure revision number 1
    Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
    # 1  Extended offline    Completed: read failure       90%      4254         11388318
    # 2  Extended offline    Completed: read failure       90%      4244         11388318
    # 3  Short offline       Completed without error       00%      4244         -
    # 4  Extended offline    Completed: read failure       90%      4244         11388318
    # 5  Extended offline    Completed: read failure       90%      4243         11388318

    SMART Selective self-test log data structure revision number 1
     SPAN  MIN_LBA  MAX_LBA  CURRENT_TEST_STATUS
        1        0        0  Not_testing
        2        0        0  Not_testing
        3        0        0  Not_testing
        4        0        0  Not_testing
        5        0        0  Not_testing
    Selective self-test flags (0x0):
      After scanning selected spans, do NOT read-scan remainder of disk.
    If Selective self-test is pending on power-up, resume after 0 minute delay.


    Nie wiem co obecnie zrobić.Te 200 bad blockow i przerwana praca smart powinna od razu sugerować ,że to dysk twardy i nie ma co kombinować tylko kupić nowy ? czy może rozkręcać i wyjąć karte sieciową? - bo to też mi teraz przychodzi do głowy.

    Edit

    Dodano po 43 [minuty]:

    Przewietrzyłem sprężonym powietrzem co się dało bez rozkręcania i usunąłem ten sterownik. Przy normalnym uruchomieniu bez efektu,ale uruchomiłem tryb awaryjny wyskoczył ten sam error co wcześniej o nie możności dokończenia i instalacji .Komputer zbootował się i ku mojemu zaskoczeniu dokończył instalacje.

    Tak więc system się zainstalował i już go użytkuje 20 minut bez problemów i boję się skorzystać z przycisku ponownie uruchom komputer zanim nie dowiem się czegoś więcej.

    Temperatura procesora przy maksymalnym obciążeniu

    64 stopnie
    Bez obciążenia 58 stopni

    dysk twardy 44 stopnie.


    Mimo ,że usunąłem nwifi.sys wifi działa bez problemu.

    Dodano po 3 [godziny] 6 [minuty]:

    no nic zainstalowało się jakimś cudem ,ale nadal się wiesza.