Elektroda.pl
Elektroda.pl
X
Arrow Multisolution Day
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Atmega8 złe działanie programu

patrykan15p 18 Lut 2015 22:49 540 7
  • #1 18 Lut 2015 22:49
    patrykan15p
    Poziom 8  

    Witam. Zaczynam naukę programowania. Posiadam atmege8 .Napisałem prosty program(w Bascomie) , który ma zapalać diodę na 1sek. , po czym ją gasić na 1 sek. Po zaprogramowaniu dioda zapala się na ok. 8 sek. ,i gaśnie też na ok. 8 sek. dlaczego?

    0 7
  • Arrow Multisolution Day
  • #2 18 Lut 2015 22:55
    Pi0trek121
    Poziom 23  

    Najprawdopodobniej funkcja delay której użyłeś jest przeznaczona na kwarc 8MHz a Twój procesor ma częstotliwość 1Mhz, tak na przyszłość podawaj kod, bo bez tego można tylko gdybać.

    0
  • #3 18 Lut 2015 22:57
    patrykan15p
    Poziom 8  

    Kod: basic4gl
    Zaloguj się, aby zobaczyć kod

    0
  • Arrow Multisolution Day
  • #4 18 Lut 2015 23:11
    Pi0trek121
    Poziom 23  

    No niestety, nie mój język, (następnym razem pisz w jakim języku piszesz) mogę Ci polecić półśrodek... zwiększ częstotliwość wewnętrznego oscylatora na 8MHz

    0
  • #5 18 Lut 2015 23:17
    patrykan15p
    Poziom 8  

    A wiesz jak to zrobić w Bascomie?

    0
  • #6 18 Lut 2015 23:24
    Pi0trek121
    Poziom 23  

    Nie, znam tylko C, poczekaj trochę ktoś Ci pomoże, i popraw temat i treść - napisz jaki język zanim moderator dostanie się do Twojego tematu.

    0
  • Pomocny post
    #7 19 Lut 2015 00:19
    373522
    Użytkownik usunął konto  
  • #8 19 Lut 2015 00:21
    patrykan15p
    Poziom 8  

    Wielkie Dzięki zadziałało.

    0