Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Port szeregowy COM nie działa z dekoderem.

ONTI 20 Mar 2006 09:33 1172 10
  • #1
    ONTI
    Level 10  
    Witam!

    Szukałem na forum czegoś na ten temat lecz nie znalazłem.
    Mam nową płytę EPoX 4PDA3 która posiada jeden port COM1.
    W panel ster., urządzenia, ... pisze że urządzenie (COM1) działa poprawnie. Jednak po podłączeniu np. dekodera Ferguson i próbie połączenia pokazuje się komunikat: "SetupCoom function failed (win error code:1) " (próbowałem zaznaczać również COM2 i nic)
    Na innych kompach nie ma najmniejszego problemu, ten sam dekoder i kabelek, i wszystko chodzi.

    Proszę o pomoc
    z góry dziękuje

    Onti
  • #3
    ONTI
    Level 10  
    Mam xp, jestem laikiem co znaczy "userport"?
  • #4
    Zuchan
    Level 16  
    To programik do obsługi portów, nazwa programu - useport, link do ściągnięcia masz powyżej.
  • #6
    jankolo
    R.I.P. Meritorious for the elektroda.pl
    edi22 wrote:
    uwalony RS-232

    Uzasadnij, proszę, swoją diagnozę.
  • #7
    mbo
    VIP Meritorious for electroda.pl
    edi22 wrote:
    uwalony RS-232


    W jaki sposób może być uszkodzony jeśli pod innym systemem działa poprawnie ?
  • #8
    Brick_G
    Level 28  
    Czego uzywasz do rozmowy z Ferdkiem? Arionera? Zodiac Edita? Tam w opcjach ustawia sie port na ktorym pracuje program to raz. Czasem trzeba wlaczyc program 2x zeby uzyskal dostep do portu, albo uzyc innego programu. Pod 9x na pewno to dziala bo tam mozliwy jest bezposredni dostep do portow COM. Przykladowo SM2BUs nie chce dzialac w zaden sposob pod XPekiem.

    Polecam fajne forum : http://laki.dvhk.pl/
  • #9
    ONTI
    Level 10  
    Pracujęe na tych samych programach, na tym samym kabelku, i na innym PC działa!

    Dodano po 4 [minuty]:

    Spróbowałem userport-em, ale choć robie w/g wskazówek to nie działa.
    W jaki sposób mogę sprawdzać czy działa port COM żeby nie testować ciągle na fergusonie (mogę go uszkodzić).
    Może jakieś napięcie na wyjściu, na którymś pinie?
  • #10
    jankolo
    R.I.P. Meritorious for the elektroda.pl
    ONTI wrote:
    W jaki sposób mogę sprawdzać czy działa port COM żeby nie testować ciągle na fergusonie (mogę go uszkodzić).

    Najprościej - moim zdaniem - przy pomocy starej myszy dostosowanej do pracy w porcie szeregowym.
  • #11
    marek003
    Level 40  
    A może na twoi kompie inny program już używa (rezerwuje dla siebie) com1 ???