Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Debian Sarge - problem z siecią :|

29 Sty 2007 11:19 1592 20
  • Poziom 25  
    Po instalacji systemu bazowego Debian Sarge konfiguruję kartę sieciową. Została ona poprawnie wykryta i moduł obsługi został władowany do jądra systemu. Dopisałem tylko do pliku /etc/network/interfaces ip, bramę, maskę i dnsy
    Code:
    # This file describes the network interfaces available on your system
    
    # and how to activate them. For more information, see interfaces(5).

    # The loopback network interface
    auto lo
    iface lo inet loopback

    # The primary network interface
    auto eth0
    iface eth0 inet static
       address 192.168.1.2
       netmask 255.255.255.0
       network 192.168.1.0
       broadcast 192.168.1.255
       gateway 192.168.1.2
       # dns-* options are implemented by the resolvconf package, if installed
       dns-nameservers 194.204.151.34,194.204.159.1


    Po restarcie karta sieciowa działa i internet powinen tez ale jest problem. Gdy puszczam pinga na router to dostaje odpowiedz, wpisując zamiast ip np. onet.pl ping nie zostaje wysłany tylko piszę że host nie znany :(
    Może trzeba coś zmienić ?? Prosiłbym o pomoc bo bez internetu nie mogę zainstalować x.org. Na innych dystrybucjach linux internet działa bez problemu, więc nie jest to winna sprzętu.

    Pozdrawiam
  • Poziom 20  
    Cytat:

    dns-nameservers 194.204.151.34,194.204.159.1

    Mały błąd nie daje się przecina tylko "; " ma być tak
    dns-nameservers 194.204.151.34;194.204.159.1
    albo tak :
    dns-nameservers 194.204.151.34
    dns-nameservers 194.204.159.1
  • Poziom 25  
    Internet już działa, ale problem pojawił się z zainstalowaniem x.org. Uzupełniłem repozytoria o testowe. Gdy juz pobrało wszystkie pakiet na końcu pyta:

    Remove the running kernel image (kernel-image-2.4.27-2-386)

    wyskakuje bład i nie kończy :(

    Czy musze zaktualizować jądro systemu aby zainstalować x.org ??
  • Poziom 20  
    jeśłi masz nowe pakiety i nowe x to niestety tak jajko 2.6
  • Poziom 25  
    Próbuje zainstalować kernel 2.6.8.-3 ale dalej wyskakuje błąd z
    Remove the running kernel image (kernel-image-2.4.27-2-386)
  • Poziom 20  
    Hmm nie było problemów z zależnościami pakietów , poszukaj w wyszukiwarce czytałem jest tam dużo na ten temat, jeśli wszystko było ok "usmaż" sobie jajeczko sam takie jakie potrzebujesz .
  • Poziom 25  
    Udało mi się zainstalować jądro 2.6.8 i x.org dopiero po aktualizacji systemu. X'y się uruchomiły :) lecz radość była przedwczesna po ponownym uruchomieniu juz się nie pojawiły :|

    i wywala to

    Code:
    Fatal server error:
    
    failed to initialize core devices
    (**) RADEON(0): RADEONLeaveVT
    (**) RADEON(0): RADEONRestore
    (**) RADEON(0): RADEONRestoreMode()
    (**) RADEON(0): RADEONRestoreMode(0x81fca28)
    (**) RADEON(0): RADEONRestoreMemMapRegisters() :
    (**) RADEON(0):   MC_FB_LOCATION   : 0x1fff0000
    (**) RADEON(0):   MC_AGP_LOCATION  : 0x27ff2000
    (**) RADEON(0):   Map Changed ! Applying ...
    (**) RADEON(0):   Map applied, resetting engine ...
    (**) RADEON(0): Updating display base addresses...
    (**) RADEON(0): Memory map updated.
    (**) RADEON(0): Programming CRTC1, offset: 0x00000000
    (**) RADEON(0): Wrote: 0x0000000c 0x00030065 0x00000000 (0x0000a700)
    (**) RADEON(0): Wrote: rd=12, fd=101, pd=3
    (**) RADEON(0): Ok, leaving now...
  • Poziom 20  
    Kłania się kofiguracja sterowników od ATI ew. pobrać i zainstalować nowe
  • Poziom 25  
    Nadali ciemność robiłem dpkg-reconfigure xserver-xorg i dalej nic :|

    Code:
    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath " /usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic" ;
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/sha re/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:u nscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts /X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath &q uot;/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi& quot;
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/ lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "bitmap"
    Load "dbe"
    Load " ddc"
    Load "dri"
    Load "extmod"
    Load "freetype& quot;
    Load "glx"
    Load "int10"
    Load "record" < br> Load "v4l"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Opt ion "XkbRules" "xorg"
    Option "XkbModel" "pc105&q uot;
    Option "XkbLayout" "pl"
    Option "XkbVariant" "en"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Optio n "Device" "/dev/psaux"
    Option "Protocol" "ImP S/2"
    Option "Emulate3Buttons" "true"
    EndSection
    Section "Device"
    Identifier "ATI Technologies Inc RV280 [Radeon 9200 PRO]"
    Driver "ati"
    BusID "PCI:1:0:0"
    VideoRam 13 1072
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    HorizSync 31-70
    VertRefresh 50-160
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "ATI Technologies Inc RV280 [Radeon 9200 PRO]"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1152x864" "1152x768" "1024x768" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection
  • Poziom 20  
    A co słychać w logach systemowych gdy startują X-y , bo tutaj wydaje się wszystko ok. Mniemam że koputer pracuje we właśćiwym init -cie graficznym (domyśny dla debiana)
  • Poziom 25  
    Pobrałem sterowniki i zainstalowałe ale ciągle nic :|
    a tu są logi x.org
    http://phpfi.com/198912

    Jeszcze mam pytanie jak zainstalowac paczki deb jeśli mam jen na dysku twardym ??
  • Poziom 33  
    paczki deb instalujesz poleceniem
    Code:
    dpkg --install nazwa_paczki.deb
    


    napisałes wczesniej :
    Cytat:
    Próbuje zainstalować kernel 2.6.8.-3 ale dalej wyskakuje błąd z
    Remove the running kernel image (kernel-image-2.4.27-2-386)


    tłumacząc bład :
    usun juz uruchomiony obraz (kernel-image) wiec pozbadź się wczesniejszej wersji i spróbuj ponownie
  • Poziom 20  
    Witam patrz na znaczniki " (EE) " tam są błędy , co do instalacji pakietów w debianie zalecam poczytać dokumentację dpkg-doc ew man .
    http://www.debian.org/

    Dodano po 5 [minuty]:

    Witam czy w debianie trzeba usuwać obraz jądra skoro wybiera się je zaraz po wczytaniu lilo bądz grub -a , faktem jest że debian żądzi się swoimi prawami . Pozdrawiam
  • Poziom 25  
    Czyli dobrze zrozumiałem, że problem jest po stromie myszki.
    Code:
    (EE) xf86OpenSerial: Cannot open device /dev/psaux
    
        No such device.
    (EE) Configured Mouse: cannot open input device
    (EE) PreInit failed for input device "Configured Mouse"
    (II) UnloadModule: "mouse"
    (WW) No core pointer registered
    (II) XINPUT: Adding extended input device "Generic Keyboard" (type: KEYBOARD)
        xkb_keycodes             { include "xfree86+aliases(qwerty)" };
        xkb_types                { include "complete" };
        xkb_compatibility        { include "complete" };
        xkb_symbols              { include "pc(pc105)+pl(en)" };
        xkb_geometry             { include "pc(pc105)" };
    No core pointer

    Fatal server error:
    failed to initialize core devices

    Zaraz po instalcji x.org myszka działała :| jest to myszka pod usb na przejściówce ps/2.
  • Poziom 20  
    ale zobacz na pierwszy wpis w sekcji :
    (II) fglrx(0): [drm] drmOpen failed
    (EE) fglrx(0): DRIScreenInit failed!
  • Poziom 33  
    axeland napisał:

    Witam czy w debianie trzeba usuwać obraz jądra skoro wybiera się je zaraz po wczytaniu lilo bądz grub -a , faktem jest że debian żądzi się swoimi prawami . Pozdrawiam

    niemusisz debian jak kazdy inny linux mam taki sam bootloader
    np u mnie lilo wygląda tak :
    Code:
    lba32 # Allow booting past 1024th cylinder with a recent BIOS
    
    boot = /dev/hda
    prompt
    timeout = 50
    # Normal VGA console
    vga = normal

    image = /boot/vmlinuz
    root = /dev/hda2
    label = Linux

    #
    image = /boot/vmlinuz24
    root = /dev/hda2
    label = Linux24
    #
    image = /boot/vmlinuz2.6.16.1
    root = /dev/hda2
    label = Linux26a
    ########################################
    image = /boot/vmlinuz2.6.16.1    -         sciezka do kernela i nazwa pliku pod jaka siedzi
    root = /dev/hda2             -  partycja na jakiej sie znajduje
    label = Linux26a         - nazwa pod jaka ma byc w okienku wyboru

    a jeszcze jedno jajko chce zainstalować ;)
  • Poziom 25  
    Tylko nie wiem co z tym zrobić :|

    Code:
    (II) fglrx(0): [drm] drmOpen failed
    
    (EE) fglrx(0): DRIScreenInit failed!
  • Poziom 20  
    Cytat:
    niemusisz debian jak kazdy inny linux mam taki sam bootloader

    Też tak sądziłem bo mam ich kilka jak się skończy 100M w /boot to będę usuwał te które mi nie leżą ,

    Z tego co opisywał Kolega Mody zmieniał jajko 2.4 na ,2.6.8.-3 niestety duże zmiany pomiędzy tymi dwoma jądrami dodatkowo nowe X-y i nowe jądro aktualizacje pakietów aby to wszysko pogodzić naprawdę trzeba się pomęczyć , często problemy z prawidłową konfiguracją karty graficznej choć to ATI 9200i z nimi raczej nie ma aż tak wielkich problemów , ciężko przez to przebrnąć , dodatkowo dużo komunikatów ostrzeżeń sekcje zaczynające się na : (WW) oczywiście (EE) to już następstwo wcześniejszych błędów . Ze nie znalazło myszy PS2 to nic skoro istnieje Na USB (tym można zając się puźniej ) najbardziej marwi mnie sekcja "(EE) fglrx(0): DRIScreenInit failed" mniemam że to problem ze sterownikiem .
  • Poziom 25  
    Ponownie zainstalowaem system ale ju bez aktualizacji do etcha i jadra do 2.6.3. Zaraz po instalacji xfree86 doinstalowale sterowki ati i teraz smiga. Pojawil sie problem z obsluga klawiatury a dokladnie nie ma polskich znakow i wyskakuje taki blad
    https://obrazki.elektroda.pl/39_1170192843.png
  • Poziom 33  
    Mody napisał:
    Ponownie zainstalowaem system ale ju bez aktualizacji do etcha i jadra do 2.6.3. Zaraz po instalacji xfree86 doinstalowale sterowki ati i teraz smiga. Pojawil sie problem z obsluga klawiatury a dokladnie nie ma polskich znakow i wyskakuje taki blad
    https://obrazki.elektroda.pl/39_1170192843.png

    zainstaluj spolszczenie do debiana :)
    Code:
    apt-get install fonty
    
    apt-get install manpages-pl
    apt-get install manpages-pl-dev
    apt-get install doc-linux-pl
    apt-get install doc-linux-pl-html

    powinno pomóc ,
    ja z etch mam przykre doswiadczenia polecam wersje sarge z kernelem 2.6.18 ,tu masz szerszy opis http://forum.dug.net.pl/viewtopic.php?t=4771 ,etch jest dosc niestabliny ,niewiem czy to przez niektóre pakiety (libgc+,gcc) ale lepieje przejsc z sarge na sid .

    przejscie z jajka 2.4 na 2.6 to nic trudnego ,wsytarzy zainstalowac odpowiednie pakiety przed kompilacja jajka , po zainstalowaniu i uruchomieniu upgrade systemu i sam pozamienia pakiety w systemie :D
  • Poziom 25  
    Dalej męczę się z klawiaturą ciągle mam problem xkb :|