Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Gamma 3 Philips, nowa pamięć, SAFE, SAFE1, przyczyna?

curylop 19 Kwi 2008 18:29 2676 13
  • #1 19 Kwi 2008 18:29
    curylop
    Poziom 15  

    Mam takie radio posiada pamięci 24C02 i 24C04. Ponieważ miałem problem że kaseta cicho grała i radio na FM (ledwie było co słychać). Pomyślałem ze to coś z pamięciami. przekładając pamięć 24c04 z programatora do radia - tak parę razy. Urwały mi się nóżki i włożyłem nową pamięć do radia. I teraz gdy włączę radio pisze SAFE, wpisze kod (na pewno dobry) wyskakuje SAFE 1 puszcze przyciski i tyle. Nic na wyświetlaczu nie pokazuje. Co może być przyczyną tego że tak jest??

    0 13
  • #2 19 Kwi 2008 18:40
    jurkuc
    Poziom 27  

    Tak się właśnie kończy - przepraszam za wyrażenie - bezmyślne przekładanie pamięci. Tym bardziej, że w tym radioodtwarzaczu kod nie jest zapisany w żadnej z tych pamięci, lecz w jednym z procesorów.
    Ale do rzeczy, napis SAFE to nic innego jak pytanie o kod. Aby wywołać możliwość wpisywania kodu należy nacisnąć jednocześnie klawisze:
    M + VF ( przez co najmniej 5 s ), następnie wpisać kod i ponownie zatwierdzić tymi samymi klawiszami. A skoro pojawia się napis SAFE1 więc kod jest nieprawidłowy. Tak mogło się stać właśnie z powodu zamiany eepromów.
    Odszukanie właściwego ( czytaj zmnienionego ) kodu można zrealizować tzw. " klepaczem ", o którym pisano wielokrotnie na elektrodzie.

    0
  • #3 19 Kwi 2008 20:41
    LWD11
    Poziom 29  

    brrrrrrrrrr. nie lubie klepać gammy3

    0
  • #4 19 Kwi 2008 23:41
    curylop
    Poziom 15  

    jurkuc napisał:
    Tak mogło się stać właśnie z powodu zamiany eepromów.
    Odszukanie właściwego ( czytaj zmnienionego ) kodu można zrealizować tzw. " klepaczem ", o którym pisano wielokrotnie na elektrodzie.

    sam wyżej napisałeś ze kod siedzi w procesorze wiec kod się nie mógł zmienić. najwyżej licznik błędów mógł się zmienić.

    0
  • #6 20 Kwi 2008 15:28
    rob1
    Poziom 23  

    witam
    dla niemajacego wprawy radio trudne do zrobienia,wymaga klepacza a przy niektorych kompach jest wymagana jego modyfikacja gdyz podlaczenie blokuje szyne i2c ,jesli niemasz doswiadczenia to sobie odpusc

    0
  • #7 20 Kwi 2008 21:18
    SlaweK
    Poziom 43  

    Tak, tylko że Gamm3 było kilka wersji różniących się softem i dlatego podkładanie pamięci nie zawsze się udaje jak nie znasz wersji. Miałem sztuki z wysypaną samoczynnie pamięcią i z wysypaną podczas szukania kodu a także źle wlutowane pamieci, to delikatny druk, trzeba uważać.

    SławeK

    0
  • #8 20 Kwi 2008 22:13
    apap
    Poziom 21  

    Curylop, były trzy wersje gammy. Gamma3 miała dwie pamięci x2404, gamma 3A i 3B miały X2404 i X2402. Napisz, jaki masz procesor, gamma 3b miała najbardziej wyrafinowany algo znajdowania kodu.
    Jurkuc - nieprawda, w gammie 3b przy niewłaściwym wpisie w #EEh nawet podanie właściwego kodu również skutkuje SAFE1

    0
  • #9 20 Kwi 2008 22:31
    curylop
    Poziom 15  

    rob1 napisał:
    witam
    dla niemajacego wprawy radio trudne do zrobienia,wymaga klepacza a przy niektorych kompach jest wymagana jego modyfikacja gdyz podlaczenie blokuje szyne i2c ,jesli niemasz doswiadczenia to sobie odpusc


    Powtarzam po raz kolejny kod posiadam. Wiec nie wiem po co ten klepacz.

    Procesor to TMP47P860N

    0
  • #10 20 Kwi 2008 23:08
    apap
    Poziom 21  

    Jeżeli Twój kod jest właściwy, to wrzuć do 2402:
    #CD: 00
    #EE: 00
    Jeżeli kod masz np. 1234, to wpisz:
    #FE: 12 - pierwsza i druga cyfra kodu
    #FF: 34 - trzecia i czwarta cyfra kodu.
    Wlutuj eeprom, podłącz i włącz radio - jeżeli kod jest właściwy, radio MUSI włączyć się bez kodu -
    Pozdr

    0
  • #11 21 Kwi 2008 18:28
    curylop
    Poziom 15  

    Zrobiłem tak jak apap pisze i po włączeniu już nie pyta o kod tylko od razu czysty wyświetlacz

    0
  • Pomocny post
    #12 21 Kwi 2008 18:32
    apap
    Poziom 21  

    OK, od tego trzeba może było zacząć - prześlij mi oryginalną treść Twojej pamięci.

    0
  • #13 21 Kwi 2008 19:47
    curylop
    Poziom 15  

    wgrałem tez pliki jurkuca i dalej to samo wiec jeśli przyśle swoje pliki to nic to nie da chyba ze się mylę.

    Dodano po 1 [godziny] 6 [minuty]:

    Witam ponownie problem rozwiązany.
    Na samym początku jak się zabrałem za to do roboty radio na FM i kaseta cicho grała. wiec jak lutowałem to cyna przypadkowo złączyła mi 2 miejsca na płytce i stąd ten pusty wyświetlacz. zmiana binów w pamięciach tez myślę ze pomogła. Dziękuje wszystkim za pomoc

    0
  • #14 21 Kwi 2008 22:12
    apap
    Poziom 21  

    Cieszę się, że w końcu sukces, proponował bym Ci jednak użyć Twojego oryginalnego bina, nie pamiętam na 100%, ale tam mogą być parametry poustawiane przez factory na etapie strojenia, jest wiele takich sprzętów, w tej chwili masz działającego klona cudzego radia, na Twoim binie może być po prostu lepiej.
    Pozdrowienia

    0
  Szukaj w 5mln produktów