Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Compaq Armada 1700 - który komponent nawala ?

strazaq 13 Mar 2009 18:12 1589 8
  • #1
    strazaq
    Level 10  
    Witam,
    kupiłem ostatnio na allegro używanego Compaqa Armade 1700 6233/T/4000/D/0/1. Po odpaleniu laptopa zauważyłem zmodyfikowany nieco ekran powitalny. Pod nazwą Compaq widnieje nazwa prywatnego warsztatu samochodowego. Dysk laptopa jest "czysty". Nie ma na nim żadnego systemu. Laptop na starcie bootuje z dyskietki, z CD i z HDD. Pierwsze próby bootowania systemu z CD nie powiodły się. Zmieniałem płyty od Win95 po XP i żadna nie ruszyła. Przy czytaniu niektórych płyt napęd chrobotał, więc padło na wadliwy CD. Spróbowałem więc bootowania z dyskietki. Miałem kilka dyskietek startowych z różnych systemów, ale odpaliła tylko jedna, z najstarszym DOSem. Co ciekawe napęd nie widzi dyskietek formatowanych jako FAT w systemie XP. Z kolei dyskietki formatowane w laptopie nie są widziane w XP na drugim komputerze i nie dają się w nim ponownie sformatować. Trochę zgłupiałem i nie wiem dlaczego tak się dzieje.
    Korzystając z tego, że DOS mi się uruchomił z dyskietki, odpaliłem FDISK. Na komputerze była tylko jedna partycja, zajmująca cały dysk. Dysk jest sprawny, bo jest widziany w innym laptopie i da się go formatować. Wyczytałem, że te laptopy mają BIOS na dysku, na specjalnej partycji. FDISK nie znalazł żadnej takiej partycji, więc zdziwiłem się skąd ta reklama warsztatu przy starcie laptopa. Próbowałem wejść do biosu przez F10, DEL, F1 i F2. Nie da się, czyli Biosu raczej nie ma (logiczne skoro nie ma partycji biosowej, tylko gdzie siedzi ta reklama?). Ściągnąłem ze strony HP odpowiedni Setup for portables oraz Rompaq. Wrzuciłem je na dyskietki pod XP na drugim komputerze i oczywiście laptop tych dyskietek nie widzi. Jakimś cudem udało mi się jednak nagrać płytę bootowalną z Win98 i dorzuciłem do tej płyty programy od Compaqa. Nie wiem dlaczego komputer bootuje się tylko z tej jednej płyty. Inne płyty, które działały na drugim komputerze, na tym się nie bootują. Po starcie udało mi się odpalić najpierw Setup for portables, jednak od razu wyskakuje error. Odpaliłem więc Rompaq, przechodzę przez pierwsze opcje programu, ale przy próbie kopiowania wyskakuje Error allocating memory. Czyli ani Setup, ani Rompaq nie rusza. Wywaliłem partycję fdiskiem, stworzyłem nową i jest dokładnie to samo. Pokusiłem się w końcu o instalację Windowsa 98. Za którymś razem płyta bootująca odpaliła się całkiem poprawnie i weszła do instalatora. Przeszedłem przez pierwszy etap instalacji, jednak po resecie wyskoczył błąd, że command.com jest uszkodzony lub go nie ma. Sięgnąłem wreszcie po zakurzonego linuxa mandrake 9.0. System o dziwo się zainstalował, nie było problemu z przeczytaniem 3 płyt, system się odpala, działa i nie widać problemów.

    Czy ten laptop jest sprawny? Dlaczego czyta tylko niektóre dyskietki i niektóre płyty? Czyściłem napęd płytą czyszczącą i nic się nie zmieniło. Sprawdzałem połączenia obydwu napędów z płytą główną i wydają się być ok. Wyjmowałem i wkładałem baterię, wyglądało jakby bios się resetował, ale problemy są ciągle te same. Reklama na ekranie startowym ciągle się pojawia. Gdzie siedzi ten bios? Dlaczego nie mogę go zaktualizować? Jak do niego wejść, skoro F10 nie działa? Jak na nim zainstalować Win98 (teraz już mi nie chce czytać tej płyty)? Ogólnie co mi radzicie zrobić z tym sprzętem lub co wymienić? Z góry dziękuję za odpowiedzi cierpliwym, którzy doczytali do końca.
    [28-30.06.2022, targi] PowerUP EXPO 2022 - zasilanie w elektronice. Zarejestruj się za darmo
  • #2
    PitD

    VIP Meritorious for electroda.pl
    Na tym archaicznym sprzęcie bios jest w postaci dyskietki albo partycji na dysku. Tam też możesz zmienić wpis o użytkowniku.

    Brak czytania dyskietek nawzajem dwóch komputerów wynika ze zużycia się stacji w którymś komputerze. Pewno w tym Compaq jest już rozkalibrowana głowica i nie czyta poprawnie. Sprzęt jest przecież mocno wiekowy.
  • #3
    strazaq
    Level 10  
    Tak, tylko że usunąłem fdiskiem jedyną wykrytą partycję i bios dalej siedzi. Udało mi się odpalić Ranisha i też nie widzi partycji z biosem, więc jej nie ma. Jak zatem wejść do biosu? Brak wejścia do biosu bym przeżył, ale dlaczego wyskakuje błąd przy jego aktualizacji? Jak mam zainstalować teraz windows'a, jeśli po pierwszym etapie wywala mi brak command.com? Czym to jest spowodowane?
  • #4
    PitD

    VIP Meritorious for electroda.pl
    Wejścia do biosu takiego jak teraz jest tam niema.
    Po uruchomieniu z dyskietki możesz ustawiać wszystko.
    To nie jest współczesny komputer.
    Możesz wgrać ten "bios" z dyskietki na dysk.
    Na stronie HP jest wszystko co potrzeba.
  • #5
    strazaq
    Level 10  
    A z płyty się nie da? Odpalałem ten niby bios z płyty i wyskakiwał error na samym starcie. Zgrałem to na dysk i też error. Z dyskietki mi go nie przeczyta, bo nie mam jak tego nagrać na dyskietkę, skoro nie widzi moich dyskietek z xp. Stronę hp znam i ściągnąłem z niej Rompaq i Setup for portables, który miał tworzyć partycję z biosem. Odpalany z płyty nie tworzy, z dysku też nie. Wywala error. Rompaq to samo, tylko error innego rodzaju.
  • #6
    PitD

    VIP Meritorious for electroda.pl
    To musi być z dyskietki. Tam sobie coś zapisuje. Na płycie nic nie zapisze i dlatego wyświetla błąd.
    Uruchom z płytki i potem stwórz na nim dyskietki. Tak powinien zrobić i potem wystartować.
    A na przyszłość podaj dokładną treść komunikatu.
  • #7
    strazaq
    Level 10  
    Coraz lepsze sceny... Dograłem pliki rompaq na płytę, żeby go odpalić na laptopie i nagrać na dyskietkę, a tymczasem laptop część plików na płycie widzi, a część nie. Nie widzi m.in. tych dogranych, ale zniknęły też niektóre z widzianych wcześniej. Nie są ani ukryte, ani nie mają nazw ponad 8 znaków. Komunikaty o błędach to było coś mniej więcej "Error while loading" a w rompaq "Error while allocating memory". Nie mam jednak pewności, tyle zapamiętałem, a nie mogę tych programów odpalić ponownie, bo jakby poznikały z płyty :/
  • Helpful post
    #8
    PitD

    VIP Meritorious for electroda.pl
    Tak stary napęd nie widzi poprawnie płyt Multisesion.
    Nagraj to w jednej zamkniętej sesji. Tak zobaczy wszystko.
  • #9
    strazaq
    Level 10  
    Nowo nagrana płyta w Nero z prędkością 4x w jednej zamkniętej sesji nie bootuje się wcale. Pozostała mi jedna dyskietka startowa starego dosa bez sterowników do cd-romu. Z takim arsenałem nic już chyba nie zdziałam. Mam dość i zgłaszam do sprzedawcy chęć zwrotu laptopa.