Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - zagnieżdżona funkcja "jeżeli"

28 Cze 2011 08:50 5195 4
  • Poziom 9  
    Witam, mam taką oto formułę "=JEŻELI(V25<>"";DATA(ROK(AM25);MIESIĄC(AM25);DZIEŃ(AM25)+1);JEŻELI(W25<>"";DATA(ROK(AM25);MIESIĄC(AM25);DZIEŃ(AM25)+7);JEŻELI(X25<>"";DATA(ROK(AM25);MIESIĄC(AM25)+1;DZIEŃ(AM25));JEŻELI(Z25<>"";DATA(ROK(AM25);MIESIĄC(AM25)+3;DZIEŃ(AM25));JEŻELI(AB25<>"";DATA(ROK(AM25);MIESIĄC(AM25)+6;DZIEŃ(AM25));JEŻELI(AC25<>"";DATA(ROK(AM25)+1;MIESIĄC(AM25);DZIEŃ(AM25))))))))". Adresy V25,W25,X25 itd oznaczają częstotliwości, np. codziennie, co tydzień, co miesiąc, itd.. Muszę dodać tutaj jeszcze "jeżeli" dwa razy, lecz z racji, że pracuję na wersji 2003 program tego już nie dopuszcza. Czytałem, że można to zastąpić jakoś funkcją SZUKAJ.PIONOWO, lecz nie bardzo mi to wychodzi... Będę wdzięczny za wszelkie sugestie... Pozdrawiam
  • Pomocny post
    Moderator Programowanie
    Można podzielić całość na 3 etapy. Potrzebne będą trzy wolne komórki do wykorzystania jako pomocnicze, w których liczysz dni, miesiące i lata, które należy dodać do daty z AM25.
    Np w X24
    Code:
    =JEŻELI(V25<>"";1;JEŻELI(W25<>"";7;0))
    w Y24
    Code:
    =JEŻELI(X24=0;JEŻELI(X25<>"";1;JEŻELI(Z25<>"";3;JEŻELI(AB25<>"";6;0)));0)
    w Z24
    Code:
    =JEŻELI(ORAZ(X24=0;Y24=0);JEŻELI(AC25<>"";1;0);0)

    Wtedy formuła
    Code:
    =DATA(ROK(AM25)+Z24;MIESIĄC(AM25)+Y24;DZIEŃ(AM25)+X24)
    zwróci ten sam wynik i (co najważniejsze) mamy sporo rezerw.
  • Pomocny post
    Poziom 10  
    A więc.. sprawa jest bardzo prosta,

    musisz stworzyć warunki w kolumnach np z prawej strony danych.
    Warunki takie będą wyświetlać 1 lub 0 w przypadku prawdy i fałszu (D, E, F), w kolumnie G za pomocą znaków konkatenacji lub funkcji złącz.teksty() łączysz wszystkie 1 i 0 z kolumn w których znajdują się warunki.

    Powstają Ci w ten sposób słowa kodowe np: 101

    Przykład:

    Imie | Nazwisko | Wiek | D | E | F | G |
    --------------------------------------------------------------
    Jan Kowalski 41 1 0 1 101


    Teraz wystarczy abyś w osobnym arkuszu, lub w dalszych kolumnach stworzył książkę kodów:

    A | B
    ------------------------------
    001 Nie jest stary, nie ma ładnego imienia ale ma ciekawe nazwisko
    011 Nie jest stary, ma ładne imię i ciekawe nazwisko
    111 Jest stary, ma ładne imię i ciekawe nazwisko
    etc.....


    i w kolejnej kolumnie przy danych wstawił formułę wyszukaj.pionowo(komórka_szukana, tabela_z_kodami, 2, 0)

    W przypadku dalszych pytań pisz, lub podlinkuj interesujący Cię skoroszyt

    Dodatkowe informacje:
    Kolumny z pojedynczymi warunkami jak i samo połączone słowo, można ukryć.
    Konkatenacje (złączanie tekstów) w excel wykonujemy za pomocą takiej składni:
    =A1&A2 lub ="Test"&A1&"Złączania" lub =A1&B1&C1&D1&E1
  • Poziom 9  
    bardzo Wam dziękuję za podpowiedzi, popróbuję w wolnej chwili i dam znać jakie efekty
  • Poziom 9  
    Poradziłem sobie wg pomysłu Adamasa. Bardzo dziękuję za pomoc