Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Nieudana próba wgrania DD-WRT

cool_aikon 12 Jul 2011 20:58 5816 34
GoodRam konkurs
  • #1
    cool_aikon
    Level 10  
    Próbowałem wgrać alternatywne oprogramowanie DD-WRT niestety coś poszło nie tak i teraz w ogóle z routerem nie mogę się połączyć. Wgrywanie zakończyłem na 14 lub jak kto woli 15 punkcie tej instrukcji. Przy próbie wykonania kroków od 16 lub nawet os kroku 9 putty przez chwile ma otwarte okno a potem się zamyka samoczynnie. Czy da się jeszcze coś zrobić aby dokończyć wgrywanie lub przywrócić oryginalny soft, czy może już mam się pożegnać z routerem bo to złom. Zaznaczam że robiłem to po raz pierwszy i prosił bym o tłumaczenie jak laikowi.
  • GoodRam konkurs
  • #2
    hermes-80
    Level 43  
    Do czego - do pralki próbowałeś wgrać DD-WRT.
  • #3
    cool_aikon
    Level 10  
    D-Link DIR-300
  • #4
    hermes-80
    Level 43  
    Dokładnie - jaka rewizja.
  • #5
    cool_aikon
    Level 10  
    Nie wiem dokładnie o co tobie chodzi więc spisze wszytko z nalepki
    P/N: EIR300EEU.....A1G
    H/W: Ver. A1 F/W: Ver: 1.03
    S/N: P1JT.......
    Z tym ze chyba F/W było: 1.04 lub 1.05 teraz nie pamiętam.
  • #6
    hermes-80
    Level 43  
    Jaką wersje FW wgrałeś ??
  • GoodRam konkurs
  • #7
    cool_aikon
    Level 10  
    DD-WRT v 24preSP2 beta [Bulid:13064] zgodnie z instrukcją do której podałem linka w pierwszym poście. Zanim zacząłem wgrywać DD-WRT F/W d-linka było 1.04 lub 1.05 tego właśnie już nie pamiętam :(
  • #8
    hermes-80
    Level 43  
    Wgrywałeś to przez serial??
  • #9
    cool_aikon
    Level 10  
    nie przez złącze WAN w ruterze. Tak jak opisuje to instrukcja wgrania alternatywnego oprogramowania DD-WRT.
  • #10
    hermes-80
    Level 43  
    No ale instrukcja wskazuje użycie portu szeregowe rs232.
    A co teraz dostajesz w konsoli jak podepniesz rs232?
    Napisałeś że umarł ?? ale jakie dokładnie są tego objawy?
  • #11
    cool_aikon
    Level 10  
    Spójrz dokładnie na link który wskazałem w pierwszym poście i tam nie ma nawet słowem o RS232 wszystko jest WAN i adresy IP które wpisuje się w przeglądarkę. Świeci się kontrolka od zasilania i jak podepnę skrętkę pod WAN to mruga lub świeci się dioda od tego portu. PUTTY zaraz po uruchomieniu zamyka się.
  • #12
    hermes-80
    Level 43  
    To teraz musisz podłączyć router przez port rs232.
    I zobaczysz co się dzieje w konsoli.
    Czemu nie użyłeś tej instrukcji Link??
    Teraz będziesz musiał za pomocą niej wgrać przez RS232.
  • #13
    cool_aikon
    Level 10  
    A jakim kabelkiem należy się połączyć i gdzie go mogę dostać. Jakim oprogramowaniem trzeba to wgrać. Jak możesz to podaj instrukcje krok po kroku taka jak dla laika bo ja się kompletnie na tym nie znam.
  • #14
    Mexit
    Level 25  
    cool_aikon wrote:
    A jakim kabelkiem należy się połączyć i gdzie go mogę dostać. Jakim oprogramowaniem trzeba to wgrać. Jak możesz to podaj instrukcje krok po kroku taka jak dla laika bo ja się kompletnie na tym nie znam.

    Do tego najbardziej nadają się kable od telefonów np. kabel nokia ca-42 (Link) z konwerterem napięć na RS232TTL
    Więcej masz tu: http://wiki.openwrt.org/doc/hardware/port.serial

    Do tego potrzebny jest jeszcze program np. PuTTY

    PS. Żeby PuTTY się nie zamykał automatycznie to zaznacz "Never" w "Close window on exit"
  • #15
    alex-68
    Level 2  
    Witam! Mam d-linka-300 dir ver.A1 Flashowałem na dd-wrt Niestety po odpaleniu router się resetuje!Brak połączenia po lanie! Putty po rs lączy się z routerem ale nie ma w konsoli zachęty Redboot. Oto logi.:
    Linux version 2.6.23.17 (root@dd-wrt) (gcc version 4.1.1) #5266 Mon Jul 28 20:44 :08 CEST 2008
    CPU revision is: 00019064
    mem setup
    Determined physical RAM map:
    memory: 01000000 @ 00000000 (usable)
    User-defined physical RAM map:
    memory: 01000000 @ 00000000 (usable)
    Built 1 zonelists in Zone order. Total pages: 4064
    Kernel command line: console=ttyS0,115200 root=/dev/mtdblock2 rootfstype=squashf s noinitrd mem=16M
    Primary instruction cache 16kB, physically tagged, 4-way, linesize 16 bytes.
    Primary data cache 16kB, 4-way, linesize 16 bytes.
    Synthesized TLB refill handler (20 instructions).
    Synthesized TLB load handler fastpath (32 instructions).
    Synthesized TLB store handler fastpath (32 instructions).
    Synthesized TLB modify handler fastpath (31 instructions).
    PID hash table entries: 64 (order: 6, 256 bytes)
    Using 92.000 MHz high precision timer.
    console [ttyS0] enabled
    Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
    Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
    Memory: 13060k/16384k available (2203k kernel code, 3324k reserved, 292k data, 1 24k init, 0k highmem)
    Mount-cache hash table entries: 512
    NET: Registered protocol family 16
    Found board config at 0xa83f0000
    Radio config found at offset 0xf8(0x1f8) (a83f00f8)
    Generic PHY: Registered new driver
    NET: Registered protocol family 2
    Time: MIPS clocksource has been installed.
    IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
    TCP established hash table entries: 512 (order: 0, 4096 bytes)
    TCP bind hash table entries: 512 (order: -1, 2048 bytes)
    TCP: Hash tables configured (established 512 bind 512)
    TCP reno registered
    gpio_proc: module loaded and /proc/gpio/ created
    devfs: 2004-01-31 Richard Gooch (rgooch@atnf.csiro.au)
    devfs: boot_options: 0x1
    squashfs: version 3.0 (2006/03/15) Phillip Lougher
    io scheduler noop registered
    io scheduler deadline registered (default)
    Serial: 8250/16550 driver $Revision: 1.90 $ 1 ports, IRQ sharing disabled
    serial8250: ttyS0 at MMIO 0xb1100003 (irq = 37) is a 16550A
    serial8250 serial8250.0: unable to register port at index 0 (IO3f8 MEM0 IRQ4): - 28
    serial8250 serial8250.0: unable to register port at index 1 (IO2f8 MEM0 IRQ3): - 28
    serial8250 serial8250.0: unable to register port at index 2 (IO3e8 MEM0 IRQ4): - 28
    serial8250 serial8250.0: unable to register port at index 3 (IO2e8 MEM0 IRQ3): - 28
    Infineon ADM6996: Registered new driver
    Marvell 88E6060: Registered new driver
    PPP generic driver version 2.4.2
    PPP Deflate Compression module registered
    PPP BSD Compression module registered
    MPPE/MPPC encryption/compression module registered
    NET: Registered protocol family 24
    tun: Universal TUN/TAP device driver, 1.6
    tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>
    scanning for root partition
    [0x00000000]
    [0x00010000]
    [0x00020000]
    [0x00030000]
    [0x00040000]
    [0x00050000]
    [0x00060000]
    [0x00070000]
    [0x00080000]
    [0x00090000]
    [0x000A0000]
    [0x000B0000]
    [0x000C0000]
    [0x000D0000]
    [0x000E0000]
    [0x000F0000]
    [0x00100000]

    found squashfs at 100000
    found RedBoot partition at [0xBFC00000]
    found linux partition at [0xBFC30000]
    Creating 8 MTD partitions on "spiflash":
    0x00000000-0x00030000 : "RedBoot"
    0x00030000-0x003d0000 : "linux"
    0x00100000-0x003b0000 : "rootfs"
    0x003b0000-0x003d0000 : "ddwrt"
    0x003d0000-0x003e0000 : "nvram"
    0x003e0000-0x003f0000 : "FIS Directory"
    0x003f0000-0x00400000 : "board_config"
    0x00030000-0x003e0000 : "fullflash"
    watchdog hb: 20 ISR: 0x20 IMR: 0x8 WD : 0x1ba84b94 WDC: 0x0
    ar2315_wdt_init using heartbeat 20 s cycles 800000000
    watchdog hb: 20 ISR: 0x20 IMR: 0x88 WD : 0x2fa9dfda WDC: 0x0
    u32 classifier
    Actions configured
    Netfilter messages via NETLINK v0.30.
    nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
    ctnetlink v0.93: registering with nfnetlink.
    IPv4 over IPv4 tunneling driver
    GRE over IPv4 tunneling driver
    ip_tables: (C) 2000-2006 Netfilter Core Team
    ClusterIP Version 0.8 loaded successfully
    TCP bic registered
    TCP cubic registered
    TCP westwood registered
    TCP highspeed registered
    TCP hybla registered
    TCP htcp registered
    TCP vegas registered
    TCP scalable registered
    NET: Registered protocol family 1
    NET: Registered protocol family 17
    Welcome to PF_RING 3.2.1
    (C) 2004-06 L.Deri <deri@ntop.org>
    NET: Registered protocol family 27
    PF_RING: bucket length 128 bytes
    PF_RING: ring slots 4096
    PF_RING: sample rate 1 [1=no sampling]
    PF_RING: capture TX No [RX only]
    PF_RING: transparent mode Yes
    PF_RING initialized correctly.
    PF_RING: registered /proc/net/pf_ring/
    802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
    All bugs added by David S. Miller <davem@redhat.com>
    decode /dev/mtdblock2
    VFS: Mounted root (squashfs filesystem) readonly.
    Mounted devfs on /dev
    Freeing unused kernel memory: 124k freed
    ar2315_wdt: starting watchdog w/timeout 20 seconds
    watchdog hb: 20 ISR: 0x20 IMR: 0x89 WD : 0x2fad08bf WDC: 0x0
    Algorithmics/MIPS FPU Emulator v1.5
    test pattern is FFFFFFFF
    eth0: Atheros AR231x: 00:24:01:af:f8:74, irq 4
    ar2313_eth_mii: probed
    eth0: attached PHY driver [Generic PHY] (mii_bus:phy_addr=0:00)
    ath_hal: module license 'Proprietary' taints kernel.
    Reset ICPLUS Phy
    Start Autonegotiation
    Port 0, Negogiation timeout
    Port 1, Negogiation timeout
    Port 2, Negogiation timeout
    Port 3, Negogiation timeout
    Port 4, Negogiation timeout
    Port 5, Negogiation timeout
    Setup VLANS
    sh: cannot create /proc/sys/net/ipv4/tcp_westwood: nonexistent directory
    sh: cannot create /proc/sys/net/ipv4/tcp_vegas_cong_avoid: nonexistent directory
    sh: cannot create /proc/sys/net/ipv4/tcp_vegas_alpha: nonexistent directory
    sh: cannot create /proc/sys/net/ipv4/tcp_vegas_beta: nonexistent directory
    br0: Dropping NETIF_F_UFO since no NETIF_F_HW_CSUM feature.
    device vlan0 entered promiscuous mode
    device eth0 entered promiscuous mode
    sh: cannot create /proc/sys/dev/wifi0/compression: nonexistent directory
    ath0
    Interface doesn't accept private ioctl...
    compression (8BE0): Invalid argument
    Interface doesn't accept private ioctl...
    ff (8BE0): Invalid argument
    Invalid command : scandisable
    Interface doesn't accept private ioctl...
    compression (8BE0): Invalid argument
    Interface doesn't accept private ioctl...
    ff (8BE0): Invalid argument
    SET failed on device ath0 ; Invalid argument.
    Interface doesn't accept private ioctl...
    compression (8BE0): Invalid argument
    Interface doesn't accept private ioctl...
    ff (8BE0): Invalid argument
    device ath0 entered promiscuous mode
    Invalid command : scandisable
    br0: port 2(ath0) entering learning state
    br0: port 1(vlan0) entering learning state
    br0: topology change detected, propagating
    br0: port 2(ath0) entering forwarding state
    br0: topology change detected, propagating
    br0: port 1(vlan0) entering forwarding state
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    SIOCGIFFLAGS: No such device
    CPU 0 Unable to handle kernel paging request at virtual address 2bfd1b2a, epc == c00d8120, ra == c00da4fc
    Oops[#1]:
    Cpu 0
    $ 0 : 00000000 10009400 0000ffff 2bfd1b26
    $ 4 : 0000ffff c0107c40 00000000 00280400
    $ 8 : 00000024 00000002 00000002 82848b96
    $12 : 2aaae804 2ac5a7bc 2ac5dfac 2ab7af05
    $16 : 80a22c46 808a83a0 80c9c3a0 808ba000
    $20 : 808a8b58 808ba1cf 00000000 00016826
    $24 : 00000002 2aaa9464
    $28 : 80e2a000 80e2bb58 c0110000 c00da4fc
    Hi : 00000000
    Lo : 00000000
    epc : c00d8120 Tainted: P
    ra : c00da4fc Status: 10009403 KERNEL EXL IE
    Cause : 30800008
    BadVA : 2bfd1b2a
    PrId : 00019064
    Modules linked in: ath_ahb ath_hal(P) ar2313
    Process startservices (pid: 217, threadinfo=80e2a000, task=803a1088)
    Stack : 802e0000 00000001 80a22c36 808a83a0 c00da4fc 808a8b58 c00f7338 80000000
    80b39ac0 80b682a8 808ba000 808a8b58 8097ebe0 808a83a0 80c9c3a0 80934000
    c00da860 c00da844 00000000 00000001 ffffffea 803a1088 80a22c28 80c9c3a0
    808a83a0 80c9c3a0 808ba000 80998800 00000000 c00c5738 000200d2 00000000
    00000001 00000044 00001000 c0000000 80332ca0 00000001 000200d2 00000000
    ...
    Call Trace:[<c00da4fc>][<c00f7338>][<c00da860>][<c00da844>][<c00c5738>][<c00d21c c>][<802b8860>][<8008b604>][<8008d6fc>][<80042a40>][<800bea74>][<80043164>][<800 95c88>][<802b8860>][<8004ec48>][<800a1f50>][<800a1f30>][<800a3d98>][<800604a8>][ <80060444>][<802b88a0>][<802b8860>][<802b8894>][<8004e29c>][<802b8860>][<8005f06 8>][<800b0544>][<800a6e2c>][<800a6e0c>][<802649a8>][<80069128>][<80069120>][<800 6af24>][<8006af24>][<80043140>][<8004c0d0>]

    Code: 3402ffff 10620002 3404ffff <90640004> 8fbf0010 00801021 03e00008 27bd 0018 3c02c00f
    Kernel panic - not syncing: Fatal exception in interrupt
    Rebooting in 1 seconds..

    Czy ktoś pomoże?
  • #16
    freetz_master
    Level 31  
    Robi sie petla.
    Musisz wgrac poprawne oprogramowanie od nowa.
  • #17
    alex-68
    Level 2  
    Tylko jak wgrać po rs? Brak zachęty RedBoota!Putty ustawiona na serial, mozna tylko wpisać predkość i com! Putty ustawiona na telnet, po lanie nie widzi routera! Może ktoś łopatologicznie wytłumaczyć..
  • #18
    alex-68
    Level 2  
    Próbowałem połączyć się skryptem, bez powodzenia! 30/30/30 reset też nie daje rezultatu! Jakieś sugestie?
  • #19
    spacemen
    Level 11  
    też przyłączam się do prośby,router to wl-wr841n v.7.1
  • #21
    spacemen
    Level 11  
    podobnie wgrałem złą wersję i się zapętla
  • #22
    CHACA
    Level 43  
    I co chcesz teraz osiągnąć? Chcesz wrócić jeszcze raz do oprogramowania firmowego i wgrać od początku dd-wrt?
  • #25
    spacemen
    Level 11  
    to jest sposób gdy mamy możliwość zalogowania się do routera a mi chodzi gdy router się zapętla,jak zatrzymać i w jaki sposób wgrać na nowo firmowy soft ?
  • #26
    CHACA
    Level 43  
    Czyli zostaje tylko zrobić to przez RS-232 i programik putty.
  • #28
    TheMoth
    Level 11  
    stary, ale odgrzebuję żeby nie zakładać nowego.
    Też mam problem z połączeniem przez telnet z dir300, brak znaku zachęty. Wszystko było okej jak wgrałem wg instrukcji rev.A1, putty działało, a jak podbiłem z panelu Administratora do B1, to skończyło się łączenie z routerem, a wywołując telnet przez putty nie mam znaku zachęty RedBoot>.
    co to jest ten RS232? Z lutowaniem bym sobie poradził, ale co z czym połączyć? Ma ktoś może jakiś schemacik?
  • #29
    spacemen
    Level 11  
    jak wgrać firmowe oprogramowanie ?