Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Multimetr FlukeMultimetr Fluke
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

wzmacniacz operacyjny roznicowy - nie dziala...

27 Apr 2012 19:42 6044 16
  • Level 8  
    Witam,
    Pracuje nad prostym projektem w ktorym musze wzmocnic wejscie roznicowe podawane z czujnika cisnienia MPX53GP 100 krotnie. Wstepnie probuje wykorzystac wzmacniacz LM741. Uzylem rezystory tak, aby R4/R3=R2/R1 i R1=R3 i R2=R4, a wiec tak jak podaja w literaturze. Na razie uzywam rezystorow 100 i 10om, chce wzmocnic chociaz 10 krotnie. Nie dziala.
    1)Czujnik cisnienia zasilany jest typowo 3V wg dokumentacji. Zasilam go z baterii 9V po stabilizacji 3.3V i bez wzmocnienia dziala prawidlowo - podaje wartosci zgodne z charakterystyka.
    2)wzmacniacz zasilany napieciem pojedynczym z tego samego stabilizatorka 3.3V, (moze zbyt male napiecie zasilania, albo powinno byc roznicowe?). Na wejsciu sprawdzalem ma faktycznie 3.3V, wiec nie dziala tylko wzmocnienie.

    Na wyjsciu wzmacniacz podaje wartosc okolo 1,8V nie wiem skad sie to bierze. Chce wzmocnic z 20mV (tyle czujnik daje na wyjsciu) do 200mV. (Uwy=R2/R1*deltaUczujnika). Co wiecej te 1,8V jest nawet wtedy gdy nie ma nic na wejsciu wzmacniacza! Nie wykorzystalem wszystkich nozek bo nie sa chyba potrzebne tutaj, tzn nie wykorzystalem OFFSET NULL i NC.

    Ponizej schemat (czerwone cyferki na schemacie odpowiadaja tym we wzmacniaczu):
    wzmacniacz operacyjny roznicowy - nie dziala...

    linki do czesci ktorych uzylem:
    -czujnik cisnienia MPX53GP http://cache.freescale.com/files/sensors/doc/data_sheet/MPX53.pdf
    -wzmacniacz LM741 http://www.ti.com/lit/ds/symlink/lm741.pdf

    Dziekuje za pomoc
  • Multimetr FlukeMultimetr Fluke
  • Level 21  
    Witam.
    Obawiam się, ze ten wzmacniacz operacyjny nie może pracować prawidłowo
    przy tak niskim napięciu zasilania. Można poszukać inny wzmacniacz który na pewno poprawnie będzie działał przy 3V
  • Level 38  
    Zbyt niskie napięcie zasilania, minimum to +-10V, najlepiej +-15V. Powinno być symetryczne zasilanie, a nie pojedyncze.
    Za małe wartości oporników, zwiększ je co najmniej 10 krotnie.
    Nie istnieje stabilizator 7803 - ładnie to tak "cyganić"? :)
    Wzmacniacz musisz wyzerować (napięcie niezrównoważenia - pin 1-5). A w ogóle to ten wzmacniacz "średnio" się do tego celu nadaje.
    No i ten sensor ma offset, który należałoby kompensować.
  • Multimetr FlukeMultimetr Fluke
  • Level 8  
    Ok,
    1)wartosci opornikow zmienione na 100kom i 1kom. (dla 100-krotnego wzmocnienia).
    2)fakt to jest stabilizator LM1117DT33, pomylka :P
    3)sensor ma offset 20mV dla cisnienia min (czyli jak nic nie ma na wejsciu), ale czy jest potrzeba go kompensowac? w dokumentacji jest elegancki wykresik uwzgledniajacy offset, poza tym nie wiem jak to sie kompensuje
    4)Moze to podstawowe pytanie, ale dlaczego zasilanie wzmacniacza musi byc roznicowe a nie moze byc pojedyncze? Podlaczylem teraz pojedyncze bezposrednio przez baterie 9V, ale chyba powinienem zastosowac wpierw stabilizator? Czy w warunkach domowych bez zasilacza stabilizowanego moge go jakos zasilic np dwoma bateriami 9V+9V po kazdej stronie(+/-) z jakimis stabilizatorkami+/- 15V np?

    marekzi czy moglbys doradzic w jaki sposob nalezy wyzerowac te napiecie niezrownowazenia na wejsciu o ktorym napisales? (pewnie za pomoca tych pinow 1 i 5 ktore zostawilem luzne...) Wg dokumentacji wynosi ono okolo 1mV jesli dobrze patrze.
    Dziekuje
  • Helpful post
    Level 38  
    Zasilanie wzm. operacyjnego ma być symetryczne, gdyż:
    - tak jest skonstruowany,
    - żaden wzm. op. nie pracuje z napięciami wejściowymi (i wyjściowymi) równymi napięciom zasilania na jego pinach zasilających - a Twój sensor daje napięcie wyjściowe bliskie zeru,
    - tak lubi :)
    Możesz go zasilić dwiema bateriami 9V.
    I nie stabilizuj tych napięć, a już na pewno nie stabilizatorami 15V, bo się nie da!
    Do pinów 1 i 5 podłącz podkówkę 10-22k, a jej ślizgacz do ujemnego napięcia zasilającego. Obydwa wejścia 741 (piny 2 i 3) dołącz do masy, do wyjścia miliwoltomierz i kręcąc podkówką ustal napięcie na wyjściu =0,0mV.
    Później wejścia (piny 2 i 3) dołącz do sensora
  • Level 34  
    To jest wzmacniacz operacyjny i wymaga zasilania symetrycznego.Trzeba poczytać o nim dokładnie .Przy zasilaniu symetrycznym będzie mógł mieć
    0V na wyjściu.Przecież to mogą być dwie bat 9V . Przynajmniej na czas prób.
  • Level 8  
    Stabilizacje +/-15V mialem na mysli dla dwoch baterii 2x9V=18V po + i -, ale to beda az 4 baterie, wiec jak na dwoch 9V bedzie dzialac to lepiej.

    Quote:
    - żaden wzm. op. nie pracuje z napięciami wejściowymi (i wyjściowymi) równymi napięciom zasilania na jego pinach zasilających - a Twój sensor daje napięcie wyjściowe bliskie zeru,

    faktycznie racja, w przypadku gdy jeden z moich pinow bedzie mial 0V to nie zadziala. zrobie +/-9V.

    Quote:
    Do pinów 1 i 5 podłącz podkówkę 10-22k, a jej ślizgacz do ujemnego napięcia zasilającego. Obydwa wejścia 741 (piny 2 i 3) dołącz do masy, do wyjścia miliwoltomierz i kręcąc podkówką ustal napięcie na wyjściu =0,0mV.

    Jak jutro polece po druga baterie 9V to sie za to wezme i dam znac jak poszlo :). Z tym ze nie mam podkowki, ale mam potencjoimetr 10k, wiec chyba tez moge do tego celu uzyc. Zrobie to tak jak tutaj:
    http://home.agh.edu.pl/~maziarz/LabPE/wzmacniacz.html#10 (na samym dole strony jest opis kompensacji), tylko na swoich rezystorach.
  • Level 26  
    Parę spraw: raz - rezystory 100 i 10 omów to trochu mało imho. Mogę się mylić tutal, ale polecałbym dajć 100k i 10k, bo wzmacniacz może prądowo nie wyrabiać.
    Dwa: przeca można zrobić wzm. różnicowy na poj. zasilaniu, np. tak jak tu:
    http://www.eng.yale.edu/ee-labs/morse/compo/sloa058.pdf
    Trzy - można kupić wzmacniacz rail-to-rail, z reguły działają ok na poj. zasilaniu, np. TS912 dostępny np. w Seguro i wtedy z niskim napięciem aż takich problemów nie będzie.

    Pozdrawiam
  • Level 34  
    Pod tym adresem podanym jeszcze wyżej jest wszystko podane ogólnie.A kolega "poluje " na sygnały małe -rzędu 20mV .
    Przede wszystkim zasilanie 2x9V -pozwoli na pokazanie zalet wzmacniacza operacyjnego w pełni..Glównie symetrii i uwolnienie się od problemów z zasilaniem z jednego zródła.
    Wtedy ,przy Uwe=0V, na wyjściu pojawi się jakieś napięcie, które trzeba będzie
    wyzerować.Tą "podkówką".
  • Level 8  
    Panowie, sukces! :)
    Postapilem zgodnie z Waszymi radami i instrukcja marekzi. Podlaczylem druga baterie 9V, zrobilem symetryczne zasilenie wzmacniacza +/- 9V, wyzerowalem go potencjometrem 100k (napięcie na wyjściu ustawilem =0,0mV dla wejsc wzmacniacza podlaczonych do masy), na koncu z powrotem podlaczylem czujnik do wejscia.
    Okazuje sie ze dziala, i to calkiem niezle - blad jest minmalny, sprawdzalem dla 10 i 100 krotnego wzmocnienia.
    Tylko troche balagan sie zrobil :D. (robilem na plytce stykowej zdjecie ponizej).
    wzmacniacz operacyjny roznicowy - nie dziala...

    Dziekuje wszystkim za pomoc. Jutro jeszcze schemat poprawiony wrzuce (moze sie komus przyda) i zamykam temat.

    Mam jeszcze jedno pytanie. Gdybym np zastosowal zamiast wzmiacniacza 741 wzmacniacz TL072 ( http://sklep.avt.pl/photo/_pdf/TL072CN.PDF ) to jak go podlaczyc i wyzerowac skoro to sa tak naprawde dwa wzmacniacze? (rysunek ponizej). Czy wystarczy jakbym uzyl pinow 2 i 3 jako wejscie, 4 i 8 jako zasilanie,1 jako wyjscie, a reszte zostawiam wolne? Dlaczego pin 1 nazywa sie offset skoro jest to wyjscie pierwszego wzmacniacza?
    wzmacniacz operacyjny roznicowy - nie dziala...
  • Level 38  
    Nie wiem, skąd wziąłeś ten rysunek? prawdopodobnie źle czytasz datasheet - rys. TL072, ale opis końcówek jest błędny.

    Czytaj tu: http://www.ti.com/lit/ds/symlink/tl071.pdf , str. 4:
    wzmacniacz operacyjny roznicowy - nie dziala...

    A zerowanie TL071 należy zrobić nieco inaczej niż LM741 - patrz str.9:
    wzmacniacz operacyjny roznicowy - nie dziala...

    W końcu nie wiem, którego chcesz użyć - TL071 - on ma końcówki do zerowania, czy TL072 - ten nie ma końcówek.
    Jeśli TL072 - wejścia nieużywanego wzmacniacza do masy, a zerowanie można dorobić tak:
    wzmacniacz operacyjny roznicowy - nie dziala...
    Ten układ kończący się rezystorem 1M można dołączyć i do wejścia odwracającego i nieodwracającego.
    Jeśli zakres regulacji jest zbyt mały - można odpowiednio zmniejszyć rezystory 1M, 3M, ale bez przesady, gdyż to może wpłynąć na wzmocnienie.

    Co do błędu wzmocnienia - piszesz że jest minimalny; - najprawdopodobniej jest znikomy - niemierzalny (w Twoich warunkach). Używasz multimetru o niewielkiej dokładności i rozdzielczości 0,1mV - przelicz np. odchyłkę 0,1mV napięcia wejściowego na Uwy - to jest błąd 10mV (dla Ku=100).
    Poza tym masz tam zapewne błąd spowodowany wartościami rezystorów- należałoby tam użyć rezystorów precyzyjnych 0,1%, a przynajmniej 0,5%, stabilnych.
  • Level 34  
    TLO72 to dwa w jednej obudowie, ale bez możliwości zerowania.
  • Level 43  
    Quote:
    Okazuje sie ze dziala, i to calkiem niezle - blad jest minmalny, sprawdzalem dla 10 i 100 krotnego wzmocnienia.


    Ciekawe, jeśli wzmacniacz miał rezystancję wejściową (różnicowo) 2kΩ (zastosowano rezystory 1kΩ i 100kΩ), a czujnik ma rezystancję wyjściową rzędu 1kΩ to ok 1/3 katalogowej czułości straciłeś, obciążając czujnik.

    W karcie katalogowej czujnika jest informacja, że ma znaczny współczynnik temperaturowy - nie potrzebujesz kompensacji?

    Wiecie że µA741 ma aż 44 lata, w dzisiejszych czasach informacje słyszy się o nim chyba tylko w szkołach/uczelniach, co o nich dobrze nie świadczy.
    W obecnym stuleciu większość układów ze wzmacniaczami operacyjnymi jest budowana tak, aby zasilać je niskimi napięciami i niesymetrycznie. Ale jeśli ilość miejsca zajmowana przez dwie baterie nie ma znaczenia, to tak jest odrobinę prościej.
  • Level 34  
    Jeśli na WE i WY układu znajdują się kondensatory, to nie ma potrzeby stosowania "zerowania" układu, bo składowej stałej -powodujacej przesunięcie -nie ma.W takim przypadku można zrezygnować ze stosowania zasilania symetrycznego./Książka z 1975 r./
  • Level 8  
    Quote:
    Nie wiem, skąd wziąłeś ten rysunek? prawdopodobnie źle czytasz datasheet - rys. TL072, ale opis końcówek jest błędny.

    Z tego linku, str 1. ( http://sklep.avt.pl/photo/_pdf/TL072CN.PDF )

    Quote:
    W karcie katalogowej czujnika jest informacja, że ma znaczny współczynnik temperaturowy - nie potrzebujesz kompensacji?

    W karcie katalowej znalazlem taki wpis (str 4 nad wykresem):
    "...However, the properties of the strain gauge itself are temperature dependent, requiring that the device be temperature compensated if it is to be used over an extensive temperature range."
    Zakladajac, ze pomiary beda wykonywane w stalej temperaturze, nadal potrzebuje kompensacji czujnika? Jezeli tak, to jest ktos w stanie podpowiedziec w jaki sposob robi sie taka kompensacje?

    Quote:
    Wiecie że µA741 ma aż 44 lata, w dzisiejszych czasach informacje słyszy się o nim chyba tylko w szkołach/uczelniach, co o nich dobrze nie świadczy.
    W obecnym stuleciu większość układów ze wzmacniaczami operacyjnymi jest budowana tak, aby zasilać je niskimi napięciami i niesymetrycznie.

    To fakt ze ten wzmacniacz swoje lata juz ma. Czy mozesz w takim razie podac jakies przyklady wzmacniaczy ktore najlepiej by sie sprawdzily w tej aplikacji?
  • Level 43  
    Quote:
    Zakladajac, ze pomiary beda wykonywane w stalej temperaturze, nadal potrzebuje kompensacji czujnika?

    Jeśli będzie stała to nie, zależy tylko jak dokładna będzie ta stałość i jaki błąd pomiarów uznasz za dopuszczalny (trzeba policzyć).
    Quote:
    Jezeli tak, to jest ktos w stanie podpowiedziec w jaki sposob robi sie taka kompensacje?

    W karcie katalogowej jest podane, w której nocie aplikacyjnej tego szukać.

    Quote:
    To fakt ze ten wzmacniacz swoje lata juz ma. Czy mozesz w takim razie podac jakies przyklady wzmacniaczy ktore najlepiej by sie sprawdzily w tej aplikacji?

    Jeśli to układ do prób, lub ma być używany sporadycznie, to nie ma sensu optymalizować. W innym przypadku można by zrobić bardziej energooszczędny i nie wymagający symetrycznego zasilania. Czy to ma pracować w jakimś większym urządzeniu?