Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Eclipse - brak wykazu microkontrolerów

Leszek4848 20 Sty 2013 12:20 1539 8
  • #1 20 Sty 2013 12:20
    Leszek4848
    Poziom 9  

    Panowie mam problem,zaistalowałem program Eclipse, robię krok po kroku wg.filmu Pana Mirka36 ale program pokazuje puste okienko, gdy chce zaznaczyć np: ATMEGA 8, brak jakichkolwiek AVR, co może być tego przyczyną?

    0 8
  • #3 21 Sty 2013 21:28
    perlon
    Poziom 19  

    Jak już korzystasz z filmu to zajrzyj na bloga. Jest tam wyłożone jak załatać Eclipse z nowym toolchainem żeby widział procesory. Videoporadnik jest bardzo szczegółowy i trzeba go obejrzeć dokładnie i ściągnąć paczkę plików do podmiany. Wszystko jest na blogu. Ja przetestowałem u mnie działa.

    0
  • #4 21 Sty 2013 23:40
    mirekk36
    Poziom 42  

    Leszek4848 napisał:
    Panowie mam problem,zaistalowałem program Eclipse, robię krok po kroku wg.filmu Pana Mirka36 ale program pokazuje puste okienko, gdy chce zaznaczyć np: ATMEGA 8, brak jakichkolwiek AVR, co może być tego przyczyną?


    Przecież tu masz wszystko dokładniuśko krok po kroku podane ;)

    http://mirekk36.blogspot.com/2012/11/instalka-eclipse-atmel-toolchain.html

    jak pisze kolega wyżej obejrzyj bardzo dokładnie - nie wiem dlaczego część osób pomija najważniejszy krok z tego poradnika czyli wgranie

    patcha do Plugina AVR dla Eclipse

    a przecież jest pokazane jak i gdzie i jaki plik.... A patch napisany został przez dwóch świetnych kolegów SunRiver i Krauser .... Działa to ZAWSZE - tylko jeszcze raz powtarzam - obejrzyj dokładnie.

    Nie wspomnę że masz na blogu do pobrania wszystkie pliki w tym ten patch

    no nie wiem jak już dokładniej można to opisać :( ..... Jak do tej pory nie zdarzyło się żeby komuś to nie działało ... chyba że tak jak ty pominął ten jeden krok ;) ale gdy się poprawił to ładnie ruszyło - więc do roboty ;) na pewno się uda

    Dodano po 5 [minuty]:

    aha co więcej - najnowszy patch do plugina jest tak fajnie napisany, że jak masz wgrany Atmel Toolchain - to Plugin już sam go wykryje zamiast WinAVRowego toolchaina - super sprawa - więc jest nawet jeszcze prościej niż w poradniku bo nie trzeba tych ścieżek ustawiać.

    0
  • #5 26 Sty 2013 13:09
    Leszek4848
    Poziom 9  

    Przy próbie wgrywania Eclipse (plugina) pojawia się komunikat ;Problem Occured. plugina sciągnolem z bloga 36, posiadam Windows XP czy to moze być przyczyną

    0
  • #6 26 Sty 2013 13:40
    mirekk36
    Poziom 42  

    to jak ty tego plugina - wgrywasz ??? czy instalujesz ??? bo nie rozumiem ? w poradniku mowa jest o jego instalacji ....

    0
  • #7 26 Sty 2013 13:56
    Leszek4848
    Poziom 9  

    To znaczy otwieram eclipse pózniej workspace,wchodzę w zakladkę Help instaler soft plugin się wgrywa i niby wszystko ok ale pojawia się komunikat problem occured

    0
  • #8 26 Sty 2013 15:04
    mirekk36
    Poziom 42  

    Leszek4848 napisał:
    To znaczy otwieram eclipse pózniej workspace,wchodzę w zakladkę Help instaler soft plugin się wgrywa i niby wszystko ok ale pojawia się komunikat problem occured


    No to znaczy że go INSTALUJESZ a nie wgrywasz .... więc postaraj się wyrażać precyzyjniej wtedy mniej czasu stracimy na dochodzenie - "o co chodziło w wypowiedzi" .....

    Nie mniej jednak skoro masz na tym etapie kłopot - po wgraniu na czysto ECLIPSA to NA PEWNO winą nie jest Win XP, ani żaden inny rodzaj windowsa tylko ew śmietnik który ci się już zrobił w Windowsie i zainstalowanej JAVIE ....

    Sprawdź albo na innym komputerze, albo na maszynie virtualnej albo przeinstaluj windę od nowa - i zobaczysz że w każdym z tych przypadków wszystko ładnie ruszy

    0
  • #9 26 Sty 2013 17:37
    Leszek4848
    Poziom 9  

    Bardzo dziękuję za super radę obejżałem film dokładniej i Eclpse ruszyło bez problemu pokazuje wszystkie microcontrolery,teraz muszę nauczyć się pisania programu do atmegi8 dip28, chcę napisać test na mruganie diody, zestaw mam samodzielnie zrobiony pod STK200/300,czy eclpse będzie widział atmegę8 żeby wgrac program, przypominam ze jestem zielony! programowałem już fergusona HD 8900 przez Jtag, dvd viva290 U, proszę o podpowieć czy jest szansa przez stk200/300 wejść do eclipse z poważaniem leszek4848

    0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo