Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Mikrotik RB951G + ZTE MF823 - Konfiguracja Mikrotik z modemem 4G

23 Lip 2014 13:52 18036 32
  • Poziom 19  
    Konfigurowałem już tego Mikrotika do aero2 i działał bez problemu.
    Teraz w konfiguracji RB951G (v 6.15) + ZTE MF823 Lte Plusa nie mogę ruszyć z miejsca.
    Modem jest prawidłowo wykrywany, widnieje w resources usb.
    Tyle że próby konfiguracji interfejsu lte nie przynoszą efektu, pingi z interfejsu timeout.
    Tak jakby się nie uwierzytelniał w Plusie, albo był jakiś bag lub błąd konfiguracji dla lte??? Ustawienia APN OK.
    Próbowałem przez client ppp dzieje się coś, między innymi automatycznie nadaje routing i dalej to samo co z lte.
    Na pewno jest różnica w konfiguracji interfejsu lte a ppp, ale nie znalazłem pożytecznego manuala.
    Stary TPlink działa bez problemu, ale ma 100 porty i dziurawy soft dlatego mnie to nie ustawia.

    Czy ktoś konfigurował już lte plusa na mikrotiku i może pomóc?
  • Poziom 23  
    A to nie jest problem w tym, że MF823 jest urządzeniem typu HiLink i przez to widać go jako kartę sieciową na USB z adresem 192.168.0.1 (ty dostajesz jakiś numer powyżej 100) i to jest jednocześnie gateway do Internetu?
  • Poziom 19  
    Tak masz rację 192.168.0.1 tylko teraz nie wiem jak to skonfigurować z modem huawei e3131 albo wan ze stałym IP nie było problemu.
    Próbowałem jako gateway, ale brakło mi pomysłów przy odpowiednim routingu...
  • Poziom 10  
    Witam,
    Podłącze się do tematu ponieważ również mam problem z konfiguracją. Czy kolego pitron rozwiązał swój problem?
  • Poziom 19  
    ZTE to badziew wybrałem go bo w tym czasie nie było sterownika dla huawei 4G w mikrotikach.
    I co z tego skoro i tak go nie podłączyłem. W innym routerze kilka rzy zdarzyło mu się zawiesić i uruchomić czysty firmware producenta. Kolejne problemy to sporo bugów, często dla plusa trzeba ustawiać ręcznie dnsy lub wystartować własny dhcp bo inaczej nie działa net.

    Apropo mikrotia:
    ZTE należy przełączyć w tryb modem zamias hilink.
    https://wiki.archlinux.org/index.php/ZTE_MF_823_(Megafon_M100-3)_4G_Modem

    Może mikrotik wypuści firmware który pozwoli na brige usb-hilink z eth?
  • Poziom 20  
    Hej, posiadam ten router. Mnogosc opcji powala. Zrobilem update do 6.23 i E3372 (hilink) dziala bez problemu. Wiem ze to temat o ZTE ale zasada pewnie taka sama. Hilink ma jedna wade, nie wiem jak zresetowac polaczenie jakby zamarlo (nie wiem czy sam modem to zrobi, nie mialem jeszcze takiej sytuacji). Mam skrypty resetujace zwykle PPP, nie Hilinkowe a tu trzeba zrobic USB POWER reset (dostepne w menu system -> resources chyba) z tym ze nie wiem czy sie da do tego dobrac przez skrypt.

    Nie hilinkowe daja dostep do wielu informacji wprost z winbox, tu ich nie bedzie bo hilink i trzeba otworzyc jego stronke w razie co.

    Do tematu: dodajemy w IP dhcp clienta na interface LTE1 i do NAT maskarady i powinno dzialac ladnie. U mnie dziala. Tak jak windows, musi wirtualna karta pobrac adres IP i ustawic routing na ten interface. Musimy to wymusic przez dhcp clienta.
  • Poziom 19  
    Czy możesz podesłać swój konfig, mój ZTE nadal nie działa na 6.23.
    Miałem ustawione to samo już wcześniej tylko konfig i routing ręczny bez dhcp client wygląda tak samo, ale nie działa...
  • Poziom 19  
    Wstałem rano i po pierwszej kawie już działa ???
    Poniżej zrzut konfigu dla zainteresowanych:

    Kod: text
    Zaloguj się, aby zobaczyć kod
  • Moderator - Sieci, Internet
    krzys-iek napisał:
    a tu trzeba zrobic USB POWER reset (dostepne w menu system -> resources chyba) z tym ze nie wiem czy sie da do tego dobrac przez skrypt.

    A polecenie
    Code:
    /system routerboard usb power-reset duration=<il_sekund>

    nie działa? Akurat nie mam nigdzie w tym modelu wpiętego jakiegokolwiek urządzenia USB, to nie sprawdzę, ale power-reset obsługuje.
  • Poziom 20  
    A działa, dzięki

    http://wiki.mikrotik.com/wiki/Manual:USB_Features domyslnie 3 sekundy, nie trzeba podawac wiec parametru.

    Dorzucam system- scripts, zmodyfikowany skrypt (wyszukany gdzies w internecie) do nadzorowania polaczen RAS/PPP i VPN.

    Obecnie mam modem HiLink LTE i musze to przerobic aby resetowal zasilanie jakby ping do DNS google nie szedl (zakladamy zawieszenie polaczenia, nie wiem czy HiLinki nie maja juz wbudowanego watchdoga , nie zaszkodzi dodac swoj).

    Gotowy kod dla RAS/PPP i VPN:

    Code:

    ######### Script settings ##########
    :local WanName "orange"
    :local VpnName "dom-vpn"
    :local HostPingA "8.8.8.8"
    :local HostPingB "192.168.0.1"
    :local PingCount "3"
    #############################

    :local WanStat
    :local VpnStat

    # http://wiki.mikrotik.com/wiki/Manual:USB_Features
    # /system routerboard usb power-reset duration=

    /interface ppp-client monitor $WanName once do={ :set WanStat $status}
    :if ($WanStat = "connected") do={
      :local pingresultA [/ping $HostPingA count=$PingCount];

      :if ($pingresultA = 0) do={
          :log error message="Script: failed $pingresultA ping $HostPingA via <$WanName>. Reconnecting PPP & PPTP!";

          :interface pptp-client disable $VpnName;
          :delay 3;
          :interface ppp-client disable $WanName;
          :delay 3;
          :interface ppp-client enable $WanName;
          :delay 10;
          :interface pptp-client enable $VpnName;

          :log warning message="Script: PPP & PPTP <$WanName> has been reconnected.";
          :delay 20;
        }
    }

    /interface pptp-client monitor $VpnName once do={ :set VpnStat $status}
    :if ($VpnStat = "connected") do={
      :local pingresultB [/ping $HostPingB count=$PingCount];

       :if ($pingresultB = 0) do={
          :log error message="Script: failed $pingresultB ping $HostPingB via <$VpnName>. Reconnecting!";
          :interface pptp-client disable $VpnName;
          :delay 5;
          :interface pptp-client enable $VpnName;
          :log warning message="Script: PPTP <$VpnName> has been reconnected.";
        }
    }


    Dodajemy to do scripts a wywolanie do sheduler (check-intet to nazwa skryptu)

    Code:

    /system script run check-inet


    Dzialalo jak trzeba :-)
  • Poziom 15  
    Witam

    pomoże ktoś w konfiguracji tego modemu pod mikrotikiem, robię wszystko według powyższego opisu i kicha. Adres pobiera 192.168.0.198 default route dodaje jednak internetu po sieci nie ma. Czy nalezy konfigurować APN, PIN (wpisałem) ....?
  • Poziom 19  
    Sprawdź czy idą pingi po IP może nie masz dns-ów.
  • Poziom 2  
    Witam,

    wybaczcie, ale dopiero odkrywam możliwości RB 951.
    Podłączyłem modem ZTE MF821. Widzę go w Resources USB. Zlinkował się z siecią Plusa, dostał adres 5.60.117.15.

    Potrzebuję teraz pomocy, krok po kroku, jak po kolei skonfigurować RB, żeby wszystko działało.
    Co ma być bramą, jakie adresy, DNSy... Proszę o pomoc.
    Jeśli nie chce Wam się pisać, to podrzućcie chociaż jakieś konfigi. Spróbuję coś skonfigurować na tej podstawie.
    Czekam na jakiekolwiek wskazówki.
  • Poziom 19  
    Kilka postów wyżej masz jak włączyć dhcp client żeby modem dostał ip i działał jak wirtualna karta, a niżej mój config.
    Jak się wczytasz i zerkniesz na interfejs winboxa to powinno ci się udać.

    Mam teraz 2 mikrotiki w bridge-u żeby polepszyć zasięg LTE i wifi, mój nowy config raczej ci się nie przyda.
    Powodzenia
  • Poziom 2  
    pitron napisał:
    Kilka postów wyżej masz jak włączyć dhcp client żeby modem dostał ip i działał jak wirtualna karta, a niżej mój config.
    Jak się wczytasz i zerkniesz na interfejs winboxa to powinno ci się udać.

    Mam teraz 2 mikrotiki w bridge-u żeby polepszyć zasięg LTE i wifi, mój nowy config raczej ci się nie przyda.
    Powodzenia


    Dzięki za szybką odpowiedź.
    Walczę i walczę i już prawie się poddaję.
    Modem USB widoczny, działa. Pingi z interfejsu ppp idą.
    Ale nie mogę ustawić, żeby otrzymał adres jako wirtualny modem.
    Ciągle dynamicznie mi przydziela jakiś adres.
    Mam DHCPa skonfigurować dla tego interfejsu?
    Bo rozumiem, że z Twojego configu ten modem powinien dostać 192.168.0.198
    Jak próbuję zrobić DHCP Client, to nie widzę interfejsu z ppp.

    Proszę o jakąś pomoc. Jakieś info, co krok po kroku mam robić

    Dzięki.
  • Moderator - Sieci, Internet
    jacooss napisał:
    Modem USB widoczny, działa. Pingi z interfejsu ppp idą. [...]
    Bo rozumiem, że z Twojego configu ten modem powinien dostać 192.168.0.198


    To nie jest tak, że modem musi dostać konkretny IP... Twój modem łączy się po ppp i wygląda na to, że poprawnie, wystarczy zapewne skonfigurować router po stronie LAN (zestawić ewentualnie bridge, ale przede wszystkim NAT, DNS cache, serwer DHCP).
  • Poziom 2  
    Witam,
    wracam do testów... Ale po zresetowaniu ustawień fabrycznych RB951 i modemu 4g (MF821 w plusie), mam problem teraz z połączeniem samego modemu.
    Ustawiłem APN (plus) i cały czas mam Status: waiting for packets.
    I stoi...
    NIe wiem, czy to jakiś problem z modemem. Kiedyś jak go podpinałem pod zwykły router, to nie mógł mieć wyboru automatycznego trybu (LTE/3G/hspa) w profilu...

    Coś musiało się przestawić, bo jakiś czas temu ładnie mi się linkował...

    Ktoś przerabiał już taki problem?
    Problem z zasilaniem modemu? RB nie wyrabia?

    Jak podłączam do kompa modem, to normalnie się łączy i internet działa.
  • Poziom 10  
    wg mnie, nie ma co się bawić w PPP.
    Ja mam RB751U-2HnD z najnowszym FW: 6.30.2 oraz
    Urządzenie
    ZTE MF823
    Wersja oprogramowania
    WEB_PKTPOLMF823V1.0.0B05
    Wersja firmware
    BD_POLKMF823V1.0.0B03
    Wersja sprzętowa
    MF823-1.0.0

    Podłaczyłem go do USB, włączyłem dhcp client na lte, otrzymałem podsieć 192.168.0.0/24 gdzie 192.168.0.1 to MGMT nad modeme, a Mikrotik otrzymuje 192.168.0.199 albo .198.
    Co do NETa, miałem do ETH1 podpięte UPC - nie działało, chodziło o routing. Zablokowałem na chwilę port - zadziałało. Nie zapomnij dodać w NAT masquarede z interfejsem lte. DNS mam ustawiony na auto od modemu na 192.168.0.1. W Routingu nić nie dodawałem ręcznie, poszło z automatu z dhcp cl.
  • Poziom 19  
    U mnie wszystko lata zarąbiście!
    Zapomniałem że mam routery i modem tylko od czasu do czasu aktualizuję firmware.
  • Poziom 10  
    A czy ktoś z was robil update fw od modemu np od plusa ? Czy tylko mikrotik ?
  • Poziom 19  
    Nie robiłem ręcznej aktualizacji. Raz uruchomił mi się w konfiguracji default, ale działy się cuda....

    Mam tak:
    Wersja oprogramowania
    WEB_PKTPOLMF823V1.0.0B05
    Wersja firmware
    BD_POLKMF823V1.0.0B03
    Wersja sprzętowa
    MF823-1.0.0
  • Poziom 10  
    Mamy zatem to samo.
    Czy podłączenie MF823 do dowolnego RB z serii 7xx czy 9xx będzie pomyślne przy najnowszym FW ? Wczoraj testowałem na 751, a potrzebuje kupić z serii 9xx.
  • Poziom 9  
    Witam wszystkich,

    u mnie z e3372 działa jeżeli chodzi o dostęp do Internetu jednak mam problem z drugą stroną... wykupiłem zewnętrzny IP (Plus) i nie mogę się dostać z Internetu do własnej sieci po VPN.

    Dla testów chciałem odpalić jakiś wewnętrzny serwer WWW i zrobiłem taki konfig w NAT:

    Kod: text
    Zaloguj się, aby zobaczyć kod


    nie działa. Sprawdziłem ping na "niby" zewn. IP - nie idą.

    Na infolinii twierdzą, że wszystkie porty otwarte...

    Jakiś pomysł
  • Moderator - Sieci, Internet
    W regułce "0" popraw dst-address na adres publiczny.
  • Poziom 9  
    mam publiczny ale zmienny... :(

    tylko mam wrażenie, że to po stronie Plusa raczej coś nie trybi bo pingi na aktualny zewnętrzny IP nie odpowiadają...
  • Moderator - Sieci, Internet
    Zatem zamiast określać dst-address spróbuj z opcją "in-interface=LTE". Na pewno na interfejsie LTE router otrzymuje adres publiczny?
  • Poziom 9  
    na pewno jak zmieniam APN to adresy się zmieniają więc ten pro.gsmplus.pl działa - stwierdzili że wszystko powinno być ok, żebym szukał po stronie routera problemu.... przestaje w to wierzyć gdyż tak jak pisałem, z zewnątrz puszczam pinga na ten niby zewnętrzny i nie odpowiada więc chyba muszę jeszcze raz odczekać swoje na infolinii i dociekać racji...
  • Poziom 19  
    Dodaj na chwilę regułę forward na jakiś komp po stronie LAN z otwartymi portami icmp wtedy sprawdź pingi na publiczny. Może sam router nie odpowiada na icmp??
  • Moderator - Sieci, Internet
    pako_wroc napisał:
    zmieniam APN to adresy się zmieniają

    OK, ale czy ten adres, który ląduje na interfejsie LTE w routerze jest z puli publicznej?
  • Poziom 9  
    pitron napisał:
    Dodaj na chwilę regułę forward na jakiś komp po stronie LAN z otwartymi portami icmp wtedy sprawdź pingi na publiczny. Może sam router nie odpowiada na icmp??


    jak będzie wyglądać taka regułka (sorki ale firewalla dopiero uczę się ogarnąć)

    Dodano po 45 [sekundy]:

    salmon napisał:
    pako_wroc napisał:
    zmieniam APN to adresy się zmieniają

    OK, ale czy ten adres, który ląduje na interfejsie LTE w routerze jest z puli publicznej?


    jak na szybk osprawdzić?