Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
TestoTesto
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

NAD C356BEE - Brak reakcji na sprawnego pilota

03 Jan 2015 13:21 1953 2
  • Level 2  
    Witam sznownych kolegów.

    Zwracam się do was z prośbą o pomoc, gdyż wyczerpałem już wszelkie możliwości co do weryfikacji mojego problemu (elektroniką zajmuje się hobbystcznie).

    Pacjętem jest wzmacniacz zintegrowany stereo NAD C356BEE. Kupiłem go z martwym sterowaniem z pilota. Sam wzmacniacz jest sprawny, sterowanie manualne działa bez najmniejszych problemów. Co zrobiłem we własnym
    zakresie aby zweryfiować problem:
    - reset oryginalnego pilota NAD SR8
    - sprawdzenie oryginalnego pilota przez aparat cyfrowy (dioda IR nadaje)
    - sprawdzenie przy pomocy pilota uniwersalnego Harmony ONE z wgraną dedykowaną dla C365BEE biblioteką Logitecha - brak reakcji
    - wzmacniacz podłądzony przez wyjście REMOTE OUT do REMOTE IN w amlitunerze Harman Kardon AVR255 - sensor IR w NAD'zie odbiera pilota HK i bez problemu steruje amplitunerem (odbiornik podczerwieni połączony jest bypassem do wyjścia REMOTE OUT)
    - tak samo działa sterowanie BLURAY'em YAMAHA
    - w drugą stronę tzn. REMOTE IN w NAD'ie, REMOTE OUT w KH, brak jakiejkolwie reakcji
    - spawdzone napięcia (Tani Multimetr Master M830BUZ)
    napięcie na płytę KEYBOARD stanby 5,10V / power on 5,31V
    napięcie na odbiorniku podczerwieni Vs=5,31V / OUT=5,16V w spoczynku,
    od 4,62V do 4,73V w zależności od wciśniętego klawisz na pilocie
    - sprawdzone przebiegi testerem diód od odbiornika do mikrokontrolera - wszystko ok
    - weryfikacja wizualna pod kątem zimnych lutów - wszystko ok
    - podmieniony odbiornik podczerwieni 19 BCKX HS38B5 (oryginał) na TSOP4838 - brak reakcji, przyczym po podłączeniu przez REMOTE OUT apitunera HK / BLURAY YAMAHA komunikacja znowu poprawna ale niestety tylko w jedną stronę :-(

    Moje podejrzenia padły na uwalony mikrokontroler IC73 STC12C5A16S2 LQFP-44 ale jest jeszcze jedna sprawa - podłączyłem wzmacniacz przez RS232 za pośrednictwem kabelka USB to Serial Com Port i programem NAD zawartym w paczce, którą w swoim topicu zamieścił kolega paatos

    https://www.elektroda.pl/rtvforum/viewtopic.php?p=13254761#13254761

    bez najmniejszych oporów wzmacniacz zagadał - dwukierunkowo działa całe sterowanie wzmacniaczem z poziomu softwaru tzn. wysyłasz komendę, np. main.power=on, NAD włącza się, a program zmienia status tej komendy na ON.

    W złączeniu zamieszczam serwisówkę, którą się posiłkowałem niestety do poprzedniego modelu NAD C355BEE bo do mojego nigdzie nie znalazłem. Są to konstrukcyjnie bardzo zbliżone wzmacniacze. Inny mikrokontler IC73 ale wyprowadzenia są zrealizowane w ten sam sposób.
    Nie mam pojęcia czy wartości napięć są prawidłowe (niby 5,27V na zasilaniu mikrokontrolera jest w toleracji zgodnie z jego kartą techcniczną). Nie wiem też czy reset wykonuje się prawidłowo? Tu reset realizowany jest przez stałe podanie masy. Mierząc napięcie między pinami RST i Vdd wychodzi 5,27V.

    Proszę Państwa o pomoc bo wzmacniacz gra wspaniale ale miał także działać jako końcówka mocy do Amplitunera przy oglądaniu Kina Domowego, a bez sterowania pilotem cała koncepcja jest dla mnie bezsensowna. Boję się także wysyłać go gdzieś do serwisu bo za chwilę okaże się, że z przesyłką, "ekspertyzą" i naprawą mógłbym kupić nowy na gwarancji.

    Z góry dziękuję i pozdrawiam

    Wpadła mi do głowy jeszcze jedna myśl - czy możliwe żeby te problemy mogły być spowodowane uszkodzonym kwarcem przy mikrokontrolerze lub w samym pilocie? Sprawdzić w moich warunkach domowych będzie trudno ale czy jest sens podmieniać na próbę?
  • TestoTesto
  • Level 2  
    Widzę, że mój temat nie ma wzięcia. To może chociaż jest ktoś w stanie podpowiedzieć czy w opisanej przeze mnie sytuacji można wykluczyć mikrokontroler lub kwarc? Samo sterowanie lokalne działa, a dodatkowo mikrokontroler obsługuje komunikację po rs232. Czy możliwe żeby był uszkodzony częściowo?
  • Level 2  
    Kontynuując mój monolog chciałem poinformować, że nie mogąc doczekać się na pomoc forumowiczów, postanowiłem odpuścić temat naprawy. Jako, że chyba lepszy ze mnie amator "programowania" niż elektroniki zrobiłem dubel mikrokontrolera sterującego wzmacniaczem za pośrednictwem podczerwieni z wykorzystaniem Arduino Uno (które leżało niewykorzystane w szafie) i działającej we wzmacniaczu transmisji szeregowej. Generalnie wszystko działa jak fabrycznie tyle, że komendy IR odbiera Arduino i przesyła po RS232 do wzmacniacza.