Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Rozwiązano] Macbook Pro A1226 - nie moge zainstalować systemu z bootowalnego pendrive

rafont2 02 Lis 2018 16:26 291 22
  • #1 02 Lis 2018 16:26
    rafont2
    Poziom 5  

    Witam
    nabyłem ostatnio Macbooka Pro 1226 Late 2007
    Laptop nie miał dysku, ma uszkodzony napęd i matrycę (wyświetla obraz na monitorze zewnętrznym)
    Jako że brakowało w nim dysku, włożyłem inny i stworzyłem bootowalnego pendrive z systemem OS X El Capitan

    Problem polega na tym, że przy normalnym włączeniu laptopa pokazuje się ikonka folderu ze znakiem zapytania (brak dysku startowego), a przy uruchomieniu go z klawiszem Option (wywołanie menadżera uruchamiania) widnieje tylko czarny kursor z szarym tłem i nic prócz poruszania tym kursorem nie można zrobić. Próbowałem też kombinacji Shift+Option+Command+R jednak ta w ogóle nie reaguje i pojawia się ikonka braku dysku startowego.

    Dodam że jest to mój pierwszy raz z próbą instalacji systemu na Macu

    Co może być przyczyną, że nie mogę wywołać instalatora?

    Pozdrawiam

    0 22
  • #2 03 Lis 2018 00:23
    gabik001
    Poziom 37  

    A bootowalny pendrive był przygotowany gdzie? Na innym mac-u czy windows?

    0
  • #3 03 Lis 2018 11:06
    rafont2
    Poziom 5  

    Pendrive przygotowałem na Windows 10 za pomocą programu Transmac

    0
  • Pomocny post
    #4 03 Lis 2018 23:39
    gabik001
    Poziom 37  

    Nie wiem czy nie przyszalałeś z tym El Capitan. Ja bym spróbował jakiś Mountain Lion albo niżej.
    Zrób AHT - przy starcie przycisk D aż pojawi się ikonka Apple Hardware Test. Dowiesz się co nie działa.

    0
  • #5 04 Lis 2018 12:12
    rafont2
    Poziom 5  

    Ten Macbook niby spełnia wymagania El Capitana. Spróbowałem też, tak jak radziłeś Mountain Lion i wszystko się powtarza, tak jak w przypadku El Capitan.

    Przycisk D przy starcie nic nie daje: pojawia się ikona folderu ze znakiem zapytania nieco szybciej niż bez jakichkolwiek wciskanych klawiszy.

    Podłączyłem też klawiaturę zewnętrzną i dzieje się to samo, więc działania klawiatury nie można podważyć (chyba).

    Zauważyłem, że gdy pojawia się ten znak zapytania jak wyciągnę pendrive lub go podłączę to mruganie chwilowo się zatrzymuje, tak jakby myślał lub coś wykrywał, jednak dalej mruga i niczego nie wychwytuje.

    Czy jest opcja że on w ogóle nie czyta dysku ani pendriva? Może taśma od dysku albo USB jest uszkodzone?

    0
  • Pomocny post
    #6 05 Lis 2018 00:29
    gabik001
    Poziom 37  

    Jedno USB jest wlutowane w płytę więc wątpliwość komunikacji z pendrive odpada.
    Bardziej był bym za samym pendrivem że jest nieodpowiednio przygotowany.
    Można jeszcze spróbować zainstalować system na drugim pendrive (on chyba ma dwa porty USB) dla sprawdzenia bo do użytku taki sposób się nie nadaje (zbyt wolno chodzi a pendrive nie jest do tego stworzony).

    0
  • #7 05 Lis 2018 21:26
    rafont2
    Poziom 5  

    gabik001 napisał:
    Można jeszcze spróbować zainstalować system na drugim pendrive (on chyba ma dwa porty USB) dla sprawdzenia bo do użytku taki sposób się nie nadaje (zbyt wolno chodzi a pendrive nie jest do tego stworzony).

    Podpiąłem drugiego pendrive (uprzednio sformatowanego na exFAT) do drugiego gniazda USB jednak bez efektów. Dobrze zrozumiałem, że miałem podjąć próbę instalacji systemu na tym pendrive z pendriva wcześniej przygotowanego na boot? Czy zainstalować system na innym komputerze i wtedy spróbować? Bo jeśli opcja druga, to nie wchodzi w grę, bo nie mam dostępu do innego Maca niestety.

    Żadna komenda nie działa oprócz wciśnięcia [Option] dlaczego?
    Czy nie powinienem zauważyć też wtedy podłączonych dysków, mimo że są bez systemu? Nie wiem jak to jest na Macach :(

    gabik001 napisał:
    Bardziej był bym za samym pendrivem że jest nieodpowiednio przygotowany.

    Jeszcze jeśli chodzi o tego bootowalnego pendriva, wklejam wycinek jak to wygląda. Czy tak powinien być "złożony" instalator? (Dysk F)
    Macbook Pro A1226 - nie moge zainstalować systemu z bootowalnego pendrive

    Windows 10 po podłączeniu tego pendriva woła o sformatowanie przed użyciem. Wiem że to przez różnice systemu plików.

    0
  • Pomocny post
    #8 06 Lis 2018 00:51
    gabik001
    Poziom 37  

    No na pewno nie powinno być cyrylicy...
    Jeden pendrive z instalką, drugi czysty. Tak diagnozowałem maca pro z padniętym hdd (tanie nie są, a w zasobach części zapasowych takiegoż brak) po "lekkim" zalaniu. Po zainstalowaniu systemu można wszystko przetestować ale system strasznie wolno chodzi z racji działania pendrive'a.
    Macbook Pro A1226 - nie moge zainstalować systemu z bootowalnego pendrive
    Tak wygląda u mnie. Tworzony był na mac-u z pomocą Diskmaker X. U Ciebie brakuje folderu utilities stąd brak reakcji na skróty klawiszowe.

    0
  • #9 06 Lis 2018 17:38
    rafont2
    Poziom 5  

    Wielkie wielkie wielkie dzięki za pomoc !!!!!
    Problem tkwił właśnie w samym instalatorze i wskazanym braku folderu "Utilities"
    Wszystkie wersje systemu Mac OS X (a miałem kilka na próby) nie posiadały tego katalogu w sobie, dopiero po znalezieniu i pobraniu Mac OS X Yosemite 10.10.3 udało mi się zainstalować system (choć nie ukrywam że bez przeszkód, jakie sprawił mi nieodpowiednio sformatowany dysk -wyskakiwał mi błąd "a GUID Partition Table (GPT) partitioning scheme is required", ale po kilku formatowaniach metodą prób i błędów udało się).
    Mogłem sprawdzić działanie laptopa i wiem że jest sprawny.

    Temat jest do zamknięcia, ale miałbym jeszcze jedno pytanie, żeby rozwiać swoje wątpliwości... I jedno dotyczące poprawności działania sprzętu.

    1. Dobrze rozumiem, że aby zrobić cokolwiek na Macu bez systemu, trzeba mieć przynajmniej instalkę na pendrivie? Żaden skrót klawiaturowy nie będzie działał? Żadnego testu sprzętu nie można zrobić?
    2. Przy włączeniu laptopa wiatraki szaleją, działają na pełnych obrotach. Ale po odłączeniu klawiatury przestają i działają w wolnym tempie... Dlaczego? Da się to jakoś uregulować?

    0
  • #10 08 Lis 2018 02:43
    gabik001
    Poziom 37  

    Nawet jak jest uszkodzony system na dysku to utilities działają i dlatego można coś zdziałać. Natomiast przy szwankującym dysku będą pojawiać się problemy różnej maści: przerywanie wifi, problemy z przeglądaniem stron a w momencie próby upgrade'u systemu będzie to niemożliwe. Właśnie mam takiego pacjenta.
    Ale przy braku dysku wyskoczy ikona z pytajnikiem i niewiele da się zrobić. Dobrze jest mieć pendrive z instalką.
    Wiatraki na pełnych obrotach - a grafika w porządku?

    0
  • #11 09 Lis 2018 23:14
    rafont2
    Poziom 5  

    nie zauważyłem żadnych uchybień podczas krótkiej pracy/zaznajamianiem się z systemem. Jak mogę ją jeszcze sprawdzić?
    sama matryca nie działa, jest tylko podświetlenie, pracuje na monitorze zewnętrznym
    wiatraki zaczęły wariować, nie ukrywam przeze mnie - źle podpiąłem wtyczkę klawiatury, laptop był wtedy podpięty do zasilania ale nie włączony; po podpięciu tej wtyczki włączył się i już zaczęły pracować jak szalone. Tylko gdy odłączę klawiaturę uspokajają się. Czyżby zrobiło się jakieś zwarcie na taśmie od klawiaturki? Trzeba będzie ją wymienić? Czy można do tego jakoś dojść i naprawić mój błąd?

    0
  • #12 10 Lis 2018 00:43
    gabik001
    Poziom 37  

    Często gęsto jest tak że na zewnętrznym monitorze jest ok a na matrycy nic. Szczególnie w iMac'ach.
    Maki mają to do siebie że mają pełno czujników temperatury. Nawet dyski twarde dedykowane do mac'ów (z jabłkiem na nalepce) mają wbudowane czujniki. Właśnie taki oprawiam. Wymieniłem hdd na ssd i została mi jedna wtyczka... Okazuje się że w 21 calowym iMacu (2010) czujnik temperatury jest wykorzystany z wbudowanego w dysk twardy i trzeba podłożyć sensor temperatury (znalazłem taki OWC za 40 baksów bo na ssd nie ma) natomiast w 27 calowym jest zwykły termistor przyklejony do dysku i wystarczy go przełożyć. Piszę o tych sensorach gdyż właśnie brak któregokolwiek powoduje wariacje wentylatorów. Należy zwracać uwagę na poprawną pracę chłodzenia gdyż ma to wpływ na ew. problemy z grafiką.

    0
  • #13 10 Sty 2019 22:53
    rafont2
    Poziom 5  

    wracam do tematu jednak z innym już problemem...
    Wymieniłem matrycę na inną ale na ekranie są paski przez co obraz jest strasznie niewyraźny - dlaczego? Macbook Pro A1226 - nie moge zainstalować systemu z bootowalnego pendrive[/url]

    0
  • #14 11 Sty 2019 00:31
    gabik001
    Poziom 37  

    Obawiam się że to GPU. Oprócz pasków innych uchybień nie ma?

    0
  • #15 11 Sty 2019 10:35
    rafont2
    Poziom 5  

    nie zauważyłem innych uchybień na razie, no może po za wolną pracą laptopa ale to może być przez dysk

    gabik001 napisał:
    Obawiam się że to GPU.

    w sensie za mocno się grzeje? czy może być uszkodzony?

    0
  • #16 12 Sty 2019 01:08
    gabik001
    Poziom 37  

    Nie, chodzi mi o kulki pod GPU.

    0
  • #17 12 Sty 2019 12:34
    rafont2
    Poziom 5  

    w sumie pierwszy raz o tym słyszę...
    wcześniej jak podłączałem pod monitor to wszystko było ok, to nie powinno być też jakichś oznak na monitorze że to może być wina GPU?

    jest jakaś szansa na ratunek? jestem w stanie zrobić to sam czy jednak potrzebny jakiś spec?

    0
  • #18 12 Sty 2019 19:38
    gabik001
    Poziom 37  

    Jaki układ graficzny jest w tym laptopie?
    Jak tam siedzi nVidia no to może mieć GeForce 8600M a to było felerne w tych lapkach...
    Nawet Apple miał program darmowej wymiany ale się skończył w grudniu 2012. Wg tego co piszesz to Twój pasuje w te ramy.
    Problem w tym że na zewnętrznym monitorze defektu nie widać a wg zdjęcia to raczej GPU.
    Sam raczej niewiele zdziałasz. Chyba że dysponujesz stacją do lutowania BGA i jesteś w stanie wymienić układ.

    0
  • #19 12 Sty 2019 20:03
    rafont2
    Poziom 5  

    ehhh czyli nici z pracy na tym lapku...
    szkoda :(

    0
  • #20 12 Sty 2019 20:21
    gabik001
    Poziom 37  

    Ja nie napisałem że to jest na 100%.
    Będziesz pewny gdy sprawdzisz jaki GPU tam jest. Jeżeli układ nVidia to raczej wymagana jest jego wymiana. Sama wymiana kulek niewiele da bo te układy same w sobie były felerne. Nie tylko w makach ale też np. w HP serii DV/DX, miałem do naprawy sony AIO w którym też taki sam układ odłożył łyżkę...
    Jeżeli bardzo Ci zależy to popytaj kolegów na forum którzy bawią się w BGA za ile by mogli taki układ wymienić. Może warto.

    0
  • #21 12 Sty 2019 23:18
    rafont2
    Poziom 5  

    jest w nim karta NVIDIA GEFORCE 8600M GT 256MB
    więc to seria felerna
    jak dla mnie to nie opłaca się tego naprawiać, bo różnie bywa i nie wiadomo jak długo później karta będzie działała
    chyba że to może być też wina czegoś innego, taśma np? chociaż poprawiałem i nic sie nie zmieniało

    0
  • #22 13 Sty 2019 23:54
    gabik001
    Poziom 37  

    Po mojemu to GPU. To i tak masz szczęście że się uruchamia w ogóle...

    0
  • #23 14 Sty 2019 19:34
    rafont2
    Poziom 5  

    Podsumowując,
    system udało się zainstalować - winą było brak plików startujących na dysku instalacyjnym
    sprawa z matrycą prawdopodobnie kieruje się w stronę uszkodzonego GPU
    dzięki za pomoc
    zamykam

    0