Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

maszyna wirtualna a linux

smagciu 03 Kwi 2008 15:41 7789 13
  • #1 03 Kwi 2008 15:41
    smagciu
    Poziom 12  

    witam. tak sie zastanawiam. Chcę poznać linux'a i chcę go zainstalować na wirtualnej maszynie. Czy jak to zrobię to będzie się na tym linuksie dało zamontować te dyski z windowsa?

    0 13
  • #2 03 Kwi 2008 15:59
    mbo
    VIP Zasłużony dla elektroda

    Tak - będzie można.

    0
  • #3 03 Kwi 2008 22:10
    smagciu
    Poziom 12  

    dzieki. a jak mam to teraz zrobić?

    0
  • #4 03 Kwi 2008 22:15
    Vizzle
    Poziom 21  

    Jeśli masz dyski/partycje w /dev/ np. /dev/hda#, polecenie wygląda następująco:

    mount -t fat32 /dev/hdc# /mnt/??????

    gdzie:
    # - numer partycji
    ?????? - nazwa folderu montowania (możesz montować gdzie chcesz nie tylko w /mnt)
    parametr -t odpowiada za typ systemu plików


    Lista partycji, polecenie:
    fdisk -l

    0
  • #5 03 Kwi 2008 22:42
    _h
    Poziom 20  

    Vizzle odpowiedzial dobrze, ale nie zalozyl kilku rzeczy:

    dysk nie musi byc hda, moze to rownie dobrze byc np sda zalezy czy masz dyski ATA czy SCSI lub SATA

    fat32 jest czesto spotykany w windowsach, ale NTFS tez sie pojawia i tu trzeba miec jądro, ktore wspiera ten system plikow

    Dodatkow nalezy montowac z uprawnieniamu roota.

    No i ostatnie pytanie - jesli tworzysz maszyne w Vmware musisz miec pewnosc, ze dales mozliwosc dostepu paszynie guest do zasobow dyskowych maszyny host.

    Jesli tak nie jest fdisk -l pokaze jedynie partycje widziane w obszarze sand box - srodowisku wirtualnym stworzonym dla linuxa.

    0
  • #6 03 Kwi 2008 23:20
    smagciu
    Poziom 12  

    to tak jak wpisałem fdisk -l to mi pokazało tylko linuksowe 3 partycje. to nie mam wlaczonego w VMware tej opcji ? inaczej powinno wyswietlic mi tez inne partycje ?

    Dodano po 8 [minuty]:

    aha i szukałem i nigdzie nie moglem znaleźć tego zeby miec mozliwość wlaczenia tych zasobow dyskowych na VMware, gdzie to jest ?

    0
  • #7 04 Kwi 2008 07:22
    fox3i
    Poziom 14  

    Nie da się.Możesz jedynie wymieniać pliki między systemami za pomocą pendrive lub protokołów sieciowych.Jeżeli chcesz mieć dostęp z poziomu linuksa do dysku C,musisz zainstalować np Topologilinux,który instaluje się z poziomu Windows w katalogu systemu Windows:) Jak ci się znudzi odinstalowujesz go tak samo jak inne programy.

    0
  • #8 04 Kwi 2008 08:09
    pawelek_be
    Poziom 16  

    Vizzle napisał:
    mount -t fat32 /dev/hdc# /mnt/??????

    chyba vfat a nie fat32...
    pozatym fata nie widzialem na dyskach juz wieki... z duza doza prawdopodobienstwa ma win xp i ntfs... ;p jest projekt bodajze ntfs-3g ktory obsluguje w 99% system plikow ntfs z zapisem wlacznie...

    0
  • #9 04 Kwi 2008 08:47
    Kolobos
    Spec od komputerów

    Ale wszyscy bzdurzycie, nie mowiac juz o tym, ze chyba nigdy nie uzywaliscie vmware.

    Wystarczy ustawic w pliku vmx danej maszyny shared folders i zainstalowac vmware tools.
    Wszystkie katalogi same sie podmontuja w /mnt/hgfs/.

    0
  • #10 04 Kwi 2008 19:31
    fox3i
    Poziom 14  

    Kolobos napisał:
    Ale wszyscy bzdurzycie, nie mowiac juz o tym, ze chyba nigdy nie uzywaliscie vmware.

    Wystarczy ustawic w pliku vmx danej maszyny shared folders i zainstalowac vmware tools.
    Wszystkie katalogi same sie podmontuja w /mnt/hgfs/.

    Mam Ubuntu 8.04 na VMware,postąpiłem według porad kolegi i nic,takiego katologu /mnt/hgfs po prosu nie ma.

    0
  • #11 04 Kwi 2008 21:53
    Kolobos
    Spec od komputerów

    Tzn co dokladnie zrobiles? Wklej swoj plik vmx, jaka masz wersje vmware? Czy modul vmhgfs masz skompilowany poprawnie czy moze podczas instalacji vmware tools wywala blad?

    0
  • #12 05 Kwi 2008 10:20
    fox3i
    Poziom 14  

    Kolobos napisał:
    Tzn co dokladnie zrobiles? Wklej swoj plik vmx, jaka masz wersje vmware? Czy modul vmhgfs masz skompilowany poprawnie czy moze podczas instalacji vmware tools wywala blad?

    Witam,po poprawnym zainstalowaniu VMware tools pojawił się katalog /mnt/hgfs/ ale pusty i nie wiem jak zamontować w nim współdzielony folder.Oto mój plik wmx
    Code:
    config.version = "8"
    
    virtualHW.version = "6"
    scsi0.present = "TRUE"
    scsi0.virtualDev = "lsilogic"
    memsize = "512"
    scsi0:0.present = "TRUE"
    scsi0:0.fileName = "Ubuntu.vmdk"
    ide1:0.present = "TRUE"
    ide1:0.fileName = "D:\Nowy folder\Nowy folder\ubuntu-8.04-beta-desktop-i386.iso"
    ide1:0.deviceType = "cdrom-image"
    floppy0.autodetect = "TRUE"
    ethernet0.present = "TRUE"
    ethernet0.connectionType = "nat"
    ethernet0.wakeOnPcktRcv = "FALSE"
    usb.present = "TRUE"
    ehci.present = "TRUE"
    sound.present = "TRUE"
    sound.fileName = "-1"
    sound.autodetect = "TRUE"
    svga.autodetect = "TRUE"
    pciBridge0.present = "TRUE"
    mks.keyboardFilter = "allow"
    displayName = "Ubuntu (2)"
    guestOS = "ubuntu"
    nvram = "Ubuntu.nvram"
    deploymentPlatform = "windows"
    virtualHW.productCompatibility = "hosted"
    tools.upgrade.policy = "useGlobal"

    floppy0.fileName = "A:"

    floppy0.startConnected = "FALSE"

    isolation.tools.hgfs.disable = "FALSE"

    ide1:0.startConnected = "TRUE"
    ethernet0.addressType = "generated"
    uuid.location = "56 4d 2e 2d 3f 3a 5c b5-7d 8d 7e d6 c9 99 16 51"
    uuid.bios = "56 4d 2e 2d 3f 3a 5c b5-7d 8d 7e d6 c9 99 16 51"
    scsi0:0.redo = ""
    pciBridge0.pciSlotNumber = "17"
    scsi0.pciSlotNumber = "16"
    ethernet0.pciSlotNumber = "32"
    sound.pciSlotNumber = "33"
    ehci.pciSlotNumber = "34"
    ethernet0.generatedAddress = "00:0c:29:99:16:51"
    ethernet0.generatedAddressOffset = "0"
    tools.remindInstall = "FALSE"

    checkpoint.vmState = "Ubuntu.vmss"

    usb.autoConnect.device0 = "path:1/4/7 autoclean:1"

    sharedFolder.option = "alwaysEnabled"
    sharedFolder.maxNum = "1"
    sharedFolder0.present = "TRUE"
    sharedFolder0.enabled = "TRUE"
    sharedFolder0.readAccess = "TRUE"
    sharedFolder0.writeAccess = "TRUE"
    sharedFolder0.hostPath = "C:\"
    sharedFolder0.guestName = "Windows"
    sharedFolder0.expiration = "never"

    tools.syncTime = "FALSE"
    A to plik /etc/fstab/
    Code:
    # /etc/fstab: static file system information.
    
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    proc            /proc           proc    defaults        0       0
    # /dev/sda1
    UUID=556d0793-21a7-44c7-aa4e-86dbc56a41d6 /               ext3    relatime,errors=remount-ro 0       1
    # /dev/sda5
    UUID=5bf080a4-2f0c-4888-8d6c-f78a3ef8de38 none            swap    sw              0       0
    /dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
    /dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0

    I tu chyba brakuje odpowiedniego wpisu,a jeżeli tak to jakiego?

    0
  • #13 05 Kwi 2008 13:43
    Kolobos
    Spec od komputerów

    Na pewno poprawnym? Sam mam Ubuntu + Vmware Player i instalacja vmware tools nie przebiegla bez problemow, a dokladnie kompilacja vmhgfs, wymagana byla modyfikacja zrodel. Dlatego tez zgaduje, ze u Ciebie wystepuje ten sam problem. Zobacz czy masz w ogole zaladowany modul vmhgfs. Tutaj masz opis modyfikacji:
    http://www.debuntu.org/how-to-vmware-tools-hgfs-module-on-ubuntu-gutsy-gibbon-7.10
    Sprowadza sie ona do dodania jednego =.

    Napisze jeszcze raz NIC nie trzeba zmieniac recznie, wystarczy poprawny plik vmx i vmware tools.

    0
  • #14 31 Gru 2009 10:56
    gavron
    Poziom 22  

    krew mnie zalewa jak was wszystkich czytam....

    w VMWare w ustawieniach dyskow tworzysz dodatkowy dysk i wybierasz opcje "dostep do prawdziwego dysku".... czy cos takiego .... nie pamietam dokladnie bo nie uzywam komercyjnych programow.... (o wiele lepiej uzywac VirtualBox'a :) )

    wtedy jako dodatkowy dysk w wirtualnej maszynie bedziesz mial dostep do CALEGO dysku prawdziwego, a nie przy uzyciuu jakis SHARED FOLDERS tylko do folderow... :(

    UWAGA! bo opcja dosyc bardzo niebezpieczna jezeli sie nie wie co sie robi......


    ps. przy takich ustawieniach mozesz w wirtualnej maszynie odpalic ten sam system ktory masz zainstalowany na dysku.... tylko sie troszke wszystlko moze rozje$#@%...

    0