Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

jeszcze raz stroboskop j-111 i sterowanie lpt

wader_669 21 Nov 2008 19:32 17919 57
Metalwork
  • #1
    wader_669
    Level 28  
    zbudowalem sobie stroboskop j-111 dziala super.
    Problem taki jak chcialem dodac sterowanie ltp to stroboskop mrugnie mi raz lub mruga bardzo szybko (ale nie tak jak ustawiam), po pewnym czasie sie przepala optotriak.
    Testowalem lpt programem "parmon" i miernikiem, dziala poprawnie.

    tutaj schemat:
    jeszcze raz stroboskop j-111 i sterowanie lpt

    u1 nie wiem jaki wybrac moc3041 czy moc3021 ? (testowalem 2)
    r5 - 470 hom
    i jedno wejscie do optotriaka podlaczam do pinu 2 lpt
    drugie wejscie (to z rezystorem) podlaczam do pinu 24-18 lpt.

    jeszcze raz stroboskop j-111 i sterowanie lpt

    http://www.discolitez.com/pmwiki/pmwiki.php?n=Hardware.TRIAC
    tutaj strona ze sterownikami

    Prosze o pomoc bo nie wiem gdzie jest blad, ktos radzil zmienic kondensator c5 na 10nF 400V, czy to rozwiaze problem?
  • Metalwork
  • #2
    Popak
    Moderator on vacation ...
    Witam

    Spróbuj włączyć między optotriak a tyrystor rezystor 10K

    Pozdrawiam
  • #3
    wader_669
    Level 28  
    ok, a jaki kondensator polecasz i jaki optotriak?
  • Metalwork
  • #4
    Popak
    Moderator on vacation ...
    Witam

    Kondensator na razie zostaw jaki jest a optotriak to moc3041 bo ma detekcje przejścia przez zero.
    Aha upewni się że na wyjściu LPT masz stan wysoki i na przykład dioda LED świeci (mryga)

    Pozdrawiam
  • #5
    wader_669
    Level 28  
    wiec nie dziala z optotriakiem - moc3041, rezystorem - 10k i kondensatorem - 10uF.
    Chyba obojetnie jak podlacze wyjsca z optotriaka ?
    lpt dziala testowalem, napiecie wynosi 0,09V a jak wlacze pin to wynosi 4,60V , przy obciazeniu przez diode wynosi 2,97V
  • #6
    Popak
    Moderator on vacation ...
    Witam

    To rezystor 10k wywal a spróbuj z tym kondensatorem i napisz jakie są objawy czy mrugnie choć raz.
  • #7
    wader_669
    Level 28  
    pierw wogule nie mrugal a jak wywalilem rezystor to mrugal szybko i chyba optotriak juz sie spalil.
    Jutro sie udaje do elektronicznego to dalej po kombinuje.
    jeszcze tutaj jest orginalny schemat moze pomoze
    jeszcze raz stroboskop j-111 i sterowanie lpt
  • Helpful post
    #8
    Popak
    Moderator on vacation ...
    Witam

    niech kolega zobaczy takie rozwiązanie
    jeszcze raz stroboskop j-111 i sterowanie lpt
  • #9
    wader_669
    Level 28  
    to jest takie zgadywanie czy jestes pewien? :P dzisiaj nie bylem w elektronicznym ale w poniedzialek napewno zahacze kupie odrazu wiecej sztuk optotriakow i jakos wieczorem powiem jak wyglada rezultat
  • #10
    Popak
    Moderator on vacation ...
    wader_669 wrote:
    to jest takie zgadywanie czy jestes pewien?
    100% pewności nigdy nie ma ale jak tamto nie działało to mam nadzieje że to zadziała. Ja też czasami robię projekty metodą prób i błędów i tak się człowiek uczy (aha tak nie wyszło, a może tak) Jak wyjdzie to już na przyszłość wiemy.
  • #11
    wader_669
    Level 28  
    chyba masz racje, jak sie nie myle to tutaj ten wyzwalacz polega na bradzo protym ukladzie gdzie rc i potencjometrem decydujemy jak szybko kondensator sie naladuje i wyzwoli lapme. Pytanie czy podlaczyc optotriaka do + czy -
  • #12
    Popak
    Moderator on vacation ...
    wader_669 wrote:
    jak sie nie myle to tutaj ten wyzwalacz polega na bradzo protym ukladzie gdzie rc i potencjometrem decydujemy jak szybko kondensator sie naladuje i wyzwoli lapme.


    W tym układzie za przerywnik robi diak Db3 i on przerywa. Im większe napięcie dostanie (kręcimy potencjometrem) tym szybciej przerywa. Kondensator tylko filtruje napięcie.
    Co do + czy - to się zobaczy :)

    Pozdrawiam
  • #13
    wader_669
    Level 28  
    zrobilem tak jak na schemacie, testowale dla + i - nie dziala
  • #14
    Popak
    Moderator on vacation ...
    Witam
    To ja już nie wiem powinno zadziałać :| Bo diak działa jak przerywnik, a jak się zamieni na optotriak to on przerywa.
    Musiałeś coś robić nie tak albo masz coś skopsane. Może tyrystor?

    Pozdrawiam
  • #15
    wader_669
    Level 28  
    ja mam triak bt136
  • #16
    djtronic
    Level 20  
    a moze problem nie lezy w wyzwalaniu przez optotriak?
    Ze tak zapytam, bez optotriaka stroboskop działa poprawnie?
  • #17
    wader_669
    Level 28  
    tak
    jak zrobilem wszystko jak na 1 zdjeciu i podlaczylem optotriak do 5V to sie wszystko zgadzalo, bo blyskalo bardzo szybko. Jednak jak podlaczylem optotriaka do ltp to juz nie dziala sterowanie.
    wszystkie inne opcje testowalem i nie dzialaja.
    Przepalilem nastepny optotriak juz 6 w kolekcji. Narazie sie poddaje chyba ze ktos znajdzie rozwiazanie za ktore da glowe, bo takie testowanie za duzo mnie kosztuje
  • #18
    Popak
    Moderator on vacation ...
    wader_669 wrote:
    tak
    jak zrobilem wszystko jak na 1 zdjeciu i podlaczylem optotriak do 5V to sie wszystko zgadzalo, bo blyskalo bardzo szybko. Jednak jak podlaczylem optotriaka do ltp to juz nie dziala sterowanie.


    I tu może masz problem. Może to LPT? optotriak podłączasz przez rezystor? Jeśli tak to przez jaki?
  • #19
    djtronic
    Level 20  
    I radze dwa razy sprawdzic poprawność połączenia optotriaka do odpowiednich pinów LPT.
  • #20
    wader_669
    Level 28  
    przez 470 ohm
    lpt jest na 100% dobrze podlaczony
  • #21
    djtronic
    Level 20  
    a wiec z tego co piszesz wszystko powinno dobrze chodzic. MOze sprobuj wysłać ciagły sygnał na optotriak i sprawdz czy przewodzi, jesli tak,. to jedz dalej po lini i sprawdzaj tyrystor, i caly uklad wyzwalania...
  • #22
    wader_669
    Level 28  
    wczesniej napisalem:
    wader_669 wrote:

    lpt dziala testowalem, napiecie wynosi 0,09V a jak wlacze pin to wynosi 4,60V , przy obciazeniu przez diode wynosi 2,97V

    moze problem jest w tym ze przy obciazeniu napiecie przy lpt spada i nie wystarcza by zalaczyc optotriaka?

    (nie jestem w stanie wytestowac teraz bo nie kupilem nowego optotriaka
  • #23
    Popak
    Moderator on vacation ...
    wader_669 wrote:
    wczesniej napisalem:
    lpt dziala testowalem, napiecie wynosi 0,09V a jak wlacze pin to wynosi 4,60V , przy obciazeniu przez diode wynosi 2,97V


    Ale koledze chodziło o sprawdzenie optotriaka :) Jak mu podasz napięcie to powinien przewodzić>

    wader_669 wrote:
    moze problem jest w tym ze przy obciazeniu napiecie przy lpt spada i nie wystarcza by zalaczyc optotriaka?
    (nie jestem w stanie wytestowac teraz bo nie kupilem nowego optotriaka


    Aby się upewnić czy ze stroboskopem jest wszystko ok to zamiast diaka czy optotriaka daj przełącznik chwilowy jak naciśniesz go powinien być błysk a jak naciśniesz drugi raz też powinien być. Jeśli tu jest ok. to na 100% masz coś z LPT. A jak spada ci napięcie to podaj sygnał na tranzystor który wysteruje diodą. Wtedy napięcie nie spadnie :) Nie wiem jaka masz płytę ale wychodzi na bardzo delikatną i kapryśną :D

    Ps. Uważaj na przełącznik bo będzie podłączony do wysokiego napięcia!

    Pozdrawiam
  • #24
    wader_669
    Level 28  
    wlasnie cos kombinowalem z wlacznikiem ale tez nie dzialalo. Pomysle i ostatni raz postaram sie cos zrobic.
    Co do wzmocnienia sygnalu lpt to jest jasne, ze trzeba zastosowac tranzystor, problem jednie taki ze bym musial pociagnac dodatkowe zasilanie np. z komputera co mi sie nie zbytnio usmiecha
  • #25
    Popak
    Moderator on vacation ...
    Nie no nie chce mi się wierzyć albo nas bajerujesz :) Na diaku działa a na przełączniku czy optotriaku już nie. Kolego zrób zdjęcia twojego stroboskopu i wklej tutaj bo wydaje mi się że jest źle zmontowany.
  • #26
    djtronic
    Level 20  
    Quote:
    Na diaku działa a na przełączniku czy optotriaku już nie.


    dziwna sprawa.. :P Pozostaje mi chyba wybuchnąć smiechem. Wychodzi na to że najprawdopodobniej skopany masz układ strobskopu..

    Quote:
    Kolego zrób zdjęcia twojego stroboskopu i wklej tutaj bo wydaje mi się że jest źle zmontowany.


    To chyba najlepsze rozwiązanie..
  • #27
    wader_669
    Level 28  
    co to znaczy zle zmontowany, pisalem ze jak jest sterowanie potencjometrem to wszystko dziala super. Co do tego wlacznika to mozliwe ze on byl wadl bo robilem to szybko i na odpiepsz. Jak dostane spowrotem stroboskop to porobie zdjecia i wszystko pokolei przejde.
  • #28
    Popak
    Moderator on vacation ...
    wader_669 wrote:
    Jak dostane spowrotem stroboskop to porobie zdjecia i wszystko pokolei przejde.


    To gdzie teraz jest? ;) Z takich postów wynika że albo tego stroboskopu nie ma w rzeczywistości albo nas bajerujesz :D
  • #29
    wader_669
    Level 28  
    hahaha nie.
    stroboskop byl zrobiony dla znajomego chcialem zrobic wlasnie 2 opcje sterowania za pomoca potencjometra i lpt. Jednak stwierdzilem ze nie mam sily na bajerowanie z lpt po 6 spalonych optotriakach.
    Plan jest taki jutro jeszcze jade do elektronicznego po 2 optotriaki (ostatnie!!!) zbadac czy sie zalanczaja przy lpt jak zadziala pojade po stroboskop i robie ostatnie proby.

    Ostatnie pytanie jak dzialaja optotriaki, czy one sie po prostu zalanczaja i wylanczaja? i czy jak jest napiecie na wejsciach to powino byc zwarcie na wyjsciach? bo jak badalem miernikiem mialem jakas rezystancje i nie byla ona mala
  • #30
    djtronic
    Level 20  
    Quote:
    Ostatnie pytanie jak dzialaja optotriaki


    Jak wpiszesz słowo Optotriak w google to korona z głowy nie spadnie.

    Działa tak smao jak triak tyle że jest galwanicznie odseparowane wejscie od wyjscia. Potrzeba odpowiedniego prądu na wjesciu zeby wysterowac diode ktora przełączy nam triaka. A jakiego prądu? To juz zalezne od optotriaka.