Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Programator na płytce ZL2PRG. Nie mogę nic zaprogramować.

Akord 13 Mar 2005 21:11 5160 21
  • #1 13 Mar 2005 21:11
    Akord
    Poziom 10  

    Witam!
    Mam taki problem: Zrobiłem programator na kupionej plytce ZL2PRG i niestety nic nie mogę zaprogramować. Kompiluje program , ale jak każę programować to wyświetla mi okienko z komunikatem: Could not identify chip with ID:FFFFFF. Mam windowsa XP i BASCOM AVR DEMO. Może wiesz co z tym fantem zrobić?
    Roman

    0 21
  • #2 13 Mar 2005 21:50
    McRancor
    VIP Zasłużony dla elektroda

    Mam ten sam problem i wychodzi na to że po prostu ten programator nie działa jak powinien, za to z Xilinxami hula jak marzenie :)

    0
  • #3 13 Mar 2005 22:25
    Akord
    Poziom 10  

    dziwne, bo ztego co mówi mi znajomy, u niego programator hula donrze. Moze to kwestia ustawień windowsa, nie wiem

    0
  • #4 29 Cze 2005 15:25
    jareks91
    Poziom 21  

    Mam ten sam problem z tym wyjątkiem, że żaden komunikat mi się nie wyświetla, ale nie programuje.
    Jak mam ustawić w opcjach bascoma aby mi programował z użyciem tego programatora?
    Proszę o pomoc.
    Pozdrawiam

    0
  • #5 30 Cze 2005 21:54
    majster256
    Poziom 21  

    Witam
    To jest programator ISP???
    jaki masz procek???
    moze potrzeba dolaczyc do niego kwarc a przy takich programatorach bardzo czesto trzeba zewnetrzne zasilanie. moze podasz schemat.

    Pozdrawiam
    Adam

    0
  • #7 01 Lip 2005 22:20
    majster256
    Poziom 21  

    a kwarc?? przy tym procku jest bardzo potrzeby
    Pozdrawiam

    0
  • #8 01 Lip 2005 22:40
    jareks91
    Poziom 21  

    Kwarc jest sprawny. A płytka to AVT 3500. Podlączyłem, dobrze ale jeszcze sprawdze .
    Pozdrawiam

    0
  • #9 02 Lip 2005 12:18
    McRancor
    VIP Zasłużony dla elektroda

    Spraw sobie nowy programator, ten jest przypałowy jeśli chodzi o emulację stk200.

    0
  • #10 10 Lip 2005 21:48
    jareks91
    Poziom 21  

    McRancor napisał:
    Spraw sobie nowy programator, ten jest przypałowy jeśli chodzi o emulację stk200.

    Okazało sie że programator byl zepsuty, odlutował sie kabelek łączący piny od 20 do 25 z masą bufora
    Pozdrawiam

    0
  • #11 26 Paź 2005 00:33
    jimmi
    Poziom 13  

    Ja tez mam ten programator i tez mi nie dziala ( Wyskakuje blad, rozny w zaleznosci od programu,ale np w ponyprog2000 test konfiguracyjny przechodzi OK ... dziala tak jakby nie do konca i nie mam pojecia gdzie usterka... HELP!
    dzialam na WinXP

    a tak na marginesie,mierzyl ktos z Was czy jest napiecie na wejsciach programatora? tzn na zlaczu ISP.. ja mierze i nic nie mam > troche mnie to dziwi,a po zwarciu diody napiecie juz jest...

    J.

    Dodano po 39 [minuty]:

    i problem rozwiazalem po przegldanieciu kilkunastu postow..Mianowicie podlaczyl;em zewnetrzne zasilanie 5V, stabilizowane. W PonyProg dziala poprawnie wiec w innych tez powinno.Pamietajcie o spieciu mas razem:)
    Powodzenia!
    ZL2PRG + XP :)
    /j.

    0
  • #12 17 Lis 2005 20:13
    tomj81
    Poziom 11  

    jimmi napisał:

    i problem rozwiazalem po przegldanieciu kilkunastu postow..Mianowicie podlaczyl;em zewnetrzne zasilanie 5V, stabilizowane. W PonyProg dziala poprawnie wiec w innych tez powinno.Pamietajcie o spieciu mas razem:)
    Powodzenia!
    ZL2PRG + XP :)
    /j.


    Witam wlasnie sie zastanawiałem nad tym problemem zwiazanym z VCC na schemacie ze strony www.btc.pl zasilanie wisiało w powietrzu :D spróbuje z tym stabilizatorem a +5V skad wycaiagnełes z com-a czy z lpt-ka.

    I jeszcze jedno pytanie czym zaprogramować eeprom 24c32 jestt jakis programator do tego i czy zlpr2 da rade go obsłużyć??

    z góry dziekuję za odpowiedzi

    0
  • #13 17 Lis 2005 21:09
    zumek
    Poziom 39  

    tomj81 napisał:

    ...
    Witam wlasnie sie zastanawiałem nad tym problemem zwiazanym z VCC na schemacie ze strony www.btc.pl zasilanie wisiało w powietrzu :D spróbuje z tym stabilizatorem a +5V skad wycaiagnełes z com-a czy z lpt-ka.
    ...
    z góry dziekuję za odpowiedzi

    No przecież proca , którego będziesz programował , też musisz skądś zasilić . Z tego właśnie źródła , zasil również programator , a właściwie znajdujący się w nim bufor 244.Jeśli na złącze programatora pin nr.2 nie podasz zasilania , to zapomnij o programowaniu.

    Piotrek

    0
  • #14 17 Lis 2005 22:36
    tomj81
    Poziom 11  

    zumek napisał:

    No przecież proca , którego będziesz programował , też musisz skądś zasilić . Z tego właśnie źródła , zasil również programator , a właściwie znajdujący się w nim bufor 244.Jeśli na złącze programatora pin nr.2 nie podasz zasilania , to zapomnij o programowaniu.

    Piotrek


    witam

    chyba nastapiło przeklamanie nie pin 2 tylko pin 20 wg datasheet , a dlaczego pytam bo mam dwa chematy i na jednym podpiete jest pod pin20 bufora a na drugim juz nie stąd moje pytanie o zasilanie układu :P



    A epromik 24c32 jak mu wsada zadać jest do tego jakis programator?

    A moze sie nie męczyć i zakupic za 40zl z przesyłka programator phoenix&fun

    opis jest taki
    "
    # Programator Phoenix może być w wersji 3,57MHz(standard) lub 6MHz. - do wyboru.
    # Programator pozwala na edycje różnych kart chipowych (Phoenix),
    # w tym kart do telefonów GSM(klonowanie, edycja kodu PIN, edycja książki telefonicznej),

    * A tu wykaz kart które mozesz zaprogramować tym programatorem:
    * Karty byłej Wizji TV
    * Karty C+ stare i nowe
    * Gold Card - częściowo(do całkowitego zaprogramowania potrzeba dodatkowo JDM ISO)
    * FUNRRARI
    * Funcard - Fun Card
    * TITANIUMCARD - TITANIUM CARD.
    * Atmega - AtMega
    * Mixcard - Mix Card
    * Blackcard - Black Card
    * oraz procesory ATMEL serii 90
    "
    i o wiele szersze pole do popisu niz same mikroprocki??

    0
  • #15 17 Lis 2005 23:02
    McRancor
    VIP Zasłużony dla elektroda

    do 24C32 zl2prg się nie nada kompletnie, phoenix też się nie nada.

    Tu masz coś co się nada idealnie i jest tak proste że samemu bez problemu zrobisz nawet na pająku:
    http://www.lancos.com/siprogsch.html

    0
  • #16 17 Lis 2005 23:08
    zumek
    Poziom 39  

    Nie wiem , który z nas "kłamie" he he he , ale napisałem Jeśli na złącze programatora pin nr.2 ... miałem na myśli numer pinu złącza , a nie pin bufora 244.

    Piotrek

    0
  • #17 17 Lis 2005 23:22
    tomj81
    Poziom 11  

    zumek napisał:
    Nie wiem , który z nas "kłamie" he he he , ale napisałem Jeśli na złącze programatora pin nr.2 ... miałem na myśli numer pinu złącza , a nie pin bufora 244.

    Piotrek


    ale również napisałeś ze należy zasilic bufor a na buforze to pin20 i ja mam również rację :P zreszta na schemacie widac co trzeba zasilic pozatym schematy potrafie jeszcze czytac , a moje pytanie było o zasilanie skad z coma czy innego ustrojstwa chyba z coma pociągnę lub z zasilacza czysto estetyczno praktyczne pytanie.Jakie sa wasze rozwiazaniea w tej kwestii??


    :arrow: dzieki McRancor za linka....:D

    pozdro

    0
  • #18 17 Lis 2005 23:37
    genetix
    Poziom 24  

    :arrow: tomj81
    Ja podłączam zasilanie programatora pod programowaną kostkę (dongle STK200/300)

    Natomiast płytkę uruchomieniową zasilam z PC przez złącze 5/12V zabezpieczone wyłącznikiem i bezpiecznikami.

    0
  • #19 18 Lis 2005 12:14
    McRancor
    VIP Zasłużony dla elektroda

    Myśle że lepiej niż z COMa będzie zasilać z portu dżojstika, albo z PS2, albo z USB, Com nie posiada wyprowadzeń typowo zasilających i może się tam pojawić napięcie ujemne na każdym pinie, co skutecznie eliminuje wszelką elektronikę ;)

    0
  • #20 18 Lis 2005 13:12
    genetix
    Poziom 24  

    zawsze możesz dać gretza i 7805 :-)

    0
  • #21 18 Lis 2005 18:01
    tomj81
    Poziom 11  

    narazie dzieki za info chopaki biore sie do roboty :) jakby jakis problem to jeszcze napisze
    pozdro

    0
  • #22 10 Kwi 2007 11:46
    AGL
    Poziom 9  

    Witam. Przeczytałem wszystkie powyższe posty, sprawdziłem połączenia. Mam podłączone zasilanie +5V pin 2 złącza ISP, a błąd ID:FFFFFFF jak był tak jest. Nie wiem co się stało, bo wcześniej to działało, mam programator ZL2PRG i system XP. Brakuje mi pomysłów w tej sprawie. Pozdrawiam.

    0
  Szukaj w 5mln produktów