Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Festool ECU45 - Za wysokie napięcie ładowania

tukson 25 Sie 2015 17:59 1599 0
  • #1 25 Sie 2015 17:59
    tukson
    Poziom 11  

    Witam,

    Zabrałem się do naprawy ładowarki impulsowej Festool ECU 45 (do wkrętarki).
    Początkowo w ogóle nie dawała znaków życia. Okazało się, że po stronie pierwotnej była przebita dioda na zasilaniu power switch'a. Wymieniłem diodę oraz power switcha, oryginalnie był 1M0380R, dałem 1M0365R.

    Jest to zbliżona ładowarka do opisywanej w wątku:
    https://www.elektroda.pl/rtvforum/topic1141200.html
    Strona pierwotna wygląda na identyczną. Te samo trafo i elementy w koło.

    Po wymianie tych dwóch elementów zasilacz odżył, ale nie do końca prawidłowo.
    Po podłączeniu zasilania zapala się na chwilę żółta dioda (ładowarka gotowa do pracy) oraz po chwili zaczyna pulsować na czerwono (zwarcie, uszkodzony aku itp).
    Po włożeniu zepsutego aku (miał napięcie 0,5V - a nominalnie 12V) dioda przez chwilę pulsuje na zielono (ładowanie prawidłowe) i po chwili znów na czerwono. Akurat to by było prawidłowe.

    Nie mniej bez aku powinna świecić na żółto, a nie informować o uszkodzeniu.

    Jak mierze napięcie jałowe na zaciskach do ładowania akumulatora to jest 30V. Moim zdaniem w tym tkwi problem - wydaje mi się, że uC mierzy napięcie i zgłasza problem, a napięcie 30V nawet jak bez aku to jest za wysokie. Wg. tabliczki znamionowej napięcie ładowania 7,2-14,4V.

    Rozrysowałem fragment strony wtórnej. Zarówno przed BUZem jak i za można zmierzyć napięcie ok. 30V. Schemat wygląda tak:
    Festool ECU45 - Za wysokie napięcie ładowania


    Oraz elektronika:

    Festool ECU45 - Za wysokie napięcie ładowania Festool ECU45 - Za wysokie napięcie ładowania


    Nie mam pomysłu w czym może tkwić problem. Może ma ktoś podobną ładowarkę i byłby w stanie zmierzyć jakie jest napięcie przez BUZem? Bo może trafo jednak walnięte.

    Zastanawiam się czy uC nie powinien regulować napięcia za pomocą BUZa (z wykrorzystaniem PWM) - nie wiem czy to się praktykuje w ładowarkach tego typu - jak tak to BUZ walnięty? Zakładam, że uC i NPN jest OK.

    Z góry dziękuje za pomoc i sugestie.

    EDIT: zacząłem sobie czytać o zasilaczach impulsowych i próbuje dojść w jaki sposób regulowane jest napięcie/prąd (bo nie wiem jeszcze co). Z tego co myślę to bardziej muszę się skupić na tej części obwodów, które odpowiadają za feedback do power switcha (do 1M0365R) - czyli na połączeniach LM324 z HEF4052 oraz uC. Ale czy na pewno w ogóle jest w tym problem? Z tego co wyczytałem taki zasilacz bez obciążenia daje pełne napięcie - to mogłoby się zgadzać. To może przyczyny szukać w uC dlaczego stwierdza awarię..?

    pozdrawiam

    0 0