Elektroda.pl
Elektroda.pl
X
Hotair
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Driver LED na wzmacniaczu i tranzystorze Darlingtona - za mały prąd

plakplak 11 Sty 2018 10:56 273 10
  • #1 11 Sty 2018 10:56
    plakplak
    Poziom 3  

    Witam, zbudowałem układ widoczny na schemacie. Można nim ograniczać prąd modułu LED 50W (V=34V, In=1,5A) poprzez tranzystor Darlingtona MJ11016G.
    Na nieodwracające wejście wzmacniacza LM358N jest podawany sygnał PWM (10kHz, ale próbowałem też inne częstotliwości) w zakresie od 0 do 3.3V. Napięcie odkładane na rezystorze R4 10mOhm jest 23 krotnie zwiększane przez drugi kanał wzmacniacza operacyjnego (rezystory R2 i R3) i podawane na wejście odwracające (czyli gdy przez moduł LED przechodzi prąd znamionowy 1.5A to na wejściu jest/powinno być 1.5A*0.01Ohm*23=0.345V). Wzmacniacz steruje tranzystorem, działa jako wzmacniacz błędu, tak aby napięcie różnicowe dążyło do zera.
    I teraz jeśli zadam poprzez sygnał PWM te 345mV to prąd modułu wynosi tylko ok 0.6A, widać że nie świeci z maksymalną mocą i na wejściu odwracającym jest 138mV. Na wyjściu wzmacniacza zmierzone 1.2V multimetrem.
    Wg. noty katalogowej prąd wyjściowy LM358N to minimum 20mA, a wzmocnienie tranzystora MJ11016 to hFE = 5000 dla 1.5A Ic, czy jest możliwe prąd bazy pobierany przez tranzystor jest większy niż jest w stanie zapewnić wzmacniacz i przez to spada napięcie na wyjściu LM358N? Czy dodanie rezystora między nimi rozwiązało by problem?

    Vcc to 50V.
    Maks Vout LM358N to 3.7V przy zasilaniu 5V.
    Driver LED na wzmacniaczu i tranzystorze Darlingtona - za mały prąd
    Pozdrawiam[/tex]

    0 10
  • HotAir
  • #2 11 Sty 2018 11:10
    _jta_
    Specjalista elektronik

    A co (jakie napięcie względem masy) jest na wyjściu IC2B? Jakie na kolektorze T2?

    0
  • HotAir
  • #3 11 Sty 2018 11:23
    plakplak
    Poziom 3  

    Na wyjściu IC2B jest 23 krotne napięcie odłożone na R4 (czyli jak prąd LED a zatem i R4 (pomijając prąd bazy) wynosi 0.5A to się odkłada 5mV, czyli na wyjściu wzmacniacza IC2B jest ok 115mV).
    Przy zasileniu Vcc 56.2V, napięcie kolektora względem masy to 32.6V, dla prądu LED 260mA.

    0
  • #4 11 Sty 2018 11:28
    pawlik118
    Poziom 23  

    i druga sprawa - czy układ się nie wzbudza.
    Z racji braku rezystora w bazie mamy ogromne wzmocnienie prądowe, i brak jakiejkolwiek kompensacji częstotliwościowej.

    0
  • #5 11 Sty 2018 11:43
    trymer01
    Moderator Projektowanie

    plakplak napisał:
    Na nieodwracające wejście wzmacniacza LM358N jest podawany sygnał PWM

    Tak się nie robi, WO "głupieją" starając się nadążyć za impulsami PWM (wchodzą w nasycenie, otwierając tranzystor całkowicie, następnie w drugą stronę - zatykając go).
    Wyfiltruj PWM filtrem RC aby uzyskać napięcie stałe.
    plakplak napisał:
    prąd modułu wynosi tylko ok 0.6A

    I jak jest mierzone jest te 0,6A? - bo może to jest prąd średni (wynikający z wypełnienia PWM) i w czasie impulsu jest 1,5A? A LED-y świecą proporcjonalnie do prądu średniego.
    Poza tym dolny WO pracuje z bardzo niskim Uwy i wypadałoby mu dać pull-down, zresztą górnemu również.

    Dla Ic=1,5A trzeba się liczyć z tym, że beta spadnie nawet do 1000, czyli Ib=1,5mA, więc LM358 na pewno da radę wysterować ten tranzystor przy tym prądzie.

    Możliwe też że układ się wzbudza i generuje swoją częstotliwość.

    Dlaczego tak mała wartość R4? - to daje niskie napięcia sterujące, możliwość sporych błędów - trzeba zadbać o połączenia. Ja dałbym R4 10-20x większy i tylko jeden WO (górny).

    0
  • #6 11 Sty 2018 16:20
    _jta_
    Specjalista elektronik

    Na wyjściu IC2B jest 23 krotne napięcie odłożone na R4

    Teoretycznie, czy tyle pokazał woltomierz? Napisz, co rzeczywiście wskazuje woltomierz - przy pomiarze napięcia na R4 i na wyjściu IC2B. Sprawdź napięcie na R4 (między końcówkami, nie ścieżkami, do których jest przylutowany), oraz pomiędzy dolną końcówką R3, a dolną końcówką R4 - oporność ścieżek/lutowań może być istotna.

    Jeśli na R4 odkłada się 5mV, to nie ma gwarancji, że LM358 to wykryje; jeśli LM358 jest podłączony tak, żeby wzmacniał napięcie 23 razy, to przy 115mV na wyjściu nie wiadomo, czy na wejściu jest 0, czy 10mV - on miewa spore napięcie niezrównoważenia i przy takich małych napięciach na wejściu jest nieprzewidywalny.

    0
  • #7 11 Sty 2018 16:44
    plakplak
    Poziom 3  

    trymer01 napisał:

    plakplak napisał:
    prąd modułu wynosi tylko ok 0.6A

    I jak jest mierzone jest te 0,6A? - bo może to jest prąd średni (wynikający z wypełnienia PWM) i w czasie impulsu jest 1,5A? A LED-y świecą proporcjonalnie do prądu średniego.

    Multimetrem, średnie napięcie odłożone na rezystorze R4 (10mOhm +-5%)to 6mV (więc teoretycznie prąd wychodzi ok. 600mA, nie zmierzyłem amperomierzem, ale widać na oko że nie świeci z pełna mocą), a na wyjściu IC2B wychodzi ok. 140mV względem masy, a więc się zgadza.


    trymer01 napisał:

    Dlaczego tak mała wartość R4? - to daje niskie napięcia sterujące, możliwość sporych błędów - trzeba zadbać o połączenia. Ja dałbym R4 10-20x większy i tylko jeden WO (górny).

    Bo układ jest zasilany z 4 szeregowo połączonych ogniw 18650 (Sony US18650V3) i przetwornicy Step-UP (Vout regulowane 35V-60V, 120W, maksymalny prąd wyjściowy 2A), a więc aby były jak najmniejsze straty na rezystorze.
    Myślałem że może ta przetwornica nie dostarczać wystarczającego prądu ale podłączyłem układ do zasilacza laboratoryjnego (prąd do 3A) i przy 56V to samo.

    Pokombinuje z filtrem RC, natomiast układ ma mieć 2 tryby sterowania przez mikrokontroler: praca ciągła od 0 do 1.5A poprzez zadanie napięcia średniego PWM od 0 do 345mV; oraz praca stroboskopowa - wypełnienie ok. 1%, częstotliwość regulowana 1-100Hz a prąd impulsu od 0 do kilkakrotności prądu znamionowego, poprzez zadanie napięcia od 0mV do powiedzmy 3V. Tak więc nie mogę dać zbyt "wolnego" filtru (chodzi mi o czas ustalania się napięcia) aby działał ten drugi tryb. Ale na razie skupie się na pierwszym trybie.

    Jeszcze spróbuję zadać na przykład 500mV i zobaczę czy średni prąd wzrośnie.

    0
  • #8 11 Sty 2018 21:19
    pawlik118
    Poziom 23  

    Zastanawiam się po co Ci ta przetwornica podwyższająca. Uce = 32V * 0,26A = ponad 8W strat na tranzystorze,a Ty chcesz aby mieć jak najmniejsze straty..

    0
  • #9 11 Sty 2018 22:25
    plakplak
    Poziom 3  

    Na czas pracy ciągłej Vout przetwornicy będzie ustawione na przyjmijmy 40V i wtedy straty na tranzystora nie będą aż tak duże w porównaniu z mocą modułu LED. Na 56V ustawiłem aby wyeliminować potencjalny problem, ale na 40V jest to samo. Radiator tranzystora jest dobrany tak aby odprowadzał przynajmniej 25W.
    Jutro pokombinuje i dam znać.

    0
  • #10 13 Sty 2018 12:33
    plakplak
    Poziom 3  

    I okazało się że przyczyny były dwie. Po przepuszczeniu sygnału PWM przez filtr RC (fc~4.5kHz, sygnał PWM 64kHz) prąd zaczął wzrastać liniowo z zadanym napięciem, a nie jak poprzednio że rósł tylko do jakiś tam wartości (100mA dla 20kHz) a dalsze zwiększanie napięcia tylko minimalnie rozjaśniało i przyciemniało LED.
    Poza tym całkowita rezystancja rezystora i połączeń między emiterem a masą była trochę większa niż wartość samego R4 (deklarowana przez producenta) więc wymiana R2 by zmniejszyć wzmocnienie dolnego kanału WO pomogła.

    0
  • #11 13 Sty 2018 15:00
    jarek_lnx
    Poziom 43  

    Cytat:
    Tak więc nie mogę dać zbyt "wolnego" filtru (chodzi mi o czas ustalania się napięcia) aby działał ten drugi tryb. Ale na razie skupie się na pierwszym trybie.
    Filtrowany PWM nie jest najlepszym pomysłem do takich zastosowań, ale jest kilka sposobów żeby zrobić lepszą filtrację bez nadmiernego "rozciągania" odpowiedzi impulsowej filtru.

    Można stosować filtry wyższego rzędu
    http://www.allegromicro.com/ja-JP/Design-Cent...Output-When-Using-Hall-Effect-Sensor-ICs.aspx

    Albo redukcję tętnień
    https://www.edn.com/design/analog/4459116/Cancel-PWM-DAC-ripple-with-analog-subtraction

    0