Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Konwerter poziomów logicznych OE nie działa

DukeMZ 10 Lut 2018 22:32 357 2
  • #1 10 Lut 2018 22:32
    DukeMZ
    Poziom 11  

    Witajcie, mam mały problem z podłączeniem konwertera poziomów logicznych. Zamówiłem na znanym chińskim portalu aukcyjnym garść konwerterów NIBY TXS0108e. Planuję go wykorzystać do zaprogramowania ESP8266. Programator którym dysponuję to CH340G (posiada on dodatkowe wyjście 3.3Vcc ale nie dość że jest dokładnie 3.43 to jest to tylko zasilanie i nic poza tym). Postanowiłem wykorzystać stabilizator liniowy AMS1117 który daje mi idealnie 3.3V. Teraz do rzeczy:

    Komunikacja nie działa. Samo ESP jest dobre - poratował kolega z działającym konwerterem. Przekopałem cały internet, całą note katalogową układu TXS0108e i znalazłem kilka jak nie kilkanaście działających sposobów na podpięcie pinu OE. Na początku podpinałem go do masy przez rezystor 4.7k ale absolutnie nic się nie zmieniało.

    Postanowiłem więc sprawdzić ten konwerter "analogowo", to znaczy że podpiąłem Va (3.3V ze stabilizatora), Vb z programatora, masa z programatora, OE na razie nie podpinałem. Po przyłożeniu +5V (to samo co Vb) na któryś pin po stronie b - na stronie a nie pojawiało się 3.3V. Taka sama sytuacja była w momencie kiedy wystawiałem 3.3v na stronę a i na stronie b nie pojawiało się 5V. Po podpięciu OE do masy przez opornik dalej nic się nie zmieniało. Idziemy dalej, podpinałem OE do 3.3V przez rezystor to miałem wtedy na stałe wystawione 3.3v na stronie a nawet kiedy nie podłączyłem nigdzie sygnału. Po podpięciu OE przez rezystor do 5V wyglądało to tak samo jak w przypadku poprzednim.

    Ogólnie rzecz ujmując - konwerter nie konwerteruje NIC. Sprawdziłem w taki sposób 3 sztuki. Czy ma ktoś jakiś sprawdzony sposób podłączenia tego ustrojstwa, czy trafiłem na podróbkę układu texas instruments i mogę tymi konwerterami "wbijać gwoździe"? Z góry dziękuje za odpowiedź i pozdrawiam

    0 2
  • #2 10 Lut 2018 22:55
    BlueDraco
    Specjalista - Mikrokontrolery

    W opisie Twoich "testów" nie znalazłem nic, co by świadczyło o nieprawidłowym zachowaniu układu. Gdzie konkretnie widzisz problem?

    0
  • #3 10 Lut 2018 23:07
    DukeMZ
    Poziom 11  

    Problem widzę w tym, że nie jestem w stanie podłączyć ESP do programatora. Sam konwerter też działa co najmniej "dziwnie"

    0