Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.

Fiołek_84 20 Dec 2020 19:11 999 25
  • #1
    Fiołek_84
    Level 10  
    Witam Serdecznie
    Jakieś trzy miesiące temu zmodernizowałem komputer o nowe elementy:
    procesor, płyta główna, pamięć ram, zasilacz.

    Komputer działał prawidłowo przez ten cały czas praktycznie codziennie, prócz co jakiś czas podczas uruchamiania W10 i występowania BSOD: "PAGE FAULT IN NONPAGED AREA".

    Teraz od paru dni żaden OS nie chce się uruchomić (W10 na dysku lub Linux Mint na USB) - kończy się na MSI CPU RED LIGHT.

    Windowsa nie przeinstalowałem po wymianie sprzętu, miałem to zrobić po nowym roku jak będę miał czas.
    Zainstalowałem do nowego sprzętu sterowniki i wszystko działało.

    Sprzęt:
    Spoiler:

    MSI B450 TOMAHAWK MAX (MS-7C02), BIOS v3.A2,
    AMD Ryzen 5 1600 AF 3200,
    Corsair Vengeance RGB PRO 32GB 2x16GB 2933MHz (bios ustawia default na 2666MHz),
    AMD Radeon R7 370 4GB,
    Silentium PC Vero M3 Bronze 600W,
    Temp.CPU 32 (podczas grania max 65), Temp.GPU 30 (podczas grania max 67) - RTSS,HWinfo,
    Windows 10 Pro v1709 64bit,
    Defender,
    MSI CPU RED LIGHT, Win10 BSOD "PAGE FAULT IN NONPAGED AREA", Linux Mint "No irq handler for vector"
    Beep Code - brak (tylko standardowe przy uruchomieniu)


    Próbowałem już:
    Spoiler:

    h*****//forums.tomshardware.com/threads/no-post-system-wont-boot-and-no-video-output-troubleshooting-checklist.1285536/


    Złożyłem w życiu wiele komputerów czy sobie czy znajomym.
    Oraz drobne naprawy wykonywałem.
    Ale pierwszy raz sam nie mam pojęcia O CO CHODZI i proszę o waszą pomoc.

    Pozdrawiam i dziękuję za udzielanie rad i pomocy.
  • #3
    Fiołek_84
    Level 10  
    krzychupar wrote:
    Błąd ten może oznaczać, że zainstalowane sterowniki na dysku nie są kompatybilne z obecnym sprzętem płyty głównej i najlepszym wyjściem w tej sytuacji jest zainstalowanie na nowo Windowsa i odpowiednich sterowników.


    No dobra, ale wcześniej przez ponad dwa miechy wszystko działało, po za tym dlaczego linux z pendrive'a nie chce się też uruchomić, chociaż korzysta z własnych sterów?
  • #4
    aachi
    Level 24  
    krzychupar wrote:
    Błąd ten może oznaczać, że zainstalowane sterowniki na dysku nie są kompatybilne z obecnym sprzętem płyty głównej i najlepszym wyjściem w tej sytuacji jest zainstalowanie na nowo Windowsa i odpowiednich sterowników.


    Autorowi chyba chodzi o to, że komputer wogóle nie startuje i że na płycie świeci się dioda EZ DEBUG od CPU.

    W twojej sytuacji problem jest z płytą główną, procesorem, lub zasilaczem.

    W warunkach domowych możesz:
    CPU - wyjąć go z gniazda i obejrzeć czy są wszystkie nóżki i czy nie są pokrzywione lub brudne. Obejrzeć gniazdo czy nie jest upaćkane. Nic więcej z CPU nie zrobisz. Jeśli masz inny zestaw to ew. możesz sprawdzić czy ten CPU uruchomi się w innej płycie.

    Płyta główna - obejrz czy nie ma nigdzie widocznych uszkodzeń, zresetuj BIOS zworką (czy nie aktualizowałeś może BIOSu ostatnio?);
    Odepnij od płyty WSZYSTKO poza zasilaczem i CPU. Spróbuj uruchomić płytę przez zwarcie odpowiednich pinów na płycie i zobacz, czy diody diagnostyczne pokażą problem z RAM. Jeśli tak to dobrze. Jak masz inny zestaw to możesz sprawdzić czy ta płyta główna uruchomi się z innymi podzespołami.

    Zasilacz - dobrze byłoby pomierzyć napięcia. Odepnij i podepnij ponownie wtyczki od zasilacza. Najłatwiej sprawdzić czy to nie problem z zasilaczem podłączając inny. Odłącz też od zasilacza wszystko poza płytą główną (dwie wtyczki).

    Ogólnie jeśli na gołym "płyta, CPU i zasilacz" nic się nie zmienia, to oprócz podmiany tych elementów nic więcej nie poradzisz.
  • #5
    Fiołek_84
    Level 10  
    Wykonałem wszystkie czynności z linku, który podałem.
    CPU wyciągałem i sprawdziłem piny, gniazdo też jest ok.
    PłytaG jest cała. Bios jest zresetowany poprzez wyjęcie baterii na ponad 5min.

    Postaram się jutro rozłączyć wszystko tak jak proponujesz @aachi oraz sprawdzę na starym zasilaczu.

    Jak można pomierzyć napięcia na zasilaczu, bo miernik posiadam - jakieś instrukcje?
  • Helpful post
    #6
    aachi
    Level 24  
    https://www.elektroda.pl/rtvforum/topic1199202.html Stary temat, ale w miarę dobrze wyjaśnione. Wtyczka zasilania CPU u Ciebie pewnie ma 8 pinów. Sprawdź napięcie na niej i na tej dużej najlepiej.

    Mierzenie multimetrem jest wystarczające dla warunków domowych. Jeśli napięcia będą poza zakresem, to zasilacz jest napewno niesprawny. Jeśli napięcia będą ok to na 98% zasilacz działa prawidłowo.

    [EDIT] To jeszcze link do artykułu który pokazuje jak mierzyć napięcia zasilacza gdy jest on odłączony od komputera (płyty głównej), bo ten wątek na elektrodzie o tym nie wspomina. Możesz obejrzeć też filmiki na youtube, bo jest ich pełno.
    https://redark.pl/domowy-test-zasilacza-komputerowego
  • #7
    CrisPell
    Level 11  
    To jest ten BETA BIOS? Spróbuj zrobić downgrade do poprzedniej.
  • #8
    Fiołek_84
    Level 10  
    CrisPell wrote:
    To jest ten BETA BIOS? Spróbuj zrobić downgrade do poprzedniej.


    Awaria powstała na biosie starym (z dnia zakupu), a pózniej zaktualizowałem go do najnowszego by sprawdzić czy pomoże.
  • #9
    aachi
    Level 24  
    Fiołek_84 wrote:
    Awaria powstała na biosie starym (z dnia zakupu), a pózniej zaktualizowałem go do najnowszego by sprawdzić czy pomoże.

    Chcę się upewnić, że dobrze rozumiem. Jeśli masz błąd CPU pokazany na diodzie płyty to komputer wogóle się nie powinien uruchamiać i nie powinno być możliwości auktualizacji BIOSu. W jaki sposób więc zaktualizowałeś BIOS?
  • #10
    lisek
    Service technician RTV
    To jest oficjalna strona MSI i biosy pod tę plytę (b450-Tomahawk-MAX) Link

    Ogólnie mówiąc płyta nie należy do "najszczęśliwszych"
    - jeśli podmiana cpu / zasilacza nie daje efektu
    - :cry: pozostaje RMA płyty , zamiana
    - !? masz na nią gwarancję

    Quote:
    Plusy MSI B450 Tomahawk MAX:

    Wsparcie M. 2 zarówno NVMe i SATA;
    Możliwość aktualizacji oprogramowania układowego BIOS-u bez pamięci, procesora i karty graficznej;
    Wskaźnik LED przejścia POST;
    Obecność portów USB 3.1 Typu A i C.

    p.s
    Taki nice guide (co i jak) od MSI Link_ system-wont-boot-and-no-video-output-troubleshooting

    Temperatura pokazywana w Bios to pochodzi od kontrolera , Nie od kluczy na polowych!!
    Zasilacz na płycie to : 4+2 fazy z kontrolerem Richtek RT8894A
    - dokłądnie zaś 4(3) +2
    * bowiem dla (Vsoc ) zastosowano driver ( 4P= RT9624f ) i polowe , pozostałe zaś
    OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT. OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.

    :!: :idea: Zabezpieczenie płyty przed max. pradem / Napięciem i TDP ukryto w Bios
    - zabezpieczenie przed OC
    OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT. OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.
  • #11
    Fiołek_84
    Level 10  
    aachi wrote:
    Fiołek_84 wrote:
    Awaria powstała na biosie starym (z dnia zakupu), a pózniej zaktualizowałem go do najnowszego by sprawdzić czy pomoże.

    Chcę się upewnić, że dobrze rozumiem. Jeśli masz błąd CPU pokazany na diodzie płyty to komputer wogóle się nie powinien uruchamiać i nie powinno być możliwości auktualizacji BIOSu. W jaki sposób więc zaktualizowałeś BIOS?


    Otóż komputer się uruchamia. mogę wejść do biosu normalnie.
    Tak jak pisałem w pierwszym poście komputer nie może uruchomić żadnego OS (Linux lub Windows).
    Diagnostyka z W10 nawet się uruchamia, ale po ponownym uruchomieniu przechodzi przez wszystkie diody EZ DEBUG, przez chwilę żadna się nie świeci, wyłączają się wiatraki na karcie graficznej i po paru sekundach zapala się CPU LIGHT i na tym koniec.
  • #12
    lisek
    Service technician RTV
    Z manuala
    Quote:
    Możliwości organizacji podsystemu dyskowego przedstawione interfejsem M. 2 Socket 3 (obsługiwane formaty dysków SSD M. 2 2242, M. 2 2260, M. 2 2280 i M. 2 22110) i sześciu portów SATA 6 Gb/s.
    :idea: należy Pamiętać, że w trakcie instalacji dysku M. 2, dwa z sześciu portów SATA ("SATA5" i "SATA6") zostaną wyłączone.


    OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT. OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.
  • #13
    aachi
    Level 24  
    Zawsze co drugi raz nie startuje, czy tylko po miękkim resecie? W BIOS jak zostawisz na jakieś 20 minut to się wiesza?
    Ogólnie skoro możesz wejść do BIOS to nie jest źle. Może masz po prostu pecha i problem softwarowy na obu systemach. Próbowałeś zainstalować system Windows od nowa choćby na próbę bez kasowania poprzedniego?

    Wyjęcie baterii na 5 minut mogło nie wyczyścić ustawień BIOSu. Zrób to zgodnie z instrukcją, czyli odłącz zasilanie i zewrzyj odpowiednie piny na płycie, lub F6 w BIOS.

    Sprawdź RAM. Spróbuj uruchomić system tylko na pierwszej kości. Jeśli nadal jest problem to wtedy tylko na drugiej. Możesz też spróbować uruchomić bootowalny memtest86, lub memtest86+ i w nim testować RAM przez kilka godzin.
  • #14
    Fiołek_84
    Level 10  
    aachi wrote:
    Zawsze co drugi raz nie startuje, czy tylko po miękkim resecie? W BIOS jak zostawisz na jakieś 20 minut to się wiesza?
    Ogólnie skoro możesz wejść do BIOS to nie jest źle. Może masz po prostu pecha i problem softwarowy na obu systemach. Próbowałeś zainstalować system Windows od nowa choćby na próbę bez kasowania poprzedniego?

    Wyjęcie baterii na 5 minut mogło nie wyczyścić ustawień BIOSu. Zrób to zgodnie z instrukcją, czyli odłącz zasilanie i zewrzyj odpowiednie piny na płycie, lub F6 w BIOS.

    Sprawdź RAM. Spróbuj uruchomić system tylko na pierwszej kości. Jeśli nadal jest problem to wtedy tylko na drugiej. Możesz też spróbować uruchomić bootowalny memtest86, lub memtest86+ i w nim testować RAM przez kilka godzin.


    BIOS się nie zawiesza po 20min.
    Pech musiałby być bardzo wielki, jeśli boot'owalny pendrive z Linux'em też nie działa.
    Najpierw spróbuję stary zasilacz podłączyć, a pózniej wezmę się za instalację Windows.

    Reset BIOS'u dał radę bo wszystko zresetował, a datę cofnęło do 2018 roku.

    Ale zastanawia mnie najbardziej, że włącza się diagnostyka Win10 (Naprawa Automatyczna), ale jest tylko opcja ponownego uruchomienia, po którym oczywiście CPU LED.
    Co ciekawe zauważyłem, że tuż przed CPU LED wyłączają się wiatraki GPU i obraz robi się czarny (brak sygnału).

    Udało mi się uruchomić z USB Linux'a w opcji "compatibility mode", ale normalny start Linux'a nadal nie działa.

    WTF!!
  • Helpful post
    #15
    lisek
    Service technician RTV
    Quote:
    zauważyłem, że tuż przed CPU LED wyłączają się wiatraki GPU i obraz robi się czarny (brak sygnału).


    OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.

    Ciekawie , ale troszkę inaczej Link_ boot_vga_solid_red

    Quote:
    1x PCI Express 3.0 x16 (AMD Ryzen − x16 lub APU AMD Ryzen − x8)
    1 x PCI Express 2.0 x16 (х4)
    3 x PCI Express 2.0 x1
    or
    1x PCIe 3.0 x16 slot (PCI_E1)
    1x PCIe 2.0 x16 slot (PCI_E4, supports x4 mode)*
    3x PCIe 2.0 x1 slots*
    ... in the organization of the graphics subsystem, there are two PCI Express x16 slots, one of which (with a reinforced metal structure) is connected to the processor and always uses 16 PCI Express 3.0 lines (or 8 lines when installing an AMD Ryzen APU), while the second uses only 4 chipset lines. When you install a pair of graphics cards, they will not work according to the most optimal scheme x16+x4, which is also supported only for graphics accelerators based on AMD's GPU.


    Karta w którym slot PCIe ?
    OS się nie uruchamia, restartuje się PC, tryb awaryjnym działa. CPU RED LIGHT.
  • #16
    CrisPell
    Level 11  
    Ja bym bardziej obstawiał wadę procesora. Widziałem już przypadek z vlogów serwisowych, gdzie komputer wszystko niby wstaje, a tak jak w twoim przypadku żaden system nie jest wstanie się uruchomić. Możliwości diagnozy w warunkach domowych przypuszczam już wyczerpane. Więc zacząłbym od podmiany CPU w jakimś serwisie.
  • #17
    lisek
    Service technician RTV
    Quote:
    tuż przed CPU LED wyłączają się wiatraki GPU i obraz robi się czarny (brak sygnału).


    :?: :idea: wskazuje na cpu, podstaw inny lub niech to ... w serwisie
    ** prawie to samo opisane w temacie Link
  • #18
    malik123
    Level 17  
    nie widziałem w opisie, więc spytam czy zrobiłeś taką podstawę jak fizyczne odłącznie wszystkiego co możliwe i zostawienie tylko 1xram i k.g. , bios def. ?
    i wtedy Linux, jeden i inny drugi.
    odpalił bym też memtest
  • #19
    Fiołek_84
    Level 10  
    Otóż zainstalowałem najpierw Windows 10 build 1709 i wszystko chodziło jak należy.
    W takim razie stwierdziłem, że zainstaluję build 2004.
    Po instalacji wszedł do pulpitu, ale wystarczyło cokolwiek uruchomić i wracamy do punktu wyjścia, czyli:
    czarny ekran, a pózniej CPU RED LIGHT. :-)

    W takim razie wróciłem do zainstalowania W10 1709 i wszystko działało do momentu instalacji sterów do grafiki i znów "punkt wyjścia".
    Znów wróciłem do W10 2004 by na szybko sprawdzić jak tam ze sterownikami i się okazało, że są zainstalowane do Grafiki.
    Dlatego Linux na complatibility mode oraz Windows na trybie awaryjnym działało prawidłowo, bo korzystało ze sterów podstawowych.

    PS. po CPU RED wchodziłem do naprawy Windows i wybierałem naprawę Startup i się system uruchamiał, ale znów wystarczyło coś uruchomić i powtórka z rozrywki - tak w kółko.

    Co z tym można zrobić?
    I czy to coś z Kartą Grafiki czy jednak z CPU?

    Edit:
    Grafikę mam podłączoną przez DisplayPort, w poprzednim Kompie chodziło przez lata na HDMI - ma to jakiś wpływ?
    Przypominam, że na tej całej konfiguracji niezmiennie chodził przez dwa miechy.
  • #20
    malik123
    Level 17  
    Jak dla mnie to k.graf mocno podejrzana.
    Jakoś pominąłem, albo brak co to za k.graf.
    Instalujesz stery, odwołuje się do specyficznych właściwości k.graf. i wywala.
    Jak linux i W10, tzn. nie jest to kwestia software'u np. DX tylko sprzętowa.
  • Helpful post
    #21
    aachi
    Level 24  
    Fiołek_84 wrote:
    I czy to coś z Kartą Grafiki czy jednak z CPU?


    Bez testowania to tylko zgadywanie. Musisz sprawdzać przez podmianę poszczególne podzespoły, aż wykryjesz który powodował problem. Możliwe są scenariusze dla każdego sprzętu.
    - Cały software, w tym wszystkie sterowniki, przetwarzane są przez CPU i do tego płyta sugeruje, że ma z nim problem - więc może CPU.
    - Jednak skoro problem powoduje sterownik grafiki to można podejrzewać GPU.
    - Uszkodzony zasilacz może także powodować niestabilność całej platformy. I jak tylko instalujesz stery do grafiki, ta zaczyna pobierać więcej prądu i zasilacz siada powodując Twoje problemy.
    - Uszkodzona płyta główna, lub BIOS.

    RAM bym wykluczył, bo to CPU LED nie bardzo pasuje do typowych problemów z pamięcią.

    Szczerze nie spotkałem się jeszcze z takim przypadkiem jak Twój więc ciężko mi obstawiać który podzespół jest najprawdopodobniej winny. Układy scalone też z czasem ulegają uszkodzeniu więc to, że wcześniej działało o niczym nie świadczy.
  • #22
    Fiołek_84
    Level 10  
    Zmontowałem starego PC z dyskiem, którego używałem i w starym jak i nowym PC.
    Okazało się, że występuje ten sam problem: wchodzi do diagnostyki systemu i po ponownym uruchomieniu wyłącza się karta graficzna, a pózniej wyłącza się komputer.
    Wszedłem w tryb awaryjny i usunąłem sterowniki poprzez DDU i po ponownym uruchomieniu system się normalnie uruchomił na sterowniku "Podstawowa karta graficzna Microsoft" - tak jak w nowym kompie.

    Trzeba będzie kupić nową kartę :-(

    Czy macie może jakąś poradę co z tym (kartą) zrobić?

    Edit:
    Wygrzebałem z otchłani starą kartę GT 610 i wmontowałem ją w nowego PC, zainstalowałem sterowniki i wszystko działa.
  • #23
    malik123
    Level 17  
    Czyli tak jak pisałem uszkodzona k.graficzna z dużym prawdopodobieństwem.
    Nie napisałeś co to za karta?
    jeszcze nie ma dużej pewności bo to mogę być dalej stery, ale dziś już raczej one są mocno stabilne.
    Przed wyrzuceniem dla pewności sprawdził bym jeszcze w innym kompie.
  • #24
    Fiołek_84
    Level 10  
    malik123 wrote:
    Czyli tak jak pisałem uszkodzona k.graficzna z dużym prawdopodobieństwem.
    Nie napisałeś co to za karta?
    jeszcze nie ma dużej pewności bo to mogę być dalej stery, ale dziś już raczej one są mocno stabilne.
    Przed wyrzuceniem dla pewności sprawdził bym jeszcze w innym kompie.


    :-D
    Kolego @malik123 Proszę czytać ze zrozumieniem:
    W pierwszym poście są wymienione wszystkie komponenty komputera.
    A w poście powyżej napisałem, że sprawdziłem kartę w poprzednim (starym) PC.
  • #25
    malik123
    Level 17  
    A przepraszam, spoiler schował mi konfig. A trzy razy we wszystkich wpisach szukałem ;)
    W ostatnim poście nie miałem jasności, czyli odkurzyłeś starego PC i włożyłeś tam k. graficzną. Ale nie zrozumiałem czy HDD z nowego dałeś do tego starego, czy miał inny swój HDD - widomo mam na myśli sterowniki.
    Jednak wynika z opisu że najpierw sporadycznie BS, a teraz w ogóle, to też niestety wskazuje że postępowało jakieś uszkodzenie.
  • #26
    Fiołek_84
    Level 10  
    Po wymianie Karty Graficznej wszystko działa.

    Dziwne, ze na sterownikach Microsoft karta działa, a na producenta już nie.
    Tak jak było wspomniane wcześniej, widocznie gdy karta zaczyna używać jakiś swoich funkcji poprzez sterowniki zaczyna używać zepsutej części karty graficznej. :-(

    Dzięki Serdecznie za pomoc.