Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Pomóżcie zbudować interkom ;)

damkoz 13 May 2007 23:35 2446 15
Altium Designer Computer Controls
  • #1
    damkoz
    Level 19  
    Witam
    chcem wykonać interkom do samochodu, do połączenia rozmowy pilota i kierowcy. Otóż próbowałem wykonać układ wg schematu ze strony ale niestety nie działa.
    Dzieje się tak że cąły czas buczy.
    W zwiazku z tym postanowiłem zbudować cały układ na technologii już sprawdzonej czyli zestawach do samodzielnego montażu. Chce zrobić tak aby przez kanał prawy wzmaka przeprowadzić tor rozmowy od kierowcy do pilota a przez lewy od pilota do kierowcy.
    Na chwile obecną zakupiłem i złożyłem już wzmacniacz z Jabla na układzie TDA2822M i kwestia podłączenia do niego mikrofonów pojemnościowych i dorobienia regulacji głośności.
    Problem jest w tym że mikrofony wymagają zasilania oraz jakiegoś kondensatora, próbowałem coś takiego wykonać ale z marnym skutkiem (tylko piszczy i buczy). Prosił bym więc bardziej zorientowanych o pomoc czy są dostępne w handlu gotowe zestawy jako nazwijmy toi przedwzmacniacz takiego mikrofonu czy też trzeba taki układzik wykonać samemu i jeżeli tak, to w jaki sposób.

    Co do mikrofonu to zakupiłem sztuki 2 ale dokładnie nie wiem czy jest to pojemnościowy czy elektrytowy (nie wiem czy dobrze go nazywam)

    Problem w pierwszym interkomie był prawdopodobnie z tym ze działałon prawidłowo gdy podłączony był jeden tor - tj jedna słuchawka i jeden mikrofon, gdy podłączyłem 2 to już było tylko buczenie.
    Prosze o Pomoc
  • Altium Designer Computer Controls
  • #3
    damkoz
    Level 19  
    no właśnie ten układ wykonałem, i wygląda to tak, że gdy podłącze tylko jeden mikrofon i głośnik, to wszystko działa znakomicie. Po podłączeniu drugiego głośniczka i mikrofonu słychać tylko pisk i brzęczenie.
  • #4
    januss73
    Level 32  
    jak używaż głośnika, może po prostu ci się sprzęgla, spróbuj na słuchawkach.
  • Altium Designer Computer Controls
  • #5
    damkoz
    Level 19  
    używam słuchawek wbudowanych w kaski kierowcy i pilota, to raczej nie sprzężenie
  • #6
    januss73
    Level 32  
    A mógłbyś dać schemat ideowy, bo tego z linka nie moge otworzyć.
  • #8
    januss73
    Level 32  
    No włąśnie tego nie moge otworzyć, moim eaglem przynajmniej.
  • #9
    damkoz
    Level 19  
    ale mniejsza z tym układem, tam jest opis na stronie jak to działa i wygląda, ja straciłem na nim dużo nerwów, więc zrobiłem nowy. Jak już napisałem wzmacniacz na Jablu a do tego podłączyłem mikrofony pojemnościowe zasilane przez rezystory 5.6 KOma i też buczy i piszczy więc problem jest z zasilaniem mikrofonów, ponadto znalazłem już identyczny problem na forum ale bez odpowiedzi więc może zacytuję:
    Quote:
    Otóż buduję sobie interkom do samochodu i wszystko działa pięknie kiedy jest
    jeden układ (jeden mikrofon, jedne słuchawki), a przestaje gdy zepnę ze sobą
    2 zestawy.
    Układ zbudowany jest na bazie zestawów do samodzielnego montażu f-my Jabel
    (www.jabel.com.pl), są dwa identyczne moduły zbudowane z przedwzmacniacza
    mikrofonowego (J-250) i wzmacniacza 2W (J-67).
    Problemem jest najprawdopodobniej to że mikrofon i słuchawki mają wspólną
    masę. Kiedy zepnę masę mikrofonu jednego układu z masą słuchawek drugiego, w
    słuchawkach słychać tylko brzęczenie. Jeśli działa pojedynczy układ,
    wszystko jest ok.

    I chodzi mi o to że boję się że jak zainwestuje w przed wzmacniacze to nadal będzie buczeć a ja nie wiem dlaczego!
  • Helpful post
    #10
    januss73
    Level 32  
    Nie znam sie na tym aż tak dobrze, ale kolega z cytatu może mieć racje. Te układy zasilane są napięciem niesymetrycznym, więc mają sztuczne masy. Każdy osobno, bo jak przypuszczam masz cztery osobne modyły (2xpre + 2xamp) I po zwarciu masy jednego wzmacniacza z masą preampa zaczynają się cyrki. Chyba najprostrzym sposobembyłoby przerobić zestaw mik-słuch. Puścić osobno (dwoma kablami ekranowanymi) mikrofon i głośnik. Najlepiej odlutuj całkiem oba głośniki i puść je nawet zwykłymi kablami na wyjścia ampów, oczywiście nie mostkując żadnych mas.
    Powinno zadziałać
    powodzenia
  • #11
    damkoz
    Level 19  
    mam i wzmacniacz 2 nkanałaowy więc jak ty to nazwałeś 1xamp i 2x pre czyli 2 przedwzmacniacze, dziś wszystko poskładam i pokombinuje, ale z tego co widze to wszystko ma jedną wspólną masę, od zasilania przez wszystkie mikrofony po głośniki. Nie wiem, pokombinuje i zobacze coi będzie, w nocy dam znać.

    DODANO:

    Wielkie dzięki za pomoc, na początku podłączyłem wspólną masę i było to co w cytacie czyli buczenie i piszczenie, po czym podłączyłem wszystko osobno tak jak radziłeś i jest rewelacja!! Wszystko działa i to rewelacyjnie! Mam tylko nadzieje że jak upakuje wszystko w kaski i obudowę nie powstanie kolejny kłopot.
    Niby wszystkie masy są połączone i to niby to samo ale proszę jaka jednak jest różnica.

    Jeszcze raz dziękuje!
  • #12
    januss73
    Level 32  
    Nie ma za co. W sumie to rozwiązanie problemu było dość oczywiste, nie wiem dla czego dopiero teraz na nie wpadłem.
    dobrego porozumieia życze.
  • #13
    Cineman
    Level 11  
    Witam

    Robie właśnie identyczny interkom. Problem polega na tym, że podczas przesyłania sygnału mowy występują dziwne zakłócenia .. takie pierdzenie. Układ w miarę żyje tzn, gdy się chuha w mikrofon w głośniku występuje odzew, jednak przesyłanie konkretnych wyrazów raczej jest niemożliwe. Na początku myślałem że to kwestia zasilacza, jednak po przetestowaniu na dwóch różnych doszedłem do wniosku że to nie to ...
    Układ działa na razie w jedną stronę tzn. jedna płytka mikrofon i na wyjściu głośnik ...

    Ktoś ma jakieś pomysły jak to ugryźć ??
  • #14
    damkoz
    Level 19  
    ja moją bitwę zakończyłem na tym szczeblu, z tymi objawami i dalej dałem sobie spokój. Teraz jak tak sobie myślę to układ powinien zadziałać jeżeli zastosuje się galwaniczne rozdzielenie zasilania na każdy tor osobno. Nie mam tylko pomysłów jak to zrobić tak aby zasilić wszystko z jednej baterii
  • #15
    Cineman
    Level 11  
    Czołem ...:)

    Nie wiem czy pomogę .... okazało się, że trzaski powodowały:
    - zasilanie (po podłączeniu profilaktycznie kondensatora 220u równolegle do zasilania zakłóceń brak)
    - mikrofony ... wrrr - nie wiedziałem już co jest powodem braku czystego sygnału mowy .. i wymieniłem na głośniki słuchawkowe.

    Moje mikrofony były felerne ? nie wiem w każdym razie teraz działa wszystko glancuś .. NA WSPÓLNEJ MASIE. Nie widzę potrzeby rozdzielania na zasilania na dwa tory. 4 przewody będą ponieważ wspólne zasilanie także zastosowane . Przyczyn trzasków doszukiwałbym się od zasilania, no chyba że przy testowaniu zasilasz baterią ..:/

    Kolejny problem to wzmocnienie .. przydałoby się jeszcze głośniej heh. Teraz układ chodzi na wzmocnieniu 200 przy obciążeniu głóśnikiem 8 Ohm 0,5W , natomiast mikrofonem jest głośnik ze słuchawek 400 Ohm .. Może jeszcze jakiś stopień wzmacniający ??

    Pozdrawiam
  • #16
    damkoz
    Level 19  
    właśnie w tym rzecz że jak podłączysz głośnik słuchawkowy w miejscu mikrofonów to zakłóceń nie będzie bo bardzo spada wzmocnienie sygnału. Sygnał z mikrofonu pojemnościowego jest wiele słabszy od tego z dynamicznej słuchawki stąd też, jak mówisz że przydało by się głośniej.