Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Vmware nie działa internet w maszynach wirtualnych

iphonek 07 Lis 2012 07:39 5679 9
  • #1 07 Lis 2012 07:39
    iphonek
    Poziom 15  

    Witam od jakiegoś czasu zajmuje się hobbistycznie sieciami komputerowymi. Postanowiłem że zrobię maszynę z Windows Server 2003 standard i kilka maszyn z Windows xp jako klienci. Chcę aby działała usługa Active Directory poprawnie skonfigurowałem domenę na win2k3 i klientów na Windows xp. Jednak ku mojemu zdziwieniu karta sieci Host-Only działa bo komputery się logują ale nie działa Internet czyli NAT kombinowałem dużo z tym co mam zrobić?

    0 9
  • #2 07 Lis 2012 08:21
    bogiebog
    Specjalista Sieci, Internet

    iphonek napisał:
    Host-Only

    A jakie inne opcje karty masz do wyboru ?

    Dodano po 58 [sekundy]:

    Zmień "host only" na "bridged"

    0
  • #3 07 Lis 2012 08:28
    Andrzej.w
    Poziom 10  

    ...ale czy tryb "bridged" nie sprawi, że nie będą mogły między sobą komunikować się maszyny wirtualne?

    Sprawdź "NAT: Used to share the host’s IP address".

    0
  • #4 07 Lis 2012 08:30
    bogiebog
    Specjalista Sieci, Internet

    Bridge - to są virtualne karty podpięte do sieci hosta, bez natu.

    0
  • #5 07 Lis 2012 16:21
    iphonek
    Poziom 15  

    Ja mam dwie karty jedna to Host only a dryga to nat kombinowałem już z bridged ale nic

    0
  • #6 07 Lis 2012 21:36
    marek1712
    Poziom 16  

    Źle kombinujesz.
    Masz trzy tryby:
    - bridged - towrzony jest mostek z kartą hosta. VM dostaje adres z tego samego DHCP co host, ma równy dostęp do zasobów sieci. Internet powinien działać bez problemów.
    - NAT - tak jakby host był routerem (czyli np musisz przekierować porty jeśli jakaś inna maszyna fizyczna z LANu ma się dostać do RDP VM). Internet również powinien działać poprawnie;
    - Host-only - VM łączą się ztylko z innymi VM należącymi do sieci HO oraz z interfejsem hosta (interfejsem ustawionym jako Host Only). Internetu nie będzie dopóki któraś z VM nie dostanie drugiego interfejsu (NAT lub bridged) i nie zacznie robić za router dla innych maszyn z kartami Host Only.

    Jeśli już zaczniesz grzebać z AD - zwróć uwagę jaki VM dostają DNS i czy mogą się komunikować z kontrolerem.

    0
  • #7 08 Lis 2012 15:28
    iphonek
    Poziom 15  

    Chodzi oto karta Host Only działa poprawnie wszystkie maszyny mają po dwie karty jedna do komunikacji miedzy nimi a druga do odbierania Internetu z hosta czyli NAT Nie dziła mi tylko karta do natu

    0
  • Pomocny post
    #8 08 Lis 2012 17:49
    marek1712
    Poziom 16  

    Możesz używać znaków interpunkcyjnych? Bo nie za bardzo rozumiem...
    W ogóle multihoming to średni pomysł jeśli myślisz o AD.

    0
  • #9 08 Lis 2012 18:37
    iphonek
    Poziom 15  

    Kolego nie rozumiem cię tzn. multihoming Active Directory to podstawowe założenie.

    0
  • #10 09 Lis 2012 16:11
    iphonek
    Poziom 15  

    Już wszystko działa w network editor zrobiłem reset ustawień i cacy :-)

    0