Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

AVR - USB AVR ISP II zgodny z STK500v2

greeco 11 Jan 2013 17:33 3726 7
  • #1
    greeco
    Level 9  
    Posiadam programator jak w tytule, pracuję na win 7 32-bit. Programator zainstalował się poprawnie, windows pobrał sterowniki z sieci, ale nie mogę połączyć się z moją atmegą8.

    system widzi programator jako urządzenie interfejsu HID
    AVR - USB AVR ISP II zgodny z STK500v2

    Chciałem wgrać program przez WinAVR i dostaję taki komunikat:
    AVR - USB AVR ISP II zgodny z STK500v2

    jestem początkujący, bardzo proszę o wskazówki...
  • #2
    Komar91
    Level 18  
    weź odinstaluj i spróbuj zainstalować jako COM tylko odpowiednio daj zworki
  • #3
    greeco
    Level 9  
    pracuję na laptopie, nie mam COMa.
  • Helpful post
    #4
    Gienek
    Level 37  
    Co pobrał Windows z sieci, to nie wiadomo. Aby programator działał poprawnie, to musi być widoczny jako port, a nie jako urządzenie HID. Dlatego musisz wszystko odinstalować, pobrać właściwe sterowniki (dostępne w sieci) i podczas powtórnej instalacji wskazać sterowniki (te zachowane na komputerze).
    Poczytaj: https://www.elektroda.pl/rtvforum/topic1329045.html
  • #5
    piotrva
    VIP Meritorious for electroda.pl
    http://and-tech.pl/avr-prog-usb-v2/
    Tu masz instrukcję - postępuj zgodnie z zawartym w niej opisem...
  • #6
    Komar91
    Level 18  
    ale ten programator pracuje jako COM tylko trzeba zworki poprzestawiać poczytaj w instrukcji do niego.

    Proszę poprawić treść wiadomości:
    3.1.13. Zabronione jest publikowanie wpisów naruszających zasady pisowni języka polskiego, niedbałych i niezrozumiałych.
    [zumek]
  • Helpful post
    #7
    GanzConrad
    Level 25  
    Nie wiem czy Twój programator jest podobny do mojego:
    USB AVR ISP II FT STK500v2
    http://www.microsense.eu/index.php/Programatory/USB-AVR-ISP-II-FT-STK500v2.html
    ale w przypadku mojego problem leżał gdzie indziej: mój nie posiada zworek do zmiany prędkości i nie znalazłem w WinAVR możliwości zmniejszenia prędkości, więc zainstalowałem Atmel Studio 6, w którym zmieniasz na 115,2 i działa. Zakładam, że masz nowy procesor, który ma ustawioną domyślną częstotliwość 1MHz, więc musisz programować z maxymalnie 1/4 tej częstotliwości.
  • #8
    greeco
    Level 9  
    Dzięki wszystkim, którzy napisali tutaj kilka słów. Niestety bieganina sesyjna sprawiła, że nie odpowiadałem na bieżąco. Problem rozwiązałem trochę na około: odpaliłem starego win xp i zainstalowałem na nim programator usbasp z are.net.pl. Jest kompatybilny z WinAVR. Wszystko zadziałało od pierwszego ;)