Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Makro do wysyłania maili z załącznikiem

23 Lip 2014 15:47 6423 24
  • Poziom 8  
    Czesc

    Chciałbym zrobic mailing poprzez excela, ale nie wiem jak sie do tego zabrac. Chce wysyłac maila do kilkunastu osób, z tą samą trescia i z tym samym załącznikiem. Wszystko znajdujes sie w jednym plike excelowym Jak to mam zrobić?
  • Poziom 38  
    Wpisać w Google np. "excel wysylanie majli", przejrzeć wyniki, wybrać pasujący kod VBA.
  • Poziom 8  
    Zanim otworzyłem ten temat, to tak zrobilem, ale zaden kod nie chciał mi działac...
  • Poziom 38  
    Co znaczy nie chciał działać? Jaki komunikat wyskoczył?
  • Poziom 8  
    Wytłumaczysz mi jeszcze jak mam usatwic aby ten program bral po jednym mailu odbiorcy, jak ustawic zalacznik i z jakiej poczty moge to zrobic. Tylko przez outlooka?
  • Poziom 38  
    Cytat:
    Tylko przez outlooka?


    No właśnie nie za pomocą Outlooka.

    Krótki opis parametrów:
    Kod: vb
    Zaloguj się, aby zobaczyć kod


    - Mejl - adres email nadawcy SMTP,
    - HasloEmail - hasło do konta nadawcy SMTP,
    Reszta chyba jasna. Jeżeli załączników jest >1, to oddzielamy je średnikiem.

    P.S. Popróbuj... Jak zdarzy się większy problem, to pisz. Domyślam się, że nawet nie spróbowałeś użyć tej procedury...
  • Poziom 8  
    Makro do wysyłania maili z załącznikiem Wyskoczylo mi cos takiego
  • Poziom 38  
    Zwróciłeś uwagę na to:

    Kod: vb
    Zaloguj się, aby zobaczyć kod
    ?
  • Poziom 8  
    Emm...no tak , ale sadziłem ze jest ok. mam wpisac smtp.wp.pl? Bo wyslalam z poczty wp
  • Poziom 38  
    Masz wpisać odpowiedni adres serwera SMTP dla konta, z którego wysyłasz.
    Czyli, jak napisałeś.
    W zasadzie, to zmienna 'SMTP' też powinna być parametrem procedury - byłaby ona uniwersalna, ale to taki zaciągnięty kod z internetu, który sobie przerobiłem pod własne potrzeby i tak jakoś jest niedorobiony.:)
  • Poziom 8  
    Dalej wyskakuje mi taki sam blad
  • Poziom 8  
    A ja zmieniłem na 587 i dalej maile nie dochodza. Mozesz mi przeslac zlacznik jak Tobie zadziałało?
  • Poziom 8  
    A jak zrobic zeby rozsylal do wszystkich z osobna z kolumny A?
  • Poziom 38  
    Czy Ty sprawdzasz to co masz napisane w kodzie i jak to działa?

    Sprawdź...
  • Poziom 8  
    Wiesz...byłoby mi latwiej gdybym sie na tym znał, ale dla mnie to czarna magia. Nie znam komend, wiec ciezko mi rozszyfrowac co jest co.

    Dodano po 2 [godziny] 12 [minuty]:

    Poczytałem troche, ale nie wiem jak zbudowac taka petle.
  • Poziom 38  
    A nacisnąłeś chociaż przycisk i sprawdziłeś, czy mejle dotarły? Nie.
    Załącznik, który ostatnio wysłałem działa tak, jak chciałeś...
  • Poziom 8  
    Nie wiem dlaczego, ale u mnie dalej nie działa, wyskakuje ciagle i ten blad z problemem polaczenia
  • Poziom 38  
    Spróbuj wyłączyć na chwile zaporę i sprawdź.
    Wina, jak widać, nie leży po stronie makra, a ustawień sieci.
    Tak mi się wydaje...
  • Poziom 8  
    A powiedz mi jeszcze gdzie mam wpisac adres zalacznika?