Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Matlab Simulink - Symulacja odbiornika 3f

17 Cze 2015 21:05 978 9
  • Poziom 21  
    Witam.

    Próbuję zrobić kompensację mocy biernej w układzie RLC, jednak mam problem z dłuższą symulacją . do 0.3 s rusza symulacja, potem jakiś problem.

    W załączniku pliki m-plik z danymi i plik z simulinka, i jak by mógł ktoś sprawdzić czy tak wykonana kompensacja mocy jest w porządku .
    A błąd to:
    Matlab Simulink - Symulacja odbiornika 3f
  • Poziom 19  
    Symulacja rusza, ale już na początku widać, że jest nie tak. Jutro postaram się to poprawić, a kompensator musi mieć taką budowę?
  • Poziom 21  
    Byłbym bardzo wdzięczny. Nie musi mieć kompensator takiej budowy... Ale jak zauważyłeś układ mam RLC, to w miejscu Cewki kompensuje ją susceptancją kondensatora natomiast kondensator kompensuje susceptancją cewki, a w miejscu rezystora (w kompensatorze) jest przerwa, dzięki temu chciałem uzyskać odbiornik rezystancyjny (po kompensacji)...

    Po prostu tylko tak to widzę jeśli masz jakiś inny pomysł to jak najbardziej jestem ciekawy rozwiązania.

    Dodano po 5 [godziny] 6 [minuty]:

    Jakieś pomysły ?
  • Poziom 19  
    Masz rację. Może być taki kompensator. A wartości odbiornika nie mogą być podane w prost? Bo widzę, że obliczasz je później z impedancji i zamiast wartości dostajesz wektor.
  • Poziom 21  
    Najpierw wszystko jest obliczone w skrypcie matlabowym .m. I te wartości są już w workspace'ie. A z wektora można wybierać np Bk(0) to pierwsza warotść - jeśli o to chodzi :)
    Bo nie widzę problemu w podawaniu wartości odbiornika przez Workspace.
    Chyba że ci chodzi o coś innego ...

    Dodano po 27 [minuty]:

    Zmieniłem na stałe wartości odbiornika tak jak mówiłeś w ten sposób że do skryptu dodałem:

    RoD=5.6 % R0=5.6 ohm
    LoD=0.0155 % L0=15.5 mH
    CoD=220*10^-6 % C0=220 uF

    i ruszyło... tylko coś słabo z kompensacją....
  • Poziom 19  
    Hej. Nie o to mi chodziło, ale nie ważne. Poprawiłem to tak, że działa. Kompensacja jakaś jest, ale nie do końca podoba mi się wynik. Nadal jest moc bierna w układzie. :| Po kompensacji nie powinno jej być, a prądy we wszystkich fazach powinny być równe. Zastanów się co jest jeszcze nie tak, coś pewnie przeoczyłem.
  • Poziom 19  
    Nie doczytałem, tego co później dopisałeś. Podobnie to wygląda jak u mnie??
  • Poziom 21  
    Nie, dzięki za pomoc, w moim było trochę namieszane...
    Tylko teraz jak do kompensować tą moc bierną ? Wszystko wydaję się ok.

    Dodano po 5 [minuty]:

    Cos jest nie tak... na symulacji w simulinku prądy fazowe są mniejsze po kompensacji, a w m-pliku odwrotnie:
    Przed kompensacją:
    If =

    3.1578 -11.7851i
    -43.9826 +11.7851i
    40.8248


    Po kompensacji:
    Ifk =

    47.1405 +40.8248i
    -58.9256 -20.4124i
    11.7851 -20.4124i

    Dodano po 27 [minuty]:

    I skąd ten pik po przełączeniu na kompensator?
  • Poziom 19  
    Fakt, źle jest dalej, ale jeszcze nie widzę czemu.
  • Poziom 21  
    A jakiś inny sposób rozwiązania tego zadania ? Skoro tu nie wiadomo co nie gra ?