Elektroda.pl
Elektroda.pl
X
Szafy Rack
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

12 Lut 2017 15:51 2640 35
  • Poziom 8  
    Dzień dobry,

    próbuję pokryć dom siecią bezprzewodową. Punktem dostępu do internetu jest modem Funbox 2.0 od Orange (w piwnicy), w którego dwa porty LAN wpięte są dwa routery,
    1. Dlink dir818lw,
    2. Xiaomi MiWiFI Router 3;

    Internet niby działa w urządzeniach klienckich po połączeniu się z którąkolwiek z sieci wifi (tak z dlinka jak i z xiaomi), ale gdy w obu sieciach jest ruch, to strony wczytują się albo natychmiast, albo bardzo powoli, albo w ogóle. Tak samo wygląda buforowanie np. YT - albo nagranie wczytuje się błyskawicznie, albo w ogóle, albo skokowo. Pobieranie torrentów - to samo, np. przez kilka minut w ogóle nie wyszukuje seedów, ale gdy już znajdzie, to leci z pełną prędkością 5-6 Mb/s.
    Wygląda to tak, jakby istniał jakiś konflikt IP, ale jakiego rozwiązania bym nie wypróbował to zawsze jest tak samo. Ustawiłem statyczne IP w Funboxie dla obu routerów, spoza puli przydzielanych adresów ale pomiędzy adresem początkowym a krańcowym (np. 192.168.1.2 i 192.168.1.3), jaki w puli (np. 192.168.1.11 i 192.168.1.12), to samo robiąc w obu routerach (ustawiając im statyczne IP). Wyłączałem serwer DHCP w obu routerach - wtedy jednak żadne urządzenia klienckie nie chciały mi się łączyć z żadnym z routerów.
    Przepinałem kable między portami Funboxa, wymieniłem kable. Wpinałem je w LAN, wpinałem je w WAN (aktualnie pozostałem przy starotestamentowym wpięciu w LAN na obu końcach).
    Ustawiłem teraz Xiaomi jako przewodowy extender, Dlink takiej opcji niestety nie ma, ale spróbuję ustawić go jako access point, bo to chyba to samo.
    Gdy ruch w którejś z sieci zamiera, tudzież gdy podłączę do Funboxa tylko jeden router, to nie ma żadnego problemu, Internet śmiga jak zły.
    Co więcej, to chyba też problem nie tylko braku połączenia z Internetem, ale w ogóle działania sieci i przydzielania adresów IP. Wskazują na to problemy w komunikacji pomiędzy urządzeniami w jednej sieci - np. pomiędzy smartfonem a amplitunerem sieciowym. Gdy wszystko było podłączone wyłącznie pod Funboxa to problem nie istniał.

    Wyczerpałem już pulę pomysłów. Rozważam dwie opcje: albo Funbox się nie nadaje do niczego, albo Dlink ze swoją ograniczoną konfiguracją nie będzie w takim trybie pracował (odradzają to zresztą w instrukcji obsługi...), choć skłaniam się ku opcji pierwszej. Wykluczam problem z Xiaomi, bo wcześniej w jego miejscu był wiekowy router Cisco, i efekty były takie same - tyle, że wtedy zakładałem, że to Cisco jest źródłem niedomagania sieci.

    Pytanie:
    Jeśli zmieniać Funboxa, to na co, i jak powinna wyglądać konfiguracja sieci? Nie potrzebuję wifi w piwnicy (tam mam switch), wystarczyłby mi sam modem, więc może coś pracującego jako bridge? Jak wtedy wygląda konfiguracja routerów, a jak bridge'a - nigdy takiego rozwiązania nie uskuteczniałem, a też jakoś specjalnie się na sieciach nie znam. Czytałem, że wystarczającym, budżetowym wyborem jest DGT RGW VDSL2 FG4v2, ale chętnie zerknę na inne rozwiązania.
    Generalnie, efekt jaki chcę osiągnąć to pokrycie siecią mojego domu, a czy to będzie jedna sieć o tej samej nazwie z dwóch urządzeń, czy to będą dwie oddzielne sieci z dwóch urządzeń - to już naprawdę szczegóły - choć z uwagi na multiroom z NC+ w sumie dobrze by było, aby dekodery mogły się ze sobą komunikować w celu synchronizacji, także opcja routerów pracujących w formie extenderów stworzonej przez urządzenie w piwnicy sieci również jest do przemyślenia).

    Z góry dziękuję za wszelkie pomysły i ewentualną pomoc.

    Pozdrawiam,
    Bartek
  • Szafy Rack
  • Specjalista Sieci, Internet
    Czy jeśli połączenie między komputerem a funboxem jest kablowo tylko, to czy net poprawnie działa ?
  • Poziom 8  
    Połączenie bezpośrednio między Funboxem a jakimkolwiek urządzeniem, czy to bezprzewodowo czy przewodowo, działa poprawnie (choćby komunikacja pomiędzy wspomnianym amplitunerem sieciowym a smartfonem/PC przebiega prawidłowo), także Funbox jako router działa poprawnie. Problem pojawia się jednak, kiedy do Funboxa podłączam dwa inne routery (w Funboxie wyłączam wtedy wifi). Wtedy - jeśli do obu sieci podłączone są urządzenia - efekty jak powyżej.
  • Pomocny post
    Specjalista Sieci, Internet
    Zamieść schemat sieci, podaj model urządzeń, opisz porty do których włączone są kable, opisz konfiguracje routerów (router vs switch, jak router to podaj adresy na wan i lan).

    Dodano po 4 [minuty]:

    Oba routery (dlink, xiaomo) ustaw jak poniżej
    - zresetuj do ustawięn fabrycznych
    - ustaw LAN ip na dlink 192.168.55.1 xioamo 192.168.66.1
    - wan automatycznie pobierz IP
    - kabel z funbox do portu _WAN_

    jak teraz podłączysz _kablem_ komptter do dlink/xiaomo to czy działa net poprawnie ?
  • Poziom 8  
    Źle się wyraziłem, pisząc "switch" miałem na myśli zwykły patch panel, switcha nie ma w tej konfiguracji. Przepraszam za wprowadzenie w błąd. Poniżej schemat.
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    Jeśli chodzi o ustawienia routerów, to jak napisałem - próbowałem różnych rozwiązań, jako osobne routery jak i jako wired repeater (Xiaomi) oraz AP (D-link, który opcji repeatera jako takiego nie posiada), w każdym przypadku podłączając do LAN lub WAN routerów. Funbox ma tylko jedno wyjście WAN, także chyba opcja z wpinaniem w WAN odpada.

    Proszę o propozycję konfiguracji lub ew. zmian sprzętu - skłaniam się po dniach walki ku przekonaniu, że to problem albo z Funboxem albo z ubogością opcji D-Linka.

    Dziękuję.

    Bartek

    Update:
    1. Ok, ale jak podłączyć do jednego portu WAN w Funboxie dwa routery?
    2. Nie, gdy połączę się kablem z Xiaomi/D-linkiem to Internet nie działa poprawnie.
  • Specjalista Sieci, Internet
    OneLazyBastard napisał:
    1. Ok, ale jak podłączyć do jednego portu WAN w Funboxie dwa routery?


    (funbox) ==== (port wan)dlink
    (funbox) ==== (port wan)xiaomi
  • Poziom 8  
    Rozumiem, ale w Funboxie do portów LAN?
  • Specjalista Sieci, Internet
    OneLazyBastard napisał:
    Rozumiem, ale w Funboxie do portów LAN?

    nom
  • Szafy Rack
  • Poziom 8  
    Ok, wypróbuję rozwiązanie jeszcze dzisiaj. Proszę tylko o wykład nt. logiki za zaproponowanym rozwiązaniem, abym wyciągnął z tego jakąś lekcję, a nie tylko wykorzystał czyjąś wiedzę.
    Dziękuję.

    Dodatkowo,
    w Funboxie DHCP server ON, w Xiaomi, D-Linku - Off?
  • Specjalista Sieci, Internet
    Na razie chcemy się upewnić ze po kablach wszystko działa jak należy, w domyślnej konfiguracji routerów.

    OneLazyBastard napisał:
    w Xiaomi, D-Linku - Off?

    Maiłeś zresetować do domyślnych ustawien routery, a każdy router w domyślnej konfiguracji ma DHCP załączone.
  • Poziom 8  
    Zrobione zgodnie z instrukcją, niestety efekt ten sam. Wydaje mi się, że jest jeszcze gorzej.
  • Pomocny post
    Specjalista Sieci, Internet
    Znaczy w konfiguracji

    (net) ===kabel==(funbox)===kabel===(dlink)===kabel===(komputer)

    jeste gorzej niż

    (net) ===kabel==(funbox)===kabel===(komputer)

    ?

    wszystkie kable są fabryczne czy samoróbki ?
  • Poziom 8  
    Konfiguracji net - kabel - funbox - kabel - komputer specjalnie nie sprawdzałem - miałem tak uruchomiony sprzęt przez rok i było ok. Później wpadłem na pomysł z dwoma routerami i dlatego tu jesteśmy.

    Opinia z postu wyżej była odnośnie konfiguracji net - kabel - funbox - kabel - xiaomi - wifi - komputer.
    W przypadku d-linka jest to samo.

    Odpaliłem teraz po kablu i wydaje się być dużo lepiej, chyba nawet po prostu jest ok, tak jak być powinno.

    Co dalej, aby tak samo dobrze było po wifi?
  • Specjalista Sieci, Internet
    Jak po kablach OK tzn że masz problemy z WIFI.

    Upewnij się że masz aktualne oprogramowanie w obu routerach, nie ? aktualizuj.

    Na laptopie zainstaluj inssider 2.x, przeskanuj sieci z laptopem w miejsach gdzie jest słaby net i pokaż zakładki Timegraph, 2ghz, 5ghz.
  • Poziom 8  
    D-Link ma najnowsze oprogramowanie (09.2014), Xiaomi również (10.2016).
    Informacyjne - gdy Funbox stał w miejscu, w którym teraz stoi Xiaomi, to wszystko było ok, internet po wifi działał poprawnie.

    "Słaby net" (czyli efekty jak opisane na początku) jest wszędzie. Większość czasu spędzam metr od miejsca, w którym stoi Xiaomi, D-link stoi w rzadziej uczęszczanej części domu. Takie koślawe działanie jest na 2.4GHz jak i 5Ghz.

    Poniżej zamówione screeny (metr od routera Xiaomi).
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    Dziękuję serdecznie za pomoc.
  • Specjalista Sieci, Internet
    Upewnij się że jak stoisz przy Xiaomi to łączysz się z xaomi 2.4ghz,
    Jak przy dlinku to z dlink-iem 2.4ghz,

    Na razie nie łącz się z 5ghz,
    Nie widzę aby dlink nadawał na 5ghz.
  • Poziom 8  
    Dzień dobry,

    Testuję od wczoraj i wydaje się być ok, choć mam wrażenie, że im bliżej godziny powrotów z pracy i szkoły, tym gorzej - zaczynam się zastanawiać czy do tego wszystkiego nie dokłada się również Orange z niskim poziomem świadczenia swoich usług telekomunikacyjnych. Niestety, nie mam (jeszcze) światłowodu, więc ruch w okolicy pewnie robi swoje - wcześniej jednak tego nie zauważyłem, ale może coś się zmieniło w infrastrukturze.

    D-Linka 5GHz nie było widać na wczorajszym wykresie, bo po prostu go komputer nie łapał - jak wspominałem, ten router jest dość daleko od Xiaomi.

    Ogromne dzięki za pomoc.

    Nie zamykam jeszcze tematu, dam sobie czas do końca tygodnia na testy, i jak będzie ok, to wtedy zamknę.

    Pozdrawiam.
  • Specjalista Sieci, Internet
    OneLazyBastard napisał:
    zaczynam się zastanawiać czy do tego wszystkiego nie dokłada się również Orange z niskim poziomem świadczenia swoich usług telekomunikacyjnych


    Sprawdź komputerem wpiętym _kablem_ do routera.
    Jak po kablu działa dobrze to problem z WIFI a nie z operatorem.
  • Poziom 8  
    Tak, jak pisałem wczoraj - sprawdzałem po kablu, było ok. Później sprawdzałem po wifi - i było równie ok.

    Teraz po wifi - jest kicha, choć może lepiej niż wczoraj. Sprawdziłem teraz specjalnie na Pańskie życzenie po kablu - to samo. Kicha. Może odrobinę lepiej, ale też lagi przy ładowaniu stron, strony nie wczytują się do końca, ping 115ms na speedteście. Choć jak zrobię po chwili, czy to na wifi, czy po kablu, to będzie standardowe 19.
  • Specjalista Sieci, Internet
    To pewnie jest przeciążenie węzła dostawcy.
    Pokaż zrzuty winMTR.exe diagnostyki w czasie OK i w czasie lagów.
  • Poziom 8  
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    W czasie lagów. W czasie OK może uda złapać mi się przed północą.
  • Specjalista Sieci, Internet
    Hmm.... tutaj wszystko wygląda OK.

    Uruchom komputer w tryb awaryjny + obsługa sieci, czy to coś zmienia ?
  • Poziom 8  
    Problem dotyczy wszystkich urządzeń pracujących w sieci, smartfonów, tabletów, amplitunera sieciowego, drugiego laptopa, także raczej nie jest to problem tego PC.

    W tej chwili zrobiony ping google.pl dał takie efekty:
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.
  • Specjalista Sieci, Internet
    Jednocześnie pinguj z komputera po kablu.
  • Poziom 8  
    Funbox-kabel-Xiaomi-kabel-PC:
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    Funbox-kabel-PC:
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    Sprawdziłem też w drugiej konfiguracji faktyczne działanie netu: wszystko śmigało tak jak powinno. No, przytkało się w jednym serwisie, ale po kilku sekundach wczytało, całą stronę.

    Więc chyba faktycznie problem z WiFi. Tylko jak go rozwiązać. Czy możliwe, że jakieś urządzenie przyłączone do jednej z sieci robi bałagan, np. tv zarejestrowany w sieci D-linka czy coś takiego? Wczoraj odkryłem, że kamerka home monitor (w sieci D-linka) przypisała sobie IP 192.168.1.11, które zarezerwowane było na Funboxie dla D-linka - gdy odpalałem w przeglądarce to IP, to wyskakiwała mi strona logowania do panelu kamerki. Myślałem, że może to robiło problemy, ale jak się okazuje chyba nie, skoro efekty znowu te same...

    Z drugiej strony, to chyba nie tylko problem WiFi, skoro po kablu przez Xiaomi jest taka sama kicha. Co więcej, do Xiaomi po kablu mam wpięty amplituner sieciowy, i gdy próbuję odpalić coś bezpośrednio z jego interfejsu, np. muzykę ze Spotify'a, to również się przytyka, i utwory albo się w ogóle nie buferują, albo przerywają w trakcie.
  • Specjalista Sieci, Internet
    adresy IP przypisane ręcznie _MUSZĄ_ być poza pulą serwera DHCP w routerze.
  • Poziom 8  
    Nie przypisywałem tych adresów ręcznie. To Funbox takie przydzielił. I w Xiaomi i w D-linku ustawiłem, tak jak powiedziałeś, kolejno: 192.168.66.1 i 192.168.55.1. Screen z Xiaomi:
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.

    Chyba, że miałem przypisać IP statyczne routera, a nie Lan IP, o, tutaj:
    Funbox 2.0 + dwa routery - Lagi przy otwieraniu stron, bufforowaniu, itd.
  • Specjalista Sieci, Internet
    Podłacz do routera (dlink lub xiaomo) dwa komputery, jeden kablem drugi po WIFI (raz 2 a raz 5ghz)

    na komputerach zainstlauj iperf3.exe
    na komp1 podłaczonym kablem wyłącz zaporę i uruchom w oknie cmd.exe
    iperf3.exe -s

    na komp2 , po wifi (w miejscu gdzie zwykle pracuje)
    iperf3.exe -c ip-adres-komputera-1
    iperf3.exe -R -c ip-adres-komputera-1

    pokaż wszystkie 8 wyników
  • Poziom 8  
    Drugi laptop to mac, także nic z tego nie będzie...

    Wracając do poprzedniego punktu: czy na pewno chodziło Ci wcześniej o przypisanie LAN IP czy jednak statycznych adresów IP zamiast DHCP/auto IP? Może to jest problem?
  • Specjalista Sieci, Internet
    google iperf3 for mac

    ehh....nic własnej inicjatywy

    Nie podłączaj nic do funboxa oprócz routerów kablami, wszystkie urządzenia podłączaj do dlink/xiamoi.