Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

SCART - skuteczne wymuszenie trybu RGB

MES Mariusz 23 Kwi 2017 22:10 1047 2
  • #1 23 Kwi 2017 22:10
    MES Mariusz
    Poziom 36  

    Witam.

    Moda na 8-bit retro przyszła, niestety czasem nowsze TV LCD stwarzają problemy.

    Próbuję podłączyć Amigę 500 do TV Samsung LE40C650

    Wykonałem kabel wg tego schematu:

    SCART - skuteczne wymuszenie trybu RGB

    Na małym kineskopie sygnał był stabilny. Dziś podłączyłem do 40 calowego Samsunga LE40C650 i widzę, że telewizor co jakiś czas, na ułamki sekund gubi sygnał (wyłącza się z trybu SCART). Sprawdziłem kabel, jest ok. "Contact Cleanerem" przeleciałem złącze w Amidze i wszystkie styki kabla. Mam jednak podejrzenie, że to nie wina ani kabla ani Amigi. Z jakiegoś powodu TV nie potrafi trzymać się wymuszonego trybu RGB.

    Znalazłem inny schemat tego samego kable, i widzę, że zastosowano inne wartości rezystorów:

    SCART - skuteczne wymuszenie trybu RGB

    Jakie napięcia muszę mieć na pinach 8 (switch), 16 (RGB mode) oraz 20 (composite video) by na 100% wymusić tryb RGB?

    0 2
  • #2 24 Kwi 2017 01:55
    humbel
    Poziom 23  

    Pin 8 - 11-12V
    Pin 16 - 1-3V (2,5V nominalne tryb RGB)

    0
  • #3 14 Maj 2017 13:41
    MES Mariusz
    Poziom 36  

    humbel napisał:
    Pin 8 - 11-12V
    Pin 16 - 1-3V (2,5V nominalne tryb RGB)


    Hmm. To już wiem, dlaczego TV gubi obraz, do u mnie na kablu:

    Pin 8 (SWITCH) = 5.2V (względem LOGIC GROUND)
    Pin 16 (RGB MODE) = 2.4V (względem LOGIC GROUND)
    Pin 20 (COMPOSITE VIDEO) = 0.7V (względem LOGIC GROUND)
    Pin 18 (LOGIC GROUND) = 0V

    W kontekście tego, co napisano na schemacie do kabla:
    SCART - skuteczne wymuszenie trybu RGB

    Czyli:
    - na pinie 16 (RGB MODE)= 2.4V mam poprawnie wymuszony tryb RGB.
    - na pinie 20 (COMPOSITE VIDEO) = 0.7V - to chyba oznacza, że tryb composite jest zablokowny (bliskie 0) - zakładam, że tak powinno być.
    - na pinie 8 (SWITCH) = 5.2V mam za niskie napięcie - powinno być 12V, a jest 5V...

    Użyłem rezystora 1k (podobno zaleca się przedział 1k...4k7:

    SCART - skuteczne wymuszenie trybu RGB


    Tylko pytanie czy ten rezystor:
    a). zbija napięcie obecne na pinie 8 TV do wartości 12V, czy
    b). dostarcza napięcie od strony Amigi.

    Zakładam, że dostarcza napięcie, bo mierząc napięcie na tym pinie, gdy TV włączony, ale nic do scarta nie podłączone, widzę 0V
    Czyli muszę użyć rezystor mniejszy niż 1k.

    0