Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MC34063A - dziwny przypadek!

mkpl 02 Cze 2017 11:45 1197 13
  • #1 02 Cze 2017 11:45
    mkpl
    Poziom 37  

    Witam
    Naprawiam ładowarkę firmy Varta.
    W układzie są dwa identyczne tory step down na MC34063A (tak mi się wydawało).

    Generalnie układ prosty z dodatkowym driverem na tranzystorach PNP/NPN i Pmos w torze mocy. Wymieniłem Pmos na znacznie lepszego (stary był uszkodzony) oraz RT34063A na MC34063A i wszystko się grzało jak głupie a przetwornica pracowała niestabilnie.

    Porównywałem oba tory między sobą podmieniałem tranzystory i nic. Podmieniłem kości 64063 i uszkodzony tor ruszył.

    Jestem 100% pewien ze moje kości MC34063A są sprawne.

    Więc pytanie czym się różnią MC34063A od RT34063A ? że na jednych układ działa a na drugich jest niestabilny?

  • #3 02 Cze 2017 13:24
    mkpl
    Poziom 37  

    Ciekawostka. W tym samym układzie generator MC34063 oscyluje na częstotliwości 157kHz natomiast RT34063 131kHz.

  • #5 02 Cze 2017 13:49
    mkpl
    Poziom 37  

    Układ dobrałem jak opisałem w poprzednich postach. Chory kanał ma obniżoną częstotliwość pracy (tak pozostawiłem eksperymentalnie).
    Oba tory jeśli chodzi o driver i stopnień mocy są sprawne, ponieważ wada przechodzi wraz z zamianą kostek 34063A.

    Schemat:
    MC34063A - dziwny przypadek!
    Schemat odpowiada strukturą układowi, który naprawiam (wartości elementów są inne i nieistotne).

    Tor sprawny:
    Dren
    MC34063A - dziwny przypadek!

    Bramka:
    MC34063A - dziwny przypadek!

    Noga 1(8)
    MC34063A - dziwny przypadek!

    CT(3)
    MC34063A - dziwny przypadek!

    Tor uszkodzony:
    Dren
    MC34063A - dziwny przypadek!

    Bramka
    MC34063A - dziwny przypadek!

    Noga 1(8)
    MC34063A - dziwny przypadek!

    CT (3)
    MC34063A - dziwny przypadek!

  • #6 02 Cze 2017 14:45
    -XantiO-
    Poziom 17  

    Porównaj pojemności bramek mosów. Wydaje mi się, że nowy ma większą.

  • #7 02 Cze 2017 14:56
    mkpl
    Poziom 37  

    To jest bez znaczenia. Jak zamienię między sobą kości to nowy mos też pracuje poprawnie. Zamieniałem też mosy między sobą i bez zmian.

  • #8 02 Cze 2017 15:06
    _lazor_
    Poziom 24  

    jedno jest pewne tranzystory wewnątrz scalaka nie otwierają się poprawnie. Możliwe że przy częstotliwości powyżej 100kHz MC34063A już się podaje i nie otworzy poprawnie tranzystorów.

    Najwyraźniej seria RT jest odporniejsza, może jakaś seria MC by to również uciągła, niestety wygląda na to, że Twój scalak przestaje poprawnie pracować (co by się zgadzało z notą katalogową gdzie częstotliwość powyżej 120kHz nie jest brana pod uwagę nawet).

  • #9 02 Cze 2017 15:07
    -XantiO-
    Poziom 17  

    A czy podstawienie MC34063 do "zdrowego" kanału powoduje na nim podobne objawy jak na tym uszkodzonym?

  • #10 02 Cze 2017 15:11
    mkpl
    Poziom 37  

    @_lazor_ nie czytałeś poprzedniego postu. W celach eksperymentalnych w kanale z scalakiem MC34063 (tym złym) częstotliwość z 157kHz zmniejszyłem do dokładnie 95kHz i bez zmian.

    @-XantiO- dokładnie tak. Podmiana scalaków powoduje, że sprawny kanał staje się tym zły a zły działa poprawnie. Dlatego odrzuciłem teorię o złym tranzystorze lub uszkodzonej części mocy (wszystkie elementy były przebadane).

  • #12 03 Cze 2017 11:26
    mkpl
    Poziom 37  

    Ponieważ kostki mam nowe na rolce a dodatkowo jedną sztukę pożyczyłem z działającego układu.

  • #13 03 Cze 2017 11:46
    -XantiO-
    Poziom 17  

    Wygląda na to, że główną różnicą będzie tu "Discharge to Charge Current Ratio "
    Dla MC34063=6.5
    Dla RT34063=6.9

    A więc wygląda na to, że będzie inna charakterystyka czasowa pomiędzy turn_on a turn_off dla obu scalaków. Co też widać na pinie CT.

    Nie wiem jaką masz wartość kondensatora CT ale spróbuj na obu dać około 2,2nF i wstaw oscylogramy.

  • #14 03 Cze 2017 12:22
    krzysiek_krm
    Poziom 29  

    Witam,
    na oscylogramach widać jakieś podejrzane oscylacje.
    Możliwe, że należy zmienić obciążenie wyjścia układu (zwiększyć albo zmniejszyć, diabli wiedzą), czyli opornik R1 na schemacie.
    W aplikacjach, w takiej konfiguracji wyjścia, stosowany jest jeszcze zazwyczaj szeregowy opornik, możliwe, że obwód wyjściowy ma jakieś nienormalnie duże wzmocnienie, dlatego wpada w oscylacje.

    Pozdrawiam

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME