Elektroda.pl
Elektroda.pl
X
Relpol
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

tensometr i przetwornik

golem 16 Paź 2006 14:21 16881 24
  • #1 16 Paź 2006 14:21
    golem
    Poziom 10  

    Witam
    Ostatnio u mnie w zakładzie uległa uszkodzeniu waga zbudowana na trzech tensometrach (na rozciąganie). Uszkodzeniu uległ jeden z tensometrów. Zaciekawila mnie jedna rzecz- w danych katalogowych tensometra przeczytalem ze oporność wejściowa jest 350Ohm, oporność wyjściowa 350Ohm. Natomiast w danych katalogowych przetwornika wspołpracującego z tensometrami jest podana taka informacja:
    - maksymalne obciążenie 300Ohm (4-20mA/0-20mA)
    - minimalne obciążenie 3000 Ohm (0-10Vcc)
    Nie udało mi się znaleźć tensometru o rezystancji takiej samej jak w uszodzonym - natomiast sa z większą rezystancją wejściową - Rwe=400Ohm. Czy z takimi tensometrami układ będzie właściwie pracował?? nie mam doświadczenia z takimi układami...

    Pozdrawiam

    0 24
  • Relpol
  • #2 16 Paź 2006 18:43
    darxxxx
    Poziom 16  

    Co ważysz ? Powiedz coś na temat cyklu produkcyjnego. Czy proces ważenia odbywa się w cyklu ciągłym? Jaki jest zainstalowany procesor- sterownik- jakiej firmy?

    0
  • #3 16 Paź 2006 19:04
    mawi2
    Poziom 25  

    Podaj typ tensometru i typ miernika - odczytu. Nie mniej z praktyki to co podales to jest OK. Obecnie wlasciwie standardem jest impedancja przetwornikow ok. 350 ohm. I kazdy miernik bedzie wsolpracowal z takimi tensometrami lub tensometrami o wiekszej impedancji. Czyli spokojnie jesli masz 400 ohm Przy wymianie wazne jest abys zastosowal tensometry identycznego typu.

    0
  • #4 17 Paź 2006 08:57
    golem
    Poziom 10  

    darxxxx napisał:
    Co ważysz ? Powiedz coś na temat cyklu produkcyjnego. Czy proces ważenia odbywa się w cyklu ciągłym? Jaki jest zainstalowany procesor- sterownik- jakiej firmy?

    Jest to waga wisząca oparta na trzech tensometrach. Ważone jest kruszywo, kamienie, piaski - w cyklu ciągłym - pomiar co około 2 min. Zarówno tensometry jak i przetwornik z nim pracujący jest firmy Laumas:
    tensometr i przetwornik
    dane przetwornika znajdują się TU
    z tą różnicą że u mnie pracuje przetwornik WT30.000 (prawdopodobnie starsza wersja) 2IN-2OUT o pozostalych danych jak przedstawilem w poscie wyżej.
    Natomiast tensometr CTL 2500
    tensometr i przetwornik
    a jego dane znajdują się
    TUTAJ


    mawi2 napisał:
    Obecnie wlasciwie standardem jest impedancja przetwornikow ok. 350 ohm. I kazdy miernik bedzie wsolpracowal z takimi tensometrami lub tensometrami o wiekszej impedancji. Czyli spokojnie jesli masz 400 ohm Przy wymianie wazne jest abys zastosowal tensometry identycznego typu.

    Zastanawia mnie tylko na co wpłynie ta różnica rezystancji (50 Ohm)
    Moze teraz bedę fantazjował ale czy czujnik nie bedzie pracował na innej częsci charakterystyki ?? Czy nie wyjdzie ze swej klasy, czy nie starci się znacząco na dokładności pomiaru... Jeśli ktoś potrafi to prosze o wyjaśnienie wpływu różnicy rezystancji wejściowej tensometru na prace z przetwornikiem.

    Pozdrawiam

    0
  • Relpol
  • #5 17 Paź 2006 18:43
    kleki
    Poziom 28  

    Trochę podpowiem - na ile wiem. :-)
    - maksymalne obciążenie 300Ohm (4-20mA/0-20mA)
    To jest parametr wyjścia pętli prądowej, czyli jak dasz np. wskaźnik o Rwe większym, to przetwornik odczyta to jako uszkodzoną (przerwaną) pętlę prądową.

    - minimalne obciążenie 3000 Ohm (0-10Vcc)
    To jest zaś parametr wyjścia napięciowego. Jak dasz obciążenie mniejsze niż 3kOhm, to możesz upalić tranzystor wyjściowy źródła napięciowego.

    Jakby nie patrzeć oba te parametry nie mają nic wspólnego z tensometrem, a jedynie decydują o możliwości podłączenia różnych urządzeń do wyjść analogowych przetwronika.

    Przy doborze tensometru interesują cię przede wszystkim:
    - nośność
    - czułość
    - max napięcie zasialnia

    U wy tensometru masz w/g wzoru
    Uwy=(ładunek/max_nośność)*Uzasilania*czułość

    Nie jestem pewien co do info zaczerpniętych z DTR przetwornika, bo w językach obcych jestem cienki i nie chciałbym wprowadzić w błąd.

    Jak zgadza ci się czułość, nośność i zasilanie to w zasadzie wszystko. 350 Ohm nie jest zbyt istotne, bo to dla ciebie rezystancja wewnętrzna źródła, a obciążeniem dla niej jest rezystancja wewnętrzna przetwornika, czyli minimalnie kilka MOhm.

    pzdr

    0
  • #6 23 Paź 2006 19:47
    mawi2
    Poziom 25  

    Witam w przypadku wagi zawieszonej na trzech przetwornikach , a domyślam sie iz urządzenie pracuje na betoniarni, nie ma problemu. Można ewentualnie w gałąź zasilania tensometru włączyć potencjometr ok 100 r i wyregulowac wskazania. Czyli: włączasz wagę przy pustym zbiorniku, czekasz aż pokaże się na wskaźniku 0 kg, następnie stawiasz na kna pierwszym przetworniku jakąśmasę np: 100 kg - robisz odczyt , to samo na pozostałych. Wtedy zwiększasz oporność PR na przetworniku który daje największe wskazanie, w ten sposób doprowdzasz do identycznych wskazan na wszystkich tensometrach. Przy braku praktyki może to troche potrwać. Jednak dla Ciebie najważniejsze są wskazania masy sumaryczne. Produkt zawsze nasypie się w miarę centralnie i proponuję jedynie kalibrację wagi poprzez postawienie znanej masy i wprowadzenie jej do terminala. Gdybyś szukał przetworników nowych daj znać a podam jakieś adresy , jeden kosztuje ok 1,2 do 2,5 kPLN. Jeśli będziesz miał kłopot z dozowaniem to pisz i czasem na mnie poczekaj - często wyjeźdźam.

    0
  • #7 28 Paź 2006 20:25
    golem
    Poziom 10  

    Witam
    Może napisze na początku coś o nieprawidłowej pracy wagi - obserwacjach i dlaczego uważalem ze to tensometr jest uszkodzony (choć jak sie okazuje to nie takie oczywiste). Sytuacja była nastepująca: po każdym naważaniu zaczeło coraz więcej zostawać na wadze (zdaniem przetwornika) choć waga fizycznie opróżniała się do końca... Na wyświetlaczu pozostawała jakas liczba kg na wadze. Program sterujący całym procesem technologicznym współpracujący z waga ma zabezpieczenie które nie pozwala przejść do kolejnego cyklu jeśli np. po opróżnieniu wagi zostanie na niej okolo 30kg. Wiec na przetworniku(wyświetlaczu) została wyzerowana waga. Przez pewien czas wszystko pracowało dobrze, az do momentu kiedy na wyświetlaczu zaczeły pojawiać się ujemne wartość na wadze. Programowi sterującemu to nie przeszkadzało bo on odczytywał ujemną wartość jako 0kg - natomiast dokładność naważania była fatalna bo do zadanej wartości kruszywa (bo to jest naważane) dochodziła jeszcze ta ujemna część która po opróżnieniu wagi wskazywał wyswietlacz przetwornika. Gdyby to była stała wartość to można by zrobić korekty i to obejść natomiast ta wartość na minusie cały czas rosla. I w tym momencie zacząłem rozgladas sie za tensometrami.
    Jak się okazało na wadze pracowały dwa tensomtery jednego typu CTL oraz jeden CTS - mają one tę samą nośność i czułość ale różnią się w rezystancjach wejsciowyc i błedach kombinacji (jakoś tak dziwnie się to nazywa).
    Wiec zdecydowalem się na zakup orginalnych tensometrów typu CTL.
    Oto dla orientacji jak wyglada waga:
    tensometr i przetwornik
    Przed wymianą tensometrów osobą długo pracująca przy wagach poradziłą mi abym spróbował znalezc uszkodzony tensometr poprzez wypinanie po jednym tensometrze i obserwowanie co sie dzieje na wyświetlaczu. Ale w kazdym z 3 przypadów tj. gdy pracowal T1 i T2, T2 i T3, T1 i T3 wartość na przetworniku spadała w czasie...
    Myslalem ze sprawe załatwi wymiana tensometrów. Najpierw wymienilem tylko jeden tensometr ten który był innego typu od dwoch pozostalych (na rysunku T3). Przetwornik wyzerowałem i wszystko pieknie się ustabilizowało. Skoki były 1-2kg ale to bylo do zaakceptowania. Po kilkudziesieciu nawazaniach znów zaczeło po opróżnianiu pozostawać na wadze (wedlug wskazan wyswietlacza) kilkanascie kg. Po wyzerowaniu zaczął się pojawiać znany problem ze wzrostem ujemnej wartości na wadze po oproznieniu.
    Kolejnego dnia wymienilem pozostale tensometry tak aby byly wszystkie nowe. Ale nic to nie pomogło. Cały czas waga nie może się ustabilizować a wartość wskazywana przez nią spada ...
    Juz brak mi pomysłów. Nie wiem czy przetwornik jest uszkodzony ... nie wiem nawet jak to sprawdzić. Urządzenia są włoskie więc na doświadczony serwis nie moge liczyć.
    Jeszcze zrobilem jeden test. sprawdzalem jakie są wskazania wagi przy włączonym jednym tensometrze. Zdrowo rozsądkowo przetwornik pracujący tylko z tensometrem T1 powinien wskazywać podobną wartość jak T2. Bardzo zdziwil mnie wynik odczytany z wyswietlacza - bo różnica była około 200 jednostek. Pisze jednostek bo waga pewnie po tych wszystkich zmianach jest rozkalibrowana...
    Jezeli macie jakies pomysly to chetnie wyslucham i przetestuje. Procz przetwornika z wyswietlaczem to chyba tylko przewodów doprowadzających nie sprawdzilem ....

    Pozdrawiam

    0
  • #8 29 Paź 2006 11:43
    darxxxx
    Poziom 16  

    Sprawdz dokładnie nastawy parametrów w sterowniku: błąd pomiaru, czas doważania czas zrzutu itd , mógł je ktoś nieświadomie zmienic lub zmieniły się same : słaba bateria, zanik napięcia. Zobacz co ile jest automatyczne tarowanie wagi jeśli trzeba skróc liczbę cykli po których następuje.
    pzd.

    0
  • #9 30 Paź 2006 18:57
    mawi2
    Poziom 25  

    Witam. Czyli jest to dozowanie na betoniarni. Czym podajesz kruszywo taśmociąg , podajnik ślimakowy? i w jaki sposób pobierasz?. Problem taki jak opisujesz może miec po pierwsze podłoże czysto mechaniczne: gdzieś podpiera się lub blokuje zbiornik wagi. Sprawdź wszstkie elementy odbojowe. Sprawdź to równiez przy obciążeniu, może gdzieś sie podgina konstrukcja betoniarni.Zmojej praktyki a robie takie urządzenia dobrych kilka lat w większości przypadków to sprawa mechaniki. Oczywiście jest jeszcze niestabilność elektroniki związana z zakłóceniami elektronagnetycznymi. W takim przypadku (brak uziemień) waga może się wachać nawet o kilkadziesiąt - kilkaset kg. Przedewszystkim - uziemienie i to zarówno miernik jak i tensometry. Od każdego do wspólnego punktu. Oczywiście nie wykluczam w tej chwili równiez błędnych nastaw, niemniej w trybie serwisowym odczyt powinien byc w miarę stabilny , dopuszczalne sa wachania ok kilkanaście działek. Jeśli po sprawdzeniu mechaniki nadal będziesz miał problem to proszę o e-mail na który mogę się kontaktować , podam do siebie kontakt telefoniczny to szybko cos wymiślimy. Informacje dotyczące rozwiązania problemu podam na forum.

    0
  • #10 30 Paź 2006 20:54
    golem
    Poziom 10  

    Jest to wytwórnia masy bitumicznej. Kruszywo po osuszeniu jest sortowane na frakcje (w zalezności od jego ziarnistości) i umieszczane w zbiornikach, które mają na dnie zasuwy otwierane przez silowniki. Zasuwy sa bezposrednio nad waga - i w zaleznosci od składu gotowej masy usypywane jest kruszywo z roznych zbiorników. Kruszywo opada grawitacyjnie na wage.
    A jeśli chodzi o sprawy mechaniczne... problemy zaczely się od momentu gdy jedno z ramion wagi się naderwało i przy większym ciezarze spieralo się o obudowe (w tych przypadkach waga przekłamywała) a większe obciążenie szło na pozostale dwa tensometry. Aby naprawić wage konieczne było zespawanie uszkodzonego ramienia.... Osobiscie tego nie widzialem ale wiem ze masa była ciągnięta ze spawarki az do ramienia wagi i prąd nie powinien przeplywać przez tensometry. Nie mniej od tego czasu zaczely się kłopoty z wagą i odczytami. Jedno zdanie odnośnie ekranowania. Trzy tensometry są połączone równolegle (zasilanie 10V). Połączenie jest zrealizowane na płytkce elektronicznej skad sygnał idzie do przetwornika (wzmacniacza) z wyświetlaczem. Są 4 przewody + ekran. Na płytkce ekran jest podlaczony natomiast przy przetworniku analogowym juz nie .... wiec jaki jest sens takiego ekranowania - no ale tak bylo od poczatku wiec sie nie czepiam.
    Więcej szczegolów przesylam na prv bo mail masz niedostepny.

    0
  • #11 31 Paź 2006 08:48
    markosik20
    Poziom 33  

    Widzę, że wszyscy szukają winy po stronie czujników. Zostały one wymienione i problem nie został rozwiazany. Można jeszcze sprawdzić co z miernikiem. Pracuje w wagarstwie kilka lat i podczas każdego lata "pada" trochę mierników od wyładowań atmosferycznych. Najlepiej zrobić prosty test - sygnał jaki idzie z czujników do miernika zewrzeć kawałkiem przewodu i zobaczyć jak wskazanie zachowuje się w czasie (powinno być w minusie tyle ile waży zbiornik) chyba, że miernik poprostu wyłączy wskazanie stwierdzając błąd. Jeżeli to nie pomoże zdemontować jeden czujnik, całość zabrać do domu i podłaczyć. Jeżeli jeszcze masz mozliwość kalibracji miernika to możesz go ustawić na najwiekszą rozdzielczośc i sprawdzić każdy z tensometrów osobno.

    1
  • #12 31 Paź 2006 18:33
    mawi2
    Poziom 25  

    Witam kolegów. Problemem jest prawdopodobnie wilgoć - to wniosek po naszej korespondencji na prv. Jeśli temat znajdzie rozwiązanie - poinformuję. Odnośnie pytania kolegi golema. dotyczącego ekranów to odpowiadam iż betoniarnie mechaniczne modernizuje na elektroniczne pewna firma z K..... Stosuje terminale produkcji polskiej. Standardowo nie daje dodatkowej masy łączącej tensometry z miernikiem - efekt to wymiana przetwornika A/D na płytce miernika a to koszt nie mały co 2 - 3 miesiące. Problemem są duże prądy zasilające silniki mieszarki, dodatkowo dochodzą wyładowania atmosferyczne. Ekran jaki jest w przewodzie tensometru nie jest wystarczający. W wiekszości przetworników jest on podłączany do punktu "zerowego" mostka tensometrycznego a nie do obudowy ptrzetwornika a masa jaką dokładam łączy właśnie obudowy z obudową miernika odczytowego. Dodatkowym efektem jest minimalizacja pływania wskazań. Jeśli mamy tutaj serwisantów od wag proponuje użyć elektroniki naszego polskiego producenta - dośc nowe wdrożenie i sprawdzić czy są połączone wewnątrz masy analogowa i cyfrowa. Jeśli nie to je połączyć i sprawdzić zmienność wskazań działek. Po szczegóły dotyczące elektroniki zapraszam na prv. Ze względów reklamowych nie podaję nazw producentów.
    Odnośnie zwierania wejść jak sugeruje kolega markosik20 to nie proponuję chyba że chcemy sie przekonać ile kosztuje naprawa układu wejściowego. Przykładem zwierania wejści lub rozwierania np: odłączenie czy zerwanie jednego z przewodów sygnałowych są stare wagi produkcji LFW z lat 90 . Produkowane w oparciu o elektronikę Campensa. Tam efektem takich zabaw było szybkie uszkodzenie wzmacniacza LTC1044, kupcie go teraz, nie tak łatwo. Wzmacniacz tan miał bardzo niskie maksymalne napięcie wejściowe kilkaset mV. I każde odlłaczenie lub podłącznie tensometru do włączonego miernika nie mówiąc o zwarciach mogło sie skończyć takim efektem. A więc powodzenia przy wykonywaniu zwarć. Oczywiście są elektroniki które takie "manewry" przechodzą bez szwanku. Jeśli nie mamy przetwornika można zastosować tzw "żródełko" po prostu mostek rezystancyjny złożony z potencjometrów i zasymulować działanie przetwornika tensometrycznego zmieniając nastawy potencjometrów. Sprawdzone działa bardzo dokładnie. Dodatkowo w ten sposób możemy sprawdzić stabilność odczytu miernika. Osobiście pracując w serwisie stosuję tensometr do którego mam dokręconą szalkę. W ten sposób podczas naprawy płyt procesora mogę sprawdzić również jego wzmocnienie co jest utrudnione w przypadku "źródełka" Pozdrawiam.

    0
  • #13 31 Paź 2006 20:10
    markosik20
    Poziom 33  

    Cytat:
    było szybkie uszkodzenie wzmacniacza LTC1044

    Po pierwsze to nie jest wzmacniacz i nie wiem co ma wspólnego bezpośrednio z torem pomiarowym sygnałów rzędu mV.
    Po drugie robienie "źródełek" z potencjometrów nic nie daje bo nie wiemy jak układ pomiarowy pracuje przy zerowym sygnale (kiedy wejście pomiarowe jest zwarte). Owszem w ten sposób sprawdzimy czy układ pomiarowy w ogóle reaguje ale nie wiemy czy prawidłowo (tutaj jak kolega mawi2 wspomniał idealnie nadaje sie jakis wozrcowy sprawdzony i o znanych parametrach tensometr). Miałem już w rękach trochę mierników (prawie wszystkich znanych producentów) i tory pomiarowe "padały" przeważnie od przepięć (wyładowania atmosferyczne) albo od strony zasilania układów w torze pomiarowym (stabilizatory). Od ilku lat mało kto stosuje skomplikowane układy tylko montowane są gotowe całe układy wzmacniaczy (typu AD7730) które nieźle się sprawują (nie mówię o produktach czysto "made in china").
    I na koniec
    Cytat:
    W wiekszości przetworników jest on podłączany do punktu "zerowego" mostka tensometrycznego a nie do obudowy ptrzetwornika
    która to jest ta większość ? Bo przyznam sie szczerze , że jak tylko się pojawiła jakaś rezystancja między mostkiem a ekranem czujnik lądował w koszu :)

    0
  • #14 01 Lis 2006 00:15
    mawi2
    Poziom 25  

    Dot."większość" czyli poza wyjątkami typu min. china ekran przewodu podłączany jest do mostka tensometrycznego to jest takie coś co jest przyklejone do metalu zwanego tensometrem inaczej obudową i nie jest ono zwarte z ta obudową. Proszę dokladnie czytać to co napisałem tam dokladnie jest powiedziane, że ekran przewodu nie jest zwarty z obudową.
    Może dokładniej wyjąsnię terminy: tensometr oraz przetwornik tensometryczny zwany w skrócie tensometrem. Sa to dwie różne rzeczy. Tensometr to cienkie ścieżki przewodzące napylone na nieprzewodzący materiał , Przetwornik tensometryczny to jednorodny obrobiony kawał metalu z naklejonymi tensometrami ich ilość jest różna i zależna od rodzaju przetwornika tensometrycznego, chodzi o jego reagowanie na siły tylko prostopadłe czy również siły przyłożone w innych kierunkach i pod rożnymi kątami.
    Tak więc błedne zrozumiienie mojej wypowiedzi może być spowodowane używaniem przeze mnie skrótów.
    Odnośnie LTC 1043 to po wpisaniu w wyszukiwarke dostałem informację iż LTC1043 w j,. angielskim jest zwany Ampliferem chyba to oznacza jednak wzmacniacz. Oczywiście nie jest on typowym operacyjnym i jest rzadko stosowany. Jest on również już konstrukcją przestarzałą. Jednak nadal jest wzmacniaczem.
    Co do toru wejściowego - radzę przejrzeć dokumentację lata 90 LFW jeśli kolega nie posiada - służę. Można sie wiele dowiedzieć.
    Co do stosowania AD7730 - oczywiście znam bardzo dobrze i sporo wymieniłem.
    "Od ilku lat mało kto stosuje skomplikowane układy tylko montowane są gotowe całe układy wzmacniaczy"
    Nie oniecznie jest to prawda - prosze zajrzeć do dokumentacji serwisowej np: bizerba, mettler toledo, precia . AD7730 ma jedną podstawową wadę - jest wolny. Jeśli zastosujemy kompensację temperaturowa programową możemy uzyskac ok. 5 pomiarów na/sec. Jeśli zastosujemy kompensacje zewnętrzną możemy uzyskac ok 15 pomiarów na //sec. nie mniej jest gotowym rozwiazaniem i na pewno tańszym niż wykonywanie wzmacniacza pomiarowego na piechotę. Dlatego nasi polscy producenci chyba wszyscy wykorzystują układy tej serii.
    Do czego potrzebna jest większ ilość pomiarów? Oto jest pytanie.

    0
  • #15 01 Lis 2006 08:52
    markosik20
    Poziom 33  

    Witam.
    Chyba była mała literówka bo kolega napisał

    Cytat:
    LTC1044
    a miało być
    Cytat:
    LTC1043
    no i sie nie zrozumieliśmy :).
    Jak zbudowany jest czujnik tensometryczny to ja wiem ale wyjaśnienie przyda się pozostałym forumowiczom :).
    Co do szybkości...... z AD7730 można wyciągnąć prawie 1000pom/sec (oczywiście kosztem niektórych parametrów). Akurat z szybkościa jest różnie bo np: Mettler ma 300pomia/sec (JagXtrem) i jest "najszybszy" na rynku. A wiadomo im więcej pomiarów tym można z nich "wyłuskać" najbardziej właściwy sygnał. Wszystko zależy przy jakiej aplikacji czy konfiguracji waga pracuje. A co do AD7730 to naprawdę ciężko go uszkodzić, parę razy dostał "impulsowo" 24V na wejscie i przeżył. Jego wadą jest to , że pracuje sekwencyjnie i gdy dostanie zakłócenie to się wyłącza i trzeba go inicjalizować od początku.
    Pozdrowienia i niech wagi się dalej psują (będzie więcej pracy) :)

    0
  • #16 01 Lis 2006 17:49
    golem
    Poziom 10  

    Witam
    Pozwólcie ze sie wtrące w tę ciekawą dyskusje :D Dziekuje w imieniu forumowiczów za wyjaśnienie różnicy między tensometrem a przetwornik tensometryczny.
    Bardzo chciałbym aby Mawi2 mial racje jesli chodzi o moje problemy z wagą. Jutro odrazu dostosuje się to jego rad i sprojuje ominąć płytkę łączeniową (na której są połączone równolegle tensometry i wyprowadzone zaciski do przetwornika analogowego z miernikiem i wyświetlaczem). Jesli to nie przyniesie efektu to trzeba bedzie zająć się. przetwornikiem analogowym z wyświetlaczem.
    We wtorek przeprowadzilem jeszcze kilka prób. Wypiąłem przewód łączący wspomnianą płytkę z przetwornikiem analogowym - zmienilem go nowym - lecz nie zmienilo niewłaściwej pracy wagi. Poodkręcałem wszystkie osłony na ramionach wagi tak aby mieć pewność ze mechanicznie nic nie przyciera... Zauwazylem ze tenosmetr T3 (zgodnie z rysunkiem) nie jest idealnie w pionie . Postaram się to poprawić. Zobacze czy te zabiegi pomogą.
    A gdyby nie to pozostaje jeszcze przetwornik analogowy WT 30.000 (dokumentacja do WT 60.000 - link podany wyzej)
    Takich przetwoników analogowych jest u mnie trzy (waga kruszywa, waga bitumu, waga wypełniacza) z tą różnicą ze one są wyskalowane na prace w zakresie od 0 do 200kg. Więc chyba mogę przepiąć je bez zadnych konsekwencji i sprawdzić co się dzieje czy wskazania beda stabilne.
    Odnośnie tego co zaproponował markosik20 - czy dobrze zrozumiałem ze trzeba zewrzeć przewody sygnałowe "sygnał" idące od tensometru do przetwornika analogowego - jak na rysunku??
    tensometr i przetwornik
    ale z tym zwieraniem wejść urządzenia to bedzie ostateczność jak juz wykorzystam wszystkie wcześniej omówione pomysły.
    Jeszcze jedno by mnie interesowało gdby jednak okazło się ze to uszkodzony przetwornik analogowy a sprowadzenie podobnego urzadzenia z wloch to czas do przynajmniej tydzien czasu - gdzie moge dostać szybko taki przetwornik wagowy z wyswietlaczem (odpowiednik WT 30.000)??

    Pozdrawiam

    0
  • #17 01 Lis 2006 18:01
    mawi2
    Poziom 25  

    Odnośnie miernika. W specyfikacji technicznej z linku podane jest że ma on kilka typów wyjść: prądowe, RS 232 oraz przekaźnikowe. Co wykorzystujesz do sterowania automatyką - bo można wykorzystać każde z tych wyjść to zalezy tylko od użytej automatyki. Najlepiej jeśli masz sterowanie poprzez styki lub 4- 20 mA bo to podepniesz bez żadnego problemu jeśli przez RS to trzeba skonfigurować "string" a wtedy trzeba wiedzieć jaki on jest, też do zrobienia tylko nieco dłużej. Jesli chcesz coś taniego choć czasami zawodnego i w innej obudowie to polecam polskiego wytwórcę Axis trzeba tylko podać jakie wyjścia mają być zamontowane, jeśli miernik palnelowy taki jak na zdjęciu to np; hottinger WE2110, przedstawicielstwo w Poznaniu. To moja propozycja , każdy może podac Ci jeszcze wiele innych rozwiązań. Wykorzystywałem i to i to. Tylko w zależności od zasobności kieszeni klienta.

    0
  • #18 01 Lis 2006 18:23
    markosik20
    Poziom 33  

    Tydzień czasu czekania na dostawę to jeszcze nie tak długo :) Jeżeli masz trzy takie same to bez problemu możesz je podmienić, może nie będzie właściwie pokazywał ale będziesz wiedział czy wskazanie będzie stabilne, czy nie. Jak dalej niestabilne to wiadomo, że miernik OK. Powodzenia i czekamy na info jak Ci poszło.

    PS. Co do tego "zwierania" to trochę to brzmi "strasznie". Proponuje poprostu zrobić mostek z kabelka na zaciskach sygnału (SIGNALE+ i SIGNALE -) i na to samo wyjdzie. Ja tak robie przy każdej wadze gdzie jest podejrzenie, że "szaleje" tor pomiarowy.

    0
  • #19 02 Lis 2006 20:26
    golem
    Poziom 10  

    Witam
    Na początku odpowiedz co do komunikacji przetwornika ze "swiatem zewnętrznym". Miernik wagowy (powtarzam ze dokumentacja jest do nowszego modeli WT60. a u mnie pracuje WT30.) jest połączony z wejściem analogowym PLC - nie wiem tylko czy jest wykorzystane w mierniku wagowym wyjście prądowe czy napięciowe (aby ewentualnie właściwy wybrać) - na przetwronikach analogowo cyfrowych PLC jest napisane 0-10V i 0-20mA. Jest jakiś sposób aby sprawdzić jaki jest to rodzaj wyjścia w przetworniku wagowym??
    A teraz to co dziś zaobserwowalem podczas podpinania tensometrów do innego miernika wagowego.
    Wszystko pięknie chodziło. Oczywiscie waga była nieskalibrowana wiec wszystkie wartości pokazywało mi na minusie. Ale za kazdym razem po oproznieniu wagi - miernik wskazywał tą samą wartość. Sądziłem ze znalazlem problem, az zauwazylem jedną rzecz - kiedy zostały wyłączane lub właczane silniki, które pracują w pobliżu wagi (nie najmniejszej mocy bo od 10 do 20kW) wskazanie miernika zaczelo troszke skakać w granicach 10 jednostek. Taka sytuacja miala jedynie miejsce jak na waga była bardzo obciążona tzn. ponad 2tony bo przy mniejszych zarobach lub pustej wadze to zjawisko sie nie pojawiało. Dodam zjawisko dość dziwne bo tak sobie mysle - gdyby w przewodzie sygnalowym podczas pracy takiego silnika indukowaly sie jakies napiecia to dlaczego tylko przy maksymalnie obciążone wadze... Niemniej postanowilem wypiąć przewód sygnałowy (orginalny) i poprowadzilem inny przewod sygnalowy z dala od tego silnika - napewno był krótszy od orginalnego a po podłączeniu waga wskazywała o 40jednostek wiecej (będąc pusta). Przetestowałem miernik wagowy na nowym przewodzie sygnałowym i sytuacja sie nie zmienila - dalej przy rozruchu albo wyłaczaniu silnika nastepowały wahania na mierniku wagowym. No ale to nie jest jeszcze problem - wahania te byly w okolicach 10kg - najwazniejsze ze waga sie opróżniała i były właściwe wskazania.
    Później wrócielem do podłączeń początkowych tzn. wróciłem do podłączenia uważanego za uszkodzony miernik wagowy. Ale co dziewne zaczynal sie dokladnie tak samo zachowywać jak ten podmieniony z innej wagi przy rozruchach wspomnianego silnika. Co ciekawe również na 4 proby dobrze wracał do pozycji 0kg przy pustej wadze.
    Tak sie zastanawiam bo wszystkie problemy zaczynają się jak w maszynie pracują wszystkie silniki i uruchomiony jest caly proces technologiczny - Dziś nie maszyna nie pracowala ze wzgledu na warunki atmosferyczne ale jak bedzie szedl caly proces poobserwuje jeszcze jak sie zachowuje ten miernik wagowy.
    Dziwi mnie tylko to ze na poczatku procesu wszystko jest ok a po jakims czasie zaczyna szalec. Jak wyłączymy maszyne to jeszcze przez jakis czas miernik wagowy wskazuje narastajacą albo malejacą wartość na wadze. Trudno jest mi to sobie wyjaśnić.
    Nie wiem tylko czy dalej za wszystko winić miernik wagowy czy są inne ukryte powody.
    Niemniej zakupić taki miernik i tak trzeba aby byl w zapasie.
    Co o tym wszystkim sądzicie??
    Jak tylko zauważe cos nowego bede pisał.

    Pozdrowienia

    0
  • Pomocny post
    #20 02 Lis 2006 22:46
    mawi2
    Poziom 25  

    Pierwsze pytanie jest na pewno łatwiejsze. Dla nie wtajemniczonych istnieją podstawowe dwa standardy komunikacji prądowej : 0 - 20 mA oraz 4 - 20 mA. W urządzeniu odbiorczym jest zainstalowane obciążenie oraz miernik prądu - tylko elektronicznie bez wskaźników interpretuje to urzadzenie. Urządzenie sterujące ma nadajnik prądowy /poprzez zmiane napięcia/ i daje na wyjsciu prąd proporcjonalny do wartości na wskażniku i tak dla 0 - 20 mA przy 0 kg jest 0 mA , dla max. obciążenia jest 20 mA. Analogicznie w przypadku 4- 20 mA. To samo w przypadku wyjscia napięciowego 0 -10 V, 0- 20 V -5 - +5V bo takie są najcześciej spotykane. Tylko w tym przypadku brakuje obciążenia na odbiorniku oraz nadajnik (waga) na wyjściu reguluje napięcie 0 V dla 0 kg i 10 V dla max. kg. Tak na szybko to tylko podstawy. W tym przypadku nie ma problemu z zamianą terminali wagowych wspólpracujących z PLC. Po prostu stosujemy tylko takie samo wyjście sygnałowe. Jak sprawdzić ? Wejść w menu konfiguracyjne, tam zawsze jest jakiś punkt który mówi o konfiguracji wyjścia lub miernikiem uniwersalny, sprawdzić zmiany napięcia (podłączenie miernika równoległe - to każdy wie) lub zmiany prądu (miernik w szereg - a to nie każdy wie) .Poza tym jeśli urządzenie pracuje z
    PLC to z reguły można przeprogramować PLC na inny typ wejścia. Z praktyki wiem że włoszczyzna to najprawdopodobniej Siemens. Ja pracuję na Omronie tańszy i przyjemniejszy.
    A teraz drugie pytanie: to już czyste czepianie się: weź UPS komputerowy i zasil z niego terminal, ale tylko z wewnetrznej bateri w celu wyeliminowania zakłócen sieciowych. Powinien popracować jakieś 40 minut. Może w końcu problem z zasilaniem.

    0
  • #21 06 Lis 2006 20:30
    golem
    Poziom 10  

    Witam

    Dziś już wiecej moge powiedzieć o problemie z wagą. Jak ostatnio pisalem wskazania sie ustabilizowaly po próbach z drugim przewodem, przepinaniem na zastępczy miernik wagowy... Dziś przed uruchomieniem całego cyklu produkcyjnego do pracy maszyny wpiałem amperomierz na wyjście analogowe przetwornika wagowego a woltomierz pod zaciski SEGNALE+/-. Obserwowałem co się dzieje ze wskazaniami i jak sie to ma do pracy wagi. Przez około 50 cykli wszystko pracowało poprawnie az nagle na wyświetlaczu wagi po opróżnieniu wagi pozostała pewna wartość na wadze i o zgrozo ta wartość zaczeła dość szybko narastać!! Zerknąłem na mierniki. Na amperomierzu wartosć prądu wzrastała natomiast woltomierz nawet nie drgnał. (W woli wyjaśnienia amperomierz przy pustej wadze wskazywał 0,1mA a przy pełnej wadze około 17mA.) Gdy swiadomie dozowałem materiał na wage wartość na woltomierzu wzrastała. Jaki wniosek... po pewnej czasie pracy przetwornika coś dziwnego zaczeło się w nim dziać, ze pomimo braku zmian sygnału z tensometrów on dokonywał zmian na wyjściu analogowym - które jest połączone z wejśćiem analogowym PLC (Mitsubishi) oraz na wyświetlaczu.
    Zastanawiałem się jeszcze jak to się ma do wspomnianego wczesniej silnika. To ze przy rozruchu bądz wyłączaniu cos się działo to nie ma znaczenia bo przy normalnej pracy w procesie produkcyjnym silnik ten cały czas pracuje i nie wpływa na wahania wskazań na wadze.
    Pozostaje chyba zakupić nowy miernik wagowy. Tylko dalej mam dylemat bo tak naprawde nie wiem jakie jest to wyjście w mierniku wagowym bo wprawdzie amperomierz wskazywał od 0-17mA ale jak dołączyłem do do tego wyjścia woltomierz to napiecie zmienialo sie od 0 - 4V... Myslalem ze pomoże mi dokumentacja Mitsubishi -jego wejścia analogowego ale tam wyczytalem bardzo podobna rzecz jak w dokumentacji miernika wagowego. Mianowicie ze jest to wejście analogowe 0-20mA lub 0-10V. Wynika z tego ze przynajmniej jesli chodzi o wejscie PLC jest to do ustawienia np. poprzez zworki. Musze jeszcze dokladnie przestudiowac dokumentacje wejścia PLC
    Mam jeszcze do Was pytanie - jaki solidny miernik wagowy polecicie mi oczywiscie z tych dostepnych w Polsce - jedyny warunek ma miec wyjście analogoweg (zapewne prądowe co mam nadzieje się juz jutro dowiem)?

    Pozdrawiam

    0
  • #22 07 Lis 2006 10:04
    markosik20
    Poziom 33  

    Jeżeli nie jest wymagany wyświetlacz to proponuje wzmacniacz RM4220 (ma wyjscie prądowe albo napięciowe) firmy HBM montowany na szynie. Oddział w Poznaniu.

    0
  • #23 10 Lis 2006 19:24
    mawi2
    Poziom 25  

    Czyli problem jaki u Ciebie występował to nie błędne działanie ukladu pomiarowego , tylko błędy w sygnale wyjściowym, poprzez który jest wykonane sterowanie dozowaniem. Tak to zrozumiałem. Jaki miernik - oczywiście HBM jak najbardziej. to dokładnie sprawdziłem koszt ok. 2,5 tys zł. Lub nieco bardziej zawodny lecz sporo tańszy bo ok. 1 tys zł - Axis. Ale o tym już pisałem. Osobiście sterowanie robię na Omronie i tam nie ma problemu z zamianą prąd - napięcie . Z dokumentacji PLC prawdopodobnie wszystkiego sie nie dowiesz Jednak o ile wiem to w Mitsubiishi zmiana prąd, napięcie polega na założeniu odpowiednich rezystorów na wejściu. Zmiana wartości jakie podałeś sugeruje zastosowanie sygnału pomiarowego 0 -20 mA. Oba wymienione terminale można zamówić lub skonfigurować na prace z tymi parametrami. Gdybyś miał problem z Mitsubishi to mam namiary na człowieka który dobrze to zna. Powodzenia i informuj o przebiegu walki.

    0
  • #24 12 Lis 2006 11:33
    jurek siedlecki
    Poziom 10  

    sprawdź ustawienia terminala wagowego.Przy jakiej wartosci wystawia sygnał- 'pusty'

    0
  • #25 03 Sty 2011 20:33
    golem
    Poziom 10  

    Witam,
    Kawał czasu minęło od tego czasu ale sprawa skończyła się tak jak napisałem w postach powyżej: pierwotnie zostały wymienione tensometry na nowe. Ostatecznie został również wymieniony miernik wagowy i przeprowadzono kalibrację. Z zakłóceniami związanymi z rozruchem napędów (silnika) poradziłem sobie uaktywniając filtr (był dostępny w jednej z opcji wzmacniacza) - oczywiście nie zniwelowało to wahań całkowicie ale znacznie je ograniczyło.
    Z tego co wiem waga pracuje po dziś dzień.

    0