Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problemy z zaprogramowaniem pamięci 93S56

02 Lip 2007 10:37 3153 3
  • Poziom 12  
    Kupiłem niedawno mały programatorek Pony (Telwis'a) - chodziło mi o programowanie pamięci 93S56
    Po pierwszym uruchomieniu było wszystko OK, potem zrobiłem przerwę i po paru dniach (a nic nie robiłem zarówno z PC jak i programatorem) wystąpiły problemy tego typu że pamięć 93S56 jest odczytywana bez problemu, jednak jej zapis się nie udaja - ale nie jest to tak że zupełnie nie dziala zapis, jeśli zapisuję całą pamięć jedną wartością np: 55 albo 00 albo FF to wszystko jest OK.
    Jednak przy zapisie różnymi wartościami różnych komórek zapis się nie udaje - po oddczycie pamięci okazuje sie że faktycznie tyko ostatnia linia (16 bajtów) się zapisuje prwaidłowo, kilka przedostatnich liniii ma krzaczki a cała reszta pamięci do początku to FF (a więc nie zapisana)

    Co ciekawe zapisywanie i odczytywanie pamięci typy 93C56 przebiega prawidłowo .... stosuję tę samą podstawkę.
    Zaznaczam że zwora jest ustawiona prawidłowo a problem występuje na wszystkich posiadanych przeze mnie pamięciach 93S56..... i przy tych samych ustawieniach wcześniej nie występowały.

    Sam programator jest napewno OK (inaczej nie programowałby 93C56, kalibrację też wykonywałem kilkakrotnie.....)

    Prosze o pomoc w rozwiązaniu problemu - ten programator jest dla mnie ważny właśnie ze względu na programowanie "eSek" a nie innych pamieci. I nie doradzajcie abym dokupił sobie inny programator bo mnie na to nie stać.

    Pozdrawiam
  • Poziom 24  
    Informacja z elektrody.

    Cytat:

    PONY zczytuje i programuje 93s56 w 100%. Też na początku miałem z tą kością problemy ale po odłączeniu pinu 7 (PE) od (+) i podaniu na (-) problemy znikły .
  • Poziom 12  
    Nie wiem czy mówimy o tym samym programatorze - u mnie na schemacie ten pin (7 czyli sterowanie wyborem programowania Protect Registera) jest podpięte do masy.... w ogóle sam soft nie daje możliwości programowania tego rejestru zabezpieczającego.

    A twoje problemy były takie same, tj czytał OK ale zapisywał tylko czesciowo czyli nie wszystkie linie - za to przy ustawieniu wypełnienia jedną wartością całej pamięci było OK?
  • Poziom 14  
    Witam mam podobny problem z tą pamięcią również programowałem kilkanaście 93s56 na ponyprogu z gotronika i nigdy nie miałem problemu a teraz programuje mi do połowy czyli przebieg zapisuje ale wyświetla write failed a reszty nie rusza ani żadnych z security bits są zapisane pierwsze 4 ale nie idzie ich wykasować a próbowałem na 2 pamięciach z licznika motometer z końcówką 861R a nigdy nie miałem z tym problemu. Programator zasilany z osobnego zasilacza tak jak wcześniej.