Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Polpak router ?

17 Sie 2009 07:55 3814 19
  • Poziom 12  
    Witam,
    Posiadam łącze POLPAK + aktualnie router brzegowy PLANET ERT-805 + kabel V.35 POLPAK

    Urządzenie ostatnie czasy uległo uszkodzeniu a już identycznych nie produkują.
    Jakich urządzeń używacie do polpaka?
    i jakie ewentualnie zakupić ??
    Zależy mi na urządzeniu które będzie prosto w konfiguracji i nie droższe niż 1000 pln.
  • Poziom 23  
    Witaj
    Ja proponuje cisco z serii 1700np 1720 używany na allegro w granicach 400-600zł
  • Poziom 26  
    Witam,

    Wybóďr sprzętu zależy od tego jakie są to polpaki. Jaka prędkość, jakie dodatkowe rzeczy ma ten router posiadać, czy ma być wielozadaniowy czy tylko jako router dostępowy/brzegowy ?

    Jeżeli tylko brzegowy i prędkość niewielka (do 10MBit) to wystarczy najzwyklejsze CISCO 2501. Jeżeli chcesz mieć oprócz tego firewalla, QoS, Traffic shaping i inne cuda, to polecałbym 1721 z minimum 64MB ram. Najlepiej oczywiście 128MB ale nie jest to konieczne. Podstawowe zarządzanie poprzez SSH/Telnet albo SDM. Niestety w tym przypadku musisz się zdecydować na jedno. Ewentualnie możesz sie pokusić o kupno routera z serii 2600/2600XM z odpowiednimi modułami.


    Pozdrawiam
    adikbo
  • Poziom 12  
    łącze 1mbit ma służyć jako brama

    Aktualnie wygląda to tak

    modem polpak alcatel - router brzegowy PLANET ERT-805 - router zyxel który służy jako nat, vpn itp
  • Poziom 26  
    W takim przypadku wystarczy tak naprawdę jakikolwiek router z odpowiednim interfejsem. Jeżeli się nie mylę to "modem" od polpaka kończy się bodajże wyjściem V35. Jeżeli tak to wystarczy jakikolwiek router z interfejsem serialowym. Odpowiedni kabel można nabyc na allegro. Jeżeli router nie ma pełnić żadnych zaawansowanych funkcji (jedno łącze, brak natów, access-list, firewalla, QoS, NAC itp) to tak naprawdę przy łączu 1Mbit wystarczyłby ci router CISCO 1600 w minimalnej konfiguracji t.j 1 Serial i 1 Ethernet (10Mbit). A i tak przez większość czasu by się nudził... C1600 można nabyć na allegro dosłownie za grosze (poniżej 50PLN) do tego kabel około 20PLN i masz niezawodny sprzęt na kilka/kilkanaście lat.
  • Poziom 12  
    Polpak router ?
    Dokładnie taki sam schemat sieci jak na rysunku tylko adresy inne
  • Poziom 26  
    Jeżeli posiadasz switch z obsługą VLAN i trunków to możesz się pokusić o zbudowanie ciekawszej topologii. Oczywiście jeżeli posiadasz w sieci wewnętrznej serwer który udostępnia jakieś usługi na zewnątrz. Jeżeli ma to być tylko brama do internetu bez wystawiania jakichś usług na zewnątrz to nie ma nawet konieczności aż tak komplikować topologię. Zastanawia mnie ten serwer z Linuxem. Ja rozumiem upodobanie niektórych osób do stawiania wszystkiego co się tylko da na Linuxie ale to nie jest właściwe podejście.

    Jeżeli zdecydujesz się na urządzenie CISCO 1721 z 128MB ram to nie potrzebujesz praktycznie nic więcej do obsługi sieci. Naty i firewalla zbudujesz sobie poprzez SDM, dorzucisz do tego Quality of Service, zepniesz VPNa a w razie konieczności zbudujesz nawet polityki NAC.

    Wszystko zależy od chęci i warunków. Dla niedowiarków, że CISCO też może być "user friendly" kilka screenów z SDMa:

    Polpak router ?

    Przykładowa polisa firewalla.
  • Poziom 12  
    Proszę nie sugerować się adresami i tym linuxem :)
    Za bramą ma stać jedynie router zyxella tak jak widać na jednym z pierwszych postów

    aktualnie:
    modem polpak alcatel - router brzegowy PLANET ERT-805 - router zyxel który służy jako nat, vpn itp

    w miejscie PLANET ERT-805 chce wpiać ten router który zakupie

    Jeśli chodzi o router który stoi za bramą zestawia mi połączenia vpn z oddziałami firmy jako że każdy oddziały ma identyczne urządzenia + wystawia usługi (terminal serwer, http, ftp dla konkretnych adresów) z których mogę się łączyć z zewnątrz.

    Jeśli chodzi o switche posiadam nie zarządzalny 24 portowy.
  • Poziom 26  
    Czyli w twoim przpadku nie ma sensu rzucać się na 1721. Osobiście radziłbym zakupić z allegro 1600 ewentualnie 2600 z wic-1t i to wystarczy. Będzie tabilne i szybkie.
  • Poziom 12  
    ok dzieki :)
    w takim razie zainteresuje się 1600 ewentualnie 2600 z wic-1t

    Czy przy takiej konfiguracji jak poniżej urządzenie będzie przepuszczać ruch do mojego routera który będzie stał za cisco ?

    Podsieć między Twoim routerem a routerem ISP to 169.254.1.0/30 (169.254.1.1 to adres routera ISP, 169.254.1.2 to adres Twojego routera), sieć LAN ma adresację 192.168.0.0/24, przy czym interfejs Ethernet Twojego routera ma adres 192.168.0.1 i jest dla tej sieci domyślną bramką.

    Dodatkowo, sieć LAN wychodzi do Internetu z adresem publicznym routera (169.254.1.2), a interfejs Frame Relay ma DLCI równe 99.

    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime
    service timestamps log datetime msec localtime
    service password-encryption
    !
    hostname rtr_cisco
    !
    enable password jakies_trudne_haslo
    !
    username user_1 password haslo_usera_1
    ip subnet-zero
    no ip source-route
    no ip domain-lookup
    ip tcp path-mtu-discovery
    !
    interface Ethernet0
    description Polaczenie dla sieci LAN
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    !
    interface Serial0
    description Konfiguracja fizycznego interfejsu szeregowego
    no ip address
    encapsulation frame-relay
    frame-relay lmi-type ansi
    !
    interface Serial0.1 point-to-point
    description Polaczenie Polpak-T do Internetu 2Mbit
    ip address 169.254.1.2 255.255.255.252
    frame-relay interface-dlci 99 IETF
    ip nat outside
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Serial0.1
    no ip http server
    !
    ip nat inside source list 100 interface Serial 0.1 overload
    !
    access-list 100 permit ip 192.168.0.0 0.0.0.255 any
    access-list 100 deny ip any any
    no cdp run
    !
    line con 0
    exec-timeout 5 0
    login local
    line vty 0 4
    exec-timeout 5 0
    login local
    !
    end
  • Poziom 26  
    Patrząc z grubsza na twoją konfigurację powinno to zadziałać bez problemu. Jeżeli masz większą podsieć publiczną to możesz nawet obyć się bez natowania i adres publiczny "wystawić" na wewnętrzny interfejs. Wtedy natowanie miałbyś na wewnętrznym routerze.
  • Poziom 12  
    adresy w powyższym configu pochodzą z faq

    Zakres adresów IP sieci Abonenta: xxx.xxx.27.160 - 163

    Aktualnie wychodzimy adresem *.27.162 i przy tym chciałbym pozostać gdyż VPN na pozostałych urządzeniach już są skonfigurowane do współpracy z tym adresem.

    Jeszcze takie pytani mi się nasuwa jak z forwardować wszystkie porty na mój router który będzie za cisco ?
  • Poziom 26  
    W takim razie musisz przebudować troszkę konfigurację routera. Zamiast NAT overload użyć mapowania 1-1. Wtedy będziesz miał wszystkie porty przekierowane na 1 adres.

    Możesz również zastosować inną sztuczkę:
    Jeżeli VPNy masz terminowane na urządzeniu w środku sieci to wtedy musisz na interfejsie wewnętrzym także mieć adresację publiczną. Masz 4 adresy od operatora. Jeden adres przyznajesz interfejsowi serial, drugi interfejsowi ethernet a trzeci firewallowi. Wtedy masz tak naprawdę bridge zamiast routera.

    Z VPNami może być problem jeżeli adres urządzenia terminującego VPN będzie inny niż adres publiczny. Może to powodować pewne kłopoty. Jutro postaram się przetestować tą konfigurację w labie i zobaczę co z tego wyjdzie.
  • Poziom 12  
    troche skomplikowane :) jak się człowiek na cisco nie zna heheheeh
    cyt. "Jutro postaram się przetestować tą konfigurację w labie i zobaczę co z tego wyjdzie."

    ok miło by było jak byś dał znać

    wcześniej miałem prosty router planeta :) chodził 4 lata jak złoto aż nagle zaczął głubić pakiety ;-)
    tam konfiguracja była prosta ;-)

    enable
    conf terminal

    interface fastethernet 0/0
    ip address *.*.27.161 255.255.255.252
    !
    interface serial 0/0
    encapsulation frame-relay
    ip address *.*.94.106 255.255.255.252
    frame-relay lmi-type ansi
    frame-relay num-dlci 99
    frame-relay map ip *.*.94.105 99
    !
    !
    ip route 0.0.0.0 0.0.0.0 *.*.94.105
    !
    exit
    write
    ---

    p.s
    kupiłem właśnie taki router na allegro :

    router_bridge_loges_2m_ll100_2_mbit_s

    może zamiast tego cisco 1720 wstawię ten router w tryb brigde i po problemie ?? ;-) spotkał się ktoś z takim urządzeniem ? konfiguracja wydaje się prosta ;)
  • Poziom 26  
    To urządzenie też może być aczkolwiek z konfiguracją będziesz musiał się pobawić sam - ja mogę służyć tylko teorią. Nie miałem doczynienia z routerami Alcatela więc na temat konfiguracji nic ci nie powiem.

    Co do CISCO 1720 to poprzez SDM konfiguracja jest trywialna.
    Jeżeli sam nie byłbyś w stanie to mogę przygotować gotową konfigurację do wklejenia w konsoli. Musiałbyś tylko rozrysować konfigurację sieci i podać mi info jaki adres ip ma mieć wewnętrzne urządzenie (Zyxel o ile się nie mylę).

    Chowanie firewalla za natem to raczej średni pomysł. Widziałem już dość dużo problemów z funkcjonalnością NAT-Traversal przy VPNach.

    W cisco jest jeszcze jedna ciekawa funkcja którą możesz wykorzystać: interfejs frame relayowy może pożyczyć swój adres z interfejsu np ethernet. Wtedy na ethernecie ustawiasz sobie IP przyznane przez providera i masz praktycznie most. Co nie zmienia faktu, że nadal masz pełną funcjonalność routera - QoS, Firewall, itp.

    Polecam przyjrzeć się bliżej urządzeniom CISCO. Na allegro nie są aż tak drogie a ich funkcjonalność i niezawodność to najwyższa światowa półka.
    Mówiąc szczerze, reszta producentów (może pomijając Juniper Networks) może się tylko przyglądać i uczyć. Nie bez powodu największe sieci stawia się właśnie na CISCO a nie na D-Linkach czy H3C/3Com.

    Pozdrawiam i życzę dobrego wyboru.
    adikbo
  • Poziom 12  
    cyt. "W cisco jest jeszcze jedna ciekawa funkcja którą możesz wykorzystać: interfejs frame relayowy może pożyczyć swój adres z interfejsu np ethernet. Wtedy na ethernecie ustawiasz sobie IP przyznane przez providera i masz praktycznie most. Co nie zmienia faktu, że nadal masz pełną funcjonalność routera - QoS, Firewall, itp. "

    Dokładnie tak samo mam na aktualnym routerze planeta :) urządzenie zyxell ma ip zewnętrzne ale z tego co mi się wydaje to to urządzenie w trybie bridge powinno dać taką samą funkcjonalność :) zobaczymy dziś kurier powinien mi je przynieść :)
    Jeśli możesz odezwij podaj mi swój adres e-mail na pw podeśle schemat sieci oraz adresy chętnie przyjże się przygotowanej przez ciebie konfiguracji.
  • Poziom 12  
    dostałem dziś ten router który zamówiłem na allegro:
    Router Bridge LOGES 2M LL100 2 Mbit/s (numer 707316808)

    ale ma złe w pudełku kable które nie pasują do modemu polpak ;( w komplecie jest kabel x21 - x21 a model polpac zakończony jest v35
    czy ktoś wie gdzie można dostać taki konwerter

    v35 - x.21 ?
  • Poziom 26  
    Prawdopodobnie w jakimś sklepie z osprzętem telekomunikacyjnym lub w zwykłym sklepie z elektroniką.
  • Poziom 12  
    z przejściówką jest bardzo ciężko :( nigdzie jej zdobyć nie można ;(
    dziś dostałem również router cisco 1600 niestety po likwidacji hasła uległ uszkodzeniu softwarowemu ;(


    po restacir wyskakuje komunikat:

    Router(boot): :( jak przywrócić router do normalnego działania ?

    --
    System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
    Copyright (c) 1999 by cisco Systems, Inc.
    C1600 platform with 16384 Kbytes of main memory

    program load complete, entry point: 0x4020060, size: 0x165eac

    %SYS-6-READ_BOOTFILE_FAIL: flash:c1600-reboot-r File boot failed -- File not acc
    essible.

    %SYS-6-BOOT_MESSAGES: Messages above this line are from the boot loader.
    boot of "cisco2-C1600" using boot helper "eprom:c1600-rboot-r.120-3.T" failed
    error returned: File boot failed -- File not accessible
    loadprog: error - on file open
    boot: cannot load "cisco2-C1600"ę


    System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
    Copyright (c) 1999 by cisco Systems, Inc.
    C1600 platform with 16384 Kbytes of main memory

    loadprog: bad file magic number: 0x0
    boot: cannot load "flash:"ę


    System Bootstrap, Version 12.0(3)T, RELEASE SOFTWARE (fc1)
    Copyright (c) 1999 by cisco Systems, Inc.
    C1600 platform with 16384 Kbytes of main memory

    program load complete, entry point: 0x4020060, size: 0x165eac

    Restricted Rights Legend

    Use, duplication, or disclosure by the Government is
    subject to restrictions as set forth in subparagraph
    (c) of the Commercial Computer Software - Restricted
    Rights clause at FAR sec. 52.227-19 and subparagraph
    (c) (1) (ii) of the Rights in Technical Data and Computer
    Software clause at DFARS sec. 252.227-7013.

    cisco Systems, Inc.
    170 West Tasman Drive
    San Jose, California 95134-1706



    Cisco Internetwork Operating System Software
    IOS (tm) 1600 Software (C1600-RBOOT-R), Version 12.0(3)T, RELEASE SOFTWARE (fc1
    )
    Copyright (c) 1986-1999 by cisco Systems, Inc.
    Compiled Mon 22-Feb-99 23:05 by ccai
    Image text-base: 0x04020060, data-base: 0x02005000

    cisco 1601 (68360) processor (revision C) with 15872K/512K bytes of memory.
    Processor board ID 16983588, with hardware revision 00000002
    1 Ethernet/IEEE 802.3 interface(s)
    1 Ethernet/IEEE 802.3 interface(s)
    Interface 1 unrecognized by boothelper
    System/IO memory with parity disabled
    8192K bytes of DRAM onboard 8192K bytes of DRAM on SIMM
    System running from ROM
    8K bytes of non-volatile configuration memory.
    6144K bytes of processor board PCMCIA flash (Read/Write)



    Press RETURN to get started!


    00:00:01: %C1600-4-INTFCNOFLH: Unable to load images or communicate over interf
    ace
    00:00:03: %LINK-5-CHANGED: Interface Ethernet0, changed state to administrativel
    y down
    00:00:04: %SYS-5-CONFIG_I: Configured from memory by console
    00:00:04: %SYS-5-RESTART: System restarted --
    Cisco Internetwork Operating System Software
    IOS (tm) 1600 Software (C1600-RBOOT-R), Version 12.0(3)T, RELEASE SOFTWARE (fc1
    )
    Copyright (c) 1986-1999 by cisco Systems, Inc.
    Compiled Mon 22-Feb-99 23:05 by ccai
    cisco(boot)>
    ---
  • Poziom 26  
    Problemem jest uszkodzony obraz IOS (systemu operacyjnego). Najprostsza metoda w przypadku routerka C1600 to wyjąć kartę Compact Flash, przełożyć do czytnika i nagrać obraz z komputera. Inna metoda to skorzystanie z trybu ROMMON routera i wgranie IOSa poprzez X-Term bądź poprzez tftp. Dokładne instrukcje na stronach CISCO.