Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wyłącznik zmierzchowy odwrotne działanie

02 Paź 2012 17:59 4212 26
  • Poziom 8  
    Witam mam taki oto problem wykonałem ten oto najprostszy wyłącznik zmierzchowy ,wszystko elegancko, lecz problemem jest to że działa "odwrotnie: (w dzień świeci w nocy gaśnie) co może być przyczyną ?
    zastosowane elementy, takie jak na schemacie
    Wyłącznik zmierzchowy odwrotne działanie
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 21  
    Zamień miejscami fotorezystor z potencjometrem
  • Poziom 14  
    Zocha24 napisał:
    Zamień miejscami fotorezystor z potencjometrem


    Dlaczego ma zamienić - schemat jest przecież dobry.
  • Specjalista - HDD i odzyskiwanie danych
    Schemat jest ok, błąd musi być w montażu i rzeczywiście zamienione miejscami to może mieć teraz, a nie na schemacie, bo jeżeli jest tak jak na schemacie to ( R fotorezystora/(Rp+R fotorezystora)) * 6V = Ube tranzystora, więc o zmroku fotorezystor zwiększa opór i Ube rośnie powodując otwarcie tranzystora, a jakby je zamienił miejscami to wtedy LED świeciłaby się w dzień.
  • Poziom 14  
    A jak juz naprawdę nie potrafisz sobie poradzić to zamiast tego leda daj rezystor z 2k , porezystorze ( czyli do kolektora tego pierwsszwego tranzystora ) podłącz rezystor pod bazę drugiego i wtedy daj leda ( do tego drugiego tranzystora)
  • Poziom 9  
    Zamień polaryzację zasilania, a problem zniknie.

    Moderowany przez _PREDATOR_:

    Szkodliwa porada!

  • Poziom 17  
    pindus1994 napisał:
    Zamień polaryzację zasilania, a problem zniknie.

    Jak to zrobi to dioda nie będzie świecić wcale.
  • Poziom 9  
    kbs napisał:
    pindus1994 napisał:
    Zamień polaryzację zasilania, a problem zniknie.

    Jak to zrobi to dioda nie będzie świecić wcale.


    Będzie, będzie. Miałem kiedyś ten sam problem, zmiana polaryzacji pomogła.

    Moderowany przez Mirek Z.:

    Regulamin p.3.1.11.

  • Specjalista - HDD i odzyskiwanie danych
    kbs napisał:
    pindus1994 napisał:
    Zamień polaryzację zasilania, a problem zniknie.

    Jak to zrobi to dioda nie będzie świecić wcale.

    Ewentualnie jak już pisałem wcześniej niech sprawdzi czy faktycznie ma między bazą a emiterem fotorezystor a między + zasilania a bazą potencjometr, kolega Zocha24 który wcześniej wspomniał o zamianie ich miejscami, miał pewnie na myśli zamianę ich w układzie a nie na schemacie bo z działania wynika że są odwrotnie założone. Załączenie odwrotnie napięcia zasilania spowoduje że tranzystor się nigdy nie otworzy( dodatnie napięcie Ueb), dioda led nigdy nie zaświeci i to z dwóch powodów itp. Można wykonać prosty pomiar napięcia Ube w dzień i w nocy ile ono wynosi.
  • Poziom 17  
    Do pindus1994: Polecam zapoznanie się z zasadami działania półprzewodników.
    Ale nie o tym jest ten temat, kolego Noplo jeżeli układ jest zmontowany dokładnie tak jak na schemacie, to zmierz napięcia na oświetlonym i zasłoniętym fotorezystorze.
  • Specjalista - HDD i odzyskiwanie danych
    A może wszystko jest ok tylko opór na potencjometrze za mały? Wówczas gdy R fotorezystora rośnie spada napięcie Ucb poniżej Uf diody i gaśnie, pomimo otwarcia tranzystora dioda nie świeci, a gdy w dzień R fotorezystora spada, Ucb rośnie a Ube jest ponad 0,6V i świeci dioda, ale o tym się przekonamy jeżeli autor zamieści wyniki pomiarów dotyczące napięcia Ube w dzień i w nocy(zasłonięty fotorezystor w czasie pomiaru) lub napięcia na fotorezystorze w dzień i w nocy(zasłonięty fotorezystor w czasie pomiaru).
  • Poziom 8  
    mati211p napisał:
    Ewentualnie jak już pisałem wcześniej niech sprawdzi czy faktycznie ma między bazą a emiterem fotorezystor a między + zasilania a bazą potencjometr,


    jest dokładnie tak jak piszesz, napięcia na fotorezystorze jutro podam bo dzisiaj już późno

    p.s zmiana polaryzacji na pewno nie pomoże, już próbowałem
  • Poziom 17  
    mati211p napisał:
    gdy R fotorezystora rośnie spada napięcie Ucb poniżej Uf diody i gaśnie, pomimo otwarcia tranzystora dioda nie świeci

    Jeżeli tranzystor byłby otwarty dioda musiała by świecić, Ucb nie ma tu znaczenia.Poza tym na schemacie brakuje rezystora ograniczającego prąd diody.
  • Specjalista - HDD i odzyskiwanie danych
    kbs napisał:
    mati211p napisał:
    gdy R fotorezystora rośnie spada napięcie Ucb poniżej Uf diody i gaśnie, pomimo otwarcia tranzystora dioda nie świeci

    Jeżeli tranzystor byłby otwarty dioda musiała by świecić, Ucb nie ma tu znaczenia.Poza tym na schemacie brakuje rezystora ograniczającego prąd diody.

    Racja, już chyba zaspany jestem, swoją drogą ciekawe po co tam jest kondensator, układ zasilany ze stałego napięcia więc kondensator i tak stanowi przerwę, w zależności od tego jaka tam jest LED trzeba by było dać rezystor szregowo z diodą ograniczający jej prąd jak najbardziej.
  • Poziom 26  
    Koledzy przecież ten schemat to jakiś żart, praktycznie to można by go nazwać blokowym. Źle narysowany, jest kondensator nie wiadomo po co, za to nie ma rezystora ograniczającego prąd LED-a, brak histerezy załączania i wyłączania - bubel.
    wpisz w "szukajkę" hasło wyłącznik zmierzchowy i znajdziesz coś co będzie działać.
    Np.
    https://www.elektroda.pl/rtvforum/topic2061190.html
    lub
    https://www.elektroda.pl/rtvforum/viewtopic.php?p=3119616#3119616
  • Poziom 8  
    W sumie chyb macie rację, najlepiej zostawić to i zrobić coś co a 100% bedzie działało
  • Poziom 14  
    Nie wiem co innego na 100 procent działało będzie skoro prosty wyłącznik zmierzchowy masz na swom schemacie - lepszego nie znajdziesz - moze zamiast tego potencjometra daj rezystor ?

    Pozdrawiam
  • Poziom 8  
    Właśnie zaobserwowałem że działało gdy podpięty był + tam gdzie powinien być - wg schematu i to by się zgadzało że działa odwrotnie( człowiek głupi nie zwrucił uwagi :D) , lecz gdy podepnę to tak jak w 100% ma być pojawia się problem że dioda świeci cały czas, co może być przyczyną?
    Z góry dziękuję
  • Poziom 17  
    Noplo napisał:
    , lecz gdy podepnę to tak jak w 100% ma być pojawia się problem że dioda świeci cały czas, co może być przyczyną?

    Za mała wartość rezystancji ustawionej na potencjometrze.
  • Poziom 8  
    tylko problem jest w tym że nie mam jak ustawić większej, a wg schematu powinno działać na tym potencjometrze
  • Poziom 17  
    To połącz potencjometr szeregowo z dodatkowym rezystorem. Przed chwilą zlutowałem ten układ według schematu i działa tak jak powinien.
  • Specjalista - HDD i odzyskiwanie danych
    Może dowiemy sie w końcu jakie są napięcia na potencjometrze i fotorezystorze gdy jest jasno i gdy jest zasłonięty?
  • Poziom 8  
    Kurcze kompletnie zapomniałem, już podaję:(1 jasno)
    Fotorezystor: U1= 0,1V U2= 5,8V
    Potencjimetr: U= 0.48V

    Dzięki wszystkim za pomoc, lecz zdecydowałem się zrobić kolejny włącznik zmierzchowy ze schematu który podał kolega Robewit , a ten zostawć jako "wyłącznik zmierzchowy" a nóż się kiedyś przyda
  • Specjalista - HDD i odzyskiwanie danych
    Noplo napisał:
    Kurcze kompletnie zapomniałem, już podaję:(1 jasno)
    Fotorezystor: U1= 0,1V U2= 5,8V
    Potencjimetr: U= 0.48V

    Dzięki wszystkim za pomoc, lecz zdecydowałem się zrobić kolejny włącznik zmierzchowy ze schematu który podał kolega Robewit , a ten zostawć jako "wyłącznik zmierzchowy" a nóż się kiedyś przyda


    Jeżeli na fotorezystorze masz 0,1V to dioda nie powinna świecić a w momencie kiedy jest na nim 5,8V powinna świecić, nie wiem które napięcie odpowiada zasłoniętemu,teoretycznie 5,8V(i jeżeli można wiedzieć opisz U1 i U2) ale na potencjometrze jest tylko jeden pomiar, więc się sam totalnie pogubiłem.
  • Poziom 8  
    U1 - jasno U2- ciemno, a na potencjometrze występuje napięcie U1= 0.6V
    U2=0V
  • Specjalista - HDD i odzyskiwanie danych
    Dalej nie rozumiem, jeżeli masz zasilanie 6,4V to wtedy U potencjometru=0,6V a U fotorezystora 5,8V(sytuacja przy zasłoniętym fotorezystorze), gdy odsłonisz powinno być przy U fotorezystora 0,1V, że U potencjometru wynosi 6,3V, w przeciwnym razie coś jest źle podłączone. Na tym dzielniku potencjometr - fotorezystor musi być całe napięcie zasilania. pomiędzy początkiem potencjometru a końcem fotorezystora. Zmiana rezystancji fotorezystora powoduje zmianę napięcia na nim a tym samym otwarcie lub zatkanie złącza B-E tranzystora BC237.
  • Poziom 8  
    no i właśnie wydaje mi się że coś źle podłączyłem, lecz działa na tylko takiej konfiguracji :)
    zdecydowałem się zostawić to tak jak jest i stworzyć nowy na wyższe napięcie
    Dzięki za pomoc wszystkim zwłaszcza mati211p