Elektroda.pl
Elektroda.pl
X
IGE-XAO
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Transmiter BT audio - hałas na wyjściu, znika po połączeniu mas

21 Paź 2014 12:46 3774 12
  • Poziom 10  
    Witajcie,
    Jakiś czas temu zachciało mi się skonstruować transmiter bluetooth audio do samochodu. W zasadzie skonstruować to zbyt duże słowo - w trakcie poszukiwania modułów BT do arduino natrafiłem na gotowy moduł BT audio oparty na OVC3868:
    Transmiter BT audio - hałas na wyjściu, znika po połączeniu mas
    Bazując na informacjach z tego wątku: Link
    I schematach:
    Transmiter BT audio - hałas na wyjściu, znika po połączeniu masTransmiter BT audio - hałas na wyjściu, znika po połączeniu mas

    Zakupiony moduł zmontowałem w coś takiego:
    Transmiter BT audio - hałas na wyjściu, znika po połączeniu mas

    Od razu wyjaśniam że:
    - zworka na zasilaniu nie powoduje opisywanego przeze mnie dalej problemu - bez niej też buczało, wstawiłem do pomiarów prądu.
    - pomarańczowy przewód - również nie powoduje problemu, używałem go do testowania funkcji przycisków.

    I teraz przejdę do sedna. Całość działa, niestety na wyjściu obecny jest szum - terkotanie, krótko mówiąc zbiera skądś. Jak tylko łapię palcami za antenę BT - szum zanika całkowicie.

    Szum zanika również gdy połączę masę audio z masą zasilania.

    Chciałbym was drodzy elektrodziarze poprosić o odpowiedź za dwa pytania:
    1. Czy połączenie mas audio i zasilania to 'bezpieczne' i prawidłowe rozwiązanie - czy też może powinienem zrobić coś innego?
    2. Na schemacie w prawym dolnym rogu (koło styku RESET) wlutowane są dwa kondensatory i rezystor podłączona do masy i 1,8V. Jesteście w stanie wyjaśnić jaka jest ich rola?
  • IGE-XAO
  • Specjalista - urządzenia lampowe
    darmach napisał:
    1. Czy połączenie mas audio i zasilania to 'bezpieczne' i prawidłowe rozwiązanie - czy też może powinienem zrobić coś innego?


    A wskaż masę analogową i wejścia audio na schemacie ideowym.

    darmach napisał:
    2. Na schemacie w prawym dolnym rogu (koło styku RESET) wlutowane są dwa kondensatory i rezystor podłączona do masy i 1,8V. Jesteście w stanie wyjaśnić jaka jest ich rola?


    Nie widzę przycisku reset na schemacie ideowym.
  • IGE-XAO
  • Poziom 10  
    jdubowski napisał:
    A wskaż masę analogową i wejścia audio na schemacie ideowym.

    Miałem na myśli wyjście opisane jako Agnd - co zrozumiałem jako audio ground. Na schemacie pin 16 chipu OVC3860 - AOM - SPKN (speaker neutral?).

    Piszesz o wejściu audio..? Tutaj nie mamy wejścia audio, tylko wyjście. Pytałem o połączenie Agnd (pin 16 chipu OVC3860 - AOM - SPKN) do masy zasilania.

    jdubowski napisał:
    Nie widzę przycisku reset na schemacie ideowym.

    Prawda, na tym rysunku nie jest opisany. Na rysunku ze zdjęciem ostatnie pole na dole po prawej stronie. pin 35 chipu OVC3860 - RESETN - RST.
  • Poziom 9  
    Hej, jakieś postępy w projekcie?
    W załączonym wątku zewnętrznego znalazłem info od pewnego użytkownika:
    "1. Audio Common (pin 1) is 0.9V, don't connect it directly to system ground.
    2. Supply voltage should be between 3.6V and 4.2V as mentioned in its datasheet.
    If the voltage is 3.3V, an 800Hz annoying noise will appear."
    Gdzie zamówiłeś moduł BT?
    pozdrawiam
  • Poziom 11  
    CZeść,

    Mam podobny problem. Jak tylko moduł zacznie gadać z telefonem to pojawia się szum. Wzmacniacz operacyjny wyłapuje go w postaci buczenia/ terkotania.

    Czy komuś udało się ten problem rozwiązać???
  • Poziom 11  
    Próbowałem i jakoś mi to nie zadziałało.

    Widziałem wydumki w stylu połączyć przez kondensator AGND i pin 20 OCV (Vmic), ale jakoś nie za bardzo to działa. Tzn. redukuje szumy, ale nie do końca....
  • Poziom 12  
    Ja dołożyłem moduł ale tez nie podziałało na zakłócenia, pomogła taśma aluminiowa założona na antenę .
    Transmiter BT audio - hałas na wyjściu, znika po połączeniu mas

    Tak to u mnie wygląda
    Transmiter BT audio - hałas na wyjściu, znika po połączeniu mas :
  • Poziom 11  
    W moim układzie musiałem wdrożyć 2 rzeczy:
    - po pierwsze odizolować zasilanie i komunikację po UART (posłużyłem się w tym celu przetwornicą DC/DC) i optotranzystorami,
    - druga sprawa to fakt, iż na AGND jest napięcie 0.6V - tak naprawdę ROUT, LOUT i AGND to wyjście dyferencyjne, na słuchawkach działa to dobrze, ale w przypadku wzmacniaczy, korektorów dźwięku itp trzeba to przepuścić przez wzmacniacz operacyjny lub w moim przypadku korektor ma wejście pseudo dyferencyjne.

    Inna sprawa to fakt, iż przy starcie (załączaniu) mój moduł OVC3860 powoduje zakłócenia (nie wiem od czego), które resetują mikrokontroler. Aby to obejść kombinuje z czymś w rodzaju soft startu.
  • Poziom 11  
    OK. A więc tak wyjściew augio z OVC3860 to wyjście dyferencyjne. Ja pozbyłem się "terkotania" poprzez podopieczne OVcx3860 do wejście pseudo diff w moim procesorze dźwięku (o ile dobrze pamiętam to: TDA7418)

    Nie zmienia to faktu, iż jak tylko BT zacznie gadać z innym sprzetem to na zasilaniu wzmacniacza pojawiają się szumy.

    Ma ktoś gotowca jakimi kondensatorami można odszumić bluetooth?? Tam chyba wchodzą w grę ogromne częstotliwości.
  • Poziom 12  
    Ja się poddałem nie warto. Kupiłem Belkin Bluetooth Music Receiver wyjąłem z opakowania, wsadziłem dla kumpla do radia samochodowego i po sprawie.
  • Poziom 1  
    Tak jak wspominano, zakrywanie anteny palcami eliminuje szumy. Zakrywanie reszty układu poza anteną palcami zmniejsza szumy. Ja odciąłem ścieżkę oryginalnej anteny i przylutowałem cienki przewód typu drut do pola na początku anteny fabrycznej- gra idealnie bez szumów; nić nie słychać (szumów) nawet przy cicho odtwarzanej muzyce. I zasięg jest też większy - można ogonek wyprowadzić w dowolne miejsce, a nie mieć na przykład zamknięty układ w obudowie odtwarzacza w samochodzie. Szumy występowały zarówno przy zasilaniu ogniwem li-ion jak i przez przetwornicę DC-DC (z izolacją wejścia i wyjścia, żeby nie zawierać masy zasilania układu z masą wyjścia audio). Teraz tylko sprawdzałem na akumulatorku, ale podejrzewam, że na przetwornicy też będzie ok.
  • Poziom 11  
    A ja na zasilaniu wzmacniacza dałem żyrator tłumiący śmieci w zasilaniu i też działa. :)