Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Błąd tworzenia partycji - Nie można stworzyć partycji błąd 0x8007045

kadavix 15 Feb 2018 14:59 3666 32
  • #1
    kadavix
    Level 6  
    Kupiłem ostatnio nowy komputer i chciałbym zainstalować na nim Windows 7 jednak na etapie tworzenia partycji w instalatorze pojawia sie błąd (0x8007045) i komunikat że nie można utworzyć partycji. Dodam że próbowałem instalować z płyty oraz z pendrivem z obrazem ISO Windowsa.
  • #2
    Kasek21
    Level 43  
    Konfiguracja komputera to jaka?
    Dysk działał wcześniej poprawnie?
  • #3
    kadavix
    Level 6  
    Kasek21 wrote:
    Konfiguracja komputera to jaka?
    Dysk działał wcześniej poprawnie?

    Wszystkie elementy pc:
    Pamięć Kingston HyperX FURY 8GB (2x4GB) DDR4 2133MHz CL14
    Napęd LG SuperMulti
    Płyta główna MSI B250M PRO-VDH
    Procesor Intel Core i5-7400, 3GHz, 6MB, BOX
    Zasilacz SilentiumPC Vero L2 500W
    Dysk Seagate BarraCuda 1TB 6Gb/s SATA
    Karta graficzna Palit GeForce GTX 1050 Ti DUAL OC 4GB GDDR5
    Obudowa Zalman Z3 PLUS

    A jeśli o dysk nowy wiec nie wiem czy działał no ale jednak to nowy wiec powinien :)
  • #4
    nomudrek
    Level 36  
    Tabela partycji może być typu GPT zamiast MBR. GPT nie jest obsługiwany przez Windows 7, dlatego należy użyć programu GParted nagranego na płytę i zmienić tabelę partycji na MBR. Sam na dniach kupiłem nowy dysk 2 TB, który miał właśnie tabelę w GPT.
  • #5
    kadavix
    Level 6  
    nomudrek wrote:
    Tabela partycji może być typu GPT zamiast MBR, który nie jest obsługiwany przez Windows 7, dlatego należy użyć programu GParted nagranego na płytę i zmienić tabelę partycji na MBR. Sam na dniach kupiłem nowy dysk 2 TB, który miał własnie tabelę w GPT.

    A posiadasz jakiś poradnik do tego? Oraz czy mogę użyć tego programu nagranego na pendrive?
  • #7
    Dra98
    Moderator of Computers service
    kadavix wrote:
    Dodam że próbowałem instalować z płyty oraz z pendrivem z obrazem ISO Windowsa.

    Było już wielokrotnie omawiane, że B150\B250 nie wspiera już standardu interfejsu EHCI co jest wymagane w Windows 7. Rozwiązaniem jest zintegrowanie sterownika XHCI wraz z instalką.
    Jeśli są zintegrowane to przydał by się S.M.A.R.T. dysku - nowy również może być niesprawny.
    https://service.msicomputer.com/msi_user/support/TechFAQdetail.aspx?formid=3339
  • #8
    kadavix
    Level 6  
    Dra98 wrote:
    kadavix wrote:
    Dodam że próbowałem instalować z płyty oraz z pendrivem z obrazem ISO Windowsa.

    Było już wielokrotnie omawiane, że B150\B250 nie wspiera już standardu interfejsu EHCI co jest wymagane w Windows 7. Rozwiązaniem jest zintegrowanie sterownika XHCI wraz z instalką.
    Jeśli są zintegrowane to przydał by się S.M.A.R.T. dysku - nowy również może być niesprawny.
    https://service.msicomputer.com/msi_user/support/TechFAQdetail.aspx?formid=3339

    Były zintegrowane a co do tego S.M.A.R.T. dysku moge to zrobić po przez zbootowanie jakiegoś programu do tego na pendrive i odczytać czy muszę podłączyć dysk pod inny komputer?
  • #13
    kadavix
    Level 6  
    Kasek21 wrote:
    Opcja nr 1.

    A po za uszkodzonym dyskiem może byc coś jeszcze innego?
  • #14
    Kasek21
    Level 43  
    kadavix wrote:
    A po za uszkodzonym dyskiem może byc coś jeszcze innego?

    Źle przygotowana instalacja Win7 -> patrz post nr 7.
  • #15
    kadavix
    Level 6  
    Kasek21 wrote:
    kadavix wrote:
    A po za uszkodzonym dyskiem może byc coś jeszcze innego?

    Źle przygotowana instalacja Win7 -> patrz post nr 7.

    to już jest sprawdzone a to zdjęcie co wysłałem wszytko tak jak ma być czy nie?
  • #16
    Dra98
    Moderator of Computers service
    Przed tworzeniem partycji można wybrać shift + F10 i użyć narzędzia diskpart, warto sprawdzić jak widzi dysk i czy można usunąć/utworzyć partycje.
  • #17
    kadavix
    Level 6  
    Dra98 wrote:
    Przed tworzeniem partycji można wybrać shift + F10 i użyć narzędzia diskpart, warto sprawdzić jak widzi dysk i czy można usunąć/utworzyć partycje.

    to wiem sprawdzałem widzi poprawny próbowałem go zmieniać na GPT i MBR jednak przy konwertowaniu wyskakiwał błąd a jeśli chodzi o stworzenie partycji po przez komende to nie próbowałem.
    A jaka jest komenda do tworzenia partycji?

    Dodano po 20 [minuty]:

    Dra98 wrote:
    Przed tworzeniem partycji można wybrać shift + F10 i użyć narzędzia diskpart, warto sprawdzić jak widzi dysk i czy można usunąć/utworzyć partycje.

    Przy tworzeniu partycji w diskpart jest taki błąd
  • #18
    Kasek21
    Level 43  
    Wyzeruj początek dysku i zrób instalację systemu.
  • #19
    kadavix
    Level 6  
    Kasek21 wrote:
    Wyzeruj początek dysku i zrób instalację systemu.

    Możesz rozwinąć?
  • #20
    Kasek21
    Level 43  
    Z tego co pobrałeś -> znajdź MHDD -> wybierz dysk i wpisz ERASE, z 5 minut.
  • #22
    Kasek21
    Level 43  
    Zmiana trybu pracy kontrolera w UEFI nie pomaga?
  • #23
    kadavix
    Level 6  
    Kasek21 wrote:
    Zmiana trybu pracy kontrolera w UEFI nie pomaga?

    W opcjach UEFI mam tylko samo UEFI oraz UEFI+LEGACY

    Dodano po 37 [minuty]:

    Kasek21 wrote:
    Zmiana trybu pracy kontrolera w UEFI nie pomaga?

    Jeszcze jakieś pomysły co może być nie tak?
  • #24
    sewek1000
    Level 15  
    spróbuj podczas instalacji systemu Shift + F10
    pokolei
    Diskpart
    List disk
    Select disk - (zaznacz swój dysk)
    Clean
    convert MBR
    create partition primary
    format fs=ntfs quick
    active
    assign
    jezeli zobaczy dysk skasuj utworzona partycje sprawdz czy będzie działało,
    Ewentualnie spróbuj windowsa 7 zbotować z DVD lub USB (polecam dvd)
    Tryb dysku w biosie na AHCI
    ewentualnie próbować bez tworzenia partycji samą komendą
    Diskpart
    List disk
    Select disk
    Clean
    Convert MBR ,
    W bios można jeszcze sprawdzić czy Windows 7 nie pójdzie po UEFI (USB nagrać rufusem , DVD oryginalny obraz MS)
    Secure Boot musi być wyłączone
    UEFI - tylko w GPT
    ,albo próbować w CSM
    Wtedy MBR

    Dodano po 2 [minuty]:

    Legacy = CSM czyli wtedy w MBR powinno pójść tylko bootowanie musi być wtedy bez dopisku UEFI
    Np.
    1.[UEFI]USB Kingston 3.0
    2.USB Kingston 3.0
    wtedy bootujemy w Legacy z opcji 2 a w trybie UEFI z opcji 1
  • #25
    kadavix
    Level 6  
    sewek1000 wrote:
    spróbuj podczas instalacji systemu Shift + F10
    pokolei
    Diskpart
    List disk
    Select disk - (zaznacz swój dysk)
    Clean
    convert MBR
    create partition primary
    format fs=ntfs quick
    active
    assign
    jezeli zobaczy dysk skasuj utworzona partycje sprawdz czy będzie działało,
    Ewentualnie spróbuj windowsa 7 zbotować z DVD lub USB (polecam dvd)
    Tryb dysku w biosie na AHCI
    ewentualnie próbować bez tworzenia partycji samą komendą
    Diskpart
    List disk
    Select disk
    Clean
    Convert MBR ,
    W bios można jeszcze sprawdzić czy Windows 7 nie pójdzie po UEFI (USB nagrać rufusem , DVD oryginalny obraz MS)
    Secure Boot musi być wyłączone
    UEFI - tylko w GPT
    ,albo próbować w CSM
    Wtedy MBR
    Dodano po 2 [minuty]:
    Legacy = CSM czyli wtedy w MBR powinno pójść tylko bootowanie musi być wtedy bez dopisku UEFI
    Np.
    1.[UEFI]USB Kingston 3.0
    2.USB Kingston 3.0
    wtedy bootujemy w Legacy z opcji 2 a w trybie UEFI z opcji 1

    Prz komendzie cnovert mbr w diskpart wywala mi błąd

    Dodano po 1 [minuty]:

    sewek1000 wrote:
    spróbuj podczas instalacji systemu Shift + F10
    pokolei
    Diskpart
    List disk
    Select disk - (zaznacz swój dysk)
    Clean
    convert MBR
    create partition primary
    format fs=ntfs quick
    active
    assign
    jezeli zobaczy dysk skasuj utworzona partycje sprawdz czy będzie działało,
    Ewentualnie spróbuj windowsa 7 zbotować z DVD lub USB (polecam dvd)
    Tryb dysku w biosie na AHCI
    ewentualnie próbować bez tworzenia partycji samą komendą
    Diskpart
    List disk
    Select disk
    Clean
    Convert MBR ,
    W bios można jeszcze sprawdzić czy Windows 7 nie pójdzie po UEFI (USB nagrać rufusem , DVD oryginalny obraz MS)
    Secure Boot musi być wyłączone
    UEFI - tylko w GPT
    ,albo próbować w CSM
    Wtedy MBR
    Dodano po 2 [minuty]:
    Legacy = CSM czyli wtedy w MBR powinno pójść tylko bootowanie musi być wtedy bez dopisku UEFI
    Np.
    1.[UEFI]USB Kingston 3.0
    2.USB Kingston 3.0
    wtedy bootujemy w Legacy z opcji 2 a w trybie UEFI z opcji 1

    I większość tego co napisałeś próbowałem myślisz że aktualizacja biosu cos da?
  • #27
    kadavix
    Level 6  
    sewek1000 wrote:
    spróbował bym win 8.1 w Uefi puścić ewentualnie wyjąć dysk sprawdzić w innym komputerze Sata w jakim trybie jest ? Ahci , Ide?

    AHCI bo tylko taka opcja jest w biosie
  • #29
    kadavix
    Level 6  
    sewek1000 wrote:
    Instalacja win 8.1 to chyba jedyne rozsądne rozwiązanie w tym przypadku

    A 10?
  • #30
    sewek1000
    Level 15  
    można ale nie wiem czy już weszła aktualizacja bo w win 10 ma być blokowane instalowanie zwyklych aplikacji programów i gier, jedyny dostęp tylko do aplikacji Windows Store, oczywiście da się odblokować dostęp do ww programów trzeba posiadać bądź instalować wersję Win 10 Pro