Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

[Solved] Amplituner Pioneer vsx-921-k - Brak dźwięku

mumian 12 Feb 2020 07:27 3267 19
  • #1
    mumian
    Level 15  
    Witam
    Amplituner pioneer vsx-921-k zakupiony jako uszkodzony. Brak jest jakiegokolwiek dźwięku na wyjściach głośnikowych pomimo załańczania przekaźników, nie zależnie od wybranego trybu dźwięku jak i pure direct. Amplituner rozpoznaje wpięcie słuchawek - wyświetlają się na ekranie, przekaźnik przełącza i słychać w nich tylko lekki szum.
    Amplituner nie wyświetla żadnego kodu błędów, wszystkie inne funkcje wydają się być sprawne, po podłączeniu telewizora (HDMI out) jest na nim sygnał video, radio internetowe działa jak i opcje sterowania nim przez telefon.
    Service manual pasuje od modelu vsx-1021k i jest dostępny na stronie https://elektrotanya.com/pioneer_vsx-1021-k_sm.pdf/download.html
    Naprawę rozpoczołem od sprawdzenia napięć zasilania na płycie głównej (C main assy), napięcia są, jedno 5v było obniżone do 3,7v - winne były dwa kondensatory obok stabilizatora -5v, oraz napięcie -vf (-30v) wynosi -23v. (Napięcie to pochodzi z głównego -55v jest stabilizowane poprzez dwie diody zenera i tranzystor Q17) elementy te sprawdzone i są sprawne. Wylutowane i sprawdzone wszystkie kondensatory elektrolityczne na tej płycie, również wszystkie tranzystory, diody wylutowane i sprawdzone na testerze. Sprawdzone i poprawione podejrzane pola lutownicze.
    Następnie na płycie O (ir assy) znalazłem uszkodzona diodę (d512) wymiana jej nie przyniosła żadnego efektu. Również na tej płycie sprawdzone wszystkie tranzystory, diody i połączenia. Sama końcówka mocy jest sprawna (B assy) po dotknieciu palcem płytki słychać przydźwięk w głośniku). Jest wyciszona sygnałem amute (tranzystory zwierające wejście z masą ( na płycie A audio assy). Do celów testowych wylutowałem rezystor R2559 podający sygnał wysoki na bazy tych tranzystorów.
    Po podaniu sygnału audio (sin 1khz) na wejście CD i przełączeniu tego wejścia na amplitunerze pojawia się on na wejściu codeka AK4588VQ, płyta S (d main assy) IC1801 ( wejście lin, rin), z amplitudą ok 0,2v (oscyloskop) wraz z napięciem offsetu 2,4v które wd. dokumentacji AK powinno być w granicach 3-3,1v. Zasilanie tego układu w sekcji analogowej i cyfrowej wynosi 5v. Na wyjściach audio z codeka jest już tylko sam offset bez żadnego sygnału audio. Wczesniej zrobiłem na profesjonalnej maszynie reballing układu (IC9002
    D810K013BZKB400-K).
    Proszę doświadczonych kolegów o pomoc w dalszym diagnozowaniu i naprawie tego sprzętu
    Pozdrawiam
  • Helpful post
    #2
    viayner
    Level 42  
    Witam,
    - lekki szum w sluchawkach to nie zly znak, znaczy ze koncowka mocy "cos tam produkuje".
    - jest spore ryzyko ze DSP moze byc uszkodzony a tu zapewne tylko wymiana pomoze, byc moze ktos wgrywal FW i cos nie poszlo.
    Pozdrawiam
  • Helpful post
    #3
    dobrykamil
    Level 16  
    O ile pamiętam, vsx-921 podobnie jak niektóre modele Onkyo, posiada felerny processor DSP od Texas Instruments. Tu masz listę wszystkich tych układów, i Twój też tam jest: https://media.digikey.com/pdf/PCNs/Texas%20Instruments/PCN20121114000_Obs.pdf
    Sprawdź w serwisówce, czy istnieje możliwośc wyświetlenia na przednim panelu wersji oprogramowania. To powinno wyglądać coś jak: 1020-5200-2102-0000. Chodzi mi o sam format. Ten ciąg liczb akurat pochodzi z modelu vsx-1131, w którym nie było dzwięku a przed naprawą wyglądał on tak: 1020-5??0-2102-0000. Te dwa znaki zapytania, oznaczały skopane oprogramowanie dla DSP.
    Jeżeli u Ciebie, nie będzie żadnych znaków ? lub *, to znaczy że procesor DSP startuje i trzeba będzie szukać usterki gdzieś indziej, np. sprawdzić linie danych pomiędzy głównym mikroprocesorem a układem ASP jak i również pomiędzy DSP a DAC.
    Dodam, że w Pionkach załączanie przekażników głośnikówych następuje nawet przy wadliwym DSP. W Onkyo tak się nie dzieje.
  • #4
    mumian
    Level 15  
    Dziękuje za odpowiedzi
    W serwisów-ce odnalazłem:

    ,,MAIN com (EMMA), SUB com (EVENT), DSP Flash ROM and BridgeCo IC Update
    by USB Memory and the Confirmation of the Version
    Procedure:
    1. While holding down "TUNE↑" key on the front panel, press "STANDBY ON/OFF" key and
    moves to the UPDATE PANEL mode.
    2. The updating process is as follows. "

    Wykonałem punkt pierwszy i na ekranie mam:
    1-151081***031
    Wygląda na problemy z DSP ,pan który mi go przelutował mówił że na co najmniej trzech kulkach były zimne luty. Może to spowodowało brak dźwięku, później ktoś próbował wgrać soft który nie poszedł? Zastanawiam się nad próba wgrania najnowszego firmware
    Pozdrawiam
  • #5
    dobrykamil
    Level 16  
    No to teraz już wiemy, gdzie leży problem. W Onkyo, dosyć często padał firmware a dokładnie bootloader. Nie pamiętam już, czy vsx-921 ma opcję „wymuszenia” wgrania oprogramowania.Jeśli nie ma, to trzeba szukać wsadu i ponownie zaprogramować pamięć.
  • #6
    mumian
    Level 15  
    Jest możliwość wgrania softu przez usb.
    Najnowsza wersja Firmware jaką znalazłem to 0.236 przy próbie updating dochodzi do 20% i później wyskakuje update error 1. Zmiana pendrive czy ściągnięcie z innego źródła nie pomaga. Z serwisów-ki wynika ze aktualizacja DSP nie wchodzi.
    Pamięć Nand układu Dsp to Ic9004 MX25L1606EM2I-12G
    Pomierzyłem napięcia w stanie normalnej pracy.
    U zas 3,28V
    reszta względem masy (pin 4)
    1 - 3,28V
    2 - 3,15V
    3 - 3,27V
    5 - 0V
    6 - 3,27V
    7 - 3,28V
  • #7
    mumian
    Level 15  
    Chciałbym zapytać czy jest jakaś szansa na zaprogramowanie tej kości ( MX25L1606EM2I-12G ) za pomocą usbasp 2.0 lub np. arduino mega czy tylko poprzez dedykowane programatory pamięci?
  • #8
    gadzina8
    Level 9  
    Ja programowałem tą kostkę CH341A na znanym portalu chyba 20zł ,który obsługuje MX25L1606E .Oczywiście kostkę do programowania trzeba wyciągać

    a wsady czy to VSX 921 czy VSX 1021 są te same
  • #9
    dobrykamil
    Level 16  
    Skoro funkcja usb działa, to pewnie skopane będzie oprogramowanie dla dsp2.Wystarczy programator CH341A i bez żadnego wylutowywania kości, można ją zaprogramować.Mam do niej wsad z VSX-LX55 który ma ten sam dsp i pamięć.Jak będę przed kompem, to podzielę się w tym wątku tym plikiem.
  • Helpful post
    #11
    gadzina8
    Level 9  
    Proszę bardzo ,tak jak mówiłem , powyżej zapodaje ci soft pewny ,zgrany z działającego VSX 1021 ,ale życzę powodzenia we wgraniu bez wylutu , oby sie coś nie uszkodziło w DSP

    szczegół to ch341 rozpoznaje tą pamięć jako MX25L1505D czy jakoś tak , jak dasz komendę wykryj układ ,ale tym sie nie przejmuj programuje i weryfikuje OK
  • #13
    mumian
    Level 15  
    Po wymianie układu pamięci na nowy z wgranym wsadem od kolegi gadzina8 w amplitunerze wrócił głos.
    Bardzo dziękuje wszystkim za pomoc a zwłaszcza kolegom za udostępnienie wsadów.
    Pozdrawiam
  • #14
    yaro
    Level 12  
    Dzien dobry .Moze ja sie podlacze z moim tunerem vsx 930.Nie chodzi mi siec,usb i osd .Brakuje mozliwosci skalibrowania,nie mam animacji tej z glosnikami pisze mi pliss wait i nic nie dzieje sie.Wersia oprogramowania wyswietla mi sie 1-283009507***
  • #15
    Szymonxx86
    Level 8  
    Witam serdecznie.

    Niestety dołączyłem do grona NO SOUND :( VSX-921 ale z tym to wiem co i jak... Problem mam z VSX 930 bo temat ten sam ale rozwiazanie chyba już nie. Update Error 1 przy 60%. Wcześniej sprawdziłem TUNE UP + POWER i na wyświetlaczy pokazały mi się 1-283009***311
    *** oznacza to problem z DSP i tym programowalnym układem? hmm w VSX 921 to MX25 a w 930?? Mam drugi VSX 930 i mógłbym zgrać wsad ale nie mogę zlokalizować co i gdzie... Trochę się zagubiłem. Nadmieniam że Pionki są moje a nie usługowo ;) 921 w garażu i dwa 930 w domu :D:D

    Bardzo proszę o naprowadzenie :)
  • #16
    dobrykamil
    Level 16  
    Szymonxx86 wrote:
    Witam serdecznie.

    Niestety dołączyłem do grona NO SOUND :( VSX-921 ale z tym to wiem co i jak... Problem mam z VSX 930 bo temat ten sam ale rozwiazanie chyba już nie. Update Error 1 przy 60%. Wcześniej sprawdziłem TUNE UP + POWER i na wyświetlaczy pokazały mi się 1-283009******
    6 ostatnich cyfr oznacza to problem z DSP i tym programowalnym hmm w VSX 921 to MX25 a w 930?? Mam drugi VSX 930 i mógłbym zgrać wsad ale nie mogę zlokalizować co i gdzie... Trochę się zagubiłem. Nadmieniam że Pionki są moje a nie usługowo ;) 921 w garażu i dwa 930 w domu :D:D

    Bardzo proszę o naprowadzenie :)


    IC9704 trzyma firmware dla dsp.
  • #17
    Piotrek_010
    Level 1  
    Witam Szanownych Kolegów.
    Jestem posiadaczem vsx-921. Nie miałem głosu ale bez żadnego błędu. Gwiazdki w nr softu. Zaprogramowałem kostkę wsadem od gadzina8. Teraz głos jest ale dopiero po kilku minutach gdy amp się nagrzeje i wywala błąd ue22. Po nagrzaniu głos jest i błąd znika. W nr softu dalej gwiazdki.
    Czy ktoś ma jakiś pomysł co jeszcze zrobić aby w końcu ożył ;-)
    Będę wdzięczny za wszelką pomoc.
  • #19
    msztula
    Level 15  
    Kupilem nowy układ 25l1606 wgrałem soft z postu wyżej , dalej brak dźwięku a kiedy chce wyłączyć amplituner poprostu się zawiesza , też mam gwiazdki w numerze , oryginalny dsp zrobiłem rebaling nic ni dało ,w
    Kupiłem 2 układy nowe z chin też nie działa ,
  • #20
    mumian
    Level 15  
    Witam, gwiazdki w numerze oznaczają że nie czyta/ rozpoznaje dsp.
    Po grzaniu układu jak Amplituner się zawiesza przy włączeniu moim zdaniem sugeruje to na zwarcia pod nim ewentualnie w samym układzie. Nawet bez samego układu dsp jednostka powinna się załączyć poprawnie.