Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Hulajnoga Xiaomi M365 - Nie ładuje po wymianie BMS

jarroQ 16 Sep 2020 18:41 4227 11
  • #1
    jarroQ
    Level 26  
    Witajcie.
    Znajomy dał mi hulajnogę Xiaomi do naprawy bo przestała się włączać i ładować przy przebiegu około 150km.
    Trochę za wcześnie na pękające blaszki więc się nieco zdziwiłem.
    Po szybkiej diagnozie okazało się że padł BMS.
    Zakupiłem zamiennik chiński z SW 115.
    Zainstalowałem i odpaliłem hulajnogę.
    Wszystko działało jak należy oprócz ładowania.
    Ładowarka świeci ciągle zielona diodą.
    Napięcie 42V dochodzi do BMS.
    Ładowarka sprawdzona - sprawna.
    Wszystkie napięcia poszczególnych sekcji czytane są poprawnie.
    Zareklamowalem więc BMS bo ewidentnie nie załącza tranzystorów odpowiedzialnych za ładowanie lub w ogóle nie widzi 42V z ładowarki.
    Otrzymałem drugi BMS i sytuacja jest ta sama.
    Przerabiał ktoś taki problem?
    Trafiłem na sprzedawcę z wadliwa partia BMS?
    Na której nodze MCU jest detekcja ładowarki?
    Pozdrawiam
    Ethernet jednoparowy (SPE) - rozwiązania w przemyśle. Szkolenie 29.09.2021r. g. 11.00 Zarejestruj się za darmo
  • #2
    zuzia3521
    Level 16  
    Mam ten sam problem gdzie można nabyć sprawny BMS żeby ładował.
  • #3
    jarroQ
    Level 26  
    Czyli zjawisko znane. Dziwne bo na razie nie za dużo jest wzmianek w internecie o tych wadliwych BMSach. Problem na pewno leży w detekcji ładowarki przez MCU.
    Detekcja realizowana jest z pinu C+ przez optotranzystor.
    Dalej się jeszcze nie dokopałem.
    Można tymczasowo zrobić zworkę pomiędzy C- a B- na BMSie ale to wyklucza kontrolę ładowania i BMS nie liczy cykli, nie wylicza też zasięgu.
    Mimo że nie mam za dużo wolnego czasu pracuję nad schematem tego zamiennika. Jest bardzo podobny do oryginału.
    Może sie uda za tydzień lub dwa.
    Obecnie chyba najlepszym sposobem jest wysłanie całej baterii do kogoś kto wymiania BMSy.
    Może się okazać że na 10 płytek jeden będzie działał poprawnie.
  • #4
    slawko_k
    Level 34  
    Co to jest SW 115?

    Zakładam że tranzystor od ładowania sprawdziłeś.

    Quote:
    Detekcja realizowana jest z pinu C+ przez optotranzystor.

    Na pewno optotranzystor ? Niejasne coś to zdanie dla mnie jest.

    Starego BMS'a nie próbowałeś naprawić?
  • #5
    jarroQ
    Level 26  
    Nie wiem czy w ogóle miałeś BMS od hulajnogi M365 w ręku ale piszesz jakbyś go nigdy nie widział.
    SW 115 to soft w nim wgrany. (software 115)
    Jak byś pomierzył płytkę to byś zobaczył że ładowanie realizowane jest nie na jednym a na dwóch tranzystorach NCEP0135AK na potencjale ujemnym.
    Na dodatnim jest tylko podwójna dioda MBRF10100CT.
    Od niej właśnie leci ścieżka przez elementy pasywne do optotranzystora. Dalej nie sprawdzałem.
    Żeby naprawić oryginalnego / zamiennego BMS'a trzeba wiedzieć jak on działa a do tego jest potrzebny schemat.
    W oryginalnym pewnie uszkodzeniu uległ jakiś element aktywny, być może któryś z układów scalonych.
    W zamienniku stawiam na wadę fabryczną.
    Na razie cała bateria z zamiennikiem BMS'a pojechała do sprzedawcy tegoż BMS'a.
    Zobaczymy jak szybko sprawdzą swoje płytki i odeślą sprawną baterię.
  • Helpful post
    #6
    zuzia3521
    Level 16  
    Jest tak pisze jarroQ .

    opto el3h7

    małe dwa układy L04a od spr cell i kontr ładowania

    prostokątny układ BQ7693003 kontrola cell i komunikacja z szyną szeregową ,z St mikrokontrolerem.

    lubią też pękać taśmy i listwy na baterii.
  • Helpful post
    #7
    Pontikos
    Level 38  
    Hm, nie chce się wymądrzać, ale jeśli mruga na czerwono BMS, to w pierwszej kolejności należy sprawdzić bezpiecznik termiczny- biała kostka na jednej z listew wklejona w akumulator. Z mojej praktyki wynika ze to 75% powodów, dla których "nie działa BMS".
    Ale może być i wadliwa seria - ja kupuje te z wlutowanymi przewodami, w komplecie z listwami - trafil mi się jeden wadliwy na dotychczasowe 68 przypadków.
  • #8
    zuzia3521
    Level 16  
    Witam u mnie był uszkodzony bms ,kupiłem drugi i po założeniu dioda mrugała na niebiesko i hulajnoga działała ,tylko było brak ładowania.Wykorzystałem nową płytkę na naprawę starej i po wymianie paru elementów nawet hulajnoga zadziałała ,ale i tak brak ładowania .Zamówiłem następną komplet z listwami ,może tu tajemnica kolejności podłączenia przewodów i listwy i uwala bms.Albo trafiłem na złą sztukę bo sprzedawca mówił że miał właśnie zgłoszenia.
  • #9
    jarroQ
    Level 26  
    Czyli można wywnioskować że pęka jakaś ścieżka na którejś z listew co nie generuje błędu BMS, wszystkie napięcia przy diagnostyce zgadzają się i hulajnoga jeździ tylko nie ładuje.
    Bardzo to dziwne ponieważ wszystkie ścieżki przemierzyłem i mają przejście do złącza, żaden rezystor na listwach nie był uszkodzony. Taśma także cała.
  • #11
    zuzia3521
    Level 16  
    Jedna BMS wadliwa sztuka ,listwy zostaną na zaś.
  • #12
    jarroQ
    Level 26  
    Serwis wymienił w mojej baterii obie listwy, taśmę i BMS.
    Przysłali mi stare listwy i okazuje się że bezpiecznik termiczny jest uszkodzony. Zapewne od wibracji, nie od temperatury.
    Nie trzeba było wymieniać listew !!! Wystarczyło wymienić bezpiecznik.
    Oryginalny BMS może jest sprawny, sprawdzę na innej baterii bo tą oplombowali.

    Jeśli oryginalny BMS działa to wniosek z tego taki że w zamienniku BMS nie ma identycznego softu jak w oryginale.
    Oryginał zupełnie odcina wszystko a zamiennik tylko ładowanie i nie krzyczy żadnym błędem.
    Pontikos miał rację.