Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Lenovo T520 czy można odblokować laptopa.

fido 21 Sep 2022 18:51 417 19
  • #2
    gumisie
    Level 43  
    fido wrote:
    czy jest jakaś szansa żeby odblokować laptopa ?
    To zależy od tego, co jest zabezpieczone hasem.
    Dysk, czy bios.
  • #3
    sosarek

    Level 43  
    @gumisie Raczej start a więc wyjęcie dysku nic nie da jeśli do tego zmierzałeś.
    Miałem podobnie z moim T530, sposoby są ale...
  • #4
    gumisie
    Level 43  
    sosarek wrote:
    @gumisie Raczej start a więc wyjęcie dysku nic nie da jeśli do tego zmierzałeś.
    O kurcze, nie dość, że FACHOWIEC, to jeszcze jasnowidz. :wink:

    Dajmy Autorowi tematu, szansę na odpowiedź.
  • #5
    fido
    Level 26  
    Zgadza się zablokowany jest start. Nie ma dysku. Nie idzie uruchomić. Jeśli ktoś wie i mógłby pomóc to byłbym wdzięczny.
  • #6
    gumisie
    Level 43  
    Te dwa obrazki z #1, dotyczą tego samego laptopa?
  • #7
    fido
    Level 26  
    Tak to jest jeden laptop
  • #8
    gumisie
    Level 43  
    Google Tłumacz:
    Quote:
    IBM Lenovo ThinkPad T520 Bios Password Bin File. IBM Thinkpad zawsze używa małej szeregowej pamięci EEPROM (24RF08, P24s08) do przechowywania nazwy komputera, numeru seryjnego, identyfikatora UUID itp. Hasło administratora (SVP) jest również przechowywane w tym małym układzie EEPROM. Hasło (SVP) można odblokować, przeprogramowując ten mały układ EEPROM. Pamiętaj! W IBM, Lenovo hasło włączenia zasilania nie jest przechowywane w głównym biosie, jest przechowywane w tym szeregowym układzie EEPROM. Odblokuj wymagany laptop IBM, tylko przeprogramuj ten mały układ EEPROM, a nie główny bios
  • #9
    sosarek

    Level 43  
    Są nawet na YT jak to zrobić sprzętowo, wyszukanie informacji zajmuje jakieś 10 sekund...
  • #10
    gumisie
    Level 43  
    sosarek wrote:
    Są nawet na YT jak to zrobić sprzętowo, wyszukanie informacji zajmuje jakieś 10 sekund...
    Z polecaniem szukania tych, co niektórych filmików na YT, ja byłbym bardzo ostrożny. :wink:
  • #11
    dt1
    Admin of Computers group
    Są różne metody, widziałem jakąś metodę ze zwieraniem pinów pamięci EEPROM zawierającej hasło w odpowiednim momencie startu, ale nie korzystałem z tej metody.

    Również chyba bym odpuścił zapisanie tej pamięci losowym wsadem z netu, generalnie Thinkpady mają dość skomplikowany system zabezpieczeń i ciężko przewidzieć, czy taka akcja nie skończy się na przykład błędem System Security-The system has been tampered with lub bad CRC1, stop POST task, czy czymś równie wesołym.

    Metoda, którą sprawdzałem na nieco innym laptopie (ale poza lokalizacją pamięci nie różni się) polega na odczytaniu zawartości pamięci 24RF08 (w T520 jest to układ PS08A i jest on zgodny z 24RF08, działają te same narzędzia). Taki odczytany wsad wrzuca się do darmowego narzędzia, które odszyfruje aktualne hasło.

    Minusem jest konieczność lutowania, zbudowania prostego interfejsu (lub skorzystania z innego programatora), plusem jest to, że jest mniejsze ryzyko na uszkodzenie sprzętu (lub oprogramowania).

    Procedura, schematy interfejsów, programy narzędziowe (do pobrania za darmo) są dostępne tutaj: https://www.allservice.ro/forum/viewtopic.php?t=47
    Na innej stronie można znaleźć lokalizację układu pamięci: http://www.ja.axxs.net/t520.htm

    Korzystałem z interfejsu drugiego (driven i2cprog) i "prawdziwego" portu RS232. Zgaduję, że można próbować skorzystać z innego programatora.
  • #12
    fido
    Level 26  
    Filmiki widziałem i udało mi się nawet zlokalizować układ PS08A i wydaj się że jest to on znajduje się w okolicy układu Winboard. Te filmiki rzeczywiście są różne i różne miejsca pokazania gdzie jest ten układ. Ze zbudowaniem układu na com1 nie będzie problemu także z lutowanie ni powinno być problemu jeśli tylko przeanalizuje instrukcje co i jak bo z angielskim nie jest aż tak dobrze ;-)

    Rozebrałem doszczętnie laptopa i jedyna różnica jaka się teraz pojawiał że podczas uruchamiania pojawia się błąd z nieprawidłową data i czasem oraz błąd wentylatora, dodam że mam nie podłączonego wentylatora ale robiłem to cały czas bez wentylatora i jedynie co zrobiłem to wyjąłem baterię i rozebrałem całość do płyty głównej.
  • #13
    dt1
    Admin of Computers group
    Jak wyjąłeś baterię, to błąd daty i czasu jest czymś normalnym. Jak ją podłączysz i ustawisz datę i czas to problem zniknie. Błąd wentylatora, gdy jest on odłączony też wydaje się być czymś normalnym.

    Tłumacz google przetłumaczy Ci stronę, jeśli angielski nie jest Twoją mocną stroną.
  • #14
    fido
    Level 26  
    Wszystko się zgadza z tymi błędami tylko cały czas robiłem testy bez wentylatora i błędu nie było dopiero teraz jak odłączyłem baterie i rozebrałem doszczętnie. Teraz po komunikacie o wentylatorze wyłącza się, nawet do etapu wpisania hasła nie dochodzi.
    Podłącze wentylator i zobaczę co będzie. Układ do zgrywania też już będzie się robił.
  • #16
    fido
    Level 26  
    Ok. No to muszę podłączyć wentylator i zobaczę co się stanie.
  • #17
    fido
    Level 26  
    A więc tak udało mi się podłączyć wentylator. Poprzez zwarcie SDA SCL udało się wejść do biosu i wstawić puste hasła. Później dałem load default i po restarcie niestety coś nie zadziałało i mam problem bo teraz nic nie wyświetla. Wiem moja wina ale czy jest szansa na uruchomienie.
  • #18
    madamsz1
    Level 39  
    W tej metodzie trochę inaczej się robi i podobno chodziło to. Ja w T60 nie eksperymentowałem, tylko zgrałem wsad i dekodowałem programem.

    "Just short 5+6 pin of u30 (L08 8 PIN IC)
    Open bios setup
    Remove shorting 5+6 pins of U30
    Change bios pass _______ save"
  • #19
    fido
    Level 26  
    Ok zobaczę bo udało się uruchomić.
    Teraz mam taki obraz jak na zdjęciu i nadal hasło jest jak chcę wejść do biosu ale przy zwarciu 5 i 6 chodzi do biosu.

    Czy przy takich zabawach bateria od biosu ma być podłączona ?



    Lenovo T520 czy można odblokować laptopa.

    Dodano po 15 [minuty]:

    madamsz1 wrote:
    W tej metodzie trochę inaczej się robi i podobno chodziło to. Ja w T60 nie eksperymentowałem, tylko zgrałem wsad i dekodowałem programem.

    "Just short 5+6 pin of u30 (L08 8 PIN IC)
    Open bios setup
    Remove shorting 5+6 pins of U30
    Change bios pass _______ save"


    Zadziałało. Hasła brak. Pozostaje włożyć dysk i zobaczyć czy pójdzie. Dam znać.
  • #20
    fido
    Level 26  
    Dziękuję wszystkim za pomoc. Jak na razie wszytko działa. Jeszcze mnie kusiło żeby zgrać wsad z układu ale jak to się mówi nie ruszać jak chodzi ;-)