Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

MS Excel i formule A1 ...

07 Sty 2007 08:38 1346 2
  • Poziom 14  
    Witam!

    Mam problem. Chciałbym zrobić np. w formule A1 wpisuję cyfrę 1, Excel wpisuje w formule A2 liczbę 12 lub w formule A1 wpisuje cyfrę 2, Excel wpisuje w formule A2 liczbę 5 i w formule B2 liczbę 6. Jak to zrobić?

    Poniżej załączam jak to ma mniej-więcej wyglądać.
    MS Excel i formule A1 ...
    Moderowany przez TONI_2003:

    :arrow: Kliknij aby powiększyć :!:
    Proszę tylko zamieszczać fotki tak jak w linku poniżej!
    Sądzę że jest to zrozumiale dla wszystkich, a przynajmniej powinno być, ale jakoś nie mogę się przekonać do tego obserwując co poniektórych!
    Ogłoszenie: Wklejanie zdjęć.

  • Pomocny post
    Poziom 39  
    Cytat:
    w formule A1
    chyba koledze chodzi o komórkę

    Z tego co zrozumiałem chcesz zmieniać wartości komórek w zależności od stanu A1
    Jeśli w A1 jest 1 to w A2 jest 12
    Jeśli w A1 jest 2 to w A2 jest 5 i w B6 jest 6

    Można to wykonać za pomocą funkcji jeżeli.

    Składnia
    Jeżeli( warunek ; wartość jeśli prawda ; wartość jeśli fałsz )


    Jeśli zatem
    A1=2 to B2=6
    A1 jest dowolne - B2=0
    Tutaj w komórce B2 należy wpisać
    =JEŻELI(A1=2;6;0)

    W komórce A2 będzie zagnieżdżona f-cja jeżeli (jedna w drugiej - gdyż mamy trzy stany).
    Jeśli wartosć
    A1 = 1 - A2=12
    A1 = 2 - A2=5
    A1 jest dowolne - A2 = 0

    Fcja będzie zatem wyglądała tak:
    =JEŻELI(A1=1;12;JEŻELI(A1=2;5;0))

    Oczywiście f-cje możesz wstawiać z kreatora (gdzie są opisane parametry i działanie f-cji (menu wstaw -> f-cję).

    W załączniku plik excela
  • Poziom 14  
    Ok dzięki za pomoc.


    Przepraszam za fotkę. Następnym razem dostosuję się do w/w wątku.