Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ATMEGA2561 - Programator jej nie widzi

11111olo 08 Kwi 2016 16:37 864 6
  • #1 08 Kwi 2016 16:37
    11111olo
    Poziom 43  

    Witam

    Zaprojektowałem płytkę którą wykonała profesjonalna firma. Po prawidłowum wlutowaniu wszystkiego przyszła pora na programowanie i tu jest problem bo programator jej nie widzi.
    Miałem druga identyczną płytkę oraz drugą atmegę - ta także nie działa.

    Programator to klon MKII. Środowisko AVRStudio 4.18.
    Aby wykluczyć uszkodzenie programatora sprawdzałem na ATTiny85, 2313 i ATMega 8, 644, 1284 oraz AT90USB1286. Na tych działa bez problemu.

    Obie atmegi kupiłem w MSelktronik. Czyżbym trafił na wadliwe?
    Ktoś miał podobny przypadek?

    0 6
  • #2 08 Kwi 2016 17:17
    2675900
    Użytkownik usunął konto  
  • #3 08 Kwi 2016 17:19
    11111olo
    Poziom 43  

    Piotrus_999 napisał:
    Zobacz czy nie blokujesz np resetu. pomierz napiecia.

    Nie ma zwarć i napięcia są ok. Próbowałem na 5V oraz 3,3V.
    Piotrus_999 napisał:
    Sprawdz jak fusebity i oscylatory.

    W ogóle nie widzi mikrokontrolera więc i tego nie da się sprawdzić.
    Reszta Twojego postu jest całkiem nie na temat :(

    0
  • #4 08 Kwi 2016 17:22
    2675900
    Użytkownik usunął konto  
  • #5 08 Kwi 2016 17:44
    11111olo
    Poziom 43  

    Piotrus_999 napisał:
    Nie pisałem o zwarciach. Ale skoro nie na temat to czesc.

    Nie pisałeś ale napisałeś
    Piotrus_999 napisał:
    Zobacz czy wazne linie dla programowania daja sie sterowac (czyli czy zero lub jeden tam) wymusza ten stan.

    Jak to zrobić skoro nie widzi mokrokontrolera czyli nie da się zaprogramować.

    Może czegoś nie wiem to napisz to wprost.

    Sprawdzałem także na BASCOMie i tam też go nie widzi, w przeciwieństwie do pozostałych układów.

    0
  • Pomocny post
    #6 08 Kwi 2016 18:08
    tmf
    Moderator Mikrokontrolery Projektowanie

    Pokaż schemat połączeń. Jesteś pewien, że ISP podpiąłeś pod właściwe piny? W tym typie MCU dla zmylenia ISP jest na pinach PDI/PDO/SCK, a nie MISO/MOSI/SCK, które są dla interfejsu SPI.

    0