Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

LM317T napięcie wyjściowe nie zmienia się przy zmianie R2

13 Sie 2019 21:03 141 9
  • Poziom 12  
    Kupiłem od chińczyków 10 szt. LM317T (mam problem z kupieniem lokalnie), gdyż chciałem zbudować ten programator: https://www.elektroda.pl/rtvforum/topic2602823.html
    Dałem najpierw rezystory R1:330 Ohm i R2: 560 Ohm no i napięcie na wyjściu 3.95V... Zasilane ładowarką USB (4.98V na wyjściu). Dałem więc R2: 515 Ohm no i brak zmian - 3.95V na wyjściu. Sprawdzałem na kilku sztukach tych regulatorów i to samo. Czy po prostu kupiłem nic nie warty szmelc czy o co tu może chodzić?

    Boję się pod to podłączyć pamięć SPI gdyż zakres napięć dla niej jak sprawdzałem to 2.7V-3.6V.
  • Poziom 27  
    Witam
    A nie pomyliłeś PIN'ów? - na schemacie zamieszczonym w podanym przez Ciebie linku jest pomyłka.
    A tak w ogóle operowanie oznaczeniami typu R2 czy coś tam bez pokazania schematu to...

    Pozdr.
  • Poziom 12  
    Wiem, że jest pomyłka, zauważyłem to przed lutowaniem, że jest adjust z Vin pomylone, jeśli chodzi o nr-y pinów. Oznaczenia takie jak podałem są "ogólnie przyjęte" i uwidocznione na schemacie np. na tej stronie z kalkulatorem: http://www.reuk.co.uk/wordpress/electric-circuit/lm317-voltage-calculator/
    R1 to rezystor między adjust a output, natomiast R2 to rezystor między adjust a masą. Dam jeszcze w wolnej chwili jakieś zupełnie inne rezystory i zobaczę co się będzie działo.
  • Poziom 32  
    kicajbas napisał:
    A nie pomyliłeś PIN'ów? - na schemacie zamieszczonym w podanym przez Ciebie linku jest pomyłka.

    Nie ma pomyłki tylko regulator jest narysowany tak, że wyjście jest po lewej.

    Mathey napisał:
    Czy po prostu kupiłem nic nie warty szmelc czy o co tu może chodzić?

    Włącz datasheet układu i podłącz wszystko zgodnie z nim.
  • Poziom 12  
    Ale Koledzy, ja właśnie od PDF'a zacząłem. I to dzięki niemu pojąłem, że na schemacie programatora jest błąd. Zaznaczę oczywiście dla formalności gdyż nie wspomniałem o tym, że chodzi tutaj o tą prostą, podstawową wersję programatora (ta druga z tego co na szybko patrzyłem nie ma w ogóle LM317). Specjalnie sprawdzałem jakie jest oznaczenie pinów, i patrząc na obudowę od strony oznaczenia układu, nóżkami skierowanymi w dól jest to kolejno od lewej do prawej: 1,2,3 (adjust, output, input).

    Andrzej42 napisał:
    zgodnie z tą notą R1 ma wartość 240 om

    No dobrze, to dlaczego wszelkie kalkulatory dopuszczają różne wartości R1 (z zakresu 100-1000 Ohm)? Jak sprawdziłem teraz, wartość 240Ohm jest zalecana, ale nie wymagana. Ja się trzymałem oryginalnego schematu programatora.
  • Poziom 38  
    1. Różnica napięcia pomiędzy pinami IN i OUT powinna wynosić co najmniej 2,5V. Poniżej tej wartści układ LM317 przestaje stabilizować. Z napięcia 4,98V możesz uzyskać max. 2,48V napięcia stabilizowanego na wyjściu.
    2. Rezystor pomiędzy pinami ADJ i OUT nie powinien być większy niż 240Ω. Większa wartość skutkuje zwiększeniem niestabilności napięcia wyjściowego.
  • Poziom 12  
    @zetdeel
    Ad1.
    Tego nie wiedziałem. Ale faktycznie jest w PDF'ie: Vi-Vo= 2.5 to 40 [V]. Zastanawia mnie więc fakt, że podobno autorowi to działo jak tam napisał. Tak więc schemat tego programatora jest niedopracowany i nie wiem jak mu to mogło działać, chyba po prostu szczęście.
    Ad2.
    Zastanawia mnie więc dlaczego przy wielu tych kalkulatorach jest informacja, iż może być z zakresu 100-1000 Ohm.

    Chyba więc dobiorę drugi rezystor do współpracy z tym 240 Ohm między ADJ i OUT i będę zasilać z 12V.

    Jeszcze pozwolę sobie na pytanie mniej związane z tematem - czy mam się spodziewać, że jak podepnę tę pamięć (Spansion FL032PIF) pod te blisko 4V to z pewnością ulegnie ona uszkodzeniu? A może jet szansa, że się uda tak zaprogramować?

    Albo gdybym zamiast całej tej części z regulatorem na schemacie wziął 3.3V z zasilacza ATX z pomarańczowego kabla? W sensie z tego samego komputera z portem LPT. Niczego nie uszkodzę?
  • Moderator Projektowanie
    Mathey napisał:
    Ale faktycznie jest w PDF'ie: Vi-Vo= 2.5 to 40 [V]

    T.zw. Vdrop czyli minimalna wartość wymagana do poprawnej pracy wynosi od ok. 1V do 3V i zależy od Iobc (oraz od egzemplarza, producenta - ale to mniej). Tu Iobc jest niewielki (jaki ?), więc Vdrop zapewne wynosi ok. 1,5-1,8V i to miało szanse u autora działać - lepszy egz, wyższe Uzas (np. 5,1V).
    Lepiej czytaj datasheet: http://www.ti.com/lit/ds/slvs044x/slvs044x.pdf - podano 3V, a tu https://www.onsemi.com/pub/Collateral/LM317-D.PDF Figure10 podaje 2,5V ale to wartość typowa.
    Mathey napisał:
    Zastanawia mnie więc dlaczego przy wielu tych kalkulatorach jest informacja, iż może być z zakresu 100-1000 Ohm.

    Bo te kalkulatory tworzą jacyś amatorzy, którzy też datasheet nie czytali.
    Użyj stabilizatora LDO - np. LF33, czytaj datasheet: https://www.google.pl/url?sa=t&rct=j&q=&esrc=...00000546.pdf&usg=AOvVaw0ROuGdZI494YCgwYO6R4ZO https://www.tme.eu/pl/details/lf33abv/stabili...piecia-nieregulowane-ldo/st-microelectronics/
  • Poziom 12  
    No przyznaję się, że aż tak dokładnie datasheet nie czytałem. Chciałem tylko zrobić coś jednorazowego żeby zaprogramować flash. Z ciekawości podpiąłem teraz zasilanie z 4 paluszków AAA (zmierzone 5,91V) i na wyjściu było 4.78V... Później zasiliłem akumulatorkiem "9V" (zmierzone 8.3V, trochę stał nieużywany od pełnego naładowania) i wyjście 4.95V.

    Na tych stabilizatorach jest logo ST Microelectronics, stawiałbym, że jakieś podróbki ale około 100 pozytywnych komentarzy (dla tej aukcji) i sklep raczej z dobrą renomą.

    EDIT 14.08.2019:
    Dziś kolejne testy - dałem "R1" 220 Ohm i "R2" 330 Ohm i dla pewności wymieniłem elektrolit za stabilizatorem (zarówno poprzedni jak i nowy na mierniku pokazał 10 uF z lekkim okładem po przecinku) i tak:
    -Na ładowarce USB (wiem, o tych 2.5V różnicy między in and out ale pomimo tego spróbowałem) wyjście 3.95V
    -Na akumulatorku "9V" (zmierzone 8.27V) wyjście 4.89V
    Później jeszcze dałem "R1" 220 Ohm i "R2" 270 Ohm - na ładowarce usb 3.95V, na zasilaczu 9V wyjście 4.5V.

    Nie wiem jeszcze, czy to ma jakieś znaczenie ale w sumie nie wiedziałem jakie te LED'y dać więc dałem po prostu obie czerwone fi 5 mm.

    Zatem to chyba jednak szmelc jakiś te chińskie regulatory. Czy mogę bez obaw dać po prostu +3.3V z wtyczki ATX? (ten sam komputer do którego będzie podpięty programator, uruchomiony)

    EDIT#2 16.08.2019:
    Podpiąłem pod +3.3V na starym kompie i niestety, brak komunikacji z flashem. Prawdopodobnie jest uszkodzony - albo od początku był, albo uwaliłem go sam tym zbyt dużym napięciem (za pierwszym razem był podłączony). Czekam na nową pamięć i wtedy będzie na 100% wiadomo czy to działa.