Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Połączenie MOC3041 i BT136-600

muaddib1985 04 Wrz 2007 10:38 15343 12
  • #1 04 Wrz 2007 10:38
    muaddib1985
    Poziom 9  

    Witam!
    Pracuję nad sterowaniem gniazdkami 230V poprzez mikrokontroler i układy z MOC3041 i BT136-600. Zlutowałem to w taki sposób ja na załączonym schemacie:
    Połączenie MOC3041 i BT136-600
    Niestety nie działa. Wystawiam zero na porcie ATMegi dioda mi się zaświeca, na nogach 1,2 odkłada się napięcie 1,1V, ale na bramce triaka BT136 nie widać żadnych zmian.
    Nie znam się zbytnio na triakach ale są one chyba wyzwalane przy jakimś prądzie bramki(w tym wypadku 35mA). U mnie na bramce ciągle 0. Ma ktoś jakiś pomysł?
    Z góry dziękuję:)

    1 12
  • #2 04 Wrz 2007 12:15
    karel21
    Poziom 27  

    Z tego co napisałeś wynika że chcesz aby triaki zadziałały po podaniu napięcia(i tak wynika ze schematu) więc zamień MOC 3041 na MOC 3021,zadziała.

    0
  • #3 04 Wrz 2007 12:36
    muaddib1985
    Poziom 9  

    Dzięki:)
    Zaraz polecę do sklepu i sprawdzę czy zadziała. Mógłbyś mi jeszcze powiedzieć czym się różnią te optotriaki? Jak wyzwolić MOC3041?

    0
  • #4 04 Wrz 2007 12:54
    lukasb9
    Poziom 28  

    Witam, różnica w tych optotriakach jest taka,że MOC3041 ma detekcje przejscia prądu przez zero, MOC3021 jej niema. W Twoim przypadku powinno wszystko działać, jeśli podłaczysz obciążenie.

    0
  • #5 04 Wrz 2007 12:55
    dex
    Poziom 27  

    to już może lepiej na moc3043 załączane w zerze. Wg. mnie tam brakuje jeszcze jednego rezystora miedzy bramką a A2. Jeśli to triak bo na schemacie jest.. tyrystor , zdałby się też układ gasikowy RC na obciążeniu. Jak to sie łączy za dużo nie ma co dumać.. wystarczy popatrzeć do katalagu http://www.fairchildsemi.com/ds/MO%2FMOC3043-M.pdf

    0
  • Pomocny post
    #6 04 Wrz 2007 16:10
    r2d2004
    Poziom 31  

    Witam!

    Tak jak napisali Koledzy wcześniej układ powinien zadziałać. Aby sprawdzić najlepiej włączyć obciążenie triaków (np. w postaci żarówek). Jedna ważna uwaga. Jako diody sygnalizacyjne masz uzyć CZERWONYCH (nie wiem jakie to są LD266 ?), a nie np. niebieskich, czy białych. Niefortunnie zastosowałes MOC3041 (duzy prąd sterujący zadziałania diodą IR - 15 mA w optotriaku). Lepsze były by MOC3043 ( 5 mA ). Gdyby układ nie chciał nadal działać to chyba będzie konieczne zmniejszenie oporników z 220 na 180, ewentualnie "wywalenie" szeregowych diod sygnalizacyjnych LED, lub po prostu zastosuj czulsze MOC3043.

    Pozdrawiam

    0
  • #7 05 Wrz 2007 13:00
    muaddib1985
    Poziom 9  

    Próbowałem już dać 15mA na MOC3041, kupiłem też MOC3022 i jeszcze nie widać wyników:) Kombinuję dalej:) Dzięki za pomoc:) Mam nadzieję, że uda mi sie to szybko skończyć, bo mają już mnie dość w domu:) Dziś wywaliłem korki:)
    Pozdrowienia:)

    0
  • Pomocny post
    #8 06 Wrz 2007 12:23
    r2d2004
    Poziom 31  

    Witam

    Nogi 6, 4 optotriaka mają byc podłączone do triaka tak jak na poniższym schemacie. Jesli nie stosujesz obciążenia o charakterze indukcyjnym (bedą tylko np. żarówki), to gasik (kondensator szeregowo z opornikiem) możesz sobie darować.

    Podłączenie triaka (widok od strony napisu, "nogami" do dołu):

    BT136 (i inne typu BTA, BTB):
    A1A2G

    KT207 (i inne triaki czeskie, które często się jeszcze używa - mają inaczej wyprowadzenia):
    A1GA2

    Na schemacie elektroda A1 to jest ta przy elektrodzie G (bramce), a A2 po przeciwnej stronie. Jeśli wszystko połączysz dobrze to nie ma cudów - musi działać ("palenie" bezpieczników oznacza, że coś masz źle polutowane).

    Pozdrawiam
    PS Pamiętaj, że w przypadku triaków BT, BTB, KT na radiatorze występuje faza (podłączony "metal" obudowy TO-220 do elektrody A2, triaki BTA mają izolowaną od metalu radiatora elektrodę A2), a więc raczej "paluchów" tam nie pchaj, jak masz toto załączone do sieci i nie podłączaj przypadkiem do masy radiatorów przy triakach! Jeszcze jedno: VDD lewe (na twoim schemacie powinno być oznaczone: AC ZERO), VDD prawe (powinno być oznaczone: AC FAZA) i tak powinno być podłączane do sieci (tej kreski "przeciągniętej" bez kropki nie powinno być, bo bedzie zwarcie rzecz jasna). Symbol VDD (wybrany niefortunnie w tym przypadku) zarezerwowany jest raczej dla oznaczenia napięcia DC (stałego) zasilającego układy scalone zawierające w strukturach tranzystory unipolarne (polowe) i oznacza dosłownie: "napięcie drenu". Przy próbach (uruchamianiu) układ minimalizuje się do jednego optotriaka i triaka (obciążonego żarówką). Nie podłączasz do komputera, tylko podajesz napięcie z zasilacza lub baterii +4.5V przez opornik na diodę IR w optotriaku i dobierasz ten opornik w razie czego. Jesli układ zadziała to wtedy montujesz na płytce elementy dla pozostałych kanałów. Dla zadziałania układu, nie ma znaczenia jaki optotriak uzyjesz. Z MOC3041 bedziesz miał sterowanie załączaniem obciążenia synchronizowane z przejściem fazy przez ZERO (układ ZERO CROSS wbudowany do środka optotriaka), a z MOC3022 sterowanie bez funkcji ZERO CROSS i tyle. Z jednym i drugim ma działać, jak dobrze podłączysz i właściwie dobierzesz prąd diody IR w zależnosci od typu optotriaka.

    1
  • #9 06 Wrz 2007 14:28
    muaddib1985
    Poziom 9  

    Chciałbym napisać, że działa, ale nie sprawdzę tego w najbliższym czasie. Przed chwilą spaliłem całą moją płytkę z wyświetlaczem, mikrokontrolerem, zegarem itp. . Do tej pory nie wiem jak to się stało, ale płytka jest czarna. Jak dojdę znów do momentu sprzed awarii to się odezwę. Dzięki wszystkim za pomoc.

    Udało mi się wrócić do stanu wyjścia. Jest jakaś możliwość, żeby zmierzyć czy optotriak działa?

    0
  • #10 11 Wrz 2007 22:19
    muaddib1985
    Poziom 9  

    Hura!!
    Działa. Zastosowałem schemat z dokumentacji MOC3041. Wszystkie inne mi nie działały. Wypróbowałem wszystkie;) Dzięki wszystkim za pomoc:)
    Do następnego układu!

    0
  • #11 23 Paź 2007 18:09
    Siersciuchyelonky
    Poziom 13  

    Witam
    Dlaczego przy obciążeniu rezystancyjnym nie ma sensu dawać układu gasikowego ?
    Jak wyeliminować zakłócenia pochodzące od triaka?

    0
  • #12 24 Paź 2007 13:59
    r2d2004
    Poziom 31  

    Witam!

    Jestem praktykiem, a nie teoretykiem, ale powiem tak. To jest tak samo jak z nieskończonością - wszyscy wiedzą, że gdzieś "tam jest", ale nikt jej "nie namacał" rzecz jasna ;-) . Podobnie jest z indukcujnością i rezystancją - nie ma obciążeń czysto rezystancyjnych, czy indukcyjnych, dlatego gasik warto zawsze dać w przypadku triaków czy tyrystorów. W układach gdzie mamy do czynienia z dużymi częstotliwościami przełączania (nie dotyczy to już raczej triaków i tyrystorów) zamiast gasików w miejscach gdzie mogą wystąpić spore przepięcia od SEM samoindukcji, stwarzające zagrożenie dla półprzewodnikowych elementów przełączających, stosuje się zabezpieczające diody typu Transil (specjalne diody Zenera, wytrzymujące w impulsie do 1,5kW mocy). Eliminacja zakłóceń w 100% jest praktycznie trudna do zrealizowania, bo zakłócenia przenoszą się nie tylko po kablach, ale również w postaci fali elektomagnetycznej. Popatrz na schematy ściemniaczy oświetlenia - jest tam stosowany dławik z kondensatorami jako filtr, który "coś tam" z tych zakłóceń ma "wyłapać". Dławik ten przy większych prądach może mieć spore gabaryty i szczególnie w rozwiązaniach amatorskich jest kłopotliwy i często się go nie stosuje, no i mamy w sieci energetycznej "to co mamy" he, he, czyli "siano".

    Pozdawiam

    0
  • #13 24 Mar 2008 00:52
    magik128
    Poziom 22  

    Cytat:
    Wg. mnie tam brakuje jeszcze jednego rezystora miedzy bramką a A2


    Stary temat ,ale pewnie jeszcze niejeden na niego trafi... Rezystor ma być między bramką G i terminalem T1 (A1)

    0