Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Uszkodzony dysk samsung SV0802N

lukasb9 28 Lut 2008 01:51 4627 16
  • #1 28 Lut 2008 01:51
    lukasb9
    Poziom 28  

    Witam mam problem z dyskiem samsung SV0802N, dysk przestał działać sam z siebie, nie był uderzony. Na chwile obecna nie jest wykrywany w biosie, bios zawiesza sie kiedy próbuje sie z nim skontaktować :). Talerze sie rozkręcają, głowica zachowuje sie prawidłowo, po odłączeniu zasilania stuka (wraca do pozycji startowej). Sprawdzałem oscyloskopem zasilanie silnika i tu też wygląda wszystko ok wszystkie trzy fazy obecne. Pobieżnie sprawdziłem miernikiem oporniki i kondensatorki na przerwy i zwarcia ale nic nie znalazłem....Moje przypuszczenie to uszkodzony firmware.
    Dokładne dane dysku:
    SAMSUNG SV0802N
    P/N:0636J1FW405035 P/V MS
    REV A
    po podłączeniu zasilania jak juz pisałem dysk rozkręca talerze i dzieje sie to bardzo spokojnie tak jak przy normalnej pracy.
    Ponieważ trafiłem na ten post - https://www.elektroda.pl/rtvforum/topic872300.html
    postanowiłem sprawdzić co powie mi ten dysk po włączeniu zasilania, zbudowałem konwerter z użyciem MAX232 ale dysk na starcie odpowiada jakimiś krzaczkami, o pomyłce w montażu raczej niema mowy, ponieważ kiedy zewrę linie TX i RX idące do dysku w terminalu dostaje wysłane znaki. Prędkość ustawiona zgodnie z instrukcją na 9600, ramka 8 bitów, 1 bit parzystości, brak sterowania przepływem.

    Code:
      }
    
                        µŽţE ů î

    coś takiego wysyła dysk, długość ramki zgadza sie zawsze natomiast zawartość czasem sie zmienia.

    Prosiłbym kolegów z forum o jakieś sugestie co z nim dalej robić, jutro planuje wszystko przelutować hotair-em a jeśli to nie pomoże polować na allegro na sprawna elektronikę do takiego dysku.

    Zapomniałem dodać, że dysk ma pojemność 80GB

    ------------------------
    Panowie zauważyłem swój błąd, źle ustawiałem terminal! ustawiałem go dla dysku seagate-a...
    Po poprawnym ustawieniu dysk wysyła następującą ramkę:
    Code:
    SpnOk
    
     DAC:-00242
     H:  +00000
     SK C: 0000D614
    ENG>SRV>
      SvoTbl Loaded
      BD
    ENG>

    0 16
  • #2 29 Lut 2008 14:34
    lukasb9
    Poziom 28  

    Panowie poradźcie coś! ma ktoś wsad do pamięci AT49F1024 tego dysku? chętnie bym ja przeflashował, ew czy jest możliwość programowania jej przez ten interfejs szeregowy?

    Ps przepraszam za pisanie posta pod postem, ale żadnego zainteresowania moim problemem nie widze, stąd chciałem temat przenieść troche wyżej, wydaje mi sie, że opisałem problem jak należy.

    0
  • Pomocny post
    #3 29 Lut 2008 15:10
    Przemcio
    VIP Zasłużony dla elektroda

    Komunikat z terminala wskazuje, że dysk zadziałał mimo problemów.
    Może natomiast być bardzo duże opóźnienie z czytaniem SA spowodowane uszkodzeniami i dlatego "wywiesza" BIOS.
    Postępowanie raczej podobne do tego tutaj czyli soft reset i możliwie najszybsza przeprowadzka danych np. programem Copyr.
    Może być też problem z taśmą ATA lub samym interfejsem IDE dysku.
    Wtedy może się przydać sprawna PCB tylko należy pamiętać o przełożeniu Flash`a.

    P.

    0
  • #4 29 Lut 2008 15:15
    Anonymous
    Użytkownik usunął konto  
  • #5 29 Lut 2008 20:35
    lukasb9
    Poziom 28  

    Witam Panowie i bardzo dziękuje za zainteresowanie. Dziś przelutowałem jak leci cała elektronikę dysku stacja hot air, i dysk jest wykrywany w biosie! bez problemowo. Tzn. bios widzi typ dysku i konkretne dane dotyczące liczby sektorów itd. Niestety trochę sie pospieszyłem i uruchomiłem dysk pod windowsem, co jak mi sie teraz wydaje nie było dobrym pomysłem, tak czy inaczej pod windowsem dysk ma pojemność zerową i jest nie sformatowany (tak twierdzi system) po stwierdzeniu tego faktu wyłączyłem komputer. Na chwile obecna nie wiem co dalej robić , bo wygląda na to, że dysk stracił tablice alokacji. Oczywiście pod windowsem nic z nim nie robiłem. Prosił bym o podanie co i jak z nim teraz zrobić, tak, żeby nie zaszkodzić temu co sie na nim znajduje.

    0
  • Pomocny post
    #6 29 Lut 2008 21:17
    migol21
    Specjalista HDD Recovery

    Jeśli masz Hirens BOOT Cd to tam jest File Recovery najlepiej jednak zrób copyr-em kopie na drugi dysk potem uruchom Hirens bota i podłączony dysk klon i File recowery przeskanuj i powinieneś zobaczyć dane. Jeśli zalezy ci na danych lepiej przekopiować dane na drugi dysk copyrem opis MHDD i copyra masz tu https://www.elektroda.pl/rtvforum/topic868490.html a w szczegulności post Copyr FAQ -Kopia posektorowa dysku.

    0
  • #7 01 Mar 2008 00:14
    lukasb9
    Poziom 28  

    Witam zrobiłem jak kolega wyżej sugerował, skopiowałem cały dysk programem "copyr" i teraz pod windowsem próbowałem odzyskać cokolwiek z dysku klona, ale PC inspector sobie z nim nie radzi, przy skanowaniu w poszukiwaniu dysków logicznych, po znalezieniu dysku klona wyrzuca komunikat "bad parameter in boot sector: root directory cluster (4119533773)> count of clusters!" komunikat ten pojawia sie dwa razy zaraz po znalezieniu dysku i chwile po tym chyba po znalezieniu dysku logicznego.
    Próba skanowania znalezionych dysków (mój systemowy skanuje bez problemu) odrazu powoduje wywalenie komunikatu :
    "Access violation at adress 0048F782 in module 'Filerecovery.exe'.Write of adress 2270631D"

    będę wdzięczny za pomoc co to z tym dalej robić - dysk klon jest całkiem sprawny fizycznie.

    0
  • #8 01 Mar 2008 00:17
    Anonymous
    Użytkownik usunął konto  
  • #9 01 Mar 2008 01:12
    migol21
    Specjalista HDD Recovery

    trzeba zrobić zrzut lba 0-100 żeby zobaczyć coś więcej. Można też podglądnąć np. Smart Fdisk lub Fdisk z Hirensa co widać jako partycje jedna dwie czy botowalne czy rozpoznaje NTFS czy pokazuje nieznany.

    Jeśli skanujesz File Recowery dysk sytemowy a chyba tak to można zrozumieć to acces violation jest normalne. Takie mam wrażenie.

    0
  • #10 01 Mar 2008 01:42
    Przemcio
    VIP Zasłużony dla elektroda

    Kolego migol21, może zamiast testować na Autorze Tematu CD Hirens`a wypadałoby chwilę się zastanowić co to dokładniej oznacza:

    Code:

    "bad parameter in boot sector: root directory cluster (4119533773)> count of clusters!"

    Właśnie ATOF 0-100 z MHDD mogłoby to wyjaśnić.

    P.

    0
  • #12 01 Mar 2008 20:45
    lukasb9
    Poziom 28  

    Witam Panowie troszke to trwało ale odczytałem co radziliście z tego dysku. Poniżej link gdzie ten plik umieściłem, ponieważ coś nie potrafie dodać załącznika . Czekam na dalsze instrukcje :)

    http://lucaslab.grandhost.pl/temp/10000

    0
  • Pomocny post
    #14 02 Mar 2008 02:30
    Anonymous
    Użytkownik usunął konto  
  • #15 04 Mar 2008 01:17
    lukasb9
    Poziom 28  

    Ogromne podziękowania Panowie! wszystko odzyskane! największe dzięki dla kolegi okzo :) .
    Nie rozumiem o co chodziło koledze w tym zdaniu :

    Cytat:
    I coś dziwnie wygląda załącznik na stronie kolegi, czasem to nie dla tego aby potem go zamienić !! Dziwne ach jakie dziwne te zabawy krakowskie !!

    jeśli można proszę wyjaśnić :)

    0
  • #16 04 Mar 2008 01:28
    Przemcio
    VIP Zasłużony dla elektroda

    Może ja wyjaśnię w kilku słowach o co chodzi z tzw. "Krakowskimi zabawami".
    W ostatnich kilku dniach pojawiło się kilka tematów Użytkowników z Krakowa gdzie uszkodzenia raczej wskazywały na dość "cudaczne" interwencje odbiegające od ogólnie znanych procedur.
    Z rozpędu chyba też przypadek Kolegi został zaliczony do tej czarnej serii co nie przeszkodziło udzielić skutecznej, jak czytamy, pomocy.

    Hmm, proszę to może potraktować jako formę żartu i nie zapomnieć o użyciu przycisku Pomógł.
    Dział bardzo specyficzny to i humor również. :D

    P.

    0
  • #17 04 Mar 2008 11:00
    lukasb9
    Poziom 28  

    Oczywiście przycisk pomógł został użyty :) nawet trzy razy w tym temacie :) i to jeszcze wczoraj (nie zapominam o "pomagaczach", klikam jeśli ktokolwiek choć trochę podpowie mi jak rozwiązać problem)
    Dziękuje koledze Przemcio za wyjaśnienie "krakowskich zabaw" oczywiście traktuje i traktowałem to jako żart :) (po poprostu nie wiedziałem o co chodzi)

    Jeszcze raz ogromne dzięki Panowie za pomoc :)

    0