Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

21 Maj 2011 13:34 10258 5
  • Poziom 10  
    Witam.
    Wykonałem przetwornice push-pull z wykorzystaniem układu tl494cn według poniższego schematu:
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Z założenia przetwornica ma być zasilana z akumulatora a na wyjściu dawać napięcie w zakresie od 25 V do 35 V ustawiane potencjometrem sprzężenia zwrotnego 22k, wydajność prądowa 5A.
    Trafo oraz dławik został obliczony i wykonany przez ferystera.
    Użyte kondensatory LOW ESR.

    W stanie jałowym przetwornica pobiera 20 mA prądu.
    Po obciążeniu silnikiem przy napięciu wyjściowym 30 V przetwornica pobiera ok 1.3 A.
    Pod obciążeniem napięcie jest stabilne.
    Wydawać by się mogło, że wszystko działa dobrze.
    Niestety słychać syczenie transformatora oraz pobór prądu jest dość duży(silnik zasilany bezpośrednio z zasilacza laboratoryjnego pobiera ok. 0.3 A prądu)

    Poza tym przebiegi z oscyloskopu wyglądają następująco (napięcie wyjściowe jest stabilne):
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Przy napięciu zasilania ok 7 V - 9 V układ tl494 kluczuje prawidłowo tranzystory.
    Dla założonych wartości napięcia na przebiegu pojawiają się szpilki (bez obciążenia), po podłączeniu silnika pojawia się zniekształcony przebieg prostokątny występujący co pewien okres.
    W momencie ustawienia potencjometru w maksymalnym położeniu na wyjściu występuje napięcie 60.7 V oraz przebieg wygląda prawidłowo.

    Próbowałem pozbyć się tych problemów dokonując modyfikacji w sprzężeniu zwrotnym, lecz bez efektów.

    W związku z tym prosiłbym o pomoc bardziej doświadczonych forumowiczów.
    P.S.
    Przetwornica raz została sprawdzona przez 7h pod obciążeniem silnikiem DC przy napięciu wyjściowym ok 30 V, trafo cały czas syczało, przetwornica chodziła stabilnie, irfz-y nagrzały się umiarkowanie.
    Po podłączeniu przetwornicy pod układ ze stabilizatorami i silnikami syczenie przetwornicy zmieniło ton na mocniejszy oraz pojawiał się pobór prądu rzędu 8A (prawdopodobnie występowało zwarcie), gdzie układ normalnie pobiera ok. 1.5 A.

    Za wszelką pomoc z góry dziękuję.
  • Pomocny post
    Poziom 33  
    O, widzę mój schemat zupełnie najprostszej przetwornicy z początków "kariery" :)

    Zaobserwowane przez ciebie przebiegi są wzorcowe - dokładnie tak ma się zachowywać przetwornica z nieskompensowaną stabilizacją napięcia. Jeśli chcesz żeby stabilizacja działała na zasadzie regulacji współczynnika wypełnienia zamiast załączać i wyłączać sterowanie tranzystorami (jak u ciebie), musisz dodać sprzężenie zwrotne przy komparatorze stabilizacji. Chodzi mi o ujemne sprzężenie zwrotne z inercją (histerezą). Zrobiłem coś takiego w innym zasilaczu:
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Wystarczy tylko dobrać odpowiednie elementy RC żeby uzyskać idealną stabilizację bez syczącego transformatora ;)

    P.S. ten kondensator 100u 63V zaraz za diodami jest niepotrzebny, a nawet szkodzi.
  • Poziom 42  
    Tyle zdjęć i ani jednego zdjęcia wykonania przetwornicy :(

    Uwagi Qweta oczywiście jak najbardziej słuszne. Brak kompensacji i kondensator za diodami - kuriozalne. Jednak mam jeszcze obawy o layout - o ile w ogóle jest płytka.
  • Poziom 10  
    Poniżej zamieszczam zdjęcie przetwornicy (wersja 1):

    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Radiator specjalnie został umieszczony odwrotnie, ponieważ jeden z jego kołków znajduje się w miejscu przechodzenia jednej ze ścieżek, co zostanie poprawione w nowej wersji przetwornicy. Bramki IRFZ-ów są od siebie odseparowane.



    Wersja 2 (wg rad Qweta)

    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Przetwornica została wykonana - działa dobrze, trafo nie syczy.
    Jedynie występuje jeszcze problem ze stabilizacją napięcia.
    Pod wpływem obciążenia spada o kilka wolt.

    Zdjęcie wykonanej przetwornicy:
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Przetwornica:

    - bez obciążenia
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - z małym obciążeniem
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - z większym obciążeniem
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - bez obciążenia (z wartościami)
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    -z lekkim obciążeniem ( z wartościami)
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Jak można zauważyć napięcie wyjściowe przetwornicy pod wpływem lekkiego obciążenia zmniejszyło z 31na 29,3V.
    Przy większych obciążeniach spadek wynosił prawie 10V.

    Oglądając przebiegi zauważyć można, że dzięki sprzężeniu zwrotnemu układ zwiększa wypełnienie PWM, ale nie wystarczająco.

    Czy istnieje możliwość zwiększenia stabilności napięcia wyjściowego ?
    Maksymalnie +-2V.

    Wskazania oscyloskopu mogą być błędne, ponieważ uległ on awarii i pokazuje błędne wartości.

    Pozdrawiam
    Vaupe115
  • Poziom 33  
    Jak mówiłem wcześniej, musisz się pobawić elementami RC sprzężenia zwrotnego. Na początek, zamiast 10k daj 47k - napięcie powinno być teraz stabilniejsze. Potem możesz zmniejszyć jeszcze ten kondensator żeby zmniejszyć zwłokę działania stabilizacji, ale uważaj żeby przetwornica nie zaczęła znowu trzeszczeć.
  • Poziom 10  
    Witam po długiej przerwie.

    Dziękuje Qwet za słuszne uwagi.

    Przetwornica chodzi stabilnie, bardzo dokładnie utrzymuje wartość napięcia wyjściowego pomimo różnych obciążeń.
    Wcześniejsze problemy z utrzymaniem napięcia wynikały z tego, że do testów w formie źródła napięcia zastosowałem zasilacz laboratoryjny - jak się okazało o zbyt małej wydajności.

    Problemem jaki jeszcze występuje jest to, że mocno grzeją się elementy (7812, bd135, bd136) - rozumiem, że przy przetwornicy o takiej mocy na IRFZach oraz diodzie MBR wydziela się spora ilość ciepła, szczególnie przy obciążeniu, ale niepokojącym faktem jest to, że również mocno grzeje się stabilizator 7812 użyty w celu stabilizacji napięcia zasilającego układ tl494.

    W dniu dzisiejszym porobiłem kilka pomiarów oscyloskopem i okazało się, że na wyjściu sygnału PWM układu TL494 przy załączaniu oraz wyłączaniu pojawiają się oscylacje - podejrzewam, że to jest powodem grzania się w większym stopniu elementów -
    jak również sygnał na IRFZie nie ciekawie nie wygląda.

    Schemat przetwornicy (bez stabilizatora 7812) znajduje się wyżej - wersja 2


    Zdjęcie wykonanej przetwornicy:
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Zdjęcie projektu płytki:
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Zdjęcia z pomiarów:
    - sygnał PWM z wyjścia TL494
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - sygnał pomiędzy źródłem a drenem tranzystora IRFZ44N
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - przebieg wyjściowy
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    - przebieg wejściowy
    Przetwornica push-pull(tl494) - syczenie trafa, nieprawidłowe przebiegi

    Poza tym przetwornica zakłóca obraz z kamery, który jest zasilany z tego samego źródła (akumulator) - pojawia się coś w rodzaju siatki, natomiast przy uruchomieniu silnika DC zasilanego z przetwornicy pojawiają się poziome linie.

    Proszę o rady jak wyeliminować występujące zakłócenia.
    Może płytka jest źle zaprojektowana ?
    Czy na tranzystory wchodzące w skład pary komplementarnej zastosować radiatory ?
    czy może zmienić je na jakieś inne ?
    dlaczego grzeje się stabilizator 7812 zasilający układ ?
    czy zastosować chłodzenie wiatrakiem w celu wymuszenia obiegu powietrza ?
    co mogę jeszcze zrobić w celu zminimalizowania zakłóceń generowanych przez przetwornice ?
    dodać metalową obudowę podłączoną pod masę w celu jej ekranowania ?

    Za wszelkie rady, opinie, sugestie z góry dziękuję.

    Pozdrawiam
    Vaupe115

    P.S.

    Ostatnio pod dużym obciążeniem rozsadziło kondensator wejściowy - 100u 25V.