Elektroda.pl
Elektroda.pl
X
Elektroda.pl
PCIM Europe 2019
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica 12/170V na TL494 - grzeją się trazystory

birut 13 Paź 2014 23:01 4317 14
  • #1 13 Paź 2014 23:01
    birut
    Poziom 21  

    Zbudowałem przetwornicę napięcia stałego z 12 na 170 V.Bez obciążenia tranzystory mocy są letnie. Regulacja napięcia dział a poprawnie, prądowe zabezpieczenie nie mam pojęcia jak sprawdzić, przy obciążeniu 1K napięcie spada z 170V do 72 V a tranzystory zaczynają się gotować. Nie wiem co zrobić by uzyskać moc z obciążeniem 1K około 30W, i bez spadu napięcia.

    0 14
  • #2 13 Paź 2014 23:20
    fuutro
    Poziom 43  

    Pokaż wykonanie i daj coś więcej wiadomości o projekcie.

    0
  • #3 14 Paź 2014 01:17
    redelektron
    Poziom 19  

    Witam
    Zabezpieczenie prądowe sprawdzisz zwiększając obciążenie - np kombinacje z żarówek 230V/15W lub rezystorów. Dopuki nie przekroczysz prądu ogranicznika przetwornica ma trzymać stabilnie napięcie wyjściowe. Jak ją przeciążysz to napięcie wyjściowe będzie spadać wraz ze wzrostem obciążenia a prąd wyjściowy będzie stały.
    To mniej więcej tyle w kwestii ograniczników. Teraz pytania:
    1. Co to jest obciązenie 1K?
    2. Przejrzałeś jakiś datasheet TL494 zanim napisałeś ten temat?
    Jeśli nie to zajrzyj do datasheeta TL494 prod. ONSEMI. Znajdziesz tam swój schemat (Fig.20).
    3. Wstawiłeś diody D1, D2 i dławik DŁ?
    4. Jaki prostownik dałeś na wyjściu?
    5. Skąd masz te dane transformatora? Przy tak małej mocy klucze powinny być zimne na biegu jałowym.

    Widzę dwa błędy w schemacie:
    1. Usuń C5 i C6 a pin8 TL494 połącz z pinami 11 i 12.
    2. Z pina 2 TL-a daj rezystor 4,7k do masy i ustaw napięcie wyjściowe na P1.
    3. Kondensator na wyjściu ma być LOW ESR.

    Tyle widzę na już z co jeszcze to się okaże. Narazie to popraw i poczytaj datasheeta. Ogólnie powinno działać chyba, że obliczenia dzielników napięcia ktoś skopał ale to już sam sobie spokojnie policzysz. Powodzenia

    0
  • #4 14 Paź 2014 10:51
    komatssu
    Poziom 29  

    To co się rzuca od razu w oczy - dławik Dł 1 powinien być za mostkiem prostowniczym, a nie w szereg z uzwojeniem wtórnym transformatora.

    0
  • #5 06 Lis 2014 16:34
    birut
    Poziom 21  

    komatssu napisał:
    To co się rzuca od razu w oczy - dławik Dł 1 powinien być za mostkiem prostowniczym, a nie w szereg z uzwojeniem wtórnym transformatora.

    Jeżeli jest to w szeregu z diodami mostka to nie ma znaczenia, prąd będzie taki sam, napięcie również.

    Kiedy spaliły mi się końcowe tranzystory to miałem takie same napięcia na wyjściu bez i z obciążeniem 1 kOhm jak z tranzystorami dobrymi, czyli pracowały jedynie tranzystory sterujące.
    Prawdopodobnie źle działa zabezpieczenie prądowe przy szpilkach, może jakiś kondensator by się przydał.
    Dostałem nowy transformato troszkę większy ale nie wiem ile zwojów nawinąć i jaką dać szczelinę.

    Dodano po 16 [minuty]:

    redelektron napisał:
    Witam
    Zabezpieczenie prądowe sprawdzisz zwiększając obciążenie - np kombinacje z żarówek 230V/15W lub rezystorów. Dopuki nie przekroczysz prądu ogranicznika przetwornica ma trzymać stabilnie napięcie wyjściowe. Jak ją przeciążysz to napięcie wyjściowe będzie spadać wraz ze wzrostem obciążenia a prąd wyjściowy będzie stały.
    To mniej więcej tyle w kwestii ograniczników. Teraz pytania:
    1. Co to jest obciązenie 1K?
    2. Przejrzałeś jakiś datasheet TL494 zanim napisałeś ten temat?
    Jeśli nie to zajrzyj do datasheeta TL494 prod. ONSEMI. Znajdziesz tam swój schemat (Fig.20).
    3. Wstawiłeś diody D1, D2 i dławik DŁ?
    4. Jaki prostownik dałeś na wyjściu?
    5. Skąd masz te dane transformatora? Przy tak małej mocy klucze powinny być zimne na biegu jałowym.

    Widzę dwa błędy w schemacie:
    1. Usuń C5 i C6 a pin8 TL494 połącz z pinami 11 i 12.
    2. Z pina 2 TL-a daj rezystor 4,7k do masy i ustaw napięcie wyjściowe na P1.
    3. Kondensator na wyjściu ma być LOW ESR.

    Tyle widzę na już z co jeszcze to się okaże. Narazie to popraw i poczytaj datasheeta. Ogólnie powinno działać chyba, że obliczenia dzielników napięcia ktoś skopał ale to już sam sobie spokojnie policzysz. Powodzenia


    3. Wstawiłeś diody D1, D2 i dławik DŁ?
    Nie wiem co to znaczy? diody i dławik są tak jak na schemacie.

    1. Usuń C5 i C6 a pin8 TL494 połącz z pinami 11 i 12.
    Na schemacie jest błąd, ma być mostek między pinami 8 i 11,12,

    3. Kondensator na wyjściu ma być LOW ESR.
    Dałem kondensatory takie jakie stosują producenci w przetwornicach na 230V (10uF/400V). Te mi się nie grzeją, natomiast mam kondensatory LOW ESR na uzwojeniu pierwotnym (C11 2 x 470uF/25V zasilanie 12V) i mimo to się lekko grzeją.

    0
  • #6 06 Lis 2014 16:44
    113673
    Użytkownik usunął konto  
  • #7 06 Lis 2014 17:50
    komatssu
    Poziom 29  

    IRFZ44 mają pojemność bramki ~2nF, to niewiele. Sterowanie tranzystorami jest jak najbardziej poprawne (obwody T1-D1, T2-D2 przyspieszają zamykanie mosfetów) i tego nie należy się czepiać.

    0
  • #8 06 Lis 2014 18:44
    akytam
    Poziom 16  

    Kolego birut,
    Spróbuję wyjaśnić Dławik.
    W uzwojeniu wtórnym transformaora masz (w uproszczeniu powinieneś mieć) napięcie o przbiegu prostokątnym symetryczne w OBIE strony. I dlatego dałeś prostownik dwupołówkowy. OK, ale prąd ma płynać w uzwojeniu wtórnym raz w jedną a raz w drugą stronę - z częstoliwością przetwonicy. A Ty mu przeszkadzasz TOTALNIE dławikiem D1!
    Energia nie przechodzi przez Tr1. Próba obciążenia wyjścia powoduje silne sterowanie FETów, FETy na zmianę popompują energię w rdzeń i odbierają spowrotem = grzeją się wściekle.
    1) Przesuń dławik za mostek a przed kondensator C12 Kolega komatssu ma rację!!!
    2) I powiększ C12 do np 47uF. Teraz się nie grzeje, bo nie płyną w nim szybkie prądy zmienne - nie masz mocy na wyjściu, przetwornica nie doładowuje go impulsowo.

    0
  • #9 10 Lis 2014 09:23
    birut
    Poziom 21  

    Na bramkach mam krótkie przebiegi prostokątne. Brak pełnego wypełnienia nawet kiedy dam obciążenie.
    Przebieg na wyjściu TR z jednego T1 daje impuls dodatni i ujemny, tak samo T2 i to się zgadza bo co drugi przebieg jest identyczny, tylko że mam szpilki a nie prostokąt.

    Przetwornica 12/170V na TL494 - grzeją się trazystoryPrzetwornica 12/170V na TL494 - grzeją się trazystoryPrzetwornica 12/170V na TL494 - grzeją się trazystory

    0
  • #10 10 Lis 2014 10:18
    birut
    Poziom 21  

    Podobnie zachowuje się przetwornica do zasilania świetlówki, t.z. ma takie same spadki napięć ale się nie grzeje. Nie mogę jej zastosować bo z założenia ma mniejszą moc.

    Zastosowałem nowy transformator dla zasilacza świetlówkowego, pierwotne 8 zw. wtórne 130 zw. Napięcie wyjściowe od = 300 V (ok 30 kHz, I = 0,28 mA) do = 350V (ok 80 kHz, I = 0,17 mA). Liczyłem że napięcie wyjściowe nie przekroczy = 200V, zasilanie 12 V. Na starym transformatorze było = 130 V ,które było za małe.
    Po obciążeniu napięcie z 350 V spada do 35 V, przy czym prąd przetwornicy się nie zmienia i pozostaje 0,17 mA. Tranzystory są letnie z obciążeniem i bez (bez radiatora). Dzięki większemu transformatorowi może uda się zwiększyć moc, ale te spadki napięć , nie wiem skąd się biorą. Jak zwiększyć prąd wyjściowy (moc) tego zasilacza.

    0
  • #11 23 Lis 2014 15:56
    birut
    Poziom 21  

    Podaję przebiegi dla przetwornicy na SG3525. po zastosowaniu przewiniętego trafa:
    pierwotne 2 x 8 zw i wtórne 90 zw. napięcia są raczej OK.
    Napięcie zasilania 13,6V, częstotliwość pracy 30 kHz, prąd w stanie jałowym 200 mA, napięcie wyjściowe 209V - przy obciążeniu 33k 2W, po obciążeniu rezystorem 1k 20W napięcie spada do 156V, prąd 2,9A.
    Przy tej częstotliwości pracy przetwornica bierze najmniej prądu pod obciążeniem 33k, zwiększając częstotliwość do 125 kHz otrzymujemy 240V, prąd 410 mA.
    Transformator (z drukarki, przetwornicy 230/12V ) ma częściową 80%, środkową szczelinę 1 mm.

    0
  • #12 29 Lis 2014 19:35
    marek_ka
    Poziom 26  

    To zmień transformator na taki bez szczeliny w rdzeniu.

    0
  • #13 02 Gru 2014 19:19
    birut
    Poziom 21  

    Kontynuuję projekt przetwornicy na SG3525 bo jest bardziej prosty. Zrobiłem regulację napięcia wyjściowego dzielnikiem z nap. U =180V do pin 1 oraz włączyłem rezystor 470k z pin 1 do pin 9, przetwornica zaczyna osiągać przyzwoite parametry. Spadek napięcia wyjściowego po obciążeniu rezystorem 1 k jest do przyjęcia = 175 V , przy zasil. 13,5 V i prądzie 2,5 A. Jest jedynie problem z napięciem zasilania, przetwornica jest mało stabilna, przy nap. 12 V załamuje się przebieg prostokątny i przy napięciu 13,5V przebieg przypomina sinusoidę o częstotliwości 2X 30 kHz f gen. a prąd zasilania zmienia się o 50%. Podmieniałem transformatory , jeden ze szczeliną drugi bez i jest to samo. Na przedstawionych przebiegach widać załamanie impulsu prostokątnego, najmniejsze szpilki na drenach uzyskuję jak dopasuję f generatora by się sinusoidy nakładały ok. 30 kHz, prąd spoczynkowy wtedy osiąga najmniejszą wartość - 90 mA.
    Czy ktoś wytłumaczy mi te zjawiska i podpowie jak wyeliminować to załamanie oraz w jakim celu jest zastosowany układ na tranzystorze T1.

    Załamanie przebiegu prostokątnego następuje wtedy, kiedy zaczyna działać ograniczenie napięcia.

    0
  • #14 06 Gru 2014 19:16
    birut
    Poziom 21  

    Powróciłem do TL494. Mając pewne doświadczenie przy prostym układzie SG3525 mogę teraz spokojniej podejść do pierwszego projektu, który bardziej pasuje do mojego zastosowania - radia samochodowego lampowego. Na początek wstawiłem nowy transformator, który dobrze sprawował się w układzie SG3525. Dławik przełożyłem wedle życzenia za minus przed rezystor R 20, choć nie jestem do końca przekonany o słuszności bo kiedy mamy symetryczne 2 uzwojenia wtórne i 2 diody to wygląda to prościej i nie widać różnicy. Przebiegi na nowym transformatorze wyglądają dużo lepiej. Niestety ten mostek S1WB się nie sprawdził niby powinien wytrzymać a jednak poszedł z dymem. Pozostaje mi wstawić 4 diody fast 1N4937 oraz sprawdzić układ ograniczający prąd, czy działa poprawnie.

    Diody wstawione.
    Ogranicznik prądowy działa nawet przy próbie zwarciowej. Prąd przetwornicy wówczas spada z 1,9A przy obciążeniu 1k do 1,1A przy zwarciu.

    0
  • #15 13 Mar 2015 09:21
    birut
    Poziom 21  

    Przetwornica zrobiona działa poprawnie. Mimo filtrów nanosi się jakieś w.cz. na falach średnich, wyraźnie słychać co ileś kHz gwizdy, jakby harmoniczne. Radio Becker Mexico zestrojone w/g instrukcji serwisowej, lampy wymienione, kondensatory (kartoflaki i elektrolity).

    Przetwornica 12/170V na TL494 - grzeją się trazystory

    0