Elektroda.pl
Elektroda.pl
X
PCBwayPCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Dziwne zachowanie zasilacza zbudowanego na stablilizatorze LM317T.

19 Lip 2011 16:06 4753 19
  • Poziom 10  
    Witam.
    Postanowiłem przerobić stary zasilacz komputerowy na "pseudo" warsztatowy z regulacją napięcia. Do tego celu zastosowałem chyba najprostsze z możliwych rozwiązań czyli:
    Dziwne zachowanie zasilacza zbudowanego na stablilizatorze LM317T.
    Zamiast rezystora R1 zastosowałem potencjometr montażowy 500R natomiast R2 to w moim przypadku potencjometr 4,7k (jak wynika z oznaczenia A czyli liniowy).

    Dopóki wszystko było zmontowane na płytce stykowej to działało tak jak należy, czyli płynna regulacja od 1,25 do około 20 V.

    Ale po zmontowaniu tego na PCB potencjometr zachowuje się jak logarytmiczny. Dokładne ustawienie napięcia od 2 do 5V graniczy z cudem. I co jest dziwne regulacja po podłączeniu na wejście -12 i 12V zaczyna się od 0,5V (a zmiana rezystancji R1 prawie w ogóle nie wpływa na napięcie wyjściowe), natomiast w przypadku podłączenia masy i 12V najniższa wartość to 0,1V.

    Wie ktoś co może być przyczyną takiego zachowania układu. Płytkę posprawdzałem już na dziesiątą stronę i albo jestem ślepy albo wszystko jest wykonane tak jak być powinno.
  • PCBwayPCBway
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    Zamiast rezystora R1 zastosowałem potencjometr montażowy 500R


    Tam się poinien znaleźć rezystor zabezpieczający - skręcenie obydwu potencjometrów na zerową rezystancję spowoduje zwarcie.

    Beat87 napisał:
    R2 to w moim przypadku potencjometr 4,7k (jak wynika z oznaczenia A czyli liniowy).


    Produkt krajowy?

    Beat87 napisał:
    I co jest dziwne regulacja po podłączeniu na wejście -12 i 12V zaczyna się od 0,5V (a zmiana rezystancji R1 prawie w ogóle nie wpływa na napięcie wyjściowe), natomiast w przypadku podłączenia masy i 12V najniższa wartość to 0,1V.


    -12V na wejście?
    Zapewne już ubiłeś tego LMa.
  • PCBwayPCBway
  • Poziom 10  
    jdubowski napisał:
    Produkt krajowy?


    Najprawdopodobniej tak dokładne oznaczenie to TELEPOD 4,7k A 6 91 (pochodzi z demontażu).


    jdubowski napisał:
    -12V na wejście?
    Zapewne już ubiłeś tego LMa.


    Dlaczego mogło go to załatwić? Gdzieś czytałem (chyba tutaj), że żeby zmniejszyć dolną granicę regulacji z 1,25 do 0V należało właśnie zamiast masy podać napięcie ujemne, chyba, że ja coś źle zrozumiałem.


    metallmaniac napisał:
    sprawdź jakie napięcie odkłada sie na R1


    Tutaj jest trochę dziwnie bo przy rezystancji 270R odkłada się kilka mV. Spróbuje go wymienić na zwykły rezystor.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    Najprawdopodobniej tak dokładne oznaczenie to TELEPOD 4,7k A 6 91 (pochodzi z demontażu).


    Sprawdź go omomierzem - z demontażu moze być uszkodzony.

    Beat87 napisał:
    że żeby zmniejszyć dolną granicę regulacji z 1,25 do 0V należało właśnie zamiast masy podać napięcie ujemne,


    Ale nie -12V tylko mniej niz 2V.

    Zrób według schematu, załóż nowego LMa, załóż stały rezystor i potencjometr a nie dwa potencjometry, bo jak widzę korci cię do krecenia nimi.
  • Poziom 10  
    jdubowski napisał:
    Sprawdź go omomierzem - z demontażu moze być uszkodzony.


    Potencjometr zachowuje się tak jak powinien więc chyba jest sprawny. Włożyłem stały rezystor w miejsce R1 podpiąłem masę i 12V ale dalej to samo. Spróbuje jeszcze wymienić LMa tylko po niego muszę się kopnąć do sklepu. I mówisz żeby już raczej nie podłączać go pod -12 i +12V? (to podłączenie zaczerpnąłem z TEGO tematu) Aha i dziwne jest to że skoro go załatwiłem to cały czas mogę regulować napięcie wyjściowe.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    mówisz żeby już raczej nie podłączać go pod -12 i +12V? (to podłączenie zaczerpnąłem z TEGO tematu)


    Dałeś link do wątku - gdzie tam masz schemat z -12V?
    Podaj numer postu w wątku (#98 na przykład).
  • Poziom 10  
    mówiłem właśnie, że mogłem coś źle zrozumieć a chodziło mi o ten fragment autora tematu
    Cytat:
    Następnie korzystając z lekko wzmocnionej linii -12v wykonałem zasilacz regulowany na stab. LM317 , do jego zasilenia użyłem napięcia 24 występującego między linią +12 a -12v .Uzyskałem w ten sposób regulowane napięcie od ok 1- do 23v i o wydajności prądowej 1,5A.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    mówiłem właśnie, że mogłem coś źle zrozumieć a chodziło mi o ten fragment autora tematu
    Cytat:
    Następnie korzystając z lekko wzmocnionej linii -12v wykonałem zasilacz regulowany na stab. LM317 , do jego zasilenia użyłem napięcia 24 występującego między linią +12 a -12v .Uzyskałem w ten sposób regulowane napięcie od ok 1- do 23v i o wydajności prądowej 1,5A.


    Autor cytatu użył linii +12V i -12V do zasilenia układu (masa zasilacza wisi w powietrzu). Obciążenie podłączył między -12V a wyjście układu.
  • Poziom 10  
    No to teraz już całkiem nie rozumiem. Czyli masa i +12V wchodzi do regulatora a na końcowe zaciski jest podane -12V i wyjście z regulatora? W takim przypadku (jeśli dobrze mi się wydaje) regulacja zaczynała by się od około 12V w górę.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    No to teraz już całkiem nie rozumiem. Czyli masa i +12V wchodzi do regulatora a na końcowe zaciski jest podane -12V i wyjście z regulatora? W takim przypadku (jeśli dobrze mi się wydaje) regulacja zaczynała by się od około 12V w górę.


    Masa nie wchodzi do regulatora.
    Dla odciążenia skołatanych myśli radzę zapomnieć o tym -12V na początek.
  • Poziom 10  
    Aha to do tej pory myślałem, że chociaż mniej więcej wiem o co chodzi ale teraz to całkowicie nic nie rozumiem. To co mam w końcu wprowadzić a co wyprowadzić z regulatora?
  • Moderator
    Nie wiem, o czym do tej pory myślałeś. -12V to jednocześnie masa wejściowa i wyjściowa tego regulatora - jeśli mowa o rozwiązaniu z podanego przykładu. O masie zasilacza zapomnij... Za to pamiętaj o "wzmocnieniu" w zasilaczu linii -12V, bo nominalnie nie jest przystosowana do takich prądów, jak podano.
  • Poziom 10  
    Mirek Z. napisał:
    Nie wiem, o czym do tej pory myślałeś. -12V to jednocześnie masa wejściowa i wyjściowa tego regulatora - jeśli mowa o rozwiązaniu z podanego przykładu. O masie zasilacza zapomnij... Za to pamiętaj o "wzmocnieniu" w zasilaczu linii -12V, bo nominalnie nie jest przystosowana do takich prądów, jak podano.


    Wydaje mi się właśnie że myślałem o tym co mówisz. Może narysuję dokładnie tak jak miałem:
    Dziwne zachowanie zasilacza zbudowanego na stablilizatorze LM317T.

    A potencjometr 500R zastosowałem właśnie dlatego, bo wiedziałem, że konieczne będzie jeszcze przystosowanie linii -12V do wyższych prądów, ale chciałem to zrobić później, a na razie mieć możliwość podpięcia np. tylko 12V.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    Wydaje mi się właśnie że myślałem o tym co mówisz. Może narysuje dokładnie tak jak miałem:


    Jeśli tak i nie używałeś masy zasilacza to nie powinno być problemów. Z tym że to nijak się ma do regulacji napięcia zaczynającej się od zera.

    Beat87 napisał:
    A potencjometr 500R zastosowałem własnie dlatego bo wiedziałe, że konieczne będzie jeszcze przystosowanie linii -12V do wyżdzych prądów,


    Wartość tego rezystora nijak się ma do prądu pobieranego z zasilacza - o tym decyduje wewnętrzne ograniczenie układu scalonego oraz możliwosc odprowadzania ciepła z niego.
  • Poziom 10  
    Rezystor 500R miał służyć tylko do pełnego wykorzystania skali potencjometru "głównego" przy ewentualnej zmianę napięcia wejściowego.
    Regulacja od zera nie jest mi potrzebna wystarczy standardowe 1,25V
    Czyli jeżeli wszystko powinno teoretycznie działać to co może być przyczyną tego że potencjometr z oznaczenia i z pomiarów jest liniowy a w układzie zachowuje się podobnie do logarytmicznego

    edit:
    Wymieniłem potencjometr na inny i dzieje się dokładnie to samo (chociaż zakres regulacji zwiększył się o około 1V). Zrezygnowałem z regulacji pomiędzy -12 i 12V wystarczy niech już będzie tylko do niecałych 12V.

    Ale Mam kolejny problem. Co może być przyczyną tego że napięcie podczas podłączenia obciążenia (w tym wypadku jakiegoś silniczka) spada do 3,6V?
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    Czyli jeżeli wszystko powinno teoretycznie działać to co może być przyczyną tego że potencjometr z oznaczenia i z pomiarów jest liniowy a w układzie zachowuje się podobnie do logarytmicznego


    Pomylone końcówki LMa?

    Beat87 napisał:
    Ale Mam kolejny problem. Co może być przyczyną tego że napięcie podczas podłączenia obciążenia (w tym wypadku jakiegoś silniczka) spada do 3,6V?


    Hipotezy:
    - pomylone końcówki LMa
    - uaktywnia się zabezpieczenie termiczne
    - "siada" napięcie zasilacza dostarczającego zasilanie do LMa
  • Poziom 10  
    jdubowski napisał:
    - pomylone końcówki LMa

    LM wydaje mi się że jest podłączony prawidłowo ale jak masz chwilę to możesz rzucić okiem na schemat płytki:
    Dziwne zachowanie zasilacza zbudowanego na stablilizatorze LM317T.

    jdubowski napisał:
    - uaktywnia się zabezpieczenie termiczne

    LM jest połączony z radiatorem, może nie z byt dużym ale w ogóle nie wyczuwam na nim ciepła.

    jdubowski napisał:
    - "siada" napięcie zasilacza dostarczającego zasilanie do LMa

    Po podłączenia silniczka bezpośrednio do 12V przed regulatorem napięcie nic się nie zmienia.
  • Specjalista - urządzenia lampowe
    Beat87 napisał:
    jdubowski napisał:
    - pomylone końcówki LMa

    LM wydaje mi się że jest podłączony prawidłowo ale jak masz chwilę to możesz rzucić okiem na schemat płytki:
    Dziwne zachowanie zasilacza zbudowanego na stablilizatorze LM317T.


    Właśnie, wydaje ci się. Popatrz do datasheetu jak są wyprowadzone końcówki dla obudowy TO-220.
  • Poziom 9  
    Cześć.O ile temat aktualny to moim zdaniem brak poprawnej pracy może być skutkiem samowzbudzania się układu.Nie znam schematu wewnętrznego tego układu scalonego,o ile to układ wielo stopniowy to niezbędna jest kompensacja częstotliwościowa.Spróbuj między ADJ a masę podpiąć kondensator około 10mikroF.Poza tym ten dzielnik oporowy w pętli ujemnego sprzężenia regulacja nie wygląda najlepiej,to powinna być regulacja typowo potencjometryczna, z szeregowym opornikiem zabezpieczającym ADJ.